Sounds like a good idea to me.
I'm thinking this is faulty hardware... I've got a handful of these at work that have been sitting around, so I'm going to see if those work better.
/interface ethernet set ether1 mac-address=xxx
/ip firewall nat add chain=dstnat dst-address=11.11.11.1 action=dst-nat to-addresses=192.168.2.1
/ip firewall nat add chain=srcnat src-address=192.168.2.1 action=src-nat to-addresses=11.11.11.1
/system logging action
add name=syslog remote=1.2.3.4 target=remote
/system logging
add action=syslog topics=firewall
add action=syslog topics=dhcp
/ip firewall nat
add action=log chain=srcnat
add action=log chain=dstnat