Model: CCR2004
Neighbor device: Edgerouter 2.0.9beta3
IPv6 routes learned from BGP always ends up unreachable as illustrated below. The same setup works fine with 6.47.
Code: Select all
Ib afi=ip6 contribution=unreachable dst-address=::/0 gateway=:: distance=200 scope=40 target-scope=10 belongs-to="BGP IP6 routes from 2001:1234:5678:402::1"
bgp.peer-cache-id=*B000030 .local-pref=100 .med=1024 .atomic-aggregate=yes .origin=incomplete
debug.fwp-ptr=0x202427D0
Ib afi=ip6 contribution=unreachable dst-address=2001:1234:5678:caff::/125 gateway=:: distance=200 scope=40 target-scope=10 belongs-to="BGP IP6 routes from 2001:1234:5678:402::1"
bgp.peer-cache-id=*B000030 .local-pref=100 .atomic-aggregate=yes .origin=incomplete
debug.fwp-ptr=0x202427D0
Ib afi=ip6 contribution=unreachable dst-address=2001:1234:5678:ffff::2 gateway=:: distance=200 scope=40 target-scope=10 belongs-to="BGP IP6 routes from 2001:1234:5678:402::1"
bgp.peer-cache-id=*B000030 .local-pref=100 .atomic-aggregate=yes .origin=incomplete
debug.fwp-ptr=0x202427D0
The neighbor sends the following data:
Code: Select all
12:12:43.912977 IP6 (flowlabel 0x3b9cc, hlim 64, next-header TCP (6) payload length: 281) 2001:1234:5678:402::1.33548 > 2001:1234:5678:402::4.179: Flags [P.], cksum 0x8657 (correct), seq 289:538, ack 152, win 225, options [nop,nop,TS val 206644115 ecr 3865752310], length 249: BGP
Update Message (2), length: 86
Origin (1), length: 1, Flags [T]: Incomplete
AS Path (2), length: 0, Flags [T]: empty
Multi Exit Discriminator (4), length: 4, Flags [O]: 1024
Local Preference (5), length: 4, Flags [T]: 100
Multi-Protocol Reach NLRI (14), length: 38, Flags [OE]:
AFI: IPv6 (2), SAFI: Unicast (1)
nexthop: 2001:1234:5678:402::1, fe80::feec:daff:fe44:2d, nh-length: 32, no SNPA
::/0
Update Message (2), length: 163
Origin (1), length: 1, Flags [T]: Incomplete
AS Path (2), length: 0, Flags [T]: empty
Local Preference (5), length: 4, Flags [T]: 100
Multi-Protocol Reach NLRI (14), length: 122, Flags [OE]:
AFI: IPv6 (2), SAFI: Unicast (1)
nexthop: 2001:1234:5678:402::1, fe80::feec:daff:fe44:2d, nh-length: 32, no SNPA
2001:1234:5678:ffff::2/128
2001:1234:5678:caff::/125
The global and link-local addresses are reachable from the CCR:
Code: Select all
[me@coregw01] /routing/bgp/template> /ping fe80::feec:daff:fe44:2d interface=edge01-coregw01-linknet
SEQ HOST SIZE TTL TIME STATUS
0 fe80::feec:daff:fe44:2d 56 64 0ms echo reply
1 fe80::feec:daff:fe44:2d 56 64 0ms echo reply
sent=2 received=2 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms
[me@coregw01] /routing/bgp/template> /ping 2001:1234:5678:402::1 interface=edge01-coregw01-linknet
SEQ HOST SIZE TTL TIME STATUS
0 2001:1234:5678:402::1 56 64 0ms echo reply
1 2001:1234:5678:402::1 56 64 0ms echo reply
sent=2 received=2 packet-loss=0% min-rtt=0ms avg-rtt=0ms max-rtt=0ms
Relevant config from the CCR:
Code: Select all
/interface vlan
add interface=sfp-sfpplus5 name=edge01-coregw01-linknet vlan-id=402
/ipv6 address
add address=2001:1234:5678:402::4 advertise=no interface=edge01-coregw01-linknet
/routing bgp template
set default disabled=yes
/routing instance
add id=192.168.254.3 name=Home vrf=main
/routing bgp template
add address-families=ip as=65000 hold-time=10s instance=Home keepalive-time=3s multihop=no name=Home-AS65000-v4
add address-families=ipv6 as=65000 hold-time=10s instance=Home keepalive-time=3s multihop=no name=Home-AS65000-v6
/routing bgp connection
add connect=yes listen=yes local.address=2001:1234:5678:402::4 .role=ibgp remote.address=2001:1234:5678:402::1 .as=65000 template=Home-AS65000-v6
The log messages are not really that helpful, but there is one debug message that appears upon connect:
Code: Select all
12:31:59 route,bgp,debug,packet OPEN Message capabilities optionLenght=6
12:31:59 route,bgp,debug,packet OPEN Message capabilityCode=multiprotocol capabilityLenght=4
12:31:59 route,bgp,debug,packet OPEN Message capabilities optionLenght=6
12:31:59 route,bgp,debug,packet OPEN Message capabilityCode=multiprotocol capabilityLenght=4
12:31:59 route,bgp,debug,packet OPEN Message capabilities optionLenght=6
12:31:59 route,bgp,debug,packet OPEN Message capabilityCode=128Lenght=0
12:31:59 route,bgp,debug Unsupported capability received, code: 128BgpStarter{ c=Connection{ ConnId{ 2001:4660:5fca:402::4:179 -> 2001:4660:5fca:402::1:33666 } Socket{ 7[\00IN] onClose } in } readsz=61 } cancel
12:31:59 route,bgp,debug,packet OPEN Message capabilities optionLenght=6
12:31:59 route,bgp,debug,packet OPEN Message capabilityCode=route refresh capabilityLenght=0
12:31:59 route,bgp,debug,packet OPEN Message capabilities optionLenght=6
12:31:59 route,bgp,debug,packet OPEN Message capabilityCode=AS 4-octet capabilityLenght=4
12:31:59 route,bgp,debug,state Entering OpenConfirm state BgpStarter{ c=Connection{ ConnId{ 2001:4660:5fca:402::4:179 -> 2001:4660:5fca:402::1:33666 } Socket{ 7[\00IN] onClose } in } readsz=61 } cancel
12:31:59 route,bgp,debug,packet,raw Sent KEEPALIVE message
12:31:59 route,bgp,debug,packet,raw Session *=0x300a0430Length=19(null)(19 bytes)
12:31:59 route,bgp,debug,packet,raw FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
12:31:59 route,bgp,debug,packet,raw 00 13 04
Is this a known bug or do I need to adjust my configuration somehow?