Community discussions

MikroTik App
 
imnew
just joined
Topic Author
Posts: 14
Joined: Tue Nov 14, 2023 4:24 am

[BGP] How to Block Multiple ASN With 1 rule

Thu Feb 20, 2025 5:17 am

I would like to ask about blocking multiple asn without filtering each time.

Currently, I have BGP connection with multiple ISPs, each ISP will announce other ISPs' asn. My problem is that I don't want some asn.

Currently, I block like this, I will do this every time there is an unwanted asn.

rule="if (bgp-as-path XXXXX) {reject;}"

But what I want is, is there a Filter or something? To block in a single rule, but multiple asn.

(For example, blocking with address-list in firewall) Can filter in bgp do something like this? Like (asn-list) something like this.

I work in ISP (Internet Service Provider).

Sorry if my English is not good. :D

Thank you all for helping me this time. :)
Last edited by imnew on Thu Feb 27, 2025 8:51 am, edited 2 times in total.
 
User avatar
baragoon
Member
Member
Posts: 399
Joined: Thu Jan 05, 2017 10:38 am
Location: Kyiv, UA
Contact:

Re: [BGP] How to Block Multiple ASN With 1 rule

Thu Feb 20, 2025 9:01 am

You may use
/routing/filter/num-list
like this:
/routing filter num-list
add comment=some_bad_as disabled=no list=BAD-AS range=200993
add comment=another_bad_as disabled=no list=BAD-AS range=200994

/routing filter rule
add chain=some_chain disabled=no rule="if (bgp-as-path [[:BAD-AS:]]) {reject}"
for the num-list range you may use a not single, but a range of ASNs:
add comment="RFC 6996" disabled=no list=BOGON-AS range=4200000000-4294967294
Last edited by baragoon on Thu Feb 20, 2025 9:58 am, edited 2 times in total.
 
imnew
just joined
Topic Author
Posts: 14
Joined: Tue Nov 14, 2023 4:24 am

Re: [BGP] How to Block Multiple ASN With 1 rule

Thu Feb 20, 2025 9:17 am

You may use
/routing/filter/num-list
like this:
/routing filter num-list
add comment=disabled=no list=BAD-AS range=200993
add comment=disabled=no list=BAD-AS range=200994

/routing filter rule
add chain=some_chain disabled=no rule="if (bgp-as-path [[:BAD-AS:]]) {reject}
for the num-list range you may use a not single, but a range of ASNs:
add comment="RFC 6996" disabled=no list=BOGON-AS range=4200000000-4294967294


Thankyou somuch i will try it :)
 
savage
Forum Guru
Forum Guru
Posts: 1280
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: [BGP] How to Block Multiple ASN With 1 rule [SOLVED]

Thu Feb 20, 2025 10:59 am

rule="if (bgp-as-path XXXXX) {reject;}"
rule="if (bgp-as-path XXXXX || bgp-as-path AAAA || bgp-as-path BBBB || bgp-as-path CCCC) {reject;};"
Or as others suggested, numbered lists.
 
imnew
just joined
Topic Author
Posts: 14
Joined: Tue Nov 14, 2023 4:24 am

Re: [BGP] How to Block Multiple ASN With 1 rule [SOLVED]

Fri Feb 21, 2025 3:40 am

rule="if (bgp-as-path XXXXX) {reject;}"
rule="if (bgp-as-path XXXXX || bgp-as-path AAAA || bgp-as-path BBBB || bgp-as-path CCCC) {reject;};"
Or as others suggested, numbered lists.
Thankyou Somuch this is work Perfect !!
 
imnew
just joined
Topic Author
Posts: 14
Joined: Tue Nov 14, 2023 4:24 am

Re: [BGP] How to Block Multiple ASN With 1 rule [SOLVED]  [SOLVED]

Fri Feb 21, 2025 3:42 am

This is work for me check status route is filtered Perfect thankyou all


/routing filter num-list
add comment="Deny-ASN" list=Deny-ASN range=10000-20000


/routing filter rule
add chain=your_chain disabled=no rule="if (bgp-as-path [[:Deny-ASN:]]) {reject}"