Client Router
(1) It would appear you are trying to use srcnat masquerade to route traffic. This is the wrong approach.
/ip firewall nat
add action=masquerade chain=srcnat dst-address=172.16.24.0/24 out-interface=\
wireguard-oam src-address=192.168.13.0/24
All you need is.......
add action=masquerade chain=srcnat out-interface=wireguard-oam
++++++++++++++++++++++++++++++++++++++++
When you have control over both ends its best to be accurate. The kludge of using sourcenat to change all IPs to the single WG IP, is a very useful tool for when you dont control the other end,
such as third party VPNs, Technically you can do it either way and it will work. The problem still remains that you need to ensure routing and firewall rules etc....
+++++++++++++++++++++++++++++++++++++++
(2) To ensure traffic from the client router to the server subnet has a path you need the route:
/ip route
add dst-address=172.16.24.0/24 gateway=wireguard-oam routing-table=main
(3) You need to match the route with allowed IPs but since you already have 0.0.0.0/0 its already covered!
(3) To allow traffic to enter the tunnel you need firewall rule.
add chain=forward action=accept src-address=192.168.13.0/24 out-interface=wiregard-oam
(By the way find it confusing for the wireguard interface to be the same as when looking at wireguard parameters, am I looking at server device or client device?, no way to distinguish by name alone........so not helpful.
To complete the circle at the other end......
SERVER ROUTER
(4) SERVER PEER SETTINGS AT SERVER ROUTER
/interface wireguard peers
add allowed-address=10.249.0.13/32,192.168.13.0/24 interface=wireguard-oam public-key=\
"averylongsecurekey"
(5) And the route back to the Client router.
/ip route
add dst-address=192.168.13.0/.24 gateway=wireguard-oam routing-table=main