I am switching from ipsec to wireguard. But for some reason one branch can communicate with the main location while the other branch not. Configs seem to me identical, but maybe I am missing something.
Sites overview
Site 1 - main site:
Public IP: 1.1.1.1
Local networks: 10.201.22.0/24, 10.201.25.0/24, ... (+ some other, but not relevant for this topic)
Wireguard interface (wgEDI) addresses:
172.16.0.1/30
172.16.1.1/30
172.16.3.1/30
Port: 12321 (udp allowed on firewall input)
Static routes defined for branches' LANs with gateway being the wireguard interface wgEDI
Site 2 - working branch:
Public IP: 2.2.2.2
Local networks: 10.201.1.0/24
Wireguard interface (wgSKL) addresses:
172.16.1.2/30
Port: 12321 (udp allowed on firewall input)
Static routes to 10.201.22.0/24 and to 10.201.25.0/24 defined with gateway wgSKL
Site 3 - not working branch:
Public IP: NO (behind NAT)
Local networks: 10.201.3.0/24
Wireguard interface (wgHOD) addresses:
172.16.3.2/30
Port: 12321 (udp allowed on firewall input)
Static routes to 10.201.22.0/24 and to 10.201.25.0/24 defined with gateway wgHOD
On ether1 ("WAN") I have address 192.168.100.2 and gateway 192.168.100.1. This is from ISP's router. I have full access to that router, but I cannot replace it with Mikrotik. So I must be behind it's NAT. I have disabled firewall on that router just to make sure the issue is not there.
The actual WAN address for that ISP router is dynamic one.
[ ISP ] <---> [ Zyxel ISP router ] (192.168.100.1) <---> (192.168.100.2) [ Mikrotik ] (10.201.3.1) <---> [ LAN 10.201.3.0/24 ]
CONFIGs
Site1
Code: Select all
# 2024-02-10 20:37:22 by RouterOS 7.13.2
# software id = GEFA-6CF8
#
# model = RB4011iGS+
# serial number = D4440D1022D0
#NOTE: Do not mind the bridge and vlan setups = work in progress...
/interface bridge
add admin-mac=08:55:31:12:92:3B auto-mac=no comment=defconf name=bridge.local \
priority=0x9000
add name=bridge.servers
/interface ethernet
set [ find default-name=ether1 ] name=e1.WAN
set [ find default-name=ether2 ] comment="LAN - trunk to crs109 - 22, 1978" \
name=e2.t.crs109
set [ find default-name=ether3 ] comment="LAN - tbd - free" name=e3
set [ find default-name=ether4 ] name=e4.srvs.private.vlan
set [ find default-name=ether5 ] name=e5.free
/interface wireguard
add listen-port=13231 mtu=1420 name=wgEDI
/interface vlan
add comment="LAN + WiFi" interface=bridge.local name=vlan22 vlan-id=22
add interface=bridge.local name=vlan25 vlan-id=25
add comment="Servers private vlan" interface=e4.srvs.private.vlan name=\
vlan1112 vlan-id=1112
add comment=Management interface=bridge.local name=vlan9999 vlan-id=1978
/interface list
add comment=defconf name=WAN
add comment="Local + VPN clients" include=dynamic name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec profile
add dh-group=modp1024 enc-algorithm=aes-128 name=prof-Sushinet-S2S
/ip ipsec peer
add address=2.2.2.2/32 disabled=yes exchange-mode=ike2 name=SKL \
profile=prof-Sushinet-S2S
add address=3.3.3.3/19 exchange-mode=ike2 name=HOD passive=yes \
profile=prof-Sushinet-S2S send-initial-contact=no
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha256,sha1 enc-algorithms=\
aes-256-cbc,aes-128-cbc
add auth-algorithms="" enc-algorithms=aes-128-gcm lifetime=4h name=\
prop-Sushinet-S2S pfs-group=none
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp_servers ranges=10.201.25.100-10.201.25.254
add name=dhcp_emerg.mgmt ranges=192.168.98.2-192.168.98.254
add name=dhcp_lan.and.wifi ranges=10.201.22.100-10.201.22.254
add name=dhcp_management ranges=10.99.99.100-10.99.99.254
add name=pool_l2tp ranges=10.201.22.70-10.201.22.79
add name=dhcp_servers.private ranges=10.11.12.200-10.11.12.220
/ip dhcp-server
add address-pool=default-dhcp disabled=yes interface=bridge.local lease-time=\
10m name=defconf
add address-pool=dhcp_servers interface=bridge.servers name=dhcp.servers
add address-pool=dhcp_emerg.mgmt interface=sfp-sfpplus1 name=\
dhcp.emer.management
add address-pool=dhcp_lan.and.wifi interface=vlan22 name=dhcp.vlan22
add address-pool=dhcp_management interface=vlan9999 name=dhcp.management
add address-pool=dhcp_servers.private interface=vlan1112 name=\
dhcp.private.servers
/ppp profile
set *FFFFFFFE bridge=bridge.local dns-server=10.201.22.1,10.201.25.5 \
local-address=10.201.22.1 remote-address=pool_l2tp
/interface bridge port
add bridge=bridge.local comment=defconf interface=e2.t.crs109
add bridge=bridge.local comment=defconf interface=e3
add bridge=bridge.local comment=defconf interface=e5.free
add bridge=bridge.servers comment=defconf interface=ether6
add bridge=bridge.servers comment=defconf interface=ether7
add bridge=bridge.servers comment=defconf interface=ether8
add bridge=bridge.servers comment=defconf interface=ether9
add bridge=bridge.servers comment=defconf interface=ether10
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface bridge vlan
add bridge=bridge.local comment="LAN & WiFi" tagged=e2.t.crs109,bridge.local \
vlan-ids=22
add bridge=bridge.local comment=Management tagged=e2.t.crs109,bridge.local \
vlan-ids=1978
add bridge=bridge.local comment="Servers private" tagged=e4.srvs.private.vlan \
vlan-ids=1112
add bridge=bridge.local comment=Servers tagged=e2.t.crs109,bridge.local \
vlan-ids=25
/interface l2tp-server server
set enabled=yes use-ipsec=yes
/interface list member
add comment=defconf interface=bridge.local list=LAN
add comment=defconf interface=e1.WAN list=WAN
add interface=bridge.servers list=LAN
add interface=vlan22 list=LAN
add interface=vlan9999 list=LAN
add interface=ether7 list=LAN
add interface=ether8 list=LAN
add interface=ether9 list=LAN
add interface=ether10 list=LAN
/interface wireguard peers
add allowed-address=172.16.0.2/32,10.201.19.0/24 comment="PST mAPlite" \
interface=wgEDI public-key=\
"9999..."
add allowed-address=172.16.1.2/32,10.201.1.0/24 comment=SKL \
endpoint-address=2.2.2.2 endpoint-port=13231 interface=wgEDI \
public-key="2222..."
add allowed-address=172.16.3.2/32,10.201.3.0/24,192.168.100.0/24 comment=\
HOD interface=wgEDI public-key=\
"3333..."
/ip address
add address=192.168.88.1/24 comment=defconf disabled=yes interface=\
bridge.local network=192.168.88.0
add address=1.1.1.1 comment="ISP public IP" interface=e1.WAN \
network=1.1.1.1
add address=10.201.25.1/24 comment="LAN - servers" interface=bridge.servers \
network=10.201.25.0
add address=192.168.98.1/24 comment="emerg. management" interface=\
sfp-sfpplus1 network=192.168.98.0
add address=10.201.22.1/24 comment="VLAN + wifi" interface=vlan22 network=\
10.201.22.0
add address=10.99.99.1/24 comment="VLAN Management" interface=vlan9999 \
network=10.99.99.0
add address=10.11.12.1/24 comment="Servers private vlan" interface=vlan1112 \
network=10.11.12.0
add address=172.16.0.1/30 comment="Wireguard Local" interface=wgEDI network=172.16.0.0
add address=172.16.3.1/30 interface=wgEDI network=172.16.3.0
add address=172.16.1.1/30 interface=wgEDI network=172.16.1.0
/ip dhcp-client
add comment=defconf interface=e1.WAN
add interface=e4.srvs.private.vlan
/ip dhcp-server network
add address=10.11.12.0/24 comment="Servers private" dns-server=10.11.12.1 \
gateway=10.11.12.1
add address=10.99.99.0/24 gateway=10.99.99.1
add address=10.201.22.0/24 dns-server=10.201.25.5,88.212.8.8,88.212.8.88 \
gateway=10.201.22.1
add address=10.201.25.0/24 dns-server=10.201.25.5,88.212.8.8,88.212.8.88 \
gateway=10.201.25.1
add address=192.168.88.0/24 comment=defconf dns-server=\
10.201.25.5,192.168.88.1 gateway=192.168.88.1
add address=192.168.98.0/24 gateway=192.168.98.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
add forward-to=10.201.25.5 regexp=".*\\.mydomain\\.com\$" type=FWD
/ip firewall address-list
add address=10.201.19.0/24 list="PST"
add address=10.201.22.90-10.201.22.99 list=Management
add address=10.201.22.129 comment=Test list=Management
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=accept chain=input dst-port=8291 in-interface-list=LAN \
protocol=tcp
add action=accept chain=input comment="Wireguard - EDI" dst-port=13231 \
in-interface-list=WAN protocol=udp
add action=accept chain=input comment="L2TP VPN" dst-port=500,1701,4500 \
in-interface=e1.WAN protocol=udp
add action=accept chain=input comment="L2TP VPN" in-interface=e1.WAN \
protocol=ipsec-esp
add action=accept chain=input comment="L2TP VPN" in-interface=e1.WAN \
protocol=ipencap
add action=accept chain=input dst-port=53 in-interface-list=!WAN protocol=tcp
add action=accept chain=input dst-port=53 in-interface-list=!WAN protocol=udp
add action=add-src-to-address-list address-list=HODO_new_IP \
...
add action=add-src-to-address-list address-list=ping-knock2 \
...
add action=add-src-to-address-list address-list=ping-knock1 \
...
add action=add-src-to-address-list address-list=ping-knock1 \
...
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward dst-address=10.99.99.0/24 src-address-list=\
!Management
add action=accept chain=forward dst-address=10.201.25.0/24 in-interface=wgEDI
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip ipsec identity
add disabled=yes peer=SKL
add peer=HOD
/ip ipsec policy
add disabled=yes dst-address=\
10.201.1.0/24 peer=SKL proposal=prop-Sushinet-S2S src-address=\
10.201.16.0/20 tunnel=yes
add comment="HOD-LAN" dst-address=10.201.3.0/24 level=unique peer=\
HOD proposal=prop-Sushinet-S2S src-address=10.201.16.0/20 tunnel=\
yes
add comment="HOD-to-intermediateNAT" dst-address=\
192.168.100.0/24 level=unique peer=HOD proposal=prop-Sushinet-S2S \
src-address=10.201.16.0/20 tunnel=yes
/ip route
add disabled=no dst-address=10.201.1.0/24 gateway=wgEDI routing-table=\
main suppress-hw-offload=no
add disabled=no distance=1 dst-address=10.201.3.0/24 gateway=wgEDI \
pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add disabled=no dst-address=192.168.100.0/24 gateway=wgEDI \
routing-table=main suppress-hw-offload=no
/ppp secret
add name=xxx profile=default-encryption service=l2tp
/tool netwatch
add disabled=no down-script="/system script run newHODOip" host=10.201.3.1 \
interval=1m timeout=1s type=simple
Code: Select all
# 2024-02-10 20:42:35 by RouterOS 7.10.2
# software id = U7D4-T1XK
#
# model = RB750Gr3
# serial number = CC210E3A152D
/interface bridge
add admin-mac=2C:C8:1B:9F:3E:B8 auto-mac=no comment=defconf name=bridge-local
/interface l2tp-server
add name=l2tp-in1-xxx user=xxx
/interface wireguard
add listen-port=13231 mtu=1420 name=wgSKL
/caps-man datapath
add bridge=bridge-local client-to-client-forwarding=yes local-forwarding=yes \
name=dtpSushinet
/caps-man security
add authentication-types=wpa2-psk encryption=aes-ccm group-encryption=aes-ccm \
name=secLAN
/caps-man configuration
add datapath=dtpSushinet mode=ap name=sushinet security=\
secLAN ssid=Sushinet
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip ipsec profile
set [ find default=yes ] dh-group=modp1024 nat-traversal=no
/ip ipsec proposal
set [ find default=yes ] enc-algorithms=aes-256-cbc,aes-192-cbc
add enc-algorithms=3des name=l2tp_vpn
/ip pool
add name=default-dhcp ranges=10.201.1.150-10.201.1.220
/ip dhcp-server
add address-pool=default-dhcp authoritative=after-2sec-delay interface=\
bridge-local lease-time=2h name=default
/port
set 0 name=serial0
/ppp profile
add dns-server=10.201.1.1 local-address=10.201.1.1 name=sstp remote-address=\
default-dhcp
add bridge=bridge-local local-address=10.201.1.1 name=l2tp remote-address=\
default-dhcp
/routing bgp template
set default disabled=no output.network=bgp-networks
/routing ospf instance
add disabled=no name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/caps-man access-list
add action=accept disabled=no interface=any signal-range=-100..120 \
ssid-regexp=""
add action=reject disabled=no interface=any signal-range=-120..-101 \
ssid-regexp=""
/caps-man manager
set enabled=yes
/caps-man provisioning
add action=create-dynamic-enabled master-configuration=sushinet name-format=\
prefix-identity name-prefix=cap-SKL
/interface bridge port
add bridge=bridge-local comment=defconf ingress-filtering=no interface=ether2
add bridge=bridge-local comment=defconf ingress-filtering=no interface=ether3
add bridge=bridge-local comment=defconf ingress-filtering=no interface=ether4
add bridge=bridge-local comment=defconf ingress-filtering=no interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface l2tp-server server
set allow-fast-path=yes default-profile=l2tp use-ipsec=required
/interface list member
add comment=defconf interface=bridge-local list=LAN
add comment=defconf interface=ether1 list=WAN
/interface ovpn-server server
set auth=sha1,md5
/interface wireguard peers
add allowed-address=172.16.1.1/32,10.201.25.0/24,10.201.22.0/24 \
endpoint-address=1.1.1.1 endpoint-port=13231 interface=wgSKL \
public-key="1111..."
/ip address
add address=192.168.88.1/24 comment=defconf disabled=yes interface=\
bridge-local network=192.168.88.0
add address=10.201.1.1/24 comment="default configuration" interface=\
bridge-local network=10.201.1.0
add address=2.2.2.2 comment="WAN public address" interface=ether1 \
network=2.2.2.2
add address=172.16.1.2/30 interface=wgSKL network=172.16.1.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server network
add address=10.201.1.0/24 comment="default configuration" dns-server=\
10.201.1.1 gateway=10.201.1.1
/ip dns
set allow-remote-requests=yes cache-max-ttl=2d
/ip dns static
add forward-to=10.201.25.5 regexp=".*\\.mydomain\\.com\$" type=FWD
add address=10.201.1.1 name=router
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall address-list
add address=1.1.1.1 comment=Edisonova list="Trusted IPs"
add address=1.1.1.1 comment=Edisonova list=Sushinet_Networks
add address=10.201.3.0/24 list=Sushinet_Networks
add address=10.201.1.0/24 list=Sushinet_Networks
add address=10.201.22.0/24 list=Sushinet_Networks
add address=10.201.25.0/24 list=Sushinet_Networks
add address=10.19.78.0/24 list=Sushinet_Networks
add address=192.168.88.0/24 list=Sushinet_Networks
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=drop chain=input comment="intruders DROP" src-address-list=\
Intruders
add action=accept chain=input comment="DNS only internal requests" dst-port=\
53 in-interface-list=!WAN protocol=tcp
add action=accept chain=input comment="DNS only internal requests" dst-port=\
53 in-interface-list=!WAN protocol=udp
add action=accept chain=input dst-port=13231 in-interface-list=WAN protocol=\
udp
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input dst-port=22 protocol=tcp src-address-list=\
Sushinet_Networks
add action=accept chain=input comment="mikrotik WinBox" dst-port=8291 \
protocol=tcp src-address-list=Sushinet_Networks
add action=accept chain=input comment="L2TP VPN" in-interface-list=WAN \
protocol=ipsec-esp
add action=jump chain=input comment="Brute-force UDP CHECK" connection-state=\
new dst-port=500,1701,4500 in-interface-list=WAN jump-target=ipsec_chain \
protocol=udp
add action=accept chain=input comment=ipsec dst-port=500,1701,4500 \
in-interface=ether1 protocol=udp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
add action=drop chain=forward comment="SECURE DROP ALL - forward" disabled=\
yes
add action=drop chain=input comment="SECURE DROP ALL - input" disabled=yes
add action=add-src-to-address-list address-list=Intruders \
...
add action=add-src-to-address-list address-list=ipsec_stage2 \
...
add action=add-src-to-address-list address-list=ipsec_stage1 \
...
add action=return chain=ipsec_chain
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip firewall raw
add action=drop chain=prerouting in-interface-list=WAN src-address-list=\
Intruders
/ip route
add disabled=no dst-address=10.201.25.0/24 gateway=wgSKL routing-table=\
main suppress-hw-offload=no
add disabled=no dst-address=10.201.22.0/24 gateway=wgSKL routing-table=\
main suppress-hw-offload=no
/ppp secret
add name=xxx profile=l2tp service=l2tp
/routing bfd configuration
add disabled=no
/system identity
set name=SKL-router-hEX
Code: Select all
# 2024-02-10 20:41:19 by RouterOS 7.13.2
# software id = KDL8-VF33
#
# model = RBD53iG-5HacD2HnD
# serial number = E7290E690E26
/interface bridge
add admin-mac=2C:C8:1B:C5:FE:22 auto-mac=no comment=defconf name=bridge \
port-cost-mode=short
/interface wireguard
add listen-port=13231 mtu=1420 name=wgHOD
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip ipsec profile
add dh-group=modp1024 enc-algorithm=aes-128 name=prof-Sushinet-S2S
/ip ipsec peer
add address=88.212.60.238/32 exchange-mode=ike2 name=EDI profile=\
prof-Sushinet-S2S
/ip ipsec proposal
set [ find default=yes ] disabled=yes enc-algorithms=aes-256-cbc,aes-192-cbc
add auth-algorithms="" enc-algorithms=aes-128-gcm lifetime=4h name=\
prop-Sushinet-S2S pfs-group=none
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=dhcp ranges=10.201.3.100-10.201.3.254
/ip dhcp-server
add address-pool=dhcp interface=bridge lease-time=10m name=defconf
/routing bgp template
set default disabled=no output.network=bgp-networks
/routing ospf instance
add disabled=no name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/interface bridge port
add bridge=bridge comment=defconf ingress-filtering=no interface=ether2 \
internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf ingress-filtering=no interface=ether3 \
internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf ingress-filtering=no interface=ether4 \
internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf ingress-filtering=no interface=ether5 \
internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf ingress-filtering=no interface=wlan1 \
internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf ingress-filtering=no interface=wlan2 \
internal-path-cost=10 path-cost=10
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set disable-ipv6=yes max-neighbor-entries=8192
/interface detect-internet
set lan-interface-list=LAN wan-interface-list=WAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=wgHOD list=LAN
/interface ovpn-server server
set auth=sha1,md5
/interface wireguard peers
add allowed-address=172.16.3.1/32,10.201.25.0/24,10.201.22.0/24 endpoint-address=\
1.1.1.1 endpoint-port=13231 interface=\
wgHOD public-key="1111..."
/ip address
add address=10.201.3.1/24 interface=bridge network=10.201.3.0
add address=172.16.3.2/30 interface=wgHOD network=172.16.3.0
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server lease
add address=10.201.3.10 client-id=1:0:1d:ec:17:3c:f8 mac-address=\
00:1D:EC:17:3C:F8 server=defconf
add address=10.201.3.11 client-id=1:7c:dd:90:d6:dc:9f mac-address=\
7C:DD:90:D6:DC:9F server=defconf
/ip dhcp-server network
add address=10.201.3.0/24 comment=defconf dns-server=10.201.3.1 gateway=\
10.201.3.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.88.1 comment=defconf disabled=yes name=router.lan
add forward-to=10.201.25.5 regexp=".*\\.mydomain\\.com\$" type=FWD
add address=10.201.3.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=accept chain=input comment="Wireguard EDI" dst-port=13231 \
in-interface-list=WAN protocol=udp
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input dst-port=500,4500 protocol=udp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=accept chain=forward disabled=yes dst-address=10.201.16.0/20 \
src-address=10.201.3.0/24
add action=accept chain=forward disabled=yes dst-address=10.201.3.0/24 \
src-address=10.201.16.0/20
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip ipsec identity
add peer=EDI
/ip ipsec policy
set 0 disabled=yes
add dst-address=10.201.16.0/20 level=unique peer=\
EDI proposal=prop-Sushinet-S2S src-address=10.201.3.0/24 tunnel=yes
add dst-address=10.201.16.0/20 peer=EDI proposal=prop-Sushinet-S2S src-address=\
192.168.100.0/24 tunnel=yes
/ip route
add comment="Wireguard - Enable" disabled=no distance=1 dst-address=\
10.201.22.0/24 gateway=wgHOD pref-src="" routing-table=main scope=\
30 suppress-hw-offload=no target-scope=10
add comment="Wireguard - Enable" disabled=no distance=1 dst-address=\
10.201.25.0/24 gateway=wgHOD pref-src="" routing-table=main scope=\
30 suppress-hw-offload=no target-scope=10
/routing bfd configuration
add disabled=no
/system identity
set name=HOD-hAPac3
Connection between Site1 and Site3 does not work. Seems wg connection is established - I can ping wg interfaces (from Site 1 I can ping Site's 3 wg interfaces address 172.16.3.2 and vice versa, from Site 3 I can ping 172.16.3.1). Please note, that ipsec tunnel is up, but the pings work with ipsec enabled or disabled, thus I believe the wireguard connection is up and running.
I cannot reach LANs however. E.g. when I ping from Site 3 a server address 10.201.25.9, it works if ipsec tunnel is up, but as soon as I shut it down, the ping times-out.
I suspected a routing issue. But since the routes are set-up the same way as for Site 2, I really do not know where the problem could be.
Any advice is appreciated!
Thank you!