We have a two firewalls ....
Ok, the schema is clear, but are missing all IPs.....
If you don't provide the configurations, you can only go blind, trying, groping, you choice...
FW1
/interface wireguard
add listen-port=22222 mtu=1420 name=wireguard-to-remote-site#1
add listen-port=33333 mtu=1420 name=wireguard-to-remote-site#2
/ip address
add address=10.20.200.1 interface=wireguard-remote-site#2 network=10.20.200.2
add address=10.21.200.1 interface=wireguard-remote-site#1 network=10.21.200.2
add address=172.50.201.1/30 interface=ether1 network=172.50.201.0
/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=\
187.122.133.144 endpoint-port=22222 interface=wireguard-to-remote-site#1 \
persistent-keepalive=10s public-key=\
"xxxxxxxxxxxxxxxxxxxxxxxxxx="
add allowed-address=0.0.0.0/0 endpoint-address=\
187.122.133.145 endpoint-port=33333 interface=wireguard-to-remote-site#2 \
persistent-keepalive=10s public-key=\
"xxxxxxxxxxxxxxxxxxxxxxxxxx="
/ip firewall filter
add action=accept chain=input comment=\
"WireGuard Ports " dst-port=22222,33333 \
protocol=udp
add action=accept chain=input comment=\
"WireGuard Ports " src-port=22222,33333 \
protocol=udp
add action=accept chain=forward-from-wan \
dst-address=10.200.40.5 dst-port=4575
/ip firewall nat
add action=dst-nat chain=dstnat-services dst-port=\
4575 protocol=tcp to-addresses=10.200.40.5
FW 2
/interface ethernet
set [ find default-name=ether2 ] speed=100Mbps
/ip dhcp-client
add interface=ether2
/ip address
add address=10.20.200.2 interface=wireguard-to-main-site#1 network=10.20.200.1
add address=10.21.200.2 interface=wireguard-to-main-site#2 network=10.21.200.1
/interface wireguard
add listen-port=22222 mtu=1420 name=wireguard-to-main-site#1
add listen-port=33333 mtu=1420 name=wireguard-to-main-site#2
/interface wireguard peers
add allowed-address=0.0.0.0/0 endpoint-address=\
188.122.133.144 endpoint-port=22222 interface=wireguard-to-main-site#1 \
persistent-keepalive=10s public-key=\
"xxxxxxxxxxxxxxxxxxxxxxxxxx="
add allowed-address=0.0.0.0/0 endpoint-address=\
188.122.133.145 endpoint-port=33333 interface=wireguard-to-main-site#2 \
persistent-keepalive=10s public-key=\
"xxxxxxxxxxxxxxxxxxxxxxxxxx="
/ip firewall filter
add action=accept chain=forward comment=\
"natted from remote site" dst-address=10.200.40.5 \
dst-port=4575 log=yes log-prefix=inside protocol=tcp
add action=accept chain=input comment=\
"WireGuard Ports " dst-port=22222,33333 \
protocol=udp
add action=accept chain=input comment=\
"WireGuard Ports " src-port=22222,33333 \
protocol=udp
Internally we are able to connect to 10.200.40.5:4575 but from external connection arrives to firewall 2 but connection fails.
Sorry but had to edit and subtract from 1000 lines of code.. so if you need anything else just ask

thanks for helping.
Further find attachment of forwaded log from FW2.
You do not have the required permissions to view the files attached to this post.