So to the point, wireless on mesh is not working on version 7, I have a hAP ac2 I'm using for testing and notice the issue, currently the device is running 7.8, for testing as well I reset the device with no defaults ether1 was configured with DHCP client and mesh was created with both wireless cards and ether5 too for Internet on my PC (by cable).
So I have done this exactly as is showed here: https://help.mikrotik.com/docs/pages/vi ... Id=8978441
Repeat this configuration on all APs:
/interface mesh add disabled=no
/interface mesh port add interface=wlan1 mesh=mesh1
/interface mesh port add interface=wlan2 mesh=mesh1
# interface used for AP interconnections
/interface wireless set wlan1 disabled=no ssid=mesh frequency=2437 band=2.4ghz-b/g/n mode=ap-bridge \
wds-mode=static-mesh wds-default-bridge=mesh1
# interface used for client connections
/interface wireless set wlan2 disabled=no ssid=mesh-clients frequency=5180 band=5ghz-a/n/ac mode=ap-bridge
# a static WDS interface for each AP you want to connect to
/interface wireless wds add disabled=no master-interface=wlan1 name=<;descriptive name of remote end> \
wds-address=<;MAC address of remote end>
With this configuration I'm able to get Internet on my PC by cable, but for example my phone is unable to get connected to wireless, it doesn't matter if I try wlan1 or wlan2 is not getting connected any way, here is the full configuration done:
Code: Select all
/interface wireless
set [ find default-name=wlan2 ] band=5ghz-a/n/ac disabled=no mode=ap-bridge \
ssid=mesh-clients
/interface mesh
add name=mesh1
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=2437 \
mode=ap-bridge ssid=mesh wds-default-bridge=mesh1 wds-mode=dynamic-mesh
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp_pool0 interface=mesh1 name=dhcp1
/ipv6 settings
set disable-ipv6=yes
/interface mesh port
add interface=wlan1 mesh=mesh1
add interface=wlan2 mesh=mesh1
add interface=ether5 mesh=mesh1
/ip address
add address=192.168.88.1/24 interface=mesh1 network=192.168.88.0
/ip dhcp-client
add interface=ether1
/ip dhcp-server network
add address=192.168.88.0/24 gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
/system clock
set time-zone-name=America/Costa_Rica
After this I have been downgrading software with several versions, so I started on 7.8 and went down up to 7.1 and wireless still not working, but as soon as I downgrade to 6.49.7 (keeping same configuration previously shared without any modifications),
, wireless starts working, my phone can get connected properly to wlan1 or wlan2, it gets IP from the DHCP Server with no problems at all, but with any of the version 7 it just not works... If someone has found something, or if there is any modification that I'm not awared that has changed between v6 and v7 please let me know. Thanksvoilà