I tried using 2.4 GHz
I tried with 2.4 GHz completely disabled.I tried using 2.4 GHz
Unlike ax, ac isn't defined for both 2.4 and 5GHz. You would have fallen down to "n" at best. If it fell down to "g" instead, that would explain your speeds.
Assuming both radios are using the same SSID, I'd try turning on FT mode on them both, giving the laptop its best chance to use its ac capabilities on the 5GHz bands. Otherwise, it is likely to decide the 2.4 GHz band is more powerful, thus a "better" choice.
If that doesn't help, post your wifi configuration. Let's work from data, not guesses, okay?
/interface/wifi/export
/interface wifi configuration
add channel.skip-dfs-channels=10min-cac country="United States" mode=ap name=nunyabinness \
security.authentication-types=wpa2-psk,wpa3-psk .ft=yes .ft-over-ds=yes ssid="Nunya Binness"
/interface wifi
set [ find default-name=wifi1 ] channel.band=5ghz-ax .width=20/40/80mhz configuration=nunyabinness
set [ find default-name=wifi2 ] channel.band=2ghz-ax .width=20/40mhz configuration=nunyabinness
I repeat: show your configuration.
[admin@MikroTik] /interface/wifi/configuration> print
Flags: X - disabled
0 name="cfg1" mode=ap ssid="**ELIDED**" country=Switzerland
security.authentication-types=wpa2-psk,wpa3-psk .group-key-update=30m .passphrase="**ELIDED**" .ft=yes .ft-mobility-domain=0x222 .connect-priority=0
datapath.bridge=bridge1 .vlan-id=1
steering=steering1
steering.neighbor-group=dynamic-home-6185ac38 .rrm=yes .wnm=yes
root@asus:~# iwconfig
lo no wireless extensions.
wlan0 IEEE 802.11 ESSID:"**ELIDED**"
Mode:Managed Frequency:5.2 GHz Access Point: **ELIDED**
Bit Rate=351 Mb/s Tx-Power=13 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=47/70 Signal level=-63 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:119 Missed beacon:0
admin@MikroTik] /interface/wifi/actual-configuration> print
0 name="wifi1-5G" l2mtu=1560 mac-address=**ELIDED** arp-timeout=auto radio-mac=**ELIDED**
configuration.mode=ap .ssid="**ELIDED**" .country=Switzerland .tx-power=15
security.authentication-types=wpa2-psk,wpa3-psk .group-key-update=30m .passphrase="**ELIDED**" .ft=yes .ft-mobility-domain=0x222 .connect-priority=0
datapath.bridge=bridge1 .vlan-id=1
channel.frequency=5000-5200
steering.neighbor-group=dynamic-home-6185ac38 .rrm=yes .wnm=yes
1 name="wifi2-2G" l2mtu=1560 mac-address=**ELIDED** arp-timeout=auto radio-mac=**ELIDED**
configuration.mode=ap .ssid="**ELIDED**" .country=Switzerland .tx-power=5
security.authentication-types=wpa2-psk,wpa3-psk .group-key-update=30m .passphrase="**ELIDED**" .ft=yes .ft-mobility-domain=0x222 .connect-priority=0
datapath.bridge=bridge1 .vlan-id=1
channel.width=20mhz
steering.neighbor-group=dynamic-home-6185ac38 .rrm=yes .wnm=yes
[/code}
My laptop has one single USB C port and I can't find a small USB C WiFi 6 dongle. I don't want to use an adapter. I want something small and unobtrusive, that won't break if I apply some force.One of the reasons I suggested using an /export command instead of /print is that it suppresses sensitive info like your WiFi password by default. I've edited that out of your postings above, but you can't count on us moderators to backstop you like that every single time.
Other than local details like that, I see no meaningful difference between your configuration and mine. You could let some of the values go to defaults instead of the local overrides you have — e.g. I see no reason to override the default mobility domain value on a simple home WiFi gateway setup — but I don't see that that would change anything.
You wanted a new 802.11ax WiFi dongle anyway, right?![]()
WiFi 6, lightweight, touchscreen, works well with linux, very long battery life, and cheap enough that I don't worry of it being stolen or damaged.
I tried booting windows 10 from a usb disk to see what happens. Got 170 Mbps.WiFi 6, lightweight, touchscreen, works well with linux, very long battery life, and cheap enough that I don't worry of it being stolen or damaged.
Sounds like a mid-range Chromebook. Mine manages to push 180 Mbit/sec to the Internet through the ax³ from a few rooms away. It's a 2021 model, so one hopes a current model will do better.
Ironically, this one appears to have a Realtek WiFi 6 radio inside. Difference being, Google has a big, weighted bat to swing around, allowing it to get Linux compatibility issues solved.
Well, the OP reported that even on his Linux, but on non-Mikrotik based wi-fi it works as well fast enough, so there must be some Mikrotik specific setting that is not compatible with the laptop setup/drivers/whatever or viceversa something in the laptop setup/drivers/whatever that is not compatible with Mikrotik (default) settings.So title should be changed to "Chromebook with RTL8821CE = bad wifi speed but works normal using Windows"
This is no Mikrotik problem.
I was just trying to remember what gave me so much trouble, just dug it out to take a pic.....Put the realtek in the real garbage.............
A different distro should then also use that same 2020 driver in order to compare apples to apples (yeah, used that one on purposeI don't think that a different distro, likely using the same rtw88_8821ce driver, ...
That did it. Using driver rtl8821ce instead of rtw88_8821ce.
So maybe the 180-190 is like the max speed available on that notebook?Edit: using TX power 10 dBm (on the laptop) I got 180 Mbps download and 97 Mbps upload. My WAN is 1 Gbps download and 100 Mbps upload.
That's how I measured the download speed.When testing with iperf3: don't forget to test with "-R" flag too. This way the iperf3 server sends data to the client, meaning you are benchmarking AP download speed to client. without -R flag you measure the client UPLOAD performance, which is wayyyyyy limited by client device antenna/driver/hardware. And I have one Intel AX200 card running on Manjaro Linux as well, and that driver or card is a bit*h. Upload is a subpar (high retransmission rate).
ax200, 201, 210 and 211 cards are regularly downloading + uploading over 700Mbit/s from AX3 on Windows 10/11 from internet, not on local network with iptraf tests (=that must be more.
Even shitty Realtek AX wifi cards can do that. I suspect those linux drivers and/or plethora of configuration options either on Linux side, or Mikrotik.
It's not sufficient just to configure 80MHz and expect miracles.
You wrote something about 10dBi antennas. Are those Mikrotik standard ? My personal experience : when I replaced original AX3 antennas with "bigger better stronger" DLink 9dbi models (something like https://www.ebay.com/itm/112387385667 ) the real throughput was decreased by 50%. Those antennas are simply trash. I didn't change anything in configuration, just replaced antennas.
I think the same really applies to your 10dBi antennas.
Next, turn down 20dBm power on laptop : you don't need that and it's harmful for ISI (intersymbol interference) of wifi. RECEIVE LEVELS OVER -50DBM UNNECESSARILY OVERLOAD ANALOG AMPLIFIERS AND MAKE YOUR THROUGHPUT WORSE, WHILE SHORTENING LIFESPAN OF YOUR DEVICES. It's too much noise, not too much music. That's a difference. You don't need -31dBm receive signal, you don't want it. IT'S BAD.
Take it slow. Keep it simple. No datapath. No steering. Nothing. WHO ADVICED YOU FREQUENCIES 5000-5200 ? Why 5000 ? No radio, no antenna, no device has been tuned to use that, not talking about AX200 unable to use those frequencies. You don't need anything less than 5160. You should not try to use.
Greetings to beautiful Alpine country !
Empirical testing of maxim eleven?Good news, the laptop fell from 2 meters and got completely destroyed.
I tested the antenna with a VNA and I can confirm that it's radiating well. As for directionality, I haven't tested that extensively but the antenna is directional and none of the signal makes it outside the house.>> I'm using the Alfa 10 dBi directional https://www.alfa.com.tw/products/apa-m2 ... 1664232520
I'm pretty sure this antenna is the reason for your low and erratic throughput.