-----
Hi,
I am trying to set up two hAP ax2 APs via CAPsMAN.
I have followed the Wiki and to some extent also mirrored the previous configurations I did with "legacy" CAPsMAN (with several working deployments).
The issue I have is that one of the APs (which also acts as the router for the network) won't provision its own Wi-Fi interfaces. In WinBox I can see that the interfaces are indeed recognized by CAPsMAN but won't get any SSID.
The other AP (standalone) gets provisioned just fine.
I tried setting up provisioning rules in a generic way (without a specific MAC address) which provisions the standalone AP just fine. Adding specific rules for the MAC addresses of the Wi-Fi Interfaces on the router didn't help.
I have also tried disabling the firewall just to make sure nothing is getting in the way of local provisioning, that didn't help either though.
Any idea what might be wrong?
Both APs have RouterOS 7.9 installed.
The configs of the router / AP:
Code: Select all
/interface/wifiwave2/export
# may/16/2023 09:33:18 by RouterOS 7.9
# software id = NV1W-R82C
#
# model = C52iG-5HaxD2HaxD
/interface wifiwave2
# managed by CAPsMAN
set [ find default-name=wifi1 ] configuration.manager=capsman .mode=ap disabled=no
# managed by CAPsMAN
set [ find default-name=wifi2 ] configuration.manager=capsman .mode=ap disabled=no
/interface wifiwave2 datapath
add bridge=bridge-internal client-isolation=no disabled=no interface-list=LAN name=datapath-internal
add bridge=bridge-guests client-isolation=yes disabled=no interface-list=LAN name=datapath-guests
/interface wifiwave2 security
add authentication-types=wpa2-psk disabled=no name=security-internal
add authentication-types=wpa2-psk disabled=no name=security-guests
/interface wifiwave2 configuration
add country=Czech datapath=datapath-internal disabled=no mode=ap name=config-internal security=security-internal ssid=CompanyName
add country=Czech datapath=datapath-guests disabled=no mode=ap name=config-guests security=security-guests ssid=CompanyName-Guests
/interface wifiwave2
add configuration=config-internal disabled=no name=cap-wifi1
add configuration=config-guests disabled=no mac-address=XX:XX:XX:XX:XX:X1 master-interface=cap-wifi1 name=cap-wifi2
add configuration=config-internal disabled=no name=cap-wifi3
add configuration=config-guests disabled=no mac-address=XX:XX:XX:XX:XX:X2 master-interface=cap-wifi3 name=cap-wifi4
/interface wifiwave2 cap
set caps-man-addresses=127.0.0.1 enabled=yes
/interface wifiwave2 capsman
set enabled=yes package-path="" require-peer-certificate=no upgrade-policy=none
/interface wifiwave2 provisioning
add action=create-enabled disabled=no master-configuration=config-internal slave-configurations=config-guests
add action=create-enabled disabled=yes master-configuration=config-internal radio-mac=YY:YY:YY:YY:YY:Y1 slave-configurations=config-guests
add action=create-enabled disabled=yes master-configuration=config-internal radio-mac=YY:YY:YY:YY:YY:Y2 slave-configurations=config-guests
Any help is appreciated.
Thanks!
-----
Notes:
1) XX:XX:XX:XX:XX:X1 and XX:XX:XX:XX:XX:X2 are MAC addresses of the standalone AP Wi-Fi interfaces
2) YY:YY:YY:YY:YY:Y1 and YY:YY:YY:YY:YY:Y2 are MAC addresses of the main router / AP Wi-Fi Interfaces (i.e. those which are not being provisioned)