Hello, I need to configure recursive routes within vrf but when doing check gateway it crashes.
/interface list
add name=wans
/ip pool
add name=dhcp_pool1 ranges=192.168.32.2-192.168.32.254
/ip dhcp-server
add address-pool=dhcp_pool1 disabled=no interface=ether4 name=dhcp1
/tool user-manager customer
set admin access=\
own-routers,own-users,own-profiles,own-limits,config-payment-gw
/interface list member
add interface=ether1 list=wans
add interface=ether2 list=wans
add interface=ether3 list=wans
/ip address
add address=192.168.17.2/24 interface=ether1 network=192.168.17.0
add address=192.168.17.3/24 interface=ether2 network=192.168.17.0
add address=192.168.17.4/24 interface=ether3 network=192.168.17.0
add address=192.168.32.1/24 interface=ether4 network=192.168.32.0
/ip dhcp-server network
add address=192.168.32.0/24 gateway=192.168.32.1
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip firewall mangle
add action=mark-connection chain=prerouting connection-state=new \
in-interface=ether1 new-connection-mark=linea_1 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new \
in-interface=ether2 new-connection-mark=linea_2 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new \
in-interface=ether3 new-connection-mark=linea_3 passthrough=yes
add action=mark-routing chain=output connection-mark=linea_1 \
new-routing-mark=to_linea1 passthrough=yes
add action=mark-routing chain=output connection-mark=linea_2 \
new-routing-mark=to_linea2 passthrough=yes
add action=mark-routing chain=output connection-mark=linea_3 \
new-routing-mark=to_linea3 passthrough=yes
add action=mark-connection chain=prerouting connection-state=new \
dst-address-type=!local in-interface=ether4 new-connection-mark=linea_1 \
passthrough=yes per-connection-classifier=both-addresses:3/0
add action=mark-connection chain=prerouting connection-state=new \
dst-address-type=!local in-interface=ether4 new-connection-mark=linea_2 \
passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=prerouting connection-state=new \
dst-address-type=!local in-interface=ether4 new-connection-mark=linea_3 \
passthrough=yes per-connection-classifier=both-addresses:3/2
add action=mark-routing chain=prerouting connection-mark=linea_1 \
in-interface=ether4 new-routing-mark=to_linea1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=linea_2 \
in-interface=ether4 new-routing-mark=to_linea2 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=linea_3 \
in-interface=ether4 new-routing-mark=to_linea3 passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface-list=wans
/ip route
add check-gateway=ping distance=1 gateway=1.0.0.1 routing-mark=to_linea2
add distance=1 dst-address=1.0.0.1/32 gateway=192.168.17.1 routing-mark=\
to_linea2 scope=10
add check-gateway=ping distance=1 gateway=9.9.9.9 routing-mark=to_linea3
add distance=1 dst-address=9.9.9.9/32 gateway=192.168.17.1 routing-mark=\
to_linea3 scope=10
add check-gateway=ping distance=1 gateway=4.2.2.1
add distance=1 dst-address=4.2.2.1/32 gateway=192.168.17.1 scope=10
/ip route vrf
add interfaces=ether2 routing-mark=to_linea2
add interfaces=ether3 routing-mark=to_linea3
/system identity
set name=balancer
please help.