What initially set me off on this parh was that i was having trouble with my main ISP so i wanted to be able to have a failover to my mobile hotspot in case i needed to access the internet while the main ISP was down.
I had found this article which shows how to do one part of the setup, specifically the wifi bridge to the AP;
https://sanisimov.com/2019/02/connect-m ... iguration.
This is designed with the older RouterOS6 so its a bit different now in RouterOS7
After some time i finally was able to spend the time to figure this out - it is relatively simple once you understand the networking, Here is the main points of my config for the hAP ax2
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp interface=bridge name=defconf
/interface bridge port
add bridge=bridge interface=ether2 internal-path-cost=10 path-cost=10
add bridge=bridge interface=ether3 internal-path-cost=10 path-cost=10
add bridge=bridge interface=ether4 internal-path-cost=10 path-cost=10
add bridge=bridge interface=ether5 internal-path-cost=10 path-cost=10
add bridge=bridge interface=WiFi_2.4G internal-path-cost=10 path-cost=10
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface detect-internet
set detect-interface-list=all
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=WiFi_5G list=WAN
/ip address
add address=192.168.88.1/24 comment="Bridge to Main Router" interface=bridge \
network=192.168.88.0
/ip dhcp-client
add comment="This is the DHCP Client to access the 5GHz AP - ie the source wif\
i connection - This connection will be invalid if not connected to the AP" \
interface=WiFi_5G
add address=192.168.88.0/24 comment=defconf dns-server=192.168.88.1 gateway=\
192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip route
add comment="Return path to Lan_Primary" disabled=no dst-address=\
192.168.10.0/24 gateway=192.168.88.1 routing-table=main \
suppress-hw-offload=no
The basic setup is setting the LAN ports (optionally add wifi_2.4 ) as a bridge, define a static IP of 192.168.88.1 on an interface (int2 in my case) , set the 5Ghz in station mode, and then join the AP of your secondary WAN. Once connected you can confirm that you have internet access through that connection. Then set a static route back to your main router LAN IP range using the interface IP on the hAP, again my case it is 192.168.88.1
Next on the main router i configured a static IP of 192.168.88.2 on int1(eth1), connect int1 (main router) to int2 on hAP and verify that you can ping both sides of the connection. Finally add an second internet route in the main router with a higher distance out to the internet using the IP of the hAP (in my case 192.168.88.1).
I made the mistake of using the IP on the main router, 192.168.88.2, as the gateway but in reflection it is the source IP and not the gateway.
Here's what the diagram looks like and i hope this helps anyone figure out this type of setup;
You do not have the required permissions to view the files attached to this post.