Community discussions

MikroTik App
 
kolinsb
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sat Jun 30, 2007 7:22 pm

bandwidth dinamic limiting

Mon Dec 31, 2007 7:49 pm

hi ppl :) i need some help. i have one small network, with 35 comp's. i have one dhcp server, and all comp's getting static ip address, gateway and dns address. comp's getting internet above gateway, no pppoe server, no hotspot, only NAT. each comp has own queue for bandwidth limiting. i wanna to do next thing: first megabyte of all connection has bandwidth down=upl=256kbps. after this first megabyte of each connection, i wanna to reduce speed on upload=download=64kbps for each connection. i hope so, that i well explained that what i would to do :)
 
User avatar
ashish
Long time Member
Long time Member
Posts: 546
Joined: Mon Feb 12, 2007 5:50 am
Location: Virginia, USA.

Re: bandwidth dinamic limiting

Tue Jan 01, 2008 6:48 am

I dont understand...what u want..
 
kolinsb
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sat Jun 30, 2007 7:22 pm

Re: bandwidth dinamic limiting

Tue Jan 01, 2008 3:50 pm

when i connect on some web page, and start to download some file of 10MB with download speed 256kbps, and when i take first MB of that file, i wanna then to increase download speed on 64kbps.
first MB download speed=256kbps
rest of 9MB download speed=64kbps
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1495
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: bandwidth dinamic limiting

Tue Jan 01, 2008 5:06 pm

You can do queue bursting for this but you would have to set it for time not size I believe.
 
kolinsb
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 63
Joined: Sat Jun 30, 2007 7:22 pm

Re: bandwidth dinamic limiting

Tue Jan 01, 2008 5:45 pm

pls, i need help, please :( i can't to do that myselfe :( i need help step by step, if is that posible
or, if is posible on this way: first 20 seconds down speed=256kbps, and rest of time down speed=64kbps, for each new connection.
 
User avatar
jwcn
Forum Guru
Forum Guru
Posts: 1495
Joined: Sun Aug 27, 2006 6:49 am
Location: Maryland, USA
Contact:

Re: bandwidth dinamic limiting

Wed Jan 02, 2008 12:22 am

Read the queue section of the manual. Then post specific questions.
 
InoX
Forum Guru
Forum Guru
Posts: 1966
Joined: Tue Jan 09, 2007 6:44 pm

Re: bandwidth dinamic limiting

Wed Jan 02, 2008 12:56 am

USe queues with burst. But burst is determined by time not by the filesize. For example if someone download a file, he will start download with 1mbps (for 10sec) and after that 10sec(or how many you want) the speed will drop to another value set by you.
 
aldalil
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Mon Jun 25, 2007 3:43 am

Re: bandwidth dinamic limiting

Mon Jan 21, 2008 4:20 am

1- To limit the bandwidth per usage, use the following script:
:local traf;
/queue simple
:for i from=1 to= 254 do = {
:if ([/queue simple find target-addresses=("192.168.1." . $i)] != "") do={
:set traf [get [find target-addresses=("192.168.1." . $i)] total-bytes]
:if ($traf > 104857600) do = {
set [find target-addresses=("192.168.1." . $i)] max-limit= 64000/64000
}
}
}

Tune it to your network special values (IP address=192.168.1.1-192.168.1.254 & traffic= 104857600), read this for more info: http://wiki.mikrotik.com/wiki/Limiting_ ... traffic_II

2- For limiting the bandwidth per time, just use the simple queue option like:
Burst limit: 256k
Burst Threshold: 64k
Burst Time: 20