Today I solved my problem.
I contacted Starlink support and they queried the captured DHCPv6 and RA messages. Everything was fine. So I looked deeper.
The problem was either my click-through or a change in the new version of RouterOS - in the IPv6 settings, "IPv6 forwarding" was enabled and at the same time "Accept Router Advertisements: yes if forwarding disabled" was selected. So my router ignored SLAAC and didn't get the address from the prefix the gateway router was in.
In short:
DHCPv6 Client will ask for a prefix and set the default route. This is how LAN clients get IPv6 addresses.
The router itself gets the address via SLAAC - in "IPv6 Settings" it must be set to accept Router Advertisements (=yes).
Last but not least, ICMPv6 and incoming UDP packets on ports 546-547 (DHCPv6) must be enabled on the IPv6 firewall.
/ipv6 dhcp-client
add add-default-route=yes interface="ether1 - Starlink" pool-name=pool6 request=prefix use-interface-duid=yes use-peer-dns=yes
/ipv6 address
add address=::1 from-pool=pool6 interface=bridge
/ipv6 nd
set [ find default=yes ] advertise-dns=no advertise-mac-address=no disabled=yes hop-limit=64 mtu=1280 other-configuration=yes
add advertise-mac-address=no interface=bridge other-configuration=yes
/ipv6 nd prefix default
set preferred-lifetime=10m valid-lifetime=15m
/ipv6 settings
set accept-router-advertisements=yes max-neighbor-entries=8192
/ipv6 firewall filter
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment=DHCPv6 protocol=udp src-port=546-547