Hello mrz!
I will post entire configurations of both routers and here it is.
# ROUTER1
/interface bridge
add name=loopback0 protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether2 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether3 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether4 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether5 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
/routing ospf instance
add disabled=no name=ospf-instance-v2 router-id=10.0.0.1
/routing ospf area
add comment=backbone_v2 disabled=no instance=ospf-instance-v2 name=area0
/ip address
add address=10.0.0.1 interface=loopback0 network=10.0.0.1
add address=192.168.1.1/30 comment=to-r4 interface=ether1 network=192.168.1.0
add address=192.168.2.1/30 comment=to-r3 interface=ether2 network=192.168.2.0
add address=192.168.0.1/30 comment=to-r2-rr interface=ether3 network=192.168.0.0
/ip dhcp-client
add interface=ether1
/ip firewall address-list
add address=192.168.0.0/16 list=bfd-allowed
add address=10.0.0.0/24 list=bfd-allowed
/routing bfd configuration
add address-list=bfd-allowed disabled=no forbid-bfd=no interfaces=all
/routing bgp connection
add as=65000 cluster-id=1.1.1.1 connect=yes listen=yes local.address=10.0.0.1 \
.role=ibgp name=to-r2-rr remote.address=10.0.0.2 .as=65000 router-id=10.0.0.1 \
use-bfd=yes
add as=65000 connect=yes listen=yes local.address=10.0.0.1 .role=ibgp-rr name=\
to-r3-rr-client remote.address=10.0.0.3 .as=65000 router-id=10.0.0.1 use-bfd=\
yes
add as=65000 connect=yes listen=yes local.address=10.0.0.1 .role=ibgp-rr name=\
to-r4-rr-client remote.address=10.0.0.4 .as=65000 router-id=10.0.0.1 use-bfd=\
yes
/routing ospf interface-template
add area=area0 disabled=no interfaces=loopback0 passive type=ptp
add area=area0 disabled=no interfaces=ether1 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether2 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether3 type=ptp use-bfd=yes
/system identity
set name=R1
[admin@R1] > routing/bfd/session/print
Flags: U - up, I - inactive
0 I ;;; BFD forbidden for destination address
multihop=yes vrf=main remote-address=10.0.0.2 local-address=10.0.0.1
desired-tx-interval=0ms required-min-rx=0ms multiplier=0
1 I ;;; BFD forbidden for destination address
multihop=yes vrf=main remote-address=10.0.0.3 local-address=10.0.0.1
desired-tx-interval=0ms required-min-rx=0ms multiplier=0
2 I ;;; BFD forbidden for destination address
multihop=yes vrf=main remote-address=10.0.0.4 local-address=10.0.0.1
desired-tx-interval=0ms required-min-rx=0ms multiplier=0
3 U multihop=no vrf=main remote-address=192.168.1.2%ether1
local-address=192.168.1.1%ether1 state=up state-changes=2 uptime=5m59s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s
packets-rx=2082 packets-tx=2684
4 U multihop=no vrf=main remote-address=192.168.2.2%ether2
local-address=192.168.2.1%ether2 state=up state-changes=2 uptime=5m8s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s
packets-rx=1786 packets-tx=2442
5 U multihop=no vrf=main remote-address=192.168.0.2%ether3
local-address=192.168.0.1%ether3 state=up state-changes=1 uptime=14m42s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s
packets-rx=5123 packets-tx=5124
#ROUTER2
/interface bridge
add name=loopback0 protocol-mode=none
/interface ethernet
set [ find default-name=ether1 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether2 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether3 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether4 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
set [ find default-name=ether5 ] advertise=10M-half,10M-full,100M-half,100M-full \
disable-running-check=no
/routing ospf instance
add disabled=no name=ospf-instance-v2 router-id=10.0.0.2
/routing ospf area
add comment=backbone_v2 disabled=no instance=ospf-instance-v2 name=area0
/ip address
add address=10.0.0.2 interface=loopback0 network=10.0.0.2
add address=192.168.4.1/30 comment=to-r3 interface=ether1 network=192.168.4.0
add address=192.168.3.1/30 comment=to-r4 interface=ether2 network=192.168.3.0
add address=192.168.0.2/30 comment=to-r1-rr interface=ether3 network=192.168.0.0
/ip dhcp-client
add interface=ether1
/ip firewall address-list
add address=192.168.0.0/16 list=bfd-allowed
add address=10.0.0.0/24 list=bfd-allowed
/routing bfd configuration
add address-list=bfd-allowed disabled=no forbid-bfd=no interfaces=all
/routing bgp connection
add as=65000 cluster-id=1.1.1.1 connect=yes listen=yes local.address=10.0.0.2 \
.role=ibgp name=to-r1-rr remote.address=10.0.0.1 .as=65000 router-id=10.0.0.2 \
use-bfd=yes
add as=65000 connect=yes listen=yes local.address=10.0.0.2 .role=ibgp-rr name=\
to-r3-rr-client remote.address=10.0.0.3 .as=65000 router-id=10.0.0.2 use-bfd=\
yes
add as=65000 connect=yes listen=yes local.address=10.0.0.2 .role=ibgp-rr name=\
to-r4-rr-client remote.address=10.0.0.4 .as=65000 router-id=10.0.0.2 use-bfd=\
yes
/routing ospf interface-template
add area=area0 disabled=no interfaces=loopback0 passive type=ptp
add area=area0 disabled=no interfaces=ether1 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether2 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether3 type=ptp use-bfd=yes
/system identity
set name=R2
[admin@R2] > routing/bfd/session/print
Flags: U - up, I - inactive
0 I ;;; BFD forbidden for destination address
multihop=yes vrf=main remote-address=10.0.0.1 local-address=10.0.0.2
desired-tx-interval=0ms required-min-rx=0ms multiplier=0
1 I ;;; BFD forbidden for destination address
multihop=yes vrf=main remote-address=10.0.0.3 local-address=10.0.0.2
desired-tx-interval=0ms required-min-rx=0ms multiplier=0
2 I ;;; BFD forbidden for destination address
multihop=yes vrf=main remote-address=10.0.0.4 local-address=10.0.0.2
desired-tx-interval=0ms required-min-rx=0ms multiplier=0
3 U multihop=no vrf=main remote-address=192.168.4.2%ether1
local-address=192.168.4.1%ether1 state=up state-changes=2 uptime=16m21s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s
packets-rx=5701 packets-tx=6501
4 U multihop=no vrf=main remote-address=192.168.3.2%ether2
local-address=192.168.3.1%ether2 state=up state-changes=2 uptime=17m12s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s
packets-rx=5991 packets-tx=6728
5 U multihop=no vrf=main remote-address=192.168.0.1%ether3
local-address=192.168.0.2%ether3 state=up state-changes=2 uptime=25m56s
desired-tx-interval=200ms actual-tx-interval=200ms required-min-rx=200ms
remote-min-rx=200ms remote-min-tx=200ms multiplier=5 hold-time=1s
packets-rx=9030 packets-tx=9035
Adding and specifying allowed address-list under bfd configuration doesn't help neither
But when i configure bgp session with ip which is configured directly on interface, the bgp and bfd is up
Show your bfd config.