/system package uninstall wifi-qcom
/tool/fetch url="https://upgrade.mikrotik.com/routeros/7.12/wifiwave2-7.12-arm.npk"
/tool/fetch url="https://upgrade.mikrotik.com/routeros/7.12/routeros-7.12-arm.npk"
/system package downgrade
- I believe @DanMos79 is asking for an alternative DIY wireless card compatible with WifiWave2 drivers for RB4011, if available in the market.
- Just a confirmation, if I update from 7.12 to 7.13 an hAP ac2 with old Wireless driver, will have the new "wireless-7.13...-arm" package installed, not "wifi-qcom-ac-7.13...-arm", right?
- Also noticed that if anyone has scripts for devices configuration, /interface/wifiwave2 is now /interface/wifi
I´ve updated my wAP AC with the wifi-qcom-ac package and the main ROS 7.13Beta1 package.
All went smooth and the change to my CAPsMAN-AX also went well.
But I get some strange error messages in the CAPsMAN AX for the AC-device:
Is it required to update the CAPsMAN AX to 7.13 Beta1 also to make it work?
https://help.mikrotik.com/docs/display/ ... stfeaturesNstreme and Nv2 wireless protocols
VLAN configuration in the wireless settings (Per-interface VLANs can be configured in bridge settings)
Compatibility with station-bridging as implemented in the 'wireless' package
/system/package/update> install
channel: testing
installed-version: 7.12
latest-version: 7.13beta1
status: wifi-qcom-ac-7.13beta1-arm64.npk missing, use ignore-missing or disable package(s)
Thanks for the reply, but I don´t understand what that exactly means? Maybe you can explain?I´ve updated my wAP AC with the wifi-qcom-ac package and the main ROS 7.13Beta1 package.
All went smooth and the change to my CAPsMAN-AX also went well.
But I get some strange error messages in the CAPsMAN AX for the AC-device:
Is it required to update the CAPsMAN AX to 7.13 Beta1 also to make it work?
Documentation states this:
https://help.mikrotik.com/docs/display/ ... stfeaturesNstreme and Nv2 wireless protocols
VLAN configuration in the wireless settings (Per-interface VLANs can be configured in bridge settings)
Compatibility with station-bridging as implemented in the 'wireless' package
I think you might have omitted the new VLAN configuration.
{
:local arr {a=1;b="abc"}
:local json [:serialize $arr to=json]
:local arrFromJson [:deserialize $json from=json]
:put "serialized json: $json"
:put "deserialized json:"
:put $arrFromJson
:put "type of deserialized json: $[:typeof $arrFromJson]"
}
/interface/print | grep anything
show run | utility egrep ....
After over an hour of extensive testing, forcing key renegotiation every 60 seconds, I can state that the memory leak issue related to OpenVPN key renegotiation has been fixed. Thanks to the Mikrotik team and to Oskars who responded to my support ticket regarding this problem.*) ovpn - improved memory allocation during key-renegotiation;
:grep script="system clock print" pattern=".*"
Why? NAT-PMP was already obsoleted by RFC6887. It would've made more sense to implement PCP, which is also usable in 464xlat, NAT64 and MAP-T.*) firewall - added "nat-pmp" support;
Already included in 7.12.still no ed25519 private key for ssh?
There is no "pipe" as it the CLI isn't a Bourne-based shell, that part is to be expected...Grep is nice, but please make it as a pipe argument. Like
Code: Select all/interface/print | grep anything
It seems what is happening here is that "wireless" was part of the "routeros" package in versions 7.x up to 7.12, and when you now upgrade to 7.13beta it doesn't bother to check if you were really using any wireless functions, and just installs the "wireless" package that has now become separate.I don't think it's a good idea to automatically install wireless package on chr. Having multiple WiFi / Wireless menus in winbox after installing the wireless package is extremely confusing.
+1, it's a mess currentlyI welcome the partial split into separate packages as we knew it in v6, but maybe the "WiFi" menu should go into a separate "wifi" package so we can uninstall that as well.
Handling of output and redirection has always been funky... hopefully they will now sit down and fix that.But I would have guess the command is:
:grep [/interface/print as-value] pattern=".*"
but that actually causes the console to CRASH — with the ".*", just using "." works without a crash.
Ignoring the ".*" crash, :grep is still pretty funky in how it work AFAIK... e.g. :grep runs a command provided and uses the terminal output from that command based on pattern=... So while this works to search the command's output, and prints the results to terminal (without a pipe needed & there is "as-array" options to use in script)
:grep "/interface/print" pattern="."
The new serialize and previous :convert fit nicely. But :grep seem askew from RouterOS CLI "philosophy" POV – e.g. everything is already key-values tables and there [:find] to search command output.That really should be cleaned up!
That's a question of a few lines code :-)There is no "pipe" as it the CLI isn't a Bourne-based shell, that part is to be expected...
Yeah, that is what Cisco also did when extending their IOS that way. Although the called it "include" rather than "grep".That's a question of a few lines code :-)There is no "pipe" as it the CLI isn't a Bourne-based shell, that part is to be expected...
The biggest advantage is that you can attach "| grep" to any command, which is more pleasant than surround a grep string around the command.
Unfortunately, it is not possible. If you need both - use wireless.npk. If you are satisfied with using just 5 GHz, then wifi-qcom-ac will work for you. Functionality in wifi (old wifiwave2) that has been changed is described in the changelog. Still, wifi package does not include drivers for RB4011 2 GHz wifi.
Yeah, that is what Cisco also did when extending their IOS that way. Although the called it "include" rather than "grep".
#sh run | utility ?
cut Cut out selected fields of each line of a file
egrep Extended regular expression grep
fgrep Fixed string expression grep
head Show set of lines/characters from the top of a file
less Fixed string pattern matching
more Paging Utility More
no-more Disable Paging Utility More
script Launch a script for post processing
sign Sign the CLI output with enrolment key
sort Sort, merge, or sequence-check text files
tail Copy the last part of files
uniq Report or filter out repeated lines in a file
wc Counting lines/words/characters of a file
xargs Construct argument list(s) and invoke a program
+1Just curious, since I think this release says both versions of wireless and wifi (formerly wave2) are now supported side by side, why can't the 2ghz radio continue to operate on the older driver and the 5ghz radio operate on the new driver? It would seem that to be the ideal balance of support & features.
For login? That has been added with 7.12.still no ed25519 private key for ssh?
Sacrilegious! ;) I personally use RouterOS over Linux since I like everything has a schema/tables and syntax is typed and regularized. RouterOS is more "nothing is a file", than the UNIX "everything is a file". And I'm not sure Cisco IOS is a great model to follow either.On XR, apart from include/exclude, there's "utility" which allows you to pipe through the most important linux commands:
I have the old wap-ac (qca9550L), seems it is not supported. Wifi-interfaces can´t be setup.Does new wireless drivers suport QCA9556?(wap ac)?
Wave 2 driver for ipq4xxx ?!Yes, WPA3 on AC devices, etc. Also old and new type of CAPsMAN can be managed on the same router. Not as a unified mechanism, but two separate and parallel systems on the same router.
oh god no!! I am still recovering from nat-ein, which gave me severe depression and life-crisis...*) firewall - added "nat-pmp" support;
Do you have the new version wAPac with an arm CPU?OMFG!!!! I had to check it out before believing - 5009 as wifi capsman, 2x cap ax and now 3x wap ac, all in the same capsman - FINALLLY!!!
working without issues, had to manually uninstall old wireless package after check for upgrade.
- I believe @DanMos79 is asking for an alternative DIY wireless card compatible with WifiWave2 drivers for RB4011, if available in the market.
Does new wireless drivers suport QCA9556?(wap ac)?
The wifi-qcom-ac-7.13beta1-arm.npk package contains drivers for IPQ4019 and QCA9984 (4011) onlyqrt-ac with 128mb...
…
What's new in 7.13beta1 (2023-Nov-09 13:15):
…
…
…
…
…
…
Can you tell me if this router is going to receive ability to handle future PCI AX wifi card by Mikrotik? I brought one but I'm disappointed WifiWave2 is not usable for the 2.4Ghz network. Can you give more information please ?Unfortunately, it is not possible. If you need both - use wireless.npk. If you are satisfied with using just 5 GHz, then wifi-qcom-ac will work for you. Functionality in wifi (old wifiwave2) that has been changed is described in the changelog. Still, wifi package does not include drivers for RB4011 2 GHz wifi.
Found it in the wiki:Do devices running the new wifi-qcom-ac package still have the old wifiwave2 limitation where VLANs couldn't be configured?
802.11ac chipsets do not support this type of VLAN tagging (vlan-id), but they can be configured as VLAN access ports in bridge settings.
I just did the upgrade on my capsman controller and on one of my cap xl ac accesspoints.Found it in the wiki:Do devices running the new wifi-qcom-ac package still have the old wifiwave2 limitation where VLANs couldn't be configured?Code: Select all802.11ac chipsets do not support this type of VLAN tagging (vlan-id), but they can be configured as VLAN access ports in bridge settings.
So you prefer the following syntaxI'm with @pe1chl , fixing "print" current inconstancies would add a lot more value... RouterOS config is not file with strings where UNIX commands are more useful.
:grep script={/log print} pattern="a pattern"
/log print | grep "a pattern"
Why is that? I'm running carrier grade NAT on some 2216's for customers and was looking into either the nat-ein or nat-pmp to try to get customers gaming setups happy with NAT types. Just trying to find a way to not get a double NAT for gaming consoles without having to give every customer a public IP.oh god no!! I am still recovering from nat-ein, which gave me severe depression and life-crisis...*) firewall - added "nat-pmp" support;
Just upgraded my hAP ac2 . The above is a bummer for me, I have VLANs configured on switch chip (under /interface/ethetnet/switch/, so bridge is clueless about VLANs. Thus my setup relies on wireless driver to deal with VLAN tags (just as legacy wireless driver does ... at least it did up to and including 7.11.2).Found it in the wiki:Do devices running the new wifi-qcom-ac package still have the old wifiwave2 limitation where VLANs couldn't be configured?Code: Select all802.11ac chipsets do not support this type of VLAN tagging (vlan-id), but they can be configured as VLAN access ports in bridge settings.
actually, neither, there is already "where"...overCode: Select all:grep script={/log print} pattern="a pattern"
?Code: Select all/log print | grep "a pattern"
/log print where topics~"info"
*) firewall - added new IPv6 filter arguments "icmp-err-src-routing-header" and "icmp-headers-too-long" for "reject-with" setting;
Dunno about "code 5" (src addr policy), but code 6 is action= "reject" action already.What about codes 5 (source address failed ingress/egress policy) and 6 (reject route to destination)?*) firewall - added new IPv6 filter arguments "icmp-err-src-routing-header" and "icmp-headers-too-long" for "reject-with" setting;
Mmm... do you mean that "action=reject" aka "action=reject reject-with=icmp-network-unreachable" sends ICMPv6 Type 1 Code 6 and not ICMPv6 Type 1 Code 0?Dunno about "code 5" (src addr policy), but code 6 is action= "reject" action already.
Any documentation on congestion avoidance yet? I don't see any mention of it on Quality of Service (QoS) or QoS with Switch Chip yet. Coming soon for 98DX8208/98DX8216?*) qos-hw - added initial congestion avoidance support for 98DX224S, 98DX226S, and 98DX3236 switch chips (CLI only);
on the v7.13?Capsman works fine in my case, vlans and everything
Yes.on the v7.13?Capsman works fine in my case, vlans and everything
3 different ones on 1 RB5009 working just fine here.It seems the wireguard is broken , can't connect to anywhere .
Yes, on 7.13, works without a problem.on the v7.13?
If you install wireless and wifi packages at the same time, then of course there are two menus. You can run both of them at the same time as separate solutions on a single router.
You do know you're contradicting yourself here a little bit ?Wireless package and wifi package can be installed on a router at the same time, but one of them will be disabled. Both can not work at the same time.
As a rule of thumb, the package is compatible with 802.11ac producs, which have an ARM CPU.
Hmm, okay.. It was "broken/incomplete" during the introduction, but indeed, not introduced with this version. I'll create a new topic.Please keep this and other version topics related to the particular version. Issues that were present in older versions should be reported to support@mikrotik.com and/or discussed in separate forum threads. These forum topics are created in order to find "what got broken". There is no need to repeat the same reports on every release, even though any relevant fixes or changes are not listed in the changelog.
"our" suggestion was that you move the WiFi menu and associated software into a separate package as well, so that it can be uninstalled on routers where no wireless interfaces are present and the user does not want to use CAPsMAN on it either.Wifi menu is included in the bundle as described in changelog. All routers will have "WifiI" menu. You can not run router without system (a.k.a. bundle) package.
At least on Windows you can install and uninstall drivers for different hardware independently, so that you are not confronted with "when you install the driver for this 5 GHz radio, your 2 GHz radio will become inoperative"...RouterOS consists of things that many people don't use. Even in Windows you have menus you can't use.
if in doubt => https://help.mikrotik.com/docs/display/ ... stfeaturesHello.
Please, help with questions. Which package should I install on each device if only 5 GHz is needed? 2.4GHz I don't need.
1) Capsman: CCR2004-16G-2S+ (ARM 64bit) + cAP ac (ARM);
2) Without capsman standalone hAP ac lite (MIPSBE RB952Ui-5ac2nD).Or will Wi-Fi never work on hAP ac lite (MIPSBE RB952Ui-5ac2nD) anymore?
3) New capsman support ec-certificate (prime256v1) or just rsa (2048)?
Audience
Audience LTE kit
Chateau (all variants of D53)
hAP ac^2
hAP ac^3
cAP ac
cAP XL ac
LDF 5 ac
LHG XL 5 ac
LHG XL 52 ac
NetMetal ac^2
mANTBox 52 15s
wAP ac (RBwAPG-5HacD2HnD)
SXTsq 5 ac
RB4011iGS+5HacQ2HnD-IN (no support for the 2.4GHz interface)
Cube 60Pro ac (no support for 60GHz interface)
wAP ac (RBwAPG-5HacT2HnD) and
all other devices with a MIPSBE CPU <=====
loved the ROS v6 MODULARITY where one could disable and even better, uninstall unused parts."our" suggestion was that you move the WiFi menu and associated software into a separate package as well, so that it can be uninstalled on routers where no wireless interfaces are present and the user does not want to use CAPsMAN on it either.Wifi menu is included in the bundle as described in changelog. All routers will have "WifiI" menu. You can not run router without system (a.k.a. bundle) package.
All of our products based on IPQ4018/4019 chips use the same driver for 2.4GHz and 5GHz interfaces.I have a HAPac2 and I need both the 2.4GHz and 5 GHz.
What is the way to go for me?
Thank you Normiszandhaas use check for updates button and ignore the above ranting. nothing special has to be done. upgrade and forget
I can´t find the "where" clause in export command.*) console - added "where" functionality for "export" command;
Does it work ?Okay, I updated ax3 to 7.13beta1, only ROS package, nothing else, do I need to install another package or what ?
That makes some sense.The way I understand it:
So when 7.12 with installed wifiwave2 package gets upgraded to 7.13beta1 (or newer), wifi-qcom (or wifi-qcom-ac) package replaces the previously installed wifiwave2 package. At the same time, the configuration subtree /interface/wifiwave2 gets renamed to /interface/wifi, but structure under it remains unchanged.The configuration menu used to be called 'wifiwave2' in RouterOS versions before 7.13, where it was a part of the 'wifiwave2' software package.
I noticed an important difference on AC2 (no previous wifiwave2).
So when 7.12 with installed wifiwave2 package gets upgraded to 7.13beta1 (or newer), wifi-qcom (or wifi-qcom-ac) package replaces the previously installed wifiwave2 package.
test successful like this:*) certificate - add support for multiple DNS names for Let's Encrypt;
I noticed an important difference on AC2 (no previous wifiwave2).So when 7.12 with installed wifiwave2 package gets upgraded to 7.13beta1 (or newer), wifi-qcom (or wifi-qcom-ac) package replaces the previously installed wifiwave2 package.
Wireless was there after upgrade...
Did you uninstall wireless package and install qcom-ac ?Can someone please shed some light how to make CAPSMAN work with wifi-qcom-ac? I have a wAP AC (the supported version), I installed 7.13b1 on it and it shows up on my CAPSMAN controller (RB4011 with manually installed wifiwave2 package, already managing 2 hap ax2-s) but I cannot provision the CAP and I also don't have the "Manager" setting (to choose if it's managed locally or via CAPSMAN). I did add 2ghz n / 5 ghz ac to my already working configuration templates, is there anything else I need to do?
If your provisioning rules are specific enough so it ends up only using AX, yes you need new rules for AC.Yes, I now see the CAP in CAPSMAN but for some reason the configuration isn't applied. Do I need to define separate configuration for AC and AX?
So the WAP R AC has a both band WiFi however I don't need CAPSMAN maybe the CAPSMAN should have own package and Im sure lots of people not using it.This upgrade does not in any way free disk space. However, on a device which does not need to have wireless package, for example, CRS which do not run CAPsMAN, you know have separate wireless package. It is not a part of bundle any more. You can now uninstall it, and you will not only save disk space, but also a little bit of RAM.
Yes. In 16 MB Hap Ac2 does not put two packages at the same time. Only one: Wireless or Wi-Fi.Space issue, perhaps ?
See 1 post above yours (and normis' post in between ours).updated a CCR2004 to 7.13beta1. Moved some hapac2 w/ wifi-qcom-ac package over to the new "WiFi capsman". The remaining devices lost connection to old capsman v1. Is it not possible to have both capsman versions running on the same device? I don't see any other reason why capsmanv1 should've stopped working.. I see incoming traffic from caps on port 5246/udp but capsman ignores it or discards the packet. Are they even using different ports for communication? I couldn't find it in the provided docs.
There are skins to remove it from UI: https://help.mikrotik.com/docs/display/ ... bfig-SkinsRouterOS consists of things that many people don't use. Even in Windows you have menus you can't use.
16:04:11 wireless,debug 12:**:**:**:78:91@wifi1 assocation rejected, can't find PMKSA
16:04:13 wireless,debug 12:**:**:**:9E:78:91@wifi1 assocation rejected, can't find PMKSA
16:05:11 wireless,debug BE:**:**:**:AE:CF:03@2Ghz-2Stavs_TV2 assocation rejected, can't find PMKSA
16:05:52 wireless,debug E6:**:**:**:3C:C5@2Ghz-Lampina-ac31 assocation rejected, can't find PMKSA
/interface wifi security add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=yes disabled=no ft=yes ft-over-ds=yes name=Sec_01
It's not working here, at least not in parallel, since both capsman daemons try to bind to the same port 5246/udp, and the one that boots up first, wins...which means you can now use a single router to run both old and new CAPsMAN.
Have the two capsmanagers listen on different interfaces/VLANs:It's not working here, at least not in parallel, since both capsman daemons try to bind to the same port 5246/udp, and the one that boots up first, wins...which means you can now use a single router to run both old and new CAPsMAN.
On my device it's either A or B, and I don't see an option to bind either version to a specific ip or interface.
/caps-man/manager/interface> print
Flags: * - DEFAULT
Columns: INTERFACE, FORBID
# INTERFACE FORBID
0 * all yes
1 [capsman-interface] no
/interface/wifi/capsman> print
enabled: yes
interfaces: [other-capsman-interface]
I do think that the wording here are messing with people. There are no "wifi package" as in a separated package. The new "wifi" are part og the standard routeros package.The new wifi package is now part of the routeros.npk bundle, beginning a new and exciting era for wifi features.
Indeed, that is not good! In my current network (still running classic wireless) I have all devices on a single SSID and I assign the VLAN for several categories of devices via user-manager.This means to me that I can only have one VLAN per WLAN Interface ? I hope, that limitation will not stay for long. I was so happy until now for the life extension for my CAP ACs, but this is a huge limitation.
Looks like you can hack around this by creating vlan interfaces on top of your main bridge interface and joining them to your wifi interfaces via additional local bridges. These kind of legacy setups are deprecated and may cause issues with STP, but this way you can keep doing hw accelerated vlan filtering on the switch chip and have your wifi traffic tagged anyway.Just upgraded my hAP ac2 . The above is a bummer for me, I have VLANs configured on switch chip (under /interface/ethetnet/switch/, so bridge is clueless about VLANs.Found it in the wiki:Code: Select all802.11ac chipsets do not support this type of VLAN tagging (vlan-id), but they can be configured as VLAN access ports in bridge settings.
Yes please make wifi a wperate package. My mikrotik router doesn't supoort wifi!+1, it's a mess currentlyI welcome the partial split into separate packages as we knew it in v6, but maybe the "WiFi" menu should go into a separate "wifi" package so we can uninstall that as well.
2023-11-13 at 18.41.17.png
It may not have wifi interface... but it still support being a CAPsMAN2 controller...so it appears just like <least favorite> routing protocol you're not using...Yes please make wifi a wperate package. My mikrotik router doesn't supoort wifi!+1, it's a mess currently
2023-11-13 at 18.41.17.png
CRS309-1G-8S+
I unistalled wireless and CAPsMAN2 was automatically removed. But still, I don't need wifi and it would be nice not to have it installed.It may not have wifi interface... but it still support being a CAPsMAN2 controller...so it appears just like <least favorite> routing protocol you're not using...
Yes please make wifi a wperate package. My mikrotik router doesn't supoort wifi!
CRS309-1G-8S+
You shouldn't get a the "messy" duplicate Wi-Fi and Wireless in menu in your case.
For flappy interfaces, and/or Wireless, what are the implications of this?*) bridge - added automatic "path-cost" values depending on interface rate;
The only reference i found to this is in the CRS3xx-specific manual*) bridge - added bridge interface property "port-cost-mode" with "short" and "long" arguments;
I see in a CRS318P-16G-2S+:*) qos-hw - added initial congestion avoidance support for 98DX224S, 98DX226S, and 98DX3236 switch chips (CLI only);
/interface ethernet switch qos tx-manager queue
set *1 schedule=low-priority-group weight=1
set *2 schedule=low-priority-group weight=2
set *3 schedule=low-priority-group weight=3
set *4 schedule=high-priority-group use-shared-buffers=yes weight=3
set *5 schedule=high-priority-group use-shared-buffers=yes weight=4
set *6 schedule=high-priority-group use-shared-buffers=yes weight=5
set *7 use-shared-buffers=yes
set *8 use-shared-buffers=yes
Is this a IP/routing thing, or a linux stack/trace thing?*) system - added "rtrace" debugging tool (CLI only);
Since we're in the mood for both console-related improvements, and comment-related imporvements:*) webfig - allow to display comments in multiline or compact modes;
docs? how does this differ from "/interface/wireless/scan" ?*) wifi - added "flat-snoop" tool for surveying WiFi APs and stations (CLI only);
yes, because RB5009 does not have wifi card inside, but it can be capsman. So no driver package, but has wifi menu.Upgraded my RB5009 (CAPsMAN), hAP ax3 (CAP) and hAP ac3 (CAP) from 7.12rc5 to 7.13beta1 using the "check for updates" and everything went fine.
RB5009 had wifiwave2 package before, now it only has routeros (since WiFi menu + CAPsMAN feature is now bundled).
hAP ax3 had wifiwave2 package before, now it has wifi-qcom.
hAP ac3 had wifiwave2 package before, now it has wifi-qcom-ac.
no, only one driver for your wifi interface is needed. wireless-qcom is for AX devices, you have a AC modelI decided to test the new build. Installed on wap ac.
after installation - routeros-7.13beta1-arm I reset to defconf
From manual:
"wifiwave2" package has been divided into distinct packages: "wifi-qcom" and "wifi-qcom-ac"
After it installed
"wifi-qcom-ac-7.13beta1-arm"
I see a interfaces wifi-2.4 and wifi-5
I don't understand.
i think that
wifi-qcom-7.13beta1-arm - for 2.4hz
wifi-qcom-ac-7.13beta1-arm - for 5hz
wireless-7.13beta1-arm - old drivers
Please describe the differences between the packages. Why AC contains 2.4
/interface wifi channel add band=2ghz-n disabled=no frequency=2412,2437,2462 name=Home-2.4GHz width=20mhz
/interface wifi channel add band=5ghz-ac disabled=no frequency=5180,5260,5500,5580,5745 name=Home-5GHz skip-dfs-channels=disabled width=20/40/80mhz
/interface wifi security add authentication-types=wpa2-psk,wpa3-psk disabled=no management-protection=allowed name=sec-home passphrase=secret-pass wps=disable
/interface wifi steering add disabled=no name=steering-LAN neighbor-group=NBG-Group-LAN rrm=yes wnm=yes
/interface wifi configuration add channel=Home-2.4GHz country=Ukraine disabled=no name=cfg-Home-2 security=sec-home security.ft=yes .ft-over-ds=yes ssid=MikroAP-Loc steering=steering-LAN
/interface wifi configuration add channel=Home-5GHz country="United States" disabled=no name=cfg-Home-5 security=sec-home security.ft=yes .ft-over-ds=yes ssid=MikroAP-Loc steering=steering-LAN
/interface wifi set [ find default-name=wifi1 ] channel.frequency=2412,2437,2462 configuration=cfg-Home-2 configuration.manager=capsman-or-local .mode=ap disabled=no
/interface wifi set [ find default-name=wifi2 ] channel.frequency=5180,5260,5500,5580,5745 configuration=cfg-Home-5 configuration.manager=capsman-or-local .mode=ap disabled=no
/interface wifi channel add band=2ghz-n disabled=no frequency=2412,2437,2462 name=Home-2.4GHz width=20mhz
/interface wifi channel add band=5ghz-ac disabled=no frequency=5180,5260,5500,5580,5745 name=Home-5GHz skip-dfs-channels=disabled width=20/40/80mhz
/interface wifi security add authentication-types=wpa2-psk,wpa3-psk disabled=no group-key-update=1h management-protection=allowed name=secur-Home passphrase=secret_pass wps=disable
/interface wifi steering add disabled=no name=steering-Home neighbor-group=NB-group-Home rrm=yes wnm=yes
/interface wifi configuration add channel=Home-5GHz country="United States" disabled=no name=Home-5ghz security=secur-Home security.ft=yes .ft-over-ds=yes ssid=MikroAP steering=steering-Home
/interface wifi configuration add channel=Home-2.4GHz country=Ukraine disabled=no name=Home-2ghz security=secur-Home security.ft=yes .ft-over-ds=yes ssid=MikroAP steering=steering-Home
/interface wifi access-list add action=accept allow-signal-out-of-range=10s disabled=no interface=all mac-address=44:D8:78:27:F9:B7 signal-range=-50..120 ssid-regexp=MikroAP*
/interface wifi access-list add action=reject disabled=no interface=all mac-address=44:D8:78:27:F9:B7 ssid-regexp=MikroAP*
/interface wifi access-list add action=accept allow-signal-out-of-range=5s disabled=no interface=all signal-range=-82..-10 ssid-regexp=MikroAP*
/interface wifi access-list add action=reject disabled=no interface=all signal-range=-120..-83 ssid-regexp=MikroAP*
/interface wifi provisioning add action=create-dynamic-enabled comment="5.0GHz Slava - Home" disabled=no master-configuration=Home-5ghz name-format=%I supported-bands=5ghz-ac
/interface wifi provisioning add action=create-dynamic-enabled comment="2.4GHz Slava - Home" disabled=no master-configuration=Home-2ghz name-format=%I supported-bands=2ghz-n
/interface wifi capsman set ca-certificate=auto enabled=yes package-path="" require-peer-certificate=no upgrade-policy=none
This was the missing information. I've set everything to auto, and while the correct certificates were generated, it didn't work.Both CAPsMAN systems can work at the same time. Yes, they use the same port, but they differ the "call" from CAP and recognise which one must manage the CAP. Common mistake might be that old CAPsMAN is trying to generate certificate on a system where WiFi CAPsMAN was already made on older version. That is why in this release, WiFi CAPsMAN has a different name for generated certificates. If both CAPsMAN systems are not working at the same time, then check "/certificates" menu and see if there are certificates for both managers. If not, then remove them, disable/enable both managers, and see how it goes. If it is still not working, as always, bugs are not fixed in user forum - write to support@mikrotik.com and send in supout file.
What's new in 7.13beta2 (2023-Nov-14 13:04):
1. Read this:Why is that? I'm running carrier grade NAT on some 2216's for customers and was looking into either the nat-ein or nat-pmp to try to get customers gaming setups happy with NAT types. Just trying to find a way to not get a double NAT for gaming consoles without having to give every customer a public IP.
IMHO this was a bad naming decision. It is causing confusion already and it is going to confuse - ongoing."wifiwave2" package has been divided into distinct packages: "wifi-qcom" and "wifi-qcom-ac"
I deleted all certificates and regenerated new ones for both types of capsman, but certificates are generated from the "new" CA for legacy caps when requested: SUP-134480Both CAPsMAN systems can work at the same time. Yes, they use the same port, but they differ the "call" from CAP and recognise which one must manage the CAP. Common mistake might be that old CAPsMAN is trying to generate certificate on a system where WiFi CAPsMAN was already made on older version. That is why in this release, WiFi CAPsMAN has a different name for generated certificates. If both CAPsMAN systems are not working at the same time, then check "/certificates" menu and see if there are certificates for both managers. If not, then remove them, disable/enable both managers, and see how it goes. If it is still not working, as always, bugs are not fixed in user forum - write to support@mikrotik.com and send in supout file.
A device with 16Mb of flash does not really fit my definition of future proof ...On router Chateau 5g will i be able to use the new wifi and zerotier at the same time?
I am using it at home and purchased as "future proof".
Am I facing a replacement? Alternatively to what model?
That is interesting! Strods says 'Please remember that actual "bugs" must be reported to support@mikrotik.com complemented with logs, supout files, etc.' above.*) disk - fixed hang on reboot when network file systems mounted;
@pe1chl, do I understand you correctly that you're complaining about MT fixing a bug which was not properly reported (and you'd like them to reintroduce that bug in following releases)?That is interesting! Strods says 'Please remember that actual "bugs" must be reported to support@mikrotik.com complemented with logs, supout files, etc.' above.*) disk - fixed hang on reboot when network file systems mounted;
:put [:serialize to=json value=a,b,c]
["a","b","c"]
:grep pattern="veth" script="/interface print"
18 X veth1 veth 00:00:00:00:00:00
And it is not a complaint, I just labeled it as "interesting".@pe1chl, do I understand you correctly that you're complaining about MT fixing a bug which was not properly reported (and you'd like them to reintroduce that bug in following releases)?
That is interesting! Strods says 'Please remember that actual "bugs" must be reported to support@mikrotik.com complemented with logs, supout files, etc.' above.
Oh my, people are never satisfied whatever one does.
Well, actually the bug isn't fixed. When I do a user manager backup to an NFS-mounted disk I still cannot unmount the disk afterwards and it still hangs on reboot!That is interesting! Strods says 'Please remember that actual "bugs" must be reported to support@mikrotik.com complemented with logs, supout files, etc.' above.*) disk - fixed hang on reboot when network file systems mounted;
I reported this bug both on the 7.12 topic and as a ticket, and now it is reported as fixed (I will test) while my ticket has not even been acknowledged yet, it is still "waiting for support"... so maybe the developers ARE reading the topics?
A device with 16Mb of flash does not really fit my definition of future proof ...On router Chateau 5g will i be able to use the new wifi and zerotier at the same time?
I am using it at home and purchased as "future proof".
Am I facing a replacement? Alternatively to what model?
FWIW I face exactly the same problem with AC3 LTE, having zerotier on it but also limit of 16Mb storage, of which 346Kb is free right now (whereas regular AC3 has 128Mb, go figure).
It is what it is, I suppose.
Make a backup, move it off device.
Upgrade and see what happens.
Remove wireless package, install qcom-ac package.
Worst case (if it doesn't work) you need to downgrade and then you can restore backup.
I'm not going to try on that AC3 LTE, it's a production device so I'm not touching it until all wrinkles are ironed out :D
And it is not a complaint, I just labeled it as "interesting".
@pe1chl, do I understand you correctly that you're complaining about MT fixing a bug which was not properly reported (and you'd like them to reintroduce that bug in following releases)?
Oh my, people are never satisfied whatever one does.
Probably the change was made as the result of someone else's ticket.
Well, actually the bug isn't even fixed...
Both methods have their pro's and con's. When bugs are reported on the forum, others can see if the bug they experience has already been reported, and it prevents many tickets being created for the same bug. That would save you a lot of work. Probably the ideal situation would be a more open ticket system, but of course it has the disadvantage that reporters may post personal information.Let us call this "luck" this time. But it would not be correct for everyone to post their findings here and assume that there is a bug and scare away others. When in the end, the issue for a particular user had nothing to do with the release/software. That is our goal - to not scare away others due to false reports here. A proper way is to let others know about known and confirmed bugs. If you can confirm the bug yourself (can reproduce it by following the same steps), or if support has confirmed that the bug is indeed introduced in this release.
I think for any software - proper way to report a bug is to contact the technical support, not user forum.
# 2023-11-15 13:32:42 by RouterOS 7.13beta2
#
# model = C52iG-5HaxD2HaxD
# serial number = ******************
/interface bridge
add admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no comment=defconf name=bridgeLocal port-cost-mode=short
/interface wifi datapath
add bridge=bridgeLocal comment=defconf disabled=no name=capdp
/interface wifi
# managed by CAPsMAN
# mode: AP, SSID: **********, channel: 5500/ax/Ceee
# no available channels
set [ find default-name=wifi1 ] configuration.country=Canada .manager=capsman .mode=ap .ssid=Home datapath=capdp disabled=no
# managed by CAPsMAN
# mode: AP, SSID: **********, channel: 2437/n/Ce
set [ find default-name=wifi2 ] configuration.country=Canada .manager=capsman .mode=ap .ssid=Home datapath=capdp disabled=no
/interface bridge port
add bridge=bridgeLocal comment=defconf interface=ether1 internal-path-cost=10 path-cost=10
add bridge=bridgeLocal comment=defconf interface=ether2 internal-path-cost=10 path-cost=10
add bridge=bridgeLocal comment=defconf interface=ether3 internal-path-cost=10 path-cost=10
add bridge=bridgeLocal comment=defconf interface=ether4 internal-path-cost=10 path-cost=10
add bridge=bridgeLocal comment=defconf interface=ether5 internal-path-cost=10 path-cost=10
/interface detect-internet
set detect-interface-list=all
/interface wifi cap
set discovery-interfaces=bridgeLocal enabled=yes slaves-datapath=capdp
/ip dhcp-client
add comment=defconf interface=bridgeLocal
/system clock
set time-zone-name=Europe/Kiev
/system identity
set name="hAP ax2"
/system note
set show-at-login=no
/system package update
set channel=testing
# 2023-11-15 13:35:35 by RouterOS 7.12
#
# model = RB5009UPr+S+
# serial number = ********************
/interface bridge
add admin-mac=xx:xx:xx:xx:xx:xx auto-mac=no comment=defconf name=bridge vlan-filtering=yes
/interface vlan
add interface=bridge name=vlan20 vlan-id=20
/interface wifiwave2 channel
add band=2ghz-n disabled=no frequency=2412,2437,2462 name=2G
add disabled=no name=5G
/interface wifiwave2 datapath
add bridge=bridge disabled=no name=Datapath-local
add bridge=bridge disabled=no name=Datapath-guest vlan-id=20
/interface wifiwave2 security
add connect-priority=0 disabled=no ft=yes name=Security
add connect-priority=0 disabled=no ft=yes name=Security-guest
/interface wifiwave2 configuration
add channel=2G country=Canada datapath=Datapath-local disabled=no mode=ap name=2Ghz security=Security security.connect-priority=0 ssid=****** steering=******
add channel=5G country=Canada datapath=Datapath-local disabled=no mode=ap name=5Ghz security=Security security.connect-priority=0 ssid=****** steering=******
add channel=2G country=Canada datapath=Datapath-guest disabled=no name="2Ghz Guest" security=Security-guest security.connect-priority=0 ssid=******
add channel=5G country=Canada datapath=Datapath-guest disabled=no name="5Ghz Guest" security=Security-guest security.connect-priority=0 ssid=******
/interface wifiwave2 steering
add disabled=no name=*********** neighbor-group=dynamic-*********-fc2a2e78 rrm=yes wnm=yes
/ip dhcp-server
add address-pool=dhcp interface=bridge lease-time=10m name=dhcp-local
add address-pool=guest interface=vlan20 name=dhcp-guest
/queue simple
add max-limit=50M/50M name="Guest Limits" target=vlan20
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf disabled=yes interface=sfp-sfpplus1
add bridge=bridge interface=ether1
/interface bridge vlan
add bridge=bridge tagged=bridge,ether2,ether8 vlan-ids=20
/interface detect-internet
set detect-interface-list=all
/interface list member
add comment=defconf interface=bridge list=LAN
add interface=sfp-sfpplus1 list=WAN
/interface wifiwave2 capsman
set ca-certificate=auto enabled=yes interfaces=bridge package-path="" require-peer-certificate=no upgrade-policy=none
/interface wifiwave2 provisioning
add action=create-dynamic-enabled disabled=no master-configuration=2Ghz name-format="" slave-configurations="2Ghz Guest" supported-bands=2ghz-n
add action=create-dynamic-enabled disabled=no master-configuration=5Ghz name-format="" slave-configurations="5Ghz Guest" supported-bands=5ghz-ax
You still have what you bought a year ago. The technical datasheet did not change. They did not promise you wifi 5 wave 2 (just wifi5). Now MT offers a wave2 driver for several devices via software upgrade - which is an improvement that no other vendor would ever give away for free nor even think of.A year ago I thought a $500 router would last me a few years, but I'm slowly realizing that I bought a castrated expensive model :(
I wanted the best LTE possible (and at that time there was no AX version).
I'll wait until 7.13 comes out of beta and take @pe1chl Netinstall's advice, maybe it will work.
13:18:02 system,error,critical router was rebooted without proper shutdown, probably kernel failure
13:18:03 system,error,critical kernel failure in previous boot
13:18:03 system,error,critical out of memory condition was detected
How much free storage did you have on 7.12? I would expect it to stay more or less the same on 7.13. Wireless is now an extra package (2.8mb) and replaced by wifi-qcom-ac (3.0mb). The main package shrinked from 13.2mb to 10.9mb.free storage space 304 KiB
How much free storage did you have on 7.12?free storage space 304 KiB
Cool, thanks for reporting your observations. ROS 7.12 reports 1232KiB free space on my D53G-5HacD2HnD. So should easily fit.I posted pretty detailed observations about storage usage in my post #71 above.
Probably not enough space for the new wifi package ?Not realy sure if i became stupid or i don't understand something.
... What am i doing wrong?
If i upload old Wireless package back again, it installs normaly and i can see my Wifi interfaces.
I think this might be a winbox thing.hAP AX2 7.13_Beta2
When I add channel to the WiFi menu with show coloums channel dissapears when I reopen the WiFi tab as follows below, also there are two instances in the show colums box.
Yes 3.40I think this might be a winbox thing.hAP AX2 7.13_Beta2
When I add channel to the WiFi menu with show coloums channel dissapears when I reopen the WiFi tab as follows below, also there are two instances in the show colums box.
I'm seeing it as well on a brand new AX2, still running 7.8.
(although it is in wireless tab there)
Are you using winbox 3.40 ?
Found the reason. Had to delete Zerotier for more space. Now it works.Probably not enough space for the new wifi package ?Not realy sure if i became stupid or i don't understand something.
... What am i doing wrong?
If i upload old Wireless package back again, it installs normaly and i can see my Wifi interfaces.
Export config
Netinstall
Import config
as I always say: use the CLIWe have managed to reproduce the memory leak introduced in beta2 release. We will fix it as soon as possible. It is caused by opened WinBox sessions.
/interface/print stats
The problem is that I can not access the device, so no support outfile file...Supout and support, I would say...
It may be related to the trouble I have with DHCP? Maybe multicasting is fouled up in the VLAN-filtering bridge.After installing 7.13Beta2 on my CRS Switches (1x CRS326-24S+2Q+, 2x CRS328-24P-4S+, 2x CRS326-24G-2S+) the IPv6 Prefixes from all VLANs were propagated in all networks.
I think that message is very good.IMHO this was a bad naming decision. It is causing confusion already and it is going to confuse - ongoing.
Better would have been:
* wifi-qcom-ac
* wifi-qcom-ax
Furthermore, better not integrating the new "wifi" config-module into the base ROS bundle already. Having a wifi menu without actually having wifi anywhere? Pretty weird decision.
So better package bundling from my point of view:
* wifi-common (or wifi-base or wifi-config) -> put the wifi config module stuff into this package
* wifi-qcom-ac -> only the AC drivers and related to AC. depends on wifi-common.
* wifi-qcom-ax -> only the AX drivers and related to AX. depends on wifi-common.
Then tell people:
Old wireless: install package "wireless"
New wireless: install package "wifi-common" and depending on your chipset use either "wifi-qcom-ac" or "wifi-qcom-ax".
No confusion. Everybody understands without even reading a manual.
Personal comment: when you add wifiwave2 package to AC3 (pre-7.13 chain), you would have to do the exact same thing.i.e. To me it was not clear that after the upgrade and the installation off the qcom-ac package I have to reconfigure my wifi and under which menu tab I had to do that.
I the mean time I know that.Personal comment: when you add wifiwave2 package to AC3 (pre-7.13 chain), you would have to do the exact same thing.i.e. To me it was not clear that after the upgrade and the installation off the qcom-ac package I have to reconfigure my wifi and under which menu tab I had to do that.
Old wireless gone, new wifi menu with new setup to be done.
So no difference there.
But I need capsman for 2x AX devices, so is the qcom-ac right?@Rox,
qcom-ac
You just need to update using "check for updates." If wifivawe2 is installed, it will be updated automatically.
# 2023-11-16 13:10:49 by RouterOS 7.13beta2
# software id = G4****
#
# model = RBD52G-5HacD2HnD
# serial number = E*********
/interface bridge
add name=bridgeLocal
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/interface wifi
# managed by CAPsMAN
# mode: AP, SSID: Magalis, channel: 2412/n
set [ find default-name=wifi1 ] channel.frequency=2437 comment=2.4GHz configuration=*9 configuration.manager=capsman .mode=ap datapath.bridge=\
bridgeLocal disabled=no
# managed by CAPsMAN
# mode: AP, SSID: Magalis, channel: 5220/ac/eeCe
set [ find default-name=wifi2 ] channel.frequency=5250-5330 comment=5GHz configuration=*2 configuration.manager=capsman .mode=ap datapath.bridge=\
bridgeLocal disabled=no
/interface bridge port
add bridge=bridgeLocal interface=ether1
add bridge=bridgeLocal interface=ether2
add bridge=bridgeLocal interface=ether3
add bridge=bridgeLocal interface=ether4
add bridge=bridgeLocal interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=!dynamic
/interface wifi cap
set caps-man-addresses=192.168.53.1 certificate=CAP-2CC81BC912CA discovery-interfaces=bridgeLocal enabled=yes lock-to-caps-man=yes
/ip dhcp-client
add interface=bridgeLocal
/system clock
set time-zone-name=Europe/Madrid
/system identity
set name=hAP-ac2
/system note
set show-at-login=no
/system package update
set channel=testing
/tool graphing interface
add interface=ether1 store-on-disk=no
/tool graphing resource
add store-on-disk=no
Due to the memory leak in beta2 you should keep your winbox connection closed whenever possible and maybe reboot to reclaim any leaked RAM.although as you can see it has few RAM [ ... ] resources left
Well I do not think this is a hill to die on I agree with previous statement. My understanding is that management software ie. CapsMAN, is built into the bundle and drivers for wireless interfaces are the additional packages. So sooner or later AX will be legacy as well so to make it easier on my brain having the version name at the end makes it easier to understand what is what. So once new versions comes along then a new package and AX drivers do not have to share with new versions.this is not true.
-ac in this case is legacy (old) compatibility package.
we don't plan to make -be packages, it will always be wifi only
Did you look at the updated documentation?On the wireless→wifi (wave2) migration, did anyone write a guide? Or is the recommendation to rebuild from scratch, and look at all the settings?
(I understand the limitations for ac devices/VLANs and datapath changes. I'm asking in general, what should one pay attention to when migrating.)
MEE TOO!Something is really fishy here... Installed version 7.13beta1 on my hAP ac² on Tuesday with routeros and wifi-qcom-ac, configured wifi from scratch as needed.
The device did not start up the next morning, just had a layer 2 link on ethernet every few minutes for some seconds only. No wifi, no vpn, nothing else. Did a netinstall with 7.13beta2 to restore it. It worked well all day.
This morning exactly the same... 🤨 Anybody else seen this?
Did another netinstall earlier today, that did not help. Did a configuration reset, then restored from configuration export (not backup). Up and running for now...[...] Did a netinstall with 7.13beta2 to restore it. It worked well all day.
This morning exactly the same... 🤨 Anybody else seen this?
Yes, that's a part of "upgrade and forget". If you want to replace one package with another one (i.e. replace wireless with wifi), then you'll have to (manually) convert the config. If you honestly think about it: it is not sensible to simply convert the config (to keep same functionality), because the new wifi package offers more than legacy (WPA3 security, ac rates) and some of these features require specific settings which can not be (easily) deducted from old config.zandhaas use check for updates button and ignore the above ranting. nothing special has to be done. upgrade and forget
********************************************************
And it's true but then you have the "old" wifi package and not the qcom-ac package installed.
Check storage space ... right before shutdown. If storage is full (or close to full), then this might be the reason for problems.Just wondering... Both times this happened after a regular shutdown (/system/shutdown). Is there anything special now that breaks configuration?
Well, free storage is limited... Obviously. 😝 But I am pretty sure it was not near zero.Check storage space ... right before shutdown. If storage is full (or close to full), then this might be the reason for problems.
Yes (a bit), but that’s documentation for how to configure wifiwave2, not how to migrate configs. It does have a small section about migration, but it only talks about packages.Did you look at the updated documentation?On the wireless→wifi (wave2) migration, did anyone write a guide? Or is the recommendation to rebuild from scratch, and look at all the settings?
(I understand the limitations for ac devices/VLANs and datapath changes. I'm asking in general, what should one pay attention to when migrating.)
For mixed CAPSMAN setups (qcom-ac and qcom), does it matter which package is installed on the CAPSMAN? For now I kept my RB4011 on 7.12/wifiwave2, but I cannot get VLAN-s working on hap ac2 and wap ac and I can't even connect to the same SSID that works without problems on the hap ax2 with the same security/whatever configuration (only exeption is the band in the channel & provisioning configuration).
Same here (I have an RB4011 without wifi), but I could not make VLANs work with CAPSMAN even if I manually configured bridge vlan filtering, so I have went back to manual configuration for the time being. That still works, I'll just miss fast transitioning between the CAP-s and the manual ones.
I configured the controller on a device without WiFi at all. IMHO, so there is no difference. If only version 7.13 was installed on the controller.
Create different configurations for AC and AX with a single Wifi network name.
At the moment, this is just a beta version of the firmware. The final version may vary.
The memory leak on beta2 is not only due to connections via Winbox. Even simple monitoring through Dude also causes leaks. According to my observations, 2-3 percent per hour on devices with ARM.We have managed to reproduce the memory leak introduced in beta2 release. We will fix it as soon as possible. It is caused by opened WinBox sessions.
After upgrade from 7.12, some new defaults are included in the export when they probably shouldn't be.
mtik-cfg-diff.png
I have a perl script that exports from devices every night and then shows me a diff when something has changed. The output is that of Text::Diff::FormattedHTML from CPAN. The grey blob in the middle was just a quick way to cover some parts of the config I didn't want to share.what tool you use to do that? (showed on screenshot)
I have a perl script that exports from devices every night and then shows me a diff when something has changed. The output is that of Text::Diff::FormattedHTML from CPAN. The grey blob in the middle was just a quick way to cover some parts of the config I didn't want to share.what tool you use to do that? (showed on screenshot)
The memory leak on beta2 is not only due to connections via Winbox. Even simple monitoring through Dude also causes leaks. According to my observations, 2-3 percent per hour on devices with ARM.We have managed to reproduce the memory leak introduced in beta2 release. We will fix it as soon as possible. It is caused by opened WinBox sessions.
WinBox GUI should also match CLI 1:1. Example, why is “Services” (for API, SSH, SNMP etc) inside IPv4 list, when it's actually system-level and works for both IPv4 and IPv6?WinBox in RouterOS is not just the winbox.exe. WinBox is a protocol that you use to transport RouterOS data from router to application, which includes winbox.exe, mobile applications and tne Dude.
Currently, through the standard means of checking the firmware version in the selected update channel, it is only possible to “upgrade” the firmware version. For devices with a small amount of internal memory, for example hAP ac2, there is no option to “downgrade” the firmware version. Unless using netinstall. Is it possible for Mikrotik to create another "update channel" for beta versions that would contain the previous firmware version? Then, if problems arise, such as, for example, now with a memory leak, it will be very easy to “downgrade” the firmware version.One day this will be resolved, but not in Winbox 3.x
Must be something new for 7.13b2/3 ??Winbox has nothing to do with memory leak on my test RB951 running 7.13Beta2 (since Winbox was not in use). Here you see memory usage last 2 days.
Stange it increments in the same amount, but not at a fixed time. Span on every sample is 5 min,
.
memory.png
:grep script=":put Hello123" pattern="[0-9]+" only-matching=yes
123
Putting your configs in a git repository and then using gitweb to view them provides a similar result (without sending them outside, of course there are many online versioning systems that can do it).I have a perl script that exports from devices every night and then shows me a diff when something has changed. The output is that of Text::Diff::FormattedHTML from CPAN. The grey blob in the middle was just a quick way to cover some parts of the config I didn't want to share.what tool you use to do that? (showed on screenshot)
So the default has changed. That makes sense then, thanks.The bridge port-cost-mode, and bridge port path-cost, internal-path-cost are shown in export due to new default behavior.
Previously, the defaults for path-cost and internal-path-cost were both set to 10. To ensure that the STP setup remains unchanged after an upgrade, these values were retained and are now included in the export.
Putting your configs in a git repository and then using gitweb to view them provides a similar result (without sending them outside, of course there are many online versioning systems that can do it).
I have a perl script that exports from devices every night and then shows me a diff when something has changed. The output is that of Text::Diff::FormattedHTML from CPAN. The grey blob in the middle was just a quick way to cover some parts of the config I didn't want to share.
somehow sad and pathetic this has to be told to people (or even those who refer to themselfes as network engineers)never use beta versions in routers that are used in real and important networks. use beta where you can reinstall with netinstall
+1,000,000,000,0000somehow sad and pathetic this has to be told to people (or even those who refer to themselfes as network engineers)
While I agree with this, there's also a good side to it. I'm thankful for all the people who do run the beta and report issues - I don't have the time to do it - even when they run it in production. It will result in a better final version.+1,000,000,000,0000somehow sad and pathetic this has to be told to people (or even those who refer to themselfes as network engineers)
Alpha and Beta testing have their place on production networks, especially if the builds fix critical issues on important infrastructure. Oftentimes it is hard to replicate production environments in a lab (hence the testing in the field). But seasoned engineers will have a backup plan in place, which includes, among other things, the fastest way possible to restore normality. Smart engineers will identify portions of their network that are more tolerant to testing and "practice" over there, keeping the more sensitive parts up and running without disruption.
While I agree with this, there's also a good side to it. I'm thankful for all the people who do run the beta and report issues - I don't have the time to do it - even when they run it in production. It will result in a better final version.
somehow sad and pathetic this has to be told to people (or even those who refer to themselfes as network engineers)
a better final version.
WPA/WPA2, with the old driver /wireless package/ work fine! All of the other devices can be connected without a problem!What security settings do you have on 2ghz channel ?
Some old devices only want as low as WPA.
Start telling us about your devices that only support WEP!!Some old devices only want as low as WPA.
After reading these two comments:2) if I want to use the new wifi menu & features, does it support
- A) No 2.4 GHz band at all (all 2.4 GHz is legacy on the old wireless menu)
- B) 2.4 GHz band only on specific devices (new AX routers?) with all other devices having no support for 2.4 GHz
- C) 2.4 GHz on all devices, but always using the old wireless menu (with 5Ghz configuration in the new WiFi menu)
- D) 2.4 GHz on all interfaces using the new menu, but only on some devices (ex devices like the AC2/AC3)
- E) 2.4 GHz on all interfaces on all devices
What about the possibility of using the WifiWave2 driver on the RB4011iGS+5HacQ2HnD-IN without losing the 2.4 GHz WiFi?
Or is there an alternative to exchange the built-in 2.4 GHz card to ensure compatibility?
it seems pretty obvious that option B is correct...Unfortunately, it is not possible. If you need both - use wireless.npk. If you are satisfied with using just 5 GHz, then wifi-qcom-ac will work for you. Functionality in wifi (old wifiwave2) that has been changed is described in the changelog. Still, wifi package does not include drivers for RB4011 2 GHz wifi.
On my network only a 2018 LG TV and an old BROTHER DCP-J132W printer gave me a problem at first, I solved it with this configuration, I have an ax3 as capsman and the ac2 as cap, both in version 7.13b2Wave 2 driver works fine on cAP AC. But only the TV BOX /old MXQ Pro with android 5.1 - 2016/ can't be connected to the LAN via 2GHz radio anymore!
# 2023-11-18 12:32:12 by RouterOS 7.13beta2
# software id = B******
#
# model = C53UiG+5HPaxD2HPaxD
# serial number = A********
/interface wifi channel
add band=2ghz-ax disabled=no frequency=2462 name=channel11x width=20mhz
add band=5ghz-ax comment="canal 144 solo la la portatil 80MHz" disabled=no frequency=5650-5690 name=channel132x width=20/40mhz
add band=2ghz-n disabled=no frequency=2412 name=channel01n width=20mhz
add band=5ghz-ac disabled=no frequency=5170-5250 name=channel36a skip-dfs-channels=disabled width=20/40/80mhz
/interface wifi security
add authentication-types=wpa2-psk,wpa3-psk disabled=no management-protection=allowed name=secWPA3 wps=disable
/interface wifi configuration
add channel=channel11x country=Spain disabled=no mode=ap name=cfg11x security=secWPA3 security.ft=yes .ft-over-ds=yes ssid=Magalis
add channel=channel132x country=Spain disabled=no mode=ap name=cfg132x security=secWPA3 security.ft=yes .ft-over-ds=yes ssid=Magalis
add channel=channel01n country=Spain disabled=no mode=ap name=cfg01n security=secWPA3 security.ft=yes .ft-over-ds=yes ssid=Magalis
add channel=channel36a country=Spain disabled=no mode=ap name=cfg36a security=secWPA3 security.ft=yes .ft-over-ds=yes ssid=Magalis
/interface wifi
add channel.frequency=2412 comment="2 GHz" configuration=cfg01n configuration.mode=ap disabled=no name=wifi2_ac radio-mac=2C:C8:1B:C9:12:CF
add channel.frequency=5170-5250 comment="5 GHz" configuration=cfg36a configuration.mode=ap .tx-power=14 disabled=no name=wifi5_ac radio-mac=\
2C:C8:1B:C9:12:D0
/interface wifi datapath
add bridge=bridge disabled=no name=datapath1
/interface wifi
set [ find default-name=wifi1 ] channel.frequency=5650-5690 comment=5GHz configuration=cfg132x configuration.mode=ap .tx-power=21 datapath=datapath1 \
disabled=no
set [ find default-name=wifi2 ] channel.frequency=2462 comment=2.4GHz configuration=cfg11x configuration.mode=ap .tx-power=12 datapath=datapath1 \
disabled=no mtu=1500
Try to changed toCode: Select all/interface wifi security add authentication-types=wpa2-psk,wpa3-psk disabled=no management-protection=allowed name=secWPA3 wps=disable
/interface wifi security
add authentication-types=wpa-psk,wpa2-psk disabled=no management-protection=allowed name=secWPA3 wps=disable
Thanks, but still no success!Try to changed toCode: Select all/interface wifi security add authentication-types=wpa2-psk,wpa3-psk disabled=no management-protection=allowed name=secWPA3 wps=disable
to support your older devicesCode: Select all/interface wifi security add authentication-types=wpa-psk,wpa2-psk disabled=no management-protection=allowed name=secWPA3 wps=disable
Columns: ACTION
# ACTION
0 accept
1 reject