Had the same problem here, the fix was disabling management frame protection.Wave 2 driver works fine on cAP AC. But only the TV BOX /old MXQ Pro with android 5.1 - 2016/ can't be connected to the LAN via 2GHz radio anymore!
![]()
Had the same problem here, the fix was disabling management frame protection.Wave 2 driver works fine on cAP AC. But only the TV BOX /old MXQ Pro with android 5.1 - 2016/ can't be connected to the LAN via 2GHz radio anymore!
![]()
Thank you very much Z0ltan! I disabled the management frame protection on the 2ghz radio security settings and now it works fine.Had the same problem here, the fix was disabling management frame protection.Wave 2 driver works fine on cAP AC. But only the TV BOX /old MXQ Pro with android 5.1 - 2016/ can't be connected to the LAN via 2GHz radio anymore!
![]()
As already reported, beta2 have memory leak problem.My SXT's log show this same after unsuspected reboot.By the way, both my hAP ac2 and cAP are restarting with:
every few hours.Code: Select all13:18:02 system,error,critical router was rebooted without proper shutdown, probably kernel failure 13:18:03 system,error,critical kernel failure in previous boot 13:18:03 system,error,critical out of memory condition was detected
I will upload autosupout.rif as soon as I reset my password... Done: #[SUP-134525]
Not pressing anyone, just FYI, trying to help :)
VLANs via CAPsMAN/datapath is not supported on qcom-ac models.For mixed CAPSMAN setups (qcom-ac and qcom), does it matter which package is installed on the CAPSMAN? For now I kept my RB4011 on 7.12/wifiwave2, but I cannot get VLAN-s working on hap ac2 and wap ac
I tried that but it does not work. Even if I set CAPSMAN to “create enabled” to avoid having new interfaces popping up outside the bridge, I still couldn’t get the VLAN-s working by manually setting up bridge VLAN filtering and tagged / untagged traffic. Eventually I see devices removed from the VLAN config because reprovisioning renamed the interface. Could you please post your bridge config?VLANs via CAPsMAN/datapath is not supported on qcom-ac models.For mixed CAPSMAN setups (qcom-ac and qcom), does it matter which package is installed on the CAPSMAN? For now I kept my RB4011 on 7.12/wifiwave2, but I cannot get VLAN-s working on hap ac2 and wap ac
Just use standard VLAN / Bridge filtering method on these CAPs
I am using this just fine with hap-ac3 and now additionally tested with cap-ac and wap-ac (RB4011 on 7.12, wifiwave2, no ax-devices though).
Maybe by caring to provision a separate config without VLAN set in datapath for CAPsMAN for non-ax devices would solve that.
The bridge config is to be applied on the CAP, not the router/device running capsman.I tried that but it does not work. Even if I set CAPSMAN to “create enabled” to avoid having new interfaces popping up outside the bridge, I still couldn’t get the VLAN-s working by manually setting up bridge VLAN filtering and tagged / untagged traffic. Eventually I see devices removed from the VLAN config because reprovisioning renamed the interface. Could you please post your bridge config?
/interface bridge
add name=bridge vlan-filtering=yes
/interface bridge port
add bridge=bridge interface=ether1
add bridge=bridge interface=ether2
add bridge=bridge interface=ether3
add bridge=bridge interface=ether4
add bridge=bridge interface=ether5
add bridge=bridge interface=wifi1
add bridge=bridge interface=wifi2
add bridge=bridge interface=wifi3 pvid=30
add bridge=bridge interface=wifi4 pvid=20
add bridge=bridge interface=wifi5 pvid=99
add bridge=bridge interface=wifi6 pvid=20
add bridge=bridge interface=wifi7 pvid=99
/interface bridge vlan
add bridge=bridge tagged=bridge vlan-ids=1
add bridge=bridge tagged=bridge,ether1 untagged=wifi4,wifi6 vlan-ids=20
add bridge=bridge tagged=bridge,ether1 untagged=wifi3 vlan-ids=30
add bridge=bridge tagged=bridge,ether1 untagged=wifi5,wifi7 vlan-ids=99
Create a ticket.On Hap AC2 with wifi-qcom-ac package when setting Management Protection to Allowed or Required bandwidth does not exceed 20Mbps, and when disabled I get full speed (600Mbps).
Thanks I will give this a try tonight; mine was similar with the exception of leaving the bridge out as tagged port (perhaps that was the mistake here). One interesting thing to note is that the wifix interfaces were dynamically added to the bridge when I was using CAPSMAN and I could neither add them manually nor set the pvid values for a dynamically added bridge port.
Here is my bridge config on a hap-ac3 (it is not different from a normal bridge vlan-filtering config .. capsman is running on my RB4011):before enabling CAP-Mode in the CAP, configure bridge vlan-filtering for the ethernet interfaces as usual.Code: Select all/interface bridge add name=bridge vlan-filtering=yes /interface bridge port add bridge=bridge interface=ether1 add bridge=bridge interface=ether2 add bridge=bridge interface=ether3 add bridge=bridge interface=ether4 add bridge=bridge interface=ether5 add bridge=bridge interface=wifi1 add bridge=bridge interface=wifi2 add bridge=bridge interface=wifi3 pvid=30 add bridge=bridge interface=wifi4 pvid=20 add bridge=bridge interface=wifi5 pvid=99 add bridge=bridge interface=wifi6 pvid=20 add bridge=bridge interface=wifi7 pvid=99 /interface bridge vlan add bridge=bridge tagged=bridge vlan-ids=1 add bridge=bridge tagged=bridge,ether1 untagged=wifi4,wifi6 vlan-ids=20 add bridge=bridge tagged=bridge,ether1 untagged=wifi3 vlan-ids=30 add bridge=bridge tagged=bridge,ether1 untagged=wifi5,wifi7 vlan-ids=99
Then enable the cap-mode and once the cap has registered with the capsman host, you will need to add the wifi interface wifi1 to wifiX to the bridge, assign them the respective VLAN-ID as PVID and set bridge-vlan config as untagged members for the wifi interfaces.
As said, wifi1 to wifiX will stay in the same order and of its assigned SSIDs, as long as you do not change the provisioning config in capsman.
Currently fetch can not pass more than ~ 64 kB of data. This is a known and expected limitation.With the introduction of the :serialize and :deserialize commands, a world of possibilities opens up for the consumption of the Rest API, however the size of a string variable limits this. Example: https://stat.ripe.net/data /looking-glass/data.json?resource=140.78.0.0/16 cannot be processed due to the size of the returned response.
Do you plan any type of solution or expansion in the size of the variables?
Currently fetch can not pass more than ~ 64 kB of data. This is a known and expected limitation.
True on the data to file... but that still breaks :deserialize, as subject to 64kB limit & a partial fragment of file isn't valid JSON e.g. the first { or [ needs have matching at ] }But you can still use my method for put on memory from a file one var of any size, until the memory is depleted...Currently fetch can not pass more than ~ 64 kB of data. This is a known and expected limitation.
viewtopic.php?p=1012747#p1012747
Trying to understand how 802.11ac CAP device interfaces should be configured now...
It's not visible from your post, but do you use VLANs? Without VLANs, yes, it's not a problem. The problem only appears (as I understand things) when VLANs are involved, since they can't be passed anymore via datapath, and instead need to be manually set when joining the interfaces to the bridge (statically). Hence my confusion…Trying to understand how 802.11ac CAP device interfaces should be configured now...
So far I have not encountered any problems with this (create-dynamic-enabled) configuration.
I have used the rextended method (modified by downloading the file with /tool/fetch and loading it with /file/read), and I was able to load a .json file downloaded with /tool/fetch, the file was 240KB and :deserialize processed it No problem. However, I asked to open a ticket to see if they remove that limitation from /tool/fetch.True on the data to file... but that still breaks :deserialize, as subject to 64kB limit & a partial fragment of file isn't valid JSON e.g. the first { or [ needs have matching at ] }
But you can still use my method for put on memory from a file one var of any size, until the memory is depleted...
viewtopic.php?p=1012747#p1012747
When you don't like it, of course you can change your System->Logging configuration.In v7.13beta2, NAT PMP logs are too verbose:
I hope this changes before the stable release.
I already wrote that I know that. My question is: does this mean that create-enable-dynamic doesn't work anymore? How is one supposed to configure interfaces (create-enabled probably)?@iustin @Simonej
As already written earlier, VLAN support is only through bridge ports.
Previously, the defaults for path-cost and internal-path-cost were both set to 10. To ensure that the STP setup remains unchanged after an upgrade, these values were retained and are now included in the export.
/interface/bridge
set port-cost-mode=long
/interface/bridge/port
unset value-name=path-cost [find where path-cost=10]
unset value-name=internal-path-cost [find where internal-path-cost=10]
#error exporting "/ip/hotspot/walled-garden" (timeout)
Script Error: missing value(s) of argument(s) numbers
Wait, there is an "unset" command?
If instead you wish to have your switch take the new behavior, you can clear the old defaults with:Code: Select allunset value-name=path-cost [find where path-cost=10]
Although there is a reset command on CLI - I did not find out yet what this is actually used for.
/interface/bridge/port/set !internal-path-cost !path-cost [ find ];
Wow, that article is very useful. Thank you very much!Although there is a reset command on CLI - I did not find out yet what this is actually used for.
My article showed one for removing a bogus LTE setting on non-LTE devices.
But yes, RouterOS's CLI is somewhat less than fully orthogonal. 😛
After I sent supout, I found this in logCreate a ticket.On Hap AC2 with wifi-qcom-ac package when setting Management Protection to Allowed or Required bandwidth does not exceed 20Mbps, and when disabled I get full speed (600Mbps).
In my 4011(RB4011iGS+5HacQ2HnD + wifiwave2)
When config:
/interface wifiwave2 security add disable-pmkid=yes disabled=no management-protection=allowed
the online broadcast stops and buffering begins then continues online.
When config:
/interface wifiwave2 security add disabled=no management-protection=disabled
Is ok
SUP-134428
[admin@mikrotik] > :put [:resolve domain-name=test.0vrly.eu server=2001:4c48:1::1 server-port=53]
2001:4c48:1::1
[admin@mikrotik] > :put [:resolve domain-name=test.0vrly.eu server=2001:4c48:1::1 server-port=53]
2001:4c48:1::1
[admin@mikrotik] > :put [:resolve domain-name=test.0vrly.eu server=2001:4c48:1::1 server-port=53]
2001:4c48:1::1
[admin@mikrotik] > :put [:resolve domain-name=dns.google.com server=2001:4c48:1::1 server-port=53]
8.8.8.8
[admin@mikrotik] > :put [:resolve domain-name=dns.google.com server=2001:4c48:1::1 server-port=53]
8.8.4.4
[admin@mikrotik] > :put [:resolve domain-name=dns.google.com server=2001:4c48:1::1 server-port=53]
8.8.8.8
[admin@mikrotik] > :put [:resolve domain-name=dns.google.com server=2001:4c48:1::1 server-port=53]
8.8.4.4
[admin@mikrotik] > :put [:typeof [:resolve domain-name=dns.google.com server=2001:4c48:1::1 server-port=53]]
ip
[admin@mikrotik] > :put [:typeof [:resolve domain-name=test.0vrly.eu server=2001:4c48:1::1 server-port=53]]
ip6
Well, currently fetching IPv6-only (having AAAA record, but no A record) fails anyway... 😜oh, and one more thing. please give the same treatment to /tool/fetch
currently it won't fall back to IPv6 if ipv4 is not available. i don't care if we don't get the full blown "happy eyeballs" algorithm - the routers i've seen til this day did not have eyes anyway - but if fetch would have something like af=4 or af=6 that would force it to v4 or v6, that'd be great
i also opened a request earlier today SUP-135280Reported as SUP-134908.
And of course the "check for upgrades / download upgrades" that probably uses the same routines as /tool/fetch...oh, and one more thing. please give the same treatment to /tool/fetch
currently it won't fall back to IPv6 if ipv4 is not available. i don't care if we don't get the full blown "happy eyeballs" algorithm - the routers i've seen til this day did not have eyes anyway - but if fetch would have something like af=4 or af=6 that would force it to v4 or v6, that'd be great
Certainly +1 for some "af=4|6" in :resolve — although perhaps "type=" which allow other RRs an IPv6 via type=AAAA.And of course the "check for upgrades / download upgrades" that probably uses the same routines as /tool/fetch...oh, and one more thing. please give the same treatment to /tool/fetch
currently it won't fall back to IPv6 if ipv4 is not available. i don't care if we don't get the full blown "happy eyeballs" algorithm - the routers i've seen til this day did not have eyes anyway - but if fetch would have something like af=4 or af=6 that would force it to v4 or v6, that'd be great
+1Is it possible MT can make /ip services works in multiple vrf like cisco.
because in v7 /ip service can only choose for 1 vrf only
thx
Why's that? defconf is just default config ... and one can change it as it fits.*) defconf - use device factory preset credentials when using CAPs mode;
This will make my life miserable :(
The way AFAIU this setting works, is for naming on the capsman host, not on the CAP.Trying to understand how 802.11ac CAP device interfaces should be configured now.
Currently: I have capsman setup to create-dynamic-enabled, and a datapath config that enables vlan and set vlan IDs.
In the future, vlan IDs won't be settable for 802.11ac chipsets, but instead they need to be manually added to the bridge. That also means that create-dynamic-enabled doesn't work anymore, and instead, create-enabled should be used? Does this also mean that many more settings need to be configured locally? (I haven't use create-enabled before)
Nothing changes in your workflow. When booting into CAP mode with the button, you don't need to connect to the CAP device. It gets all of it's wireless config from CAPsMAN. That is the whole point of the CAP, is that you do not connect to it for management at all. All config comes from CAPsMAN, so it does not matter whether it has a password or not.
*) defconf - use device factory preset credentials when using CAPs mode;
This will make my life miserable![]()
Thank you, this is the first answer that goes into details, much appreciated. I dislike that I have to rely on “don’t change config then mapping is stable” - not sure why capsman can’t simply add the interfaces itself, or tell the cap to do it, it doesn’t seem to need hardware support? But I can live with it….The way AFAIU this setting works, is for naming on the capsman host, not on the CAP.Trying to understand how 802.11ac CAP device interfaces should be configured now.
Currently: I have capsman setup to create-dynamic-enabled, and a datapath config that enables vlan and set vlan IDs.
In the future, vlan IDs won't be settable for 802.11ac chipsets, but instead they need to be manually added to the bridge. That also means that create-dynamic-enabled doesn't work anymore, and instead, create-enabled should be used? Does this also mean that many more settings need to be configured locally? (I haven't use create-enabled before)
The CAP would always enumerate the interfaces, starting from wifi1 to wifiN and enumeration will depend on the sequence of how the SSIDs are configured in provisioning settings on the capsman host.
For example, I have 3x SSIDs for 2.4GHz and 2 SSIDs for 5GHz, hence I will end up wifi interfaces wifi1, wifi2, ..., wifi7 on each CAP.
This is the list of wifi interfaces that need to be added to the bridge on the CAP and - as long as you do not change provisioning - will stay in the same order. So for ac chipsets, you can set individual PVIDs for each wifi interface in the bridges of each CAP.
With two CAPs in use, the capsman host will list 2x7 wifi interfaces aadn enumeration can chanage based to identity settings....but you don't need to do anything with these for the bridge on the capsman host, as CAPS will use local forwarding only, anyway.
Hi Normis,Nothing changes in your workflow. When booting into CAP mode with the button, you don't need to connect to the CAP device. It gets all of it's wireless config from CAPsMAN. That is the whole point of the CAP, is that you do not connect to it for management at all. All config comes from CAPsMAN, so it does not matter whether it has a password or not.
*) defconf - use device factory preset credentials when using CAPs mode;
This will make my life miserable :(
In the reverse situation (as it was) it was like this - you have a password protected AP, but somebody can come and boot into CAP mode and then there is no more password, anyone could get into your AP this way.
What about routerboard upgrades, i always need to log into cap and turn automatic routerboard upgrades on reboot, can you maybe in future automate/improve this process so its done automatically from capsman manager?(or just set it ON by default maybe?)Ullinator, that is not true. Nothing has to be changed on the CAP even in new capsman. Make a new topic, if you are not sure how to use it. There should be no reason to manually configure CAP clients.
This is a bit different, but I thought - yes, you need to configure wifi-qcom-ac CAP devices manually regarding VLANs? Per https://help.mikrotik.com/docs/display/ ... stfeatures, my understanding is that one needs to log in to the CAP and manually configure the bridge, as it's not possible to push the config from CapsMan?Ullinator, that is not true. Nothing has to be changed on the CAP even in new capsman. Make a new topic, if you are not sure how to use it. There should be no reason to manually configure CAP clients.
I was just about to write this...This is a bit different, but I thought - yes, you need to configure wifi-qcom-ac CAP devices manually regarding VLANs? Per https://help.mikrotik.com/docs/display/ ... stfeatures, my understanding is that one needs to log in to the CAP and manually configure the bridge, as it's not possible to push the config from CapsMan?Ullinator, that is not true. Nothing has to be changed on the CAP even in new capsman. Make a new topic, if you are not sure how to use it. There should be no reason to manually configure CAP clients.
Normis, you´re half right ;-) I´ve testet it with an CAP AX and CAP AC. In CAPS-mode everything is deployed from the CAPsMAN, but it´s different if you connect it manually to the CAPsMAN (why?)Ullinator, that is not true. Nothing has to be changed on the CAP even in new capsman. Make a new topic, if you are not sure how to use it. There should be no reason to manually configure CAP clients.
Remember with a fixed assignment of SSID to bridge port as untagged member of some VLAN it is NEVER going to work in an acceptable way! WiFi interfaces need to be able to be member of a tagged VLAN, or else we will never be able to assign a VLAN to a user via user-manager, either with MAC-based RADIUS authentication or with WPAx-EAP. That would make wifiwave2 forever be a toy in any enterprise(-like) environment.We need some automatic solution for this, like for example: CAPsMAN should instruct CAP to create: VLAN on Discovery interface, bridge with new VLAN as one of the ports, Datapath going to this new bridge, SSID with new Datapath, all with some Comments or some other info so the CAP knows not to save them to config or to ignore them when booting and request them again from CAPsMAN (I know, not a trivial task, but only in this way "reset to CAP mode" has any meaning for anything but most trivial implementations, and those don't even need CAPsMAN)
What about routerboard upgrades, i always need to log into cap and turn automatic routerboard upgrades on reboot
That was just an idea, considering that VLANs don't work on ac equipment. I can (and will) create some scripts to automate this for me, but that will be anything but "no configuration needed"...Remember with a fixed assignment of SSID to bridge port as untagged member of some VLAN it is NEVER going to work in an acceptable way! WiFi interfaces need to be able to be member of a tagged VLAN, or else we will never be able to assign a VLAN to a user via user-manager, either with MAC-based RADIUS authentication or with WPAx-EAP. That would make wifiwave2 forever be a toy in any enterprise(-like) environment.We need some automatic solution for this, like for example: CAPsMAN should instruct CAP to create: VLAN on Discovery interface, bridge with new VLAN as one of the ports, Datapath going to this new bridge, SSID with new Datapath, all with some Comments or some other info so the CAP knows not to save them to config or to ignore them when booting and request them again from CAPsMAN (I know, not a trivial task, but only in this way "reset to CAP mode" has any meaning for anything but most trivial implementations, and those don't even need CAPsMAN)
So any development effort spent on this matter is better spent at the WiFi level rather than tricks at the bridge level!
I don't think it is possible to write a script that creates the functionality of the old wireless package: to have a different VLAN for different clients connected to the same SSID (via access list or user-manager)... this has to be solved by MikroTik in the WiFi driver or some special MACVLAN-like device they put between the WiFi and the main bridge, that can tag/untag packets with different VLAN tag depending on client MAC.That was just an idea, considering that VLANs don't work on ac equipment. I can (and will) create some scripts to automate this for me, but that will be anything but "no configuration needed"...
My use case is a lot simpler that that, no RADIUS, no user-manager, only 4 SSIDs connected to 4 bridges, each connected to different VLAN, having different firewall rules on main router (RB1100AHx4 in my case).I don't think it is possible to write a script that creates the functionality of the old wireless package: to have a different VLAN for different clients connected to the same SSID (via access list or user-manager)... this has to be solved by MikroTik in the WiFi driver or some special MACVLAN-like device they put between the WiFi and the main bridge, that can tag/untag packets with different VLAN tag depending on client MAC.
Yes, I think I understand what the problem is in this case. I use pppoe in vlan on built backbone with vlans to transport L2 traffic /network/ with eoip on both ends - CCR2116 and cAP ACs. I noticed that in the tests, only one processor core works, and the more complex the configuration - two tunnels in this case, the less traffic passes....I think yours is a specific, local problem with your setup.
I had that before, but the problem is it does not scale: for every new network you need to add, you need to broadcast another SSID and waste more radiotime doing so. 4 SSIDs is about the maximum you can reasonably do.My use case is a lot simpler that that, no RADIUS, no user-manager, only 4 SSIDs connected to 4 bridges, each connected to different VLAN, having different firewall rules on main router (RB1100AHx4 in my case).
Yes, ppoe is not multi-thread in ROS, AFAIK...so this imposes a bottleneck.Yes, I think I understand what the problem is in this case. I use pppoe in vlan on built backbone with vlans to transport L2 traffic /network/ with eoip on both ends - CCR2116 and cAP ACs.
In my case, 4 SSIDs config is already over-complicated (historic reasons, will go down soon hopefully), usually only 2 are required: Private and Public/Guest. But this is not about limitations of WiFi networking, but about AUTOMATIC configuration upon factory reset to CAP mode, which is now only possible in simplest cases with no more than 1 Datapath (I'm even not convinced about this, but will test tomorrow with my home network of 2 hAP ac2s).I had that before, but the problem is it does not scale: for every new network you need to add, you need to broadcast another SSID and waste more radiotime doing so. 4 SSIDs is about the maximum you can reasonably do.
I was so happy that I had a good solution to have many different networks in a scalable way (easy to add another VLAN)... but now it seems to be a dead end, even now that my hAP ac2 is supported in the new WiFi driver.
which could be very easy to solve with OpenWRT / dynamic VLANs per passphrase.In my case, 4 SSIDs config is already over-complicated
Thank you for answer. I will just leave all CAPS on 7.13 and install 7.12.1 with Wave2 package back on 5009. So i will get speed of Wave2 drivers and stability of 7.12.1 :) Now i only must remove remaining old MIPS and SMIPS devices from network and exchange them with something else.Nope.
Only as of 7.13b this should be possible.
OMFG!!!! I had to check it out before believing - 5009 as wifi capsman, 2x cap ax and now 3x wap ac, all in the same capsman - FINALLLY!!!
working without issues, had to manually uninstall old wireless package after check for upgrade.
802.11ac chipsets do not support this type of VLAN tagging , but they can be configured as VLAN access ports in bridge settings.
Ooh, this is very useful. Just to see if I understood right - your main "wifi-2.4G" and "wifi-5G" are running on the default VLAN (pvid 1), and the "-guest" variant on VLAN 31, right?I'm attaching the wAP config - if somebody is interested. I'm not sharing hAP ax³, because I've got some amount of private stuff in there - it's my primary/edge router. However, there's nothing special done for wAP ac, the CAP was configured as hAP ax² CAP running WifiWave2. I'm using "CAPsMAN static" interface provisioning, because of the driver limitation:802.11ac chipsets do not support this type of VLAN tagging , but they can be configured as VLAN access ports in bridge settings.
Well, as some others pointed out already, maybe it's true for the way you use the caps.Nothing changes in your workflow. When booting into CAP mode with the button, you don't need to connect to the CAP device. It gets all of it's wireless config from CAPsMAN. That is the whole point of the CAP, is that you do not connect to it for management at all. All config comes from CAPsMAN, so it does not matter whether it has a password or not.
*) defconf - use device factory preset credentials when using CAPs mode;
This will make my life miserable :(
In the reverse situation (as it was) it was like this - you have a password protected AP, but somebody can come and boot into CAP mode and then there is no more password, anyone could get into your AP this way.
Wait what? wAP ac is mipsbe with AR9300, but the wifi-qcom-package works on it?I've just experimented with my wAP ac (RBwAPG-5HacD2HnD) - it's winter, not a mission critical, because nobody is really spending time outside now. I upgraded to 7.12 and then to 7.13beta2, uninstalled old wireless package and installed the new wifi-qcom-ac package. And, after a bit of setup, it works!
Sorry to burst your bubble but this is about wAP AC arm version...Wait what? wAP ac is mipsbe with AR9300, but the wifi-qcom-package works on it?
That's pretty cool!
There are two versions of wAP ac - MIPSBE and ARM. The ARM version works with new drivers, the MIPSBE version does not.Wait what? wAP ac is mipsbe with AR9300, but the wifi-qcom-package works on it?
That's pretty cool!
Ha I thought so...Sorry to burst your bubble but this is about wAP AC arm version...Wait what? wAP ac is mipsbe with AR9300, but the wifi-qcom-package works on it?
That's pretty cool!
https://mikrotik.com/product/wap_ac
(that was a reply to the confusing situation that now a device which uses the "wireless" driver has two different menus for wireless config)How is that relevant in this situation? Nothing has been broken, upgrade is transparent. Just ignore the capsman menu, you will get used to it.
The same for me: Even the change of the "Controller" from CAPsMAN or local" to "CAPsMAN" only changed nothing.There is no WiFi network after the update. Screenshot from the controller.
Operation is restored after two reboots of the wireless points and the controller.
I'm attaching the wAP config - if somebody is interested. I'm not sharing hAP ax³, because I've got some amount of private stuff in there - it's my primary/edge router. However, there's nothing special done for wAP ac, the CAP was configured as hAP ax² CAP running WifiWave2. I'm using "CAPsMAN static" interface provisioning, because of the driver limitation:
Ooh, this is very useful. Just to see if I understood right - your main "wifi-2.4G" and "wifi-5G" are running on the default VLAN (pvid 1), and the "-guest" variant on VLAN 31, right?
Could you share just the capsman config from your hAP ax³ if you can? (In old capsman, it would be "/capsman export", not sure in new one where it is). I'd like to understand the radios and provisioning rules you're using.
3E:XX:XX:XX:XX:XX@K-NET.hAP-ax2.1-5G2 roamed to 3E:XX:XX:XX:XX:XX@K-NET.wAP.1-5G2, signal strength -77
Your IP 46.XX.XXX.XXX has been blocked because it is blacklisted. For details please see http://www.spamhaus.org/query/bl?ip=46.XX.XXX.XXX.
Only once, they remain enabled after reboot.Last question: I see you're using "add action=create-disabled", interesting. Do you need to enable them only once (after they're initially created when joining)? Or after each reboot?
Probably some proprietary extension of the standard from qcom.400Mb/s maximum data rate in the 2.4GHz band for IPQ4019 interfaces
cAP AC is IPQ4018 based and support max 300mbps data rate in the 2.4GHz band: Specifications - https://mikrotik.com/product/cap_acIt's documented at https://help.mikrotik.com/docs/display/ ... i-BenefitsProbably some proprietary extension of the standard from qcom.400Mb/s maximum data rate in the 2.4GHz band for IPQ4019 interfaces
yes yes.. with the MikroTik drivers, not with the Wave2 capable ones.cAP AC is IPQ4018 based and support max 300mbps data rate in the 2.4GHz band[...]
Clear. They haven't updated the specs yet!yes yes.. with the MikroTik drivers, not with the Wave2 capable ones.cAP AC is IPQ4018 based and support max 300mbps data rate in the 2.4GHz band[...]
The cAP AC have 256MB and I think they are enough.And they probably won't. cAP ac and hAP ac2 are in the same boat, too little memory (RAM) for the full featured drivers.
They could ship some -smallbuffers version of drivers for these devices, but doubt that this will see any light.
Even the capax/hap ax3 have 128MB - meaning the 128MB is sufficient........But the same specs page you linked above lists 128MB ... hmm. You ok?
I bought over 100 of them and they were all 256MB! I think they wrote it wrong, it's even commented if I'm not messing around in threads back.But the same specs page you linked above lists 128MB ... hmm. You ok?
There were a few (?) golden batches for hAP ac2 and cAP ac with 256MB (of RAM, anav, of RAM!) but those are history already. It's not something you can currently buy.I bought over 100 of them and they were all 256MB! I think they wrote it wrong, it's even commented if I'm not messing around in threads back.But the same specs page you linked above lists 128MB ... hmm. You ok?
hAP ac2 (I believe it's almost identical inside apart from number of ether ports) has officially 128MB RAM. However, some early batches came with 256MB RAM (I happen to have one of those). Are your cAP acs early birds as well?I bought over 100 of them and they were all 256MB!But the same specs page you linked above lists 128MB ... hmm. You ok?
Yes, factory software is ROS 6.40.3 :)hAP ac2 (I believe it's almost identical inside apart from number of ether ports) has officially 128MB RAM. However, some early batches came with 256MB RAM (I happen to have one of those). Are your cAP acs early birds as well?
I bought over 100 of them and they were all 256MB!
There appear to be 2 channel options. Perhaps a duplicate, or one channel refers to old CAPSMAN. Try selecting both if you've not come right yet.Thanks.
Winbox, The channel box still isn't fixed.
What about using wAP ac as ceiling access point? It's small, white and neat - rounded edges.In all this discussion, the sad part is that the cap AX is "large", and there's no "small" size of it. I just wish they made cap AC with more ram and flash, but same size.
/interface/wifi> print
Flags: M - MASTER; D - DYNAMIC; B - BOUND; I - INACTIVE, R - RUNNING
Columns: NAME, MASTER-INTERFACE
# NAME MASTER-INTERFACE
;;; busy
0 MDBI 2Ghz-2a_TV1
1 DBI 2Ghz-2a_TV2 2Ghz-2a_TV1
;;; busy
2 MDBI 2Ghz-E1
3 DBI 2Ghz-E2 2Ghz-E1
;;; busy
4 MDBI 2Ghz-L-ac31
5 DB 2Ghz-ax31 wifi2
;;; busy
6 MDBI 5Ghz-2_TV1
7 DBI 5Ghz-2_TV2 5Ghz-2_TV1
;;; busy
Unfortunately, rebooting “fixes” the problem only partially - temporarily. And when she next appears is not clear.After full restart of all caps "busy" went away. All good for now.
Yes fully aware of that, but if you now close the windows and re-open it the channel will be once again blank. Or at least on my hAP ax2 it is!There appear to be 2 channel options. Perhaps a duplicate, or one channel refers to old CAPSMAN. Try selecting both if you've not come right yet.MT Channel.pngThanks.
Winbox, The channel box still isn't fixed.
I´ve opened a Support Ticket regarding this new issue with 7.13Beta3:Unfortunately, rebooting “fixes” the problem only partially - temporarily. And when she next appears is not clear.After full restart of all caps "busy" went away. All good for now.
I got a very very fast answer to my ticket, where Guntis gave me an actual ALPHA240 LINK, in which the bug should be fixed.I´ve opened a Support Ticket regarding this new issue with 7.13Beta3:
Unfortunately, rebooting “fixes” the problem only partially - temporarily. And when she next appears is not clear.
SUP-135880
Let´s see what MT will say ;-)
It's not ROS problem, it's web site problem:Still getting CRL fetch failed: http error: Network unreachable for: http://x1.c.lencr.org/
$ telnet x1.c.lencr.org 80
Trying 23.205.191.135...
Connected to e8652.dscx.akamaiedge.net.
Escape character is '^]'.
HEAD / HTTP/1.0
HTTP/1.0 400 Bad Request
Server: AkamaiGHost
Mime-Version: 1.0
Content-Type: text/html
Content-Length: 209
Expires: Wed, 29 Nov 2023 06:25:19 GMT
Date: Wed, 29 Nov 2023 06:25:19 GMT
Connection: close
Connection closed by foreign host.
Have a look at Let's Encrypt R3 intermediate certificate... The url is its crl endpoint.What is that site? http://x1.c.lencr.org/
It doesn't work for me too. Try other sites maybe ;)
there was a 256MB batch which shipped for a short period. (edit: typo)The cAP AC have 256MB and I think they are enough.And they probably won't. cAP ac and hAP ac2 are in the same boat, too little memory (RAM) for the full featured drivers.
They could ship some -smallbuffers version of drivers for these devices, but doubt that this will see any light.
VRF route leaking via (i)BGP on ROS v7.xx.x is a complete CF and broken. does not work.redistribute default route via VRF-BGP is completely broken on v7.
I have opened ticket with MikroTik support.
i've been told to provide more details (how it works on v6).
Once i've done that, almost five days i'm waiting for response
Yup, it's documented behaviour. See new WiFi manual under "Replacing 'wireless' package" -> "Lost features"I still cannot get VLANs working for hAP Ac2 and virtual access points for v7.13beta.
True, just it also says:Yup, it's documented behaviour. See new WiFi manual under "Replacing 'wireless' package" -> "Lost features"
here are quite a few of us hoping that this feature will come back (or rather, will be introduced to wifi driver).
So my understanding is this should work when using a bridge that has been already attached to a VLAN?VLAN configuration in the wireless settings (Per-interface VLANs can be configured in bridge settings)
Can you both email support@mikrotik.com with details.VRF route leaking via (i)BGP on ROS v7.xx.x is a complete CF and broken. does not work.redistribute default route via VRF-BGP is completely broken on v7.
I have opened ticket with MikroTik support.
i've been told to provide more details (how it works on v6).
Once i've done that, almost five days i'm waiting for response
got 4 CCR1072 and around 24 CCR2006 collecting dust because of that.
also 40 RB4011 are on hold too because of that missing core "feature" which was working on v6
Depends how you deal with VLANs on bridge.So my understanding is this should work when using a bridge that has been already attached to a VLAN?
Thanks, that was my understanding too. Just as I wrote, when adding wifi interface to bridge as port - it is shown as inactive. Here as the wifi interface it looks fineDepends how you deal with VLANs on bridgeSo my understanding is this should work when using a bridge that has been already attached to a VLAN?
Essentially: if you have bridge with VLAN filtering enabled, then currently the only option si to (manually?) add wifi interface to bridge as port with PVID set. If VLAN filtering is not enabled on bridge, then one has to play dirty games.
That would be easy, wouldn't it? :)If there is no client connected to the wireless interface, it will show as inactive.
Dear MT,providing default route via VRF-BGP is totally broken on v7.
I got ticket opened.
I've been advised to provide more details, as soon as i provided, i haven't received any response
What are you doing with a beta version on enterprise environment then ??Dear MT,
Can u check this issue please.
So many people using your hardware as enterprise things not just a home things
Thx
Still having issues with CRL
See attached
log.txt
supout.rif.txt
TIA