If the audience is "just a WAP" in my config...
So make a bridge and put the VLAN and wireless interface in it?
I think I will just put the Audience back in it's box for now.
Here is how you can do it, don't use vlan tags under wireless interfaces, i did not use them even with the old driver, instead do like so:
create one bridge, only one is needed, add wireless and physical ports to it, notice the tags I am using (10 and 20 for access ports)
/interface bridge port
add bridge=bridge ingress-filtering=no interface=ether1-trunk
add bridge=bridge ingress-filtering=no interface=ether2 pvid=10
add bridge=bridge interface=wlan10_main_2.4GHz pvid=10
add bridge=bridge interface=wlan10_main_5.0GHz pvid=10
add bridge=bridge interface=wlan10_main_5.0GHz+ pvid=10
add bridge=bridge interface=wlan20_guest_2.4GHz pvid=20
add bridge=bridge interface=wlan20_guest_5.0GHz+ pvid=20
then enable vlan filtering in the bridge section:
am basically splitting the interfaces on access and trunk, all wlans are access (I got 6: 3 phisical + 3 virtual wlans) and I tell the interfaces: some belong to vlan 10, the other to vlan 20
/interface bridge vlan
add bridge=bridge tagged=ether1-trunk,bridge untagged=ether2,wlan10_main_2.4GHz,wlan10_main_5.0GHz,wlan10_main_5.0GHz+ vlan-ids=10
add bridge=bridge tagged=ether1-trunk,bridge untagged=wlan20_guest_2.4GHz,wlan20_guest_5.0GHz+ vlan-ids=20