I have noticed that in Redundant RR scenario, when RR1 received prefix from RR-client1 and reflecting received prefix to the RR2 which is in the same cluster, originator-id and cluster-list attributes are not added to the reflected prefix. Is it known problem in Mikrotik or I'm missing something ?
As result rr-client receiving it's advertised prefix back over BGP.
RR1
Code: Select all
/routing ospf instance
add disabled=no name=ospf-instance-v2 router-id=10.0.0.1
/routing ospf area
add comment=backbone_v2 disabled=no instance=ospf-instance-v2 name=area0
/routing bfd configuration
add address-list=bfd-allowed forbid-bfd=no
add disabled=no forbid-bfd=no interfaces=all
/routing bgp connection
add as=65000 cluster-id=1.1.1.1 connect=yes listen=yes local.address=10.0.0.1 .role=\
ibgp name=to-r2-rr remote.address=10.0.0.2 .as=65000 router-id=10.0.0.1 use-bfd=\
yes
add as=65000 connect=yes listen=yes local.address=10.0.0.1 .role=ibgp-rr name=\
to-r3-rr-client remote.address=10.0.0.3 .as=65000 router-id=10.0.0.1 use-bfd=yes
add as=65000 connect=yes listen=yes local.address=10.0.0.1 .role=ibgp-rr name=\
to-r4-rr-client remote.address=10.0.0.4 .as=65000 router-id=10.0.0.1 use-bfd=yes
/routing ospf interface-template
add area=area0 disabled=no interfaces=loopback0 passive type=ptp
add area=area0 disabled=no interfaces=ether1 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether2 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether3 type=ptp use-bfd=yes
routing/bgp/advertisements/print detail
0 peer=to-r4-rr-client-1 dst=172.21.3.0/24 afi=ip local-pref=100 nexthop=10.0.0.3
origin=0 atomic-aggregate=yes
0 peer=to-r3-rr-client-1 dst=172.21.4.0/24 afi=ip local-pref=100 nexthop=10.0.0.4
origin=0 atomic-aggregate=yes
0 peer=to-r2-rr-1 dst=172.21.4.0/24 afi=ip local-pref=100 nexthop=10.0.0.4 origin=0
atomic-aggregate=yes
0 peer=to-r2-rr-1 dst=172.21.3.0/24 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
atomic-aggregate=yes
RR2
Code: Select all
/routing ospf instance
add disabled=no name=ospf-instance-v2 router-id=10.0.0.2
/routing ospf area
add comment=backbone_v2 disabled=no instance=ospf-instance-v2 name=area0
/routing bfd configuration
add address-list=bfd-allowed forbid-bfd=no
add disabled=no forbid-bfd=no interfaces=all
/routing bgp connection
add as=65000 cluster-id=1.1.1.1 connect=yes listen=yes local.address=10.0.0.2 .role=\
ibgp name=to-r1-rr remote.address=10.0.0.1 .as=65000 router-id=10.0.0.2 use-bfd=\
yes
add as=65000 connect=yes listen=yes local.address=10.0.0.2 .role=ibgp-rr name=\
to-r3-rr-client remote.address=10.0.0.3 .as=65000 router-id=10.0.0.2 use-bfd=yes
add as=65000 connect=yes listen=yes local.address=10.0.0.2 .role=ibgp-rr name=\
to-r4-rr-client remote.address=10.0.0.4 .as=65000 router-id=10.0.0.2 use-bfd=yes
/routing ospf interface-template
add area=area0 disabled=no interfaces=loopback0 passive type=ptp
add area=area0 disabled=no interfaces=ether1 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether2 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether3 type=ptp use-bfd=yes
Code: Select all
/routing ospf instance
add disabled=no name=ospf-instance-v2 router-id=10.0.0.3
/routing ospf area
add comment=backbone_v2 disabled=no instance=ospf-instance-v2 name=area0
/routing bfd configuration
add forbid-bfd=no interfaces=all
add address-list=bfd-allowed forbid-bfd=no
/routing bgp connection
add as=65000 connect=yes listen=yes local.address=10.0.0.3 .role=ibgp name=to-r1-rr \
output.redistribute=connected remote.address=10.0.0.1 .as=65000 router-id=\
10.0.0.3 use-bfd=yes
add as=65000 connect=yes listen=yes local.address=10.0.0.3 .role=ibgp name=to-r2-rr \
output.redistribute=connected remote.address=10.0.0.2 .as=65000 router-id=\
10.0.0.3 use-bfd=yes
/routing ospf interface-template
add area=area0 disabled=no interfaces=ether1 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=ether2 type=ptp use-bfd=yes
add area=area0 disabled=no interfaces=loopback0 type=ptp
R3] > routing/bgp/advertisements/print detail
0 peer=to-r2-rr-1 dst=192.168.1.0/30 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r2-rr-1 dst=192.168.3.0/30 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r2-rr-1 dst=172.21.3.0/24 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r2-rr-1 dst=10.0.0.3 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r1-rr-1 dst=192.168.1.0/30 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r1-rr-1 dst=192.168.3.0/30 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r1-rr-1 dst=172.21.3.0/24 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
0 peer=to-r1-rr-1 dst=10.0.0.3 afi=ip local-pref=100 nexthop=10.0.0.3 origin=0
R3] > ip route/print where bgp=yes
Flags: D - DYNAMIC; A - ACTIVE; b - BGP; + - ECMP
Columns: DST-ADDRESS, GATEWAY, DISTANCE
DST-ADDRESS GATEWAY DISTANCE
D b 172.21.3.0/24 10.0.0.2 200
D b+ 172.21.4.0/24 10.0.0.4 200
DAb+ 172.21.4.0/24 10.0.0.4 200
Dmitri