I think the issue you are having is because you want to tag traffic on a specific port but also setting a pvid with the same vlan id.
For example
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged interface=ether7 pvid=30
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged interface=ether9 pvid=20
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged interface=ether10 pvid=30
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged interface=ether12 pvid=20
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged interface=ether13 pvid=30
You should use the default pvid here of 1 (you can use anything else as long as it is not the same vlan id)
Logically because the option "frame-types=admit-only-vlan-tagged" is set pvid should be ignored.
But I think the pvid here is not ignored and sending the traffic as untagged on the interface.
I changed all pvid now to the default, i.e. 1 under /interface/bridge/port, still the same problem vlans do not work and traffic does not flow
Below is the configuration of the working switch, the same software version as in the switch where the vlans do not work
# mar/05/2024 16:44:26 by RouterOS 7.9.2
# software id = 9YL9-8TLR
#
# model = CRS326-24G-2S+
/interface bridge
add add-dhcp-option82=yes admin-mac=CC:2D:E0:DC:C5:4A auto-mac=no comment=\
defconf dhcp-snooping=yes name=bridge vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] advertise="10M-half,10M-full,100M-half,\
100M-full,1000M-half,1000M-full,10000M-full,2500M-full,5000M-full"
set [ find default-name=sfp-sfpplus2 ] advertise="10M-half,10M-full,100M-half,\
100M-full,1000M-half,1000M-full,10000M-full,2500M-full,5000M-full"
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/port
set 0 name=serial0
/snmp community
set [ find default=yes ] name=xxxxxxxx
/interface bridge port
add bridge=bridge comment=defconf interface=ether1 trusted=yes
add bridge=bridge comment=defconf interface=ether2 trusted=yes
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6 pvid=20
add bridge=bridge comment=defconf interface=ether7 pvid=30
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9 pvid=20
add bridge=bridge comment=defconf interface=ether10 pvid=30
add bridge=bridge comment=defconf interface=ether11
add bridge=bridge comment=defconf interface=ether12 pvid=20
add bridge=bridge comment=defconf interface=ether13 pvid=30
add bridge=bridge comment=defconf interface=ether14
add bridge=bridge comment=defconf interface=ether16
add bridge=bridge comment=defconf interface=ether17
add bridge=bridge comment=defconf interface=ether18
add bridge=bridge comment=defconf interface=ether19
add bridge=bridge comment=defconf interface=ether20
add bridge=bridge comment=defconf interface=ether21
add bridge=bridge comment=defconf interface=ether22
add bridge=bridge comment=defconf interface=ether23
add bridge=bridge comment=defconf interface=ether24
add bridge=bridge comment=defconf interface=sfp-sfpplus1
add bridge=bridge comment=defconf interface=sfp-sfpplus2
add bridge=bridge interface=ether15
/interface bridge vlan
add bridge=bridge comment=klusteri tagged=ether7,ether10,ether13 vlan-ids=30
add bridge=bridge comment=anicyna tagged=ether1,ether2,ether6 vlan-ids=60
add bridge=bridge comment=virtuaalikoneet tagged=\
ether1,ether2,ether6,ether9,ether12 vlan-ids=20
/ip address
add address=192.168.1.7/24 comment=defconf interface=bridge network=\
192.168.1.0
/ip dns
set servers=192.168.1.1
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set api disabled=yes
set winbox disabled=yes
set api-ssl disabled=yes
/ip traffic-flow target
add dst-address=192.168.1.1 port=2056
/snmp
set enabled=yes
/system clock
set time-zone-name=Europe/Helsinki
/system identity
set name=crs326-paakytkin
/system note
set show-at-login=no
/system routerboard settings
set boot-os=router-os