I was experimenting with some different settings to enable WiFi on AX APs, using CAPsMAN and assigning VLANs through Access List MAC address definition on a single SSID.
In term of VLAN assignment I can see that each device, based on their MAC address, gets assigned a properly VLAN as configured on the single SSID available through WiFi APs.
However the fast transitioning from APs to APs does not seem to work properly, when compared to a more standard setup with CAPsMAN, datapath setting each VLANs and multiple SSID per VLAN.
This is what I have done so far on CAPsMAN controller:
Code: Select all
/interface wifi datapath
add bridge=bridge disabled=no name=DPath
/interface wifi security
add authentication-types=wpa3-psk disabled=no ft=yes ft-over-ds=yes name=WPA3_5G
/interface wifi access-list
add action=accept comment=dev1 disabled=no mac-address=xx:xx:xx:xx:xx:xx vlan-id=8
add action=accept comment=dev2 disabled=no mac-address=yy:yy:yy:yy:yy:yy vlan-id=7
add action=accept comment=dev3 disabled=no mac-address=zz:zz:zz:zz:zz:zz vlan-id=9
/interface wifi configuration
add channel=5G_Ch36 country=Italy datapath=DPath disabled=no mode=ap name=rb1apx_5G_Main security=WPA3_5G ssid=SSID \
tx-power=10
add channel=5G_Ch100 country="Italy" datapath=DPath disabled=no mode=ap name=rb2apx_5G_Main security=WPA3_5G ssid=\
SSID tx-power=10
add channel=5G_Ch100 country="Italy" datapath=DPath disabled=no mode=ap name=rb3apx_5G_Main security=WPA3_5G ssid=\
SSID tx-power=5
add channel=5G_Ch36 country=Italy datapath=DPath disabled=no mode=ap name=rb4apx_5G_Main security=WPA3_5G ssid=SSID \
tx-power=5
/interface wifi provisioning
add action=create-dynamic-enabled comment=rb1apx disabled=no master-configuration=rb1apx_5G_Main name-format=%I-5G radio-mac=MAC1
add action=create-dynamic-enabled comment=rb2apx disabled=no master-configuration=rb2apx_5G_Main name-format=%I-5G radio-mac=MAC2
add action=create-dynamic-enabled comment=rb3apx disabled=no master-configuration=rb3apx_5G_Main name-format=%I-5G radio-mac=MAC3
add action=create-dynamic-enabled comment=rb4apx disabled=no master-configuration=rb4apx_5G_Main name-format=%I-5G radio-mac=MAC4
Code: Select all
/interface bridge
add admin-mac=MAC auto-mac=no comment=defconf name=bridge port-cost-mode=short vlan-filtering=yes
/interface vlan
add interface=bridge name=vlan-mgmt vlan-id=100
/interface bridge port
add bridge=bridge comment=defconf interface=ether2 internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf interface=ether3 internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf interface=ether4 internal-path-cost=10 path-cost=10
add bridge=bridge frame-types=admit-only-vlan-tagged interface=ether1
/interface bridge vlan
add bridge=bridge tagged=bridge,ether1 vlan-ids=100
/interface wifi cap
set discovery-interfaces=vlan-mgmt enabled=yes
/interface wifi
# managed by CAPsMAN
# mode: AP, SSID: SSID, channel: 5500/ax/Ceee
set [ find default-name=wifi1 ] channel.band=5ghz-ax .frequency=5500 .skip-dfs-channels=10min-cac .width=20/40/80mhz configuration.manager=capsman .mode=ap .ssid=MikroTik-CCEF5A datapath=\
datapath datapath.bridge=bridge disabled=no security.authentication-types=wpa2-psk,wpa3-psk
/interface wifi datapath
add bridge=bridge disabled=no name=datapath
So I'm not really sure whether this is still an on-going development by MikroTik or something that would never make FT working properly when using the single SSID setup and VLANs.
Anyone else has tested such config or have an opinion on this ?
Thanks.