i have purchased few months ago a RB4011iGS + RM . it is 10 port gigabit switch like router. I have started from a clean slate (no defconfig).
i have watched some youtube videos and successfully configured 3 dhcp clients on port 1, port 2 ,port 3; with per connection classifier rules in firewall.
i want todo 2 seperate networks with the 3 isps. i.e. isp1 and isp3 (ether1, ether3) in one network with access to ONLY ports 4,5,9,10 . AAND other isp2 (ether2) in another network with access to ONLY ports 6,7,8. i successfully configured this and the 2 networks were working fine BUT i wanted to forward a port from isp2 to its second network, this did NOT work. can anyone help me?
i want the two dhcp servers (or vlans) to send traffic to their respective seperate isps. i want no communication between the 2 networks.
btw, what i am doing is: testing a openvpn and wireguard server. i.e. the server is in vlan 2 and i am connecting to it from a client which is in vlan 1. thus i cannot have the vlan1 to use isp2 or vlan2 to use isp1,isp3. the vlans should have their seperate isps. the forwarded traffic must go 'out' from vlan2 to isp2 and come "in" thru the other isps on a vlan1 pc.
VPN is for remote clients coming in on a particlular WAN.
vpn is for accessing office/vlan2 network from outside. Vlan2 has a single server and other normal PCs.
'outside' network (having wireguard client soft on windows PC) is supposed to be vlan1. vlan1 has PC with wireguard client. this client is tunneling/connecting to server in vlan2.
the traffic should go from one wan to another and NOT directly from one subnet/lan to other subnet (skipping wan). thus i not include vlan2 in "LAN" list. it has its own list called "LANhathway".
this "LANhathway" list is used for outbound connections to wan2 (firewall mangle rule). i dont want vlan2 to use wan1 or wan3. it should strictly use wan2. wan2/isp2 has static ip that i can use for the wireguard server.
BTW, do i need to allow wireguard packets (i.e. some special rule) to flow through the mikrotik? i am using a wireguard client (in vlan1) to dial a connection to the wireguard server (in vlan2).
BTW, i had posted my problem in another post in 'beginner basics' section. Forum member 'Anav' simply stopped responding

Someone please help. i dont want any vpn or wbg or such complex things from the router. please help.
My current config:
# 2024-04-26 16:39:55 by RouterOS 7.11.2
# software id = xxxxx
#
# model = RB4011iGS+
# serial number = xxxxx
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=ether1-YOUbroad
set [ find default-name=ether2 ] name=ether2-hathway
set [ find default-name=ether3 ] name=ether3-TataPLAY
/interface vlan
add interface=bridge1 name=vlan1 vlan-id=10
add interface=bridge1 name=vlan2Hathwaywala vlan-id=20
/interface list
add name=WAN
add name=LAN
add name=LANhathway
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool3 ranges=192.168.9.100-192.168.9.254
add name=dhcp_pool4 ranges=192.168.12.100-192.168.12.200
/ip dhcp-server
add address-pool=dhcp_pool3 interface=vlan1 name=dhcp1
add address-pool=dhcp_pool4 interface=vlan2Hathwaywala name=dhcp2
/port
set 0 name=serial0
set 1 name=serial1
/routing table
add disabled=no fib name=toYOUbroad
add disabled=no fib name=tohathway
add disabled=no fib name=toTataPLAYy
/interface bridge port
add bridge=bridge1 interface=ether4 pvid=10
add bridge=bridge1 interface=ether5 pvid=10
add bridge=bridge1 interface=ether6 pvid=20
add bridge=bridge1 interface=ether7 pvid=20
add bridge=bridge1 interface=ether8 pvid=20
add bridge=bridge1 interface=ether9 pvid=10
add bridge=bridge1 interface=ether10 pvid=10
/interface bridge vlan
add bridge=bridge1 tagged=bridge1 untagged=ether4,ether5,ether9,ether10 \
vlan-ids=10
add bridge=bridge1 tagged=bridge1 untagged=ether6,ether7,ether8 vlan-ids=20
/interface list member
add interface=ether1-YOUbroad list=WAN
add interface=ether2-hathway list=WAN
add interface=ether3-TataPLAY list=WAN
add interface=vlan1 list=LAN
add interface=vlan2Hathwaywala list=LANhathway
/ip address
add address=192.168.9.9/24 interface=vlan1 network=192.168.9.0
add address=192.168.12.12/24 interface=vlan2Hathwaywala network=192.168.12.0
/ip dhcp-client
add add-default-route=no interface=ether1-YOUbroad
add add-default-route=no interface=ether2-hathway
add add-default-route=no interface=ether3-TataPLAY
/ip dhcp-server network
add address=192.168.9.0/24 dns-server=208.67.222.222,208.67.220.220 gateway=\
192.168.9.9
add address=192.168.12.0/24 dns-server=208.67.222.222,208.67.220.220 gateway=\
192.168.12.12
/ip dns
set servers=208.67.222.222,208.67.220.220
/ip firewall filter
add action=accept chain=forward connection-nat-state=dstnat
add action=accept chain=input connection-nat-state=dstnat
/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark \
connection-state=new in-interface=ether1-YOUbroad new-connection-mark=\
ether1-youbroadin passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark \
connection-state=new in-interface=ether2-hathway new-connection-mark=\
ether2-hathway-in passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark \
connection-state=new in-interface=ether3-TataPLAY new-connection-mark=\
ether3-tata-in passthrough=yes
add action=mark-routing chain=output connection-mark=ether1-youbroadin \
new-routing-mark=toYOUbroad passthrough=yes
add action=mark-routing chain=output connection-mark=ether2-hathway-in \
new-routing-mark=tohathway passthrough=yes
add action=mark-routing chain=output connection-mark=ether3-tata-in \
new-routing-mark=toTataPLAYy passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark \
connection-state=new dst-address-type=!local in-interface-list=LAN \
new-connection-mark=toether1-youbroad passthrough=yes \
per-connection-classifier=src-address-and-port:2/1
add action=mark-connection chain=prerouting connection-mark=no-mark \
connection-state=new dst-address-type=!local in-interface-list=LANhathway \
new-connection-mark=toether2-hathway passthrough=yes
add action=mark-connection chain=prerouting connection-mark=no-mark \
connection-state=new dst-address-type=!local in-interface-list=LAN \
new-connection-mark=toether3-tata passthrough=yes \
per-connection-classifier=src-address-and-port:2/0
add action=mark-routing chain=prerouting connection-mark=toether1-youbroad \
in-interface-list=LAN new-routing-mark=toYOUbroad passthrough=yes
add action=mark-routing chain=prerouting connection-mark=toether2-hathway \
in-interface-list=LANhathway new-routing-mark=tohathway passthrough=yes
add action=mark-routing chain=prerouting connection-mark=toether3-tata \
in-interface-list=LAN new-routing-mark=toTataPLAYy passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-YOUbroad
add action=masquerade chain=srcnat out-interface=ether2-hathway
add action=masquerade chain=srcnat out-interface=ether3-TataPLAY
add action=dst-nat chain=dstnat dst-port=11111 in-interface-list=WAN \
protocol=tcp to-addresses=192.168.12.200 to-ports=11111
add action=dst-nat chain=dstnat dst-port=11111 in-interface-list=WAN \
protocol=udp to-addresses=192.168.12.200 to-ports=11111
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
1.1.1.1 pref-src="" routing-table=toYOUbroad scope=30 \
suppress-hw-offload=no target-scope=32
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
8.8.8.8 pref-src="" routing-table=tohathway scope=30 suppress-hw-offload=\
no target-scope=32
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
8.8.4.4 pref-src="" routing-table=toTataPLAYy scope=30 \
suppress-hw-offload=no target-scope=32
add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
1.1.1.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=32
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
8.8.4.4 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=32
add disabled=no dst-address=1.1.1.1/32 gateway=192.168.4.4 routing-table=main \
scope=30 suppress-hw-offload=no target-scope=31
add disabled=no distance=1 dst-address=8.8.8.8/32 gateway=192.168.1.1 \
pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=31
add disabled=no distance=1 dst-address=8.8.4.4/32 gateway=192.168.72.72 \
pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=31
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
/system clock
set time-zone-name=Asia/Kolkata
/system note
set show-at-login=no
/system routerboard settings
set enter-setup-on=delete-key