I should be fine with the VLAN configuration,
That makes this easier - explaining vlan-filtering=yes is not easy in a forum post.
This is central question:
What makes it a "transparent" bridge or passthrough?
There are two operational mode of LTE on RouterOS.
1. One, is that's it's a local interface, and the LTE carrier-assigned IP address from their network get's assigned to the ATL. And the ATL acts like any home router with LAN+DHCP+NAT, except instead of ether1 it's lte1 that's the WAN. This is the default mode.
2. The other is
LTE Passthrough, where the IP address from LTE gets assigned to
another device. Since the LTE IP is "passthrough" the router, the ATL no longer has internet via LTE – since its interface is going somewhere else (i.e. as 2nd WAN on a main router). ATL still has it's LAN IP etc., but it need a new default gateway to the route where the LTE is going.
2 bridge ports,
one with the LTE and the eth1 port with a VLAN tag or vlanx, no ip address?
You cannot NOT bridge /interface/lte via the /interface/bridge/port, directly. So that's not how it's done.
If you want to "bridge" the LTE interface (option 2 above) you need to set the passthrough interface in APN Profile for the LTE interface. You'd want to do this only if there is some single main router that you want to get the LTE network-assigned IP address (i.e. LTE is a 2nd WAN on it). Instead of /interface/bridge/port, you assign a VLAN (or VXLAN/EoIP/etc) via /interface/lte/apn's passthrough-interface= to "bridge LTE". Something like (just example from head):
/interface/bridge/set [find name=bridge] vlan-filtering=yes
/interface/vlan add vlan-id=301 name=lte-passthrough bridge=bridge
/interface/lte/apn set [find name=default] passthrough-interface=lte-passthrough
/interface/bridge/vlan add vlan-ids=301 tagged=bridge,ether1
/interface/bridge/vlan add vlan-ids=1 untagged=bridge,ether1
Since the VLAN301 has the real LTE IP address on it, the router cannot have the LTE IP. You also need some management subnet to be able to access the router for configuration. So the native VLAN on the bridge, in defaults, have 192.168.188.1/24 address & be untagged on bridge.
How you'd want to deal with the management network is up to you. But likely re-assigning 192.168.188.0/24 stuff on ATL to some existing management network is what's you want. For simplicity, if we assume the untagged ether1 as management to the device (i.e. first switch in a hybrid port, with 301 for LTE passthrough, and untagged ether1 is management. You can undo the defaults with something like:
/ip/address/add interface=bridge address=<your-management-ip>
/ip/dhcp-server/set [find] disable
/ip/route/add dst=0.0.0.0/0 gateway=<your-management-subnet-default-gateway>
It could be a VXLAN or 2nd VLAN on ATL with more config.
There should NO IP address on the LTE interface nor whatever passthrough-interface= used on ATL (in example "vlan301"). Only one, and only one (i.e. the first, or the MAC address configured in /interface/lte/apn) & it will can DHCP to get it directly from LTE network.
1 bridge port, with eth1
also with a vlan assigned say vlanxx, and with a IP address.
If you want IP address and routing, whole different story. But another mode is can just leave the ATL as router, and add static routes (or use OSPF/BGP/RIP/etc) to your network. So your VLAN 301 is the 192.168.188.0/24 (or whatever LAN is assigned to ATL), and your other routes just send traffic to 192.168.188.1. You have to be careful no additional NAT's get in the way.
Basically it whether you want Layer2 bridge to LTE, or you want a routable subnet to LTE. Kinda your choices. The underlying VLANs can be used for either.