I saw some posts of people asking for MVRP. Now, I do see the usage of this protocol if you're not in an all Mikrotik environment. But my question is: how does this help in an all Mikrotik environment? I mean, on Mikrotik, you have to "define" the VLAN and add the tagged/untagged ports to it. This means that, having MVRP propagate VLANs across devices doesn't really do much, except adding the trunk ports to those VLANs as tagged. Am I missing something?
What I mean:
I've got two switches, connected via ether1
On the first device I defined:
Code: Select all
/interface/bridge/add name=test vlan-filtering=yes pvid=1 mvrp=yes
/interface/bridge/port add bridge=test interface=ether1 pvid=1
/interface/bridge/vlan add bridge=test vlan-ids=10,20 tagged=test,ether1
Code: Select all
/interface/bridge/vlan add bridge=test vlan-ids=10 tagged=test,ether1, untagged=ether2
Also, a related question: from what I know/tested/worked with, in order to be able to use a VLAN in a bridge, you'd have to have that bridge as a tagged port. Since MVRP only adds the ether1 as tagged, I can't really use it in the bridge unless I manually define it, right? Output of
Code: Select all
/interface/bridge/vlan print
Code: Select all
[admin@Sw02] > /interface/bridge/vlan/print
Flags: D - DYNAMIC
Columns: BRIDGE, VLAN-IDS, CURRENT-TAGGED, CURRENT-UNTAGGED
# BRIDGE VLAN-IDS CURRENT-TAGGED CURRENT-UNTAGGED
0 D test 1 test
ether1
1 D test 10 ether1
20
Code: Select all
# --- Sw01 ---
[admin@Sw01] > # Set ether2 as untagged via VLAN10 - a pc is connected here
[admin@Sw01] > /interface/bridge/port add bridge=test pvid=10 interface=ether2
# --- Sw02 ---
[admin@Sw02] > # Set ether2 as untagged via VLAN10 - a pc is connected here
[admin@Sw02] > /interface/bridge/port add bridge=test pvid=10 interface=ether2
Please, don't take this post as a "bashing" or something. I am really failing to understand how people use MVRP in environments where all the switches/routers are Mikrotik devices.