Various MT devices, CHR, all running 7.15.1.
Several sites: site1, site2, site3. All-to-all configuration - each site have a single WireGuard instance and two peers configured for other sites.
10.0.<site>.0/24 are internal networks, 10.1.<site>.0/24 are management networks.
site1:
Code: Select all
/interface wireguard add listen-port=13231 mtu=1420 name=wireguard1
/ip address add address=10.1.1.1/16 interface=name=wireguard1 network=10.1.0.0
/interface wireguard peers add allowed-address=10.1.2.0/24 endpoint-address=10.0.2.1 interface=wireguard1
/interface wireguard peers add allowed-address=10.1.3.0/24 endpoint-address=10.0.3.1 interface=wireguard1
Code: Select all
/interface wireguard add listen-port=13231 mtu=1420 name=wireguard1
/ip address add address=10.1.2.1/16 interface=name=wireguard1 network=10.1.0.0
/interface wireguard peers add allowed-address=10.1.1.0/24 endpoint-address=10.0.1.1 interface=wireguard1
/interface wireguard peers add allowed-address=10.1.3.0/24 endpoint-address=10.0.3.1 interface=wireguard1
Code: Select all
/interface wireguard add listen-port=13231 mtu=1420 name=wireguard1
/ip address add address=10.1.3.1/16 interface=name=wireguard1 network=10.1.0.0
/interface wireguard peers add allowed-address=10.1.2.0/24 endpoint-address=10.0.2.1 interface=wireguard1
/interface wireguard peers add allowed-address=10.1.1.0/24 endpoint-address=10.0.1.1 interface=wireguard1
"Last handshake" property for site3 peer on site1 and site2 show the time since the last handshake before site3 gone down.
Cycling (disable/enable) WireGuard peer entries on site3 isn't helping.
Cycling WireGuard peer entry for site3 on site1, or a ping (any packet, I believe) from site1 to site3 brings WireGuard link between site1 and site3 back to live. Same for site2 and site3.
All sites are normally online (but outages happen), so marking any peers as "responder" doesn't look reasonable.
If anyone of you have the same or similar problems with WireGuard on 7.15?