While I'd love to master VLANS, it seems to be beyond me.
@tangent solution works for me (thank you @tangent!).
These are the config entries I used (I'm sure you'll want to customize to your environment):
/interface wifi configuration add datapath.client-isolation=yes disabled=no name=guestcfg security.authentication-types=wpa2-psk .passphrase=blueberry ssid=GuestWifi
/interface wifi add configuration=guestcfg configuration.mode=ap disabled=no master-interface=wifi2 name=Guest2g
/interface wifi add configuration=guestcfg configuration.mode=ap disabled=no master-interface=wifi1 name=Guest5g
/ip pool add name=pool-guest ranges=10.0.0.10-10.0.0.252
/ip address add address=10.0.0.1/24 interface=Guest2g network=10.0.0.0
/ip address add address=10.0.0.1/24 interface=Guest5g network=10.0.0.0
/ip dhcp-server add address-pool=pool-guest interface=Guest2g name=dhcp-guest2g
/ip dhcp-server add address-pool=pool-guest interface=Guest5g name=dhcp-guest5g
/ip dhcp-server network add address=10.0.0.0/24 dns-server=1.1.1.1 gateway=10.0.0.1
/ip dns static add address=10.0.0.1 comment=defconf name=router.lan
/ip firewall address-list add address=10.0.0.2-10.0.0.254 list="Guest WiFi"
/ip firewall filter add action=accept chain=input comment="allow 67 68 to 10.0.0.1" dst-address=10.0.0.1 dst-port=67,68 log=yes log-prefix="allow 67 68 to 10.0.0.1" protocol=udp
/ip firewall filter add action=drop chain=input comment="drop all to 10.0.0.1" dst-address=10.0.0.1 in-interface=!lo log=yes log-prefix="drop all to 10.0.0.1"
/ip firewall filter add action=drop chain=forward comment="drop all 10.0.0.0/24 to not-WAN" log-prefix=drop-all-10-0-0-0-24-to-not-WAN out-interface-list=!WAN src-address=10.0.0.0/24
/ip firewall filter add action=drop chain=forward comment="drop guest to 192.168.0.0/16" dst-address=192.168.0.0/16 dst-port=!53,68,68 log=yes log-prefix=drop-guest-to-192-168-0-0-16 protocol=udp src-ad
dress-list="Guest WiFi"
#Move firewall rules to correct position number