Hi, i have created a wireguard profile to connect my phone to the network.
The connection appears to connect ok, but on my Android phone i get an error about no DNS.
I also have a site - to - site that runs just fine.
i have tried several times to sort this problem out, so there may be some old config lying around from previous attempts...
here's my config
thanks.
```
# 2024-10-12 12:50:10 by RouterOS 7.15.2
# software id = UCH8-EMCD
#
# model = RB750Gr3
# serial number =
/interface bridge
add arp=proxy-arp name=bridge1
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 user=\
bthomehub@btbroadband.com
/interface wireguard
add listen-port=51820 mtu=1420 name=wg0
add listen-port=13231 mtu=1420 name=wireguard1
/interface list
add name=LAN
add name=WAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp_pool0 ranges=192.168.1.20-192.168.1.254
/ip dhcp-server
add address-pool=dhcp_pool0 interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add interface=bridge1 list=LAN
add interface=pppoe-out1 list=WAN
add interface=wg0 list=LAN
add interface=*E list=LAN
/interface ovpn-server server
set certificate=server enabled=yes
/interface wireguard peers
add allowed-address=172.16.0.2/32,10.1.1.0/24 interface=wg0 name=peer2 \
public-key=""
add allowed-address=192.168.100.2/32 interface=wg0 name=wg1 private-key=\
"" public-key=\
""
/ip address
add address=192.168.1.1/24 interface=bridge1 network=192.168.1.0
add address=172.16.0.1/24 interface=wg0 network=172.16.0.0
add address=192.168.100.1/24 interface=wireguard1 network=192.168.100.0
/ip dhcp-server lease
add address=192.168.1.16 client-id=1:dc:a6:32:e1:8a:81 mac-address=\
DC:A6:32:E1:8A:81 server=dhcp1
add address=192.168.1.120 client-id=1:8e:41:c0:f0:3a:cd mac-address=\
8E:41:C0:F0:3A:CD server=dhcp1
add address=192.168.1.80 client-id=1:0:e:58:34:c:f2 mac-address=\
00:0E:58:34:0C:F2 server=dhcp1
add address=192.168.1.81 client-id=1:5c:aa:fd:42:9e:e4 mac-address=\
5C:AA:FD:42:9E:E4 server=dhcp1
add address=192.168.1.82 client-id=1:78:28:ca:5d:f:20 mac-address=\
78:28:CA:5D:0F:20 server=dhcp1
add address=192.168.1.83 client-id=1:0:e:58:d0:6b:34 mac-address=\
00:0E:58:D0:6B:34 server=dhcp1
add address=192.168.1.84 client-id=1:0:e:58:7c:ff:48 mac-address=\
00:0E:58:7C:FF:48 server=dhcp1
add address=192.168.1.85 client-id=1:94:9f:3e:e1:ac:ca mac-address=\
94:9F:3E:E1:AC:CA server=dhcp1
add address=192.168.1.86 client-id=1:b8:e9:37:e2:77:66 mac-address=\
B8:E9:37:E2:77:66 server=dhcp1
add address=192.168.1.87 client-id=1:94:9f:3e:72:29:b8 mac-address=\
94:9F:3E:72:29:B8 server=dhcp1
add address=192.168.1.130 mac-address=7C:F6:66:4A:7A:9A server=dhcp1
add address=192.168.1.132 client-id=1:c8:d7:78:aa:fd:6f mac-address=\
C8:D7:78:AA:FD:6F server=dhcp1
add address=192.168.1.140 client-id=1:64:16:66:75:7a:22 mac-address=\
64:16:66:75:7A:22 server=dhcp1
add address=192.168.1.142 mac-address=6C:FF:CE:95:5B:5F server=dhcp1
add address=192.168.1.143 mac-address=68:54:FD:EC:CE:9B server=dhcp1
add address=192.168.1.100 mac-address=60:32:B1:48:5D:32 server=dhcp1
add address=192.168.1.101 client-id=1:d8:d:17:23:48:d9 mac-address=\
D8:0D:17:23:48:D9 server=dhcp1
add address=192.168.1.102 client-id=1:ac:84:c6:2:ba:51 mac-address=\
AC:84:C6:02:BA:51 server=dhcp1
add address=192.168.1.144 mac-address=1C:F2:9A:46:87:58 server=dhcp1
add address=192.168.1.88 client-id=1:0:e:58:26:2e:8e mac-address=\
00:0E:58:26:2E:8E server=dhcp1
add address=192.168.1.141 mac-address=D8:EB:46:94:4B:78 server=dhcp1
add address=192.168.1.103 mac-address=00:17:88:69:60:2D server=dhcp1
add address=192.168.1.104 mac-address=DC:4F:22:93:91:37 server=dhcp1
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=8.8.8.8 gateway=192.168.1.1
/ip dns
set servers=8.8.8.8,1.1.1.1
/ip firewall filter
add action=accept chain=input comment="accept established,related,untracked" \
connection-state=established,related,untracked
add action=drop chain=input comment="drop invalid" connection-state=invalid
add action=accept chain=input comment="accept ICMP" protocol=icmp
add action=accept chain=input comment="allow colin wireguard" dst-port=13231 \
protocol=udp
add action=accept chain=input comment="Allow wireguard traffic - colin" log=\
yes log-prefix="colin WG" src-address=192.168.100.0/24
add action=accept chain=input dst-port=51820 log=yes log-prefix=\
"Incoming Wireguard" protocol=udp
add action=accept chain=input dst-port=51821 log=yes log-prefix=colinvpn \
protocol=udp
add action=accept chain=input dst-port=53 in-interface-list=LAN protocol=udp
add action=accept chain=input dst-port=53 in-interface-list=LAN protocol=tcp
add action=accept chain=input disabled=yes in-interface-list=WAN protocol=tcp \
src-port=443
add action=drop chain=input comment="block everything else" in-interface=\
ether1
add action=fasttrack-connection chain=forward comment=\
"fast-track for established,related" connection-state=established,related \
hw-offload=yes
add action=accept chain=forward comment="accept established,related" \
connection-state=established,related,untracked
add action=drop chain=forward connection-state=invalid
add action=accept chain=forward comment="internet traffic" in-interface-list=\
LAN out-interface-list=WAN
add action=accept chain=forward comment="remote access to local LAN" \
dst-address=192.168.1.0/24 in-interface=wg0 log=yes log-prefix=boat
add action=accept chain=forward comment="local access to tunnel" \
out-interface=wg0 src-address=192.168.1.0/24
add action=accept chain=forward comment="port forwarding" connection-mark="" \
connection-nat-state=dstnat
add action=drop chain=forward comment="drop all else"
add action=accept chain=forward disabled=yes in-interface=wg0 out-interface=\
bridge1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1
# no interface
add action=dst-nat chain=dstnat dst-port=51821 in-interface=*E protocol=udp \
to-ports=51821
add action=masquerade chain=srcnat disabled=yes out-interface=*F
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip route
add disabled=no distance=1 dst-address=10.1.1.0/24 gateway=wg0 pref-src="" \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add dst-address=192.168.1.0/24 gateway=*F
add dst-address=10.1.1.0/24 gateway=*F
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=192.168.1.0/24 disabled=yes
set ssh disabled=yes
set api disabled=yes
/system clock
set time-zone-name=Europe/London
/system note
set show-at-login=no
/tool bandwidth-server
set enabled=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
```