Ok, I have dynamic wifi VLANs working !! Thank you for your help with this.
Notes:
The ethernet is 802.1Q tagged for all VLANs going to the wifi router.
The main VLAN for the wifi itself is VLAN10.
There is a DHCP helper on the upstream Cisco that handles sending requests to a Microsoft DHCP server with VLAN scopes from 8-15 (192.168.8-15.0/24).
The radius server is Microsoft NPS, with the two additional Mikrotik radius attributes added, #26 and #27.
Active Directory domain accounts are mapped to the radius server by group membership.
Here is the config (unneeded stuff removed):
/interface bridge
add admin-mac=D4:01:C3:6C:7F:BA auto-mac=no comment=defconf dhcp-snooping=yes frame-types=admit-only-vlan-tagged name=bridge protocol-mode=none vlan-filtering=yes
/interface vlan
add comment=8 interface=bridge name=VLAN8 vlan-id=8
add comment=9 interface=bridge name=VLAN9 vlan-id=9
add comment=10 interface=bridge name=VLAN10 vlan-id=10
add comment=11 interface=bridge name=VLAN11 vlan-id=11
add comment=12 interface=bridge name=VLAN12 vlan-id=12
add comment=13 interface=bridge name=VLAN13 vlan-id=13
add comment=14 interface=bridge name=VLAN14 vlan-id=14
add comment=15 interface=bridge name=VLAN15 vlan-id=15
/interface list
add comment=defconf name=LAN
/interface wifi security
add authentication-types=wpa2-eap,wpa3-eap comment=wifisecurity disabled=no eap-certificate-mode=dont-verify-certificate eap-methods=peap encryption="" group-encryption=ccmp name=wifisecurity
/interface wifi
set [ find default-name=wifi1 ] channel.band=5ghz-ax .skip-dfs-channels=10min-cac .width=20/40/80mhz configuration.country="United States" .mode=ap .ssid=TEST .tx-power=14 disabled=no security=wifisecurity
set [ find default-name=wifi2 ] channel.band=2ghz-ax .skip-dfs-channels=10min-cac .width=20/40mhz configuration.country="United States" .mode=ap .ssid=TEST .tx-power=10 disabled=no security=wifisecurity
/interface bridge port
add bridge=bridge comment=defconf interface=wifi1 internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf interface=wifi2 internal-path-cost=10 path-cost=10
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged interface=ether1 internal-path-cost=10 path-cost=10 trusted=yes
/interface bridge vlan
add bridge=bridge comment=8 tagged=wifi1,wifi2,ether1 vlan-ids=8
add bridge=bridge comment=9 tagged=wifi1,wifi2,ether1 vlan-ids=9
add bridge=bridge comment=10 tagged=wifi1,wifi2,ether1,bridge vlan-ids=10
add bridge=bridge comment=11 tagged=wifi1,wifi2,ether1 vlan-ids=11
add bridge=bridge comment=12 tagged=wifi1,wifi2,ether1 vlan-ids=12
add bridge=bridge comment=13 tagged=wifi1,wifi2,ether1 vlan-ids=13
add bridge=bridge comment=14 tagged=wifi1,wifi2,ether1 vlan-ids=14
add bridge=bridge comment=15 tagged=wifi1,wifi2,ether1 vlan-ids=15
/interface list member
add comment=defconf interface=bridge list=LAN
/ip address
add address=192.168.10.137/24 comment=defconf interface=VLAN10 network=192.168.10.0
/ip dns
set servers=192.168.10.11
/ip route
add comment=defaultroute disabled=no dst-address=0.0.0.0/0 gateway=192.168.10.1 routing-table=main suppress-hw-offload=no
/radius
add address=192.168.10.11 comment=radius require-message-auth=no service=wireless timeout=3s secret=**********
/system clock
set time-zone-name=America/New_York