Community discussions

MikroTik App
 
jroy
newbie
Topic Author
Posts: 33
Joined: Fri May 28, 2004 9:41 pm
Location: Orange/LA county California
Contact:

Script to send Dynamic IP address to me in E-mail?

Mon Jul 05, 2004 5:22 am

You have a Script to send Dynamic IP address to me in E-mail via an smtp server that requires authentication?
 
edzix
Member
Member
Posts: 333
Joined: Thu Jul 01, 2004 3:01 pm
Location: Latvia

Mon Jul 05, 2004 3:36 pm

first you have to configure your SMTP server under '/tool e-mail', then make a script which will send an email including the necessary IP as body parameter. Like this:
----------
:local ip
/ip address{
:foreach i in [find dynamic=yes] do={:set ip [get $i address]}
/tool e-mail send to=someone@somewhere body=(" Dynamic IP found:" . $ip)
}
-----------

Edgars
 
jroy
newbie
Topic Author
Posts: 33
Joined: Fri May 28, 2004 9:41 pm
Location: Orange/LA county California
Contact:

Where are the username and password settings?

Mon Jul 05, 2004 8:16 pm

----------
:local ip
/ip address{
:foreach i in [find dynamic=yes] do={:set ip [get $i address]}
/tool e-mail send to=someone@somewhere body=(" Dynamic IP found:" . $ip)
}
-----------
So where are the username and password settings? I have only smtp servers that require authentication. I do not have a single server that does not require authentication.
 
edzix
Member
Member
Posts: 333
Joined: Thu Jul 01, 2004 3:01 pm
Location: Latvia

Tue Jul 06, 2004 1:35 pm

e-mail settings could be configured under '/too e-mail' submenu. See the manual for more information;
http://www.mikrotik.com/docs/ros/2.8/tools/email.main

Edgars
 
jroy
newbie
Topic Author
Posts: 33
Joined: Fri May 28, 2004 9:41 pm
Location: Orange/LA county California
Contact:

Again

Tue Jul 06, 2004 8:53 pm

AGAIN,

WHERE DO YOU SET THE USERNAME AND PASSWORD FOR THE SMTP SERVER????
 
changeip
Forum Guru
Forum Guru
Posts: 3833
Joined: Fri May 28, 2004 5:22 pm

Tue Jul 06, 2004 10:02 pm

I thought Mikrotik supported smtp auth as well, but I dont see the commands that support it anywhere... i guess they dont.

Sam
 
cmit
Forum Guru
Forum Guru
Posts: 1547
Joined: Fri May 28, 2004 12:49 pm
Location: Germany

Wed Jul 07, 2004 9:57 am

You should just go to the MikroTik download page http://www.mikrotik.com/download.html where you'll find your Windows MAC Telnet Client at the bottom of the page (which has been there at least since February 2003...).

Regarding SMTP auth: Yes, this would be handy...
 
cmit
Forum Guru
Forum Guru
Posts: 1547
Joined: Fri May 28, 2004 12:49 pm
Location: Germany

Wed Jul 07, 2004 9:59 am

Ooops?! I actually responded to a post from "jroy" where he was stating he won't carry a MikroTik router everywhere just to able to use MAC Telnet and was asking for a Windows MAC telnet client.

Looks like his post just got removed...