Thanks for TheCat12 and anav.
The configuration of Router A
# 2024-10-31 20:51:53 by RouterOS 7.16.1
# software id = <code>
#
# model = RB5009UG+S+
# serial number = <code>
/interface bridge
add admin-mac=78:9A:18:XX:XX:XX auto-mac=no comment=defconf name=bridge
/interface wireguard
add listen-port=11140 mtu=1420 name=wg-fs
/disk
set usb1 media-interface=bridge media-sharing=yes slot=usb1 smb-sharing=yes \
smb-user=guest
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=172.16.10.10-172.16.10.254
/ip dhcp-server
add address-pool=dhcp interface=bridge name=defconf
/disk settings
set auto-media-interface=bridge auto-media-sharing=yes auto-smb-sharing=yes
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=sfp-sfpplus1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/interface wireguard peers
add allowed-address=10.2.200.2/30,192.168.201.1/32 endpoint-address=\
<code> endpoint-port=59123 interface=wg-fs name=\
fs persistent-keepalive=25s preshared-key=\
"<code>" public-key=\
"<code>"
/ip address
add address=172.16.10.1/24 comment=defconf interface=bridge network=\
172.16.10.0
add address=192.168.55.28/24 interface=ether1 network=192.168.55.0
add address=10.2.200.2/30 interface=wg-fs network=10.2.200.0
/ip dhcp-client
add comment=defconf disabled=yes interface=ether1
/ip dhcp-server network
add address=172.16.10.0/24 comment=defconf dns-server=172.16.10.1 gateway=\
172.16.10.1 netmask=24
/ip dns
set allow-remote-requests=yes servers=192.168.55.1
/ip dns static
add address=172.16.10.1 comment=defconf name=router.lan type=A
/ip firewall filter
add action=accept chain=input comment=wg-cc dst-port=59123 protocol=udp
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="allow winbox" dst-port=8291 protocol=\
tcp
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.55.1 \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=1 dst-address=192.168.201.0/24 gateway=wg-fs \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/system clock
set time-zone-name=Asia/Shanghai
/system note
set show-at-login=no
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
The configuration of Router B
# 2024-10-31 21:09:04 by RouterOS 7.15.3
# software id = <code>
#
# model = RBD52G-5HacD2HnD
# serial number = <code>
/interface bridge
add admin-mac=74:4D:28:XX:XX:XX auto-mac=no comment=defconf name=bridge \
port-cost-mode=short
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-XX \
country=china disabled=no distance=indoors frequency=auto installation=\
indoor mode=ap-bridge ssid=MK-2.4G wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=\
20/40/80mhz-XXXX country=china disabled=no distance=indoors frequency=\
auto installation=indoor mode=ap-bridge ssid=MK-5G wireless-protocol=\
802.11
/interface pppoe-client
add add-default-route=yes disabled=no interface=ether1 name=pppoe-out1 \
use-peer-dns=yes user=<code>
/interface wireguard
add listen-port=59123 mtu=1420 name=wg-cc
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
dynamic-keys supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.201.50-192.168.201.100
/ip smb users
set [ find default=yes ] disabled=yes
/interface bridge port
add bridge=bridge comment=defconf interface=ether2 internal-path-cost=10 \
path-cost=10
add bridge=bridge comment=defconf interface=ether3 internal-path-cost=10 \
path-cost=10
add bridge=bridge comment=defconf interface=ether4 internal-path-cost=10 \
path-cost=10
add bridge=bridge comment=defconf interface=ether5 internal-path-cost=10 \
path-cost=10
add bridge=bridge comment=defconf interface=wlan1 internal-path-cost=10 \
path-cost=10
add bridge=bridge comment=defconf interface=wlan2 internal-path-cost=10 \
path-cost=10
/ip firewall connection tracking
set udp-timeout=10s
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=pppoe-out1 list=WAN
/interface wireguard peers
add allowed-address=10.2.200.2/30,172.16.10.1/32 interface=wg-cc name=dangtu \
preshared-key="<code>" public-key=\
"<code>"
/ip address
add address=192.168.201.1/24 comment=defconf interface=bridge network=\
192.168.201.0
add address=10.2.200.1/30 interface=wg-cc network=10.2.200.0
/ip dhcp-client
add comment=defconf disabled=yes interface=ether1
/ip dhcp-server
add address-pool=dhcp interface=bridge lease-time=10m name=defconf
/ip dhcp-server network
add address=192.168.201.0/24 comment=defconf dns-server=192.168.201.1 \
gateway=192.168.201.1 netmask=24
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.201.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment=wg-cc dst-port=59123 protocol=udp
add action=accept chain=input comment="Winbox remote access" dst-port=8291 \
protocol=tcp
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip route
add disabled=no distance=1 dst-address=172.16.10.0/24 gateway=wg-cc \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/ip service
set telnet disabled=yes
set ssh disabled=yes
/ip smb shares
set [ find default=yes ] directory=/flash/pub
/system clock
set time-zone-name=Asia/Shanghai
/system note
set show-at-login=no
/system ntp server
set use-local-clock=yes
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Now in Router A (connected under Router C), I am able to ping 192.168.201.1. Also in Router B (connected to Internet, Wireguard server) is the same, I am able to ping 172.16.10.1. In Router A, beside the original allowed address=10.2.200.0/30, by adding 192.168.201.1/32. In Router B, 172.16.10.1/32 is added to 10.2.200.0/30.
A new PC is added to Router A and PC terminal is not able to ping 192.168.201.1. My expectation on PC terminal will be the same as Router A's terminal.