############ New information for PASS PPTP and L2TP/IPsec servers ############
Updated information for PPTP on Dec 28, 2024. The remote 2000 km site hAP ac^3 with v7.16.2, public IP, local IP=172.16.88.0/x.
Configuration 1: Windows 10,Honor phone or Huawei PPTP clients passed the tests.
Code: Select all
/interface pptp-server server set enabled=yes
/ppp secret add local-address=172.16.88.1 name=vpn password=vpn profile=default-encryption remote-address=172.16.88.5 service=pptp
/ip firewall filter
add action=accept chain=input comment="PPTP China" dst-port=1723 \
in-interface=ether1 protocol=tcp
Code: Select all
/ip pool
add name=PPTP_pool ranges=172.16.88.100-172.16.88.150
/ppp profile add name=PPTP_prof local-address=172.16.88.1 \
remote-address=PPTP_pool use-encryption=yes
/ppp secret add name=vpn password=vpn profile=PPTP_prof service=pptp
/interface pptp-server server set default-profile=PPTP_prof enabled=yes
/ip firewall filter
add action=accept chain=input comment="PPTP China" dst-port=1723 \
in-interface=ether1 protocol=tcp
Configuration 3:Same as Config. 2 with a different segment.
Code: Select all
/ip pool
add name=pptp_pool ranges=172.31.255.2-172.31.255.254
/ppp profile add name=pptp_profile local-address=172.31.255.1 \
remote-address=pptp_pool use-encryption=yes
/ppp secret add name=vpn password=vpn service=pptp profile=pptp_profile
/interface pptp-server server set default-profile=pptp_profile enabled=yes
/ip firewall filter
add action=accept chain=input comment="PPTP China" dst-port=1723 \
in-interface=ether1 protocol=tcp
L2TP/IPsec settings: iPhone, iPad, Honor phone, Huawei pad, and Windows 10 passed.
Code: Select all
/ip pool
add name=l2tp-pool ranges=172.31.254.2-172.31.254.254
/ppp profile add name=l2tp-profile local-address=172.31.254.1 \
remote-address=l2tp-pool use-encryption=yes
/ppp secret add name=vpn password=vpn profile=l2tp-profile service=l2tp
/interface l2tp-server server set default-profile=l2tp-profile enabled=yes \
use-ipsec=required ipsec-secret=vpn
/ip firewall filter
add action=accept chain=input comment="L2TP China" dst-port=1701 \
in-interface=ether1 protocol=udp
add action=accept chain=input comment="IPsec" dst-port=500,4500 \
in-interface=ether1 protocol=udp
PPTP is no longer in v7.x
Although PPTP is an old protocol, in MikroTik manual it can be used in v7. For the beginners like me, we may learn basic VPN like PPTP. For other two protocols WireGuard and IPSec IKEv2, these two protocols have been verified in v7 without any problems.
The following scripts demonstration how router DOES NOT work!!!
Hap ac3 v7.16.2
public IP=114.100.x,y, local IP=192.168.55.0/24
/interface pptp-server server set enabled=yes
/ppp secret add local-address=192.168.89.1 name=vpn password=vpn profile=default-encryption remote-address=192.168.89.5 service=pptp
/ip firewall filter
add action=accept chain=input comment="PPTP China" dst-port=1723 \
in-interface=ether1 protocol=tcp
/ip firewall filter
add action=accept chain=input comment="GRE" protocol=47 in-interface=ether1
/ip firewall nat
add chain=srcnat src-address=192.168.89.0/24 out-interface=ether1 action=masquerade
When a PC connected to the internal segment 192.168.55.0/24, the Windows PPTP (server: 114.100.x.y, user=vpn, password=vpn) could log in "ac3" without any problems.
When the PC connected to the external world via iPhone , the PC was not able to login the "ac3".
When the same PC connected the "ac3" using WireGuard or IPSec IKEv2 in v7,it could connect the "ac3" without any problems.
In v6 or v5, there were no problems in the past but v7 cannot work!!!
Please help!