I have an IPsec tunnel set between a Sophos XG and a mikrotik
connection is established but no data is passing
Both devices have public ips
firewall rules set on both devices but still nothing
Sophos engineers checked their side - all is good
what am i missing ?
Code: Select all
/interface bridge
add name=bridge-LAN port-cost-mode=short
/interface ethernet
set [ find default-name=ether1 ] mac-address=74:4D:28:A6:86:06 name=ether1-WAN-MAIN-DSL-MODEM
set [ find default-name=ether2 ] mac-address=74:4D:28:A6:86:07
set [ find default-name=ether3 ] mac-address=74:4D:28:A6:86:08
set [ find default-name=ether4 ] mac-address=74:4D:28:A6:86:09
set [ find default-name=ether5 ] advertise=100M-baseT-half,100M-baseT-full,1G-baseT-half,1G-baseT-full mac-address=74:4D:28:A6:86:0A
set [ find default-name=ether10 ] mac-address=74:4D:28:A6:86:0B name=ether6
set [ find default-name=ether9 ] mac-address=74:4D:28:A6:86:0C name=ether7
set [ find default-name=ether8 ] mac-address=74:4D:28:A6:86:0D
set [ find default-name=ether7 ] mac-address=74:4D:28:A6:86:0E name=ether9
set [ find default-name=ether6 ] mac-address=74:4D:28:A6:86:0F name=ether10
/interface wireguard
add listen-port=13231 mtu=1380 name=Mikrotik-Leb
/interface ethernet switch port
set 5 default-vlan-id=0
set 6 default-vlan-id=0
set 7 default-vlan-id=0
set 8 default-vlan-id=0
set 9 default-vlan-id=0
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface lte apn
set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/ip ipsec profile
set [ find default=yes ] dpd-interval=2m dpd-maximum-failures=5
add dh-group=modp2048 enc-algorithm=aes-256 hash-algorithm=sha256 name=socitrans nat-traversal=no
/ip ipsec peer
add address=xxx.xxx.xxx.78/32 exchange-mode=ike2 name=socitrans-peer profile=socitrans
/ip ipsec proposal
add auth-algorithms=sha512,sha256 enc-algorithms=aes-256-cbc,aes-256-ctr,aes-256-gcm name=socitrans-proposal pfs-group=modp2048
/ip pool
add name=dhcp_pool0 ranges=192.168.1.112-192.168.1.199
add name=dhcp_poolVPN ranges=192.168.251.2-192.168.251.254
/ip dhcp-server
add address-pool=dhcp_pool0 interface=bridge-LAN name=dhcp1
/ip smb users
set [ find default=yes ] disabled=yes
/port
set 0 name=serial0
/ppp profile
set *0 only-one=no
add dns-server=192.168.1.1 local-address=dhcp_pool0 name=profile1 only-one=no remote-address=dhcp_poolVPN
/routing bgp template
set default disabled=no output.network=bgp-networks
/routing ospf instance
add disabled=no name=default-v2
/routing ospf area
add disabled=yes instance=default-v2 name=backbone-v2
/system logging action
set 0 memory-lines=1111
set 1 disk-lines-per-file=11111
/interface bridge port
add bridge=bridge-LAN interface=ether2
add bridge=bridge-LAN interface=ether3
add bridge=bridge-LAN interface=ether4
add bridge=bridge-LAN interface=ether5
add bridge=bridge-LAN interface=ether6
add bridge=bridge-LAN interface=ether7
add bridge=bridge-LAN interface=ether8
add bridge=bridge-LAN interface=ether9
add bridge=bridge-LAN interface=ether10
add bridge=bridge-LAN interface=ether11
add bridge=bridge-LAN interface=ether12
add bridge=bridge-LAN interface=ether13
/ip firewall connection tracking
set udp-timeout=10s
/ip neighbor discovery-settings
set discover-interface-list=all
/ip settings
set max-neighbor-entries=8192
/ipv6 settings
set forward=no max-neighbor-entries=8192
/interface l2tp-server server
set default-profile=profile1 enabled=yes keepalive-timeout=60 max-mru=1400 max-mtu=1400 mrru=1600 use-ipsec=yes
/interface list member
add comment=defconf interface=bridge-LAN list=LAN
add comment=defconf interface=ether1-WAN-MAIN-DSL-MODEM list=WAN
/interface ovpn-server server
set auth=sha1,md5
/interface wireguard peers
add allowed-address=192.168.120.0/24,10.125.100.0/24,192.168.1.0/24,192.168.130.0/24 comment=DRC endpoint-address=xxx.xxx.xxx.186 endpoint-port=13231 interface=Mikrotik-Leb is-responder=yes name=peer1 persistent-keepalive=10s public-key=\
/ip address
add address=192.168.1.111/24 interface=bridge-LAN network=192.168.1.0
add address=yyy.yyy.yyy174/29 interface=ether1-WAN-MAIN-DSL-MODEM network=yyy.yyy.yyy168
add address=10.125.100.101/24 interface=Mikrotik-Leb network=10.125.100.0
/ip arp
add address=192.168.1.112 interface=bridge-LAN mac-address=00:45:E2:F6:AB:D7
/ip dhcp-client
add disabled=yes interface=bridge-LAN
/ip dhcp-server network
add address=192.168.1.0/24 dns-server=192.168.1.1 gateway=192.168.1.111
/ip dns
set allow-remote-requests=yes servers=xxxxxxxx
/ip dns static
add address=192.168.88.1 name=router.lan type=A
/ip firefirewall filter
add action=accept chain=forward dst-address=192.168.1.0/24 src-address=192.168.120.0/24
add action=accept chain=forward dst-address=192.168.1.0/24 src-address=192.168.140.0/24
add action=accept chain=forward dst-address=192.168.120.0/24 src-address=192.168.1.0/24
add action=accept chain=forward dst-address=192.168.140.0/24 src-address=192.168.1.0/24
add action=drop chain=forward comment="drop NVR " disabled=yes dst-address=192.168.1.10
add action=accept chain=input protocol=ipsec-esp
add action=accept chain=input protocol=udp src-port=4500
/ip firewall nat
add action=src-nat chain=srcnat out-interface=ether1-WAN-MAIN-DSL-MODEM to-addresses=yyy.yyy.yyy174
add action=accept chain=srcnat disabled=yes dst-address=192.168.140.0/24 log=yes src-address=192.168.1.0/24 to-addresses=yyy.yyy.yyy174
/ip ipsec identity
add peer=socitrans-peer
/ip ipsec policy
add dst-address=192.168.140.0/24 peer=socitrans-peer proposal=socitrans-proposal src-address=192.168.1.0/24 tunnel=yes
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=yyy.yyy.yyy169
add disabled=no dst-address=192.168.120.0/24 gateway=Mikrotik-Leb routing-table=main suppress-hw-offload=no