Mon Jan 06, 2025 2:27 am
Sure thats very logical.
THe problem is how to do that depends on the current setup.
If it was connect to router A via wireguard and then over existing tunnels go to any other device or any other LAN on any device is TOO easy.
This assumes device A is the server for handshake, and device B,C,D,E,F are client peers for handshake.
It sounds though what you have or attempted to setup is different or some variant thereof:
Assumes any router can initiate connection to any router and that all routers have reachable public IP addresses or ISP router can forward port to MT device.
A to B and B to A
router A--> endpoint port 15102 and keep alive // interface=wgA listening port=15101, allowed IP=10.100.100.2/32
Throw in appropriate remote subnets in allowed IPs.
ip address is 10.100.100.1/24
router B-> endpoint port 15101 and keep alive // interface=wgB listening port=15102, allowed IP=10.100.100.1/32
Throw in appropriate remote subnets in allowed IPs.
ip address is 10.100.100.2/24
A to C and C to A
router A--> endpoint port 15103 and keep alive // interface=wgA listening port=15101, allowed IP=10.100.100.3/32
Throw in appropriate remote subnets in allowed IPs.
ip address is 10.100.100.1/24
router C > endpoint port 15101 and keep alive // interface=wgC listening port=15103, allowed IP=10.100.100.1/32
Throw in appropriate remote subnets in allowed IPs.
ip address is 10.100.100.3/24
Router A has 3 other Wireguard interfaces. Repeat and rinse.
A to D and D to A
A to E and E to A
A to F and F to A
Routers B,C, D, E, F Repeat and rinse.
However the problem with this approach is it doesnt lend itself at all to having road warriors traverse to any other device after arriving at Device A.
Each router would need to have a road warrior definition, specific to that router.
So in your smart phone you would have 6 different VPN connections to choose and same with Laptop etc........
Each device would need an allowed IP simply for that single device. So thats a total of 6 pairs of keys needed to exchange.
THe more devices the more profiles, with two devices thats 12 pairs of keys.
+++++++++++++++++++++++++++++++++++++++
If not, you need to explain exactly how you have setup wireguard for the six devices............
+++++++++++++++++++++++++++++++++++++++
I can see multiple WIREGUARD for redundancy purposes with only one acting as server at a time
Router A is server for handshake all others go through A.
If Router A goes down.
Then Router B is new primary and Routers C,D,E use Router B as primary
If Router A and B go down, then Router C is the new Primary and Routers D, E use Router C as primary
If Router A and B and C go down, then Router D is the new primary and Router E uses Router D as primary
If Router A and B and C dog down, the Router E needs to be reached directly and is the new and only primary.
With this in mind, the above first iteration, may actually be less complex.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
I cannot recall the thread but was this not already done and can be reviewed ---> your current config or is this something you came up with on your own???
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
So with a bit more info, may be able to proceed............
What I would consider doing.
IS ONE ROUTER, most stable connection as ONLY ONE server..............all other devices are peers.
Separate WG interface on each device, solely for you as admin to connect to each router, in case Router A goes down.
THis is what I would do, to lessen the complexity of at least the admin being able to reach every device.
It does not help with LAN devices reaching Remote LAN devices if the Router A goes down.
How long are outages normally.
How critical is the connectivity?
+++++++++++++++++++++++++++++++++++++++++++
Thinking of another complex setup.
13 Separate wireguard interfaces per router
Each router is a Peer Server for one other Router and and a peer Client for each other router. 12 Tunnels.
So a Router is Server 6 times and a CLient 6 times all on different wg interfaces.
I thrown in a 13th for road warriors only.
Your smart phone would need six profiles, one for each router anyway.
But in this way we can reach any other router by way of firewall rules.
think ( legend. wireguard interface the first letter in capital identifies the server for handshake )
Router A:
/interface list
add name=wg-GROUP comment="list of router client peers the roadwarrior can reach"
/interface list members
add interface=wgAb list=wg-Group
add interface=wgAc list=wg-Group
add interface=wgAd list=wg-Group
add interface=wgAe list=wg-Group
add interface=wgAf list=wg-Group
add interface=wgRW list=wg-Group
/ip firewall
add chain=forward action=accept in-interface=wg-Group out-interface=wg-Group
Thus any roadwarrior coming into A, has a path now to any of the other device.
example.
smartphone admin profile for Router A, is assigned WG address of 192.168.100.2
smartphone connects via WG to interface wgRW on Router A.
User types in any subnet address on the browser and is then connected to the correct peer for that subnet through wireguard.
User types in any wireguard IP address for any other router, and is connected to the config........ (using the MT App).
This is because Router A on the client peer definitions has all the subnets identified and the client peer address identified.
One would have to ensure that all subnets AS PER NORMAL are identified correctly to the correct WG gateway.
++++++++++++++++++++++++++++++++++++++++++++++++++++++
Not saying there is not an easier way, but its late and Im tired LOL
Maybe need NY coffee LOL