Long story short:
To get the above to work with a BGP route reflector you have to use routeros v6 for the route reflector. The peers can be v7. However since v7.16 was released the ibgp-rr-client option has been removed from bgp and now routeros v7.16 and up no longer work with this setup. We would stay on v7.15.3 and v6 but new orders of mikrotik hardware have the firmware locked at v7 which makes it impossible to continue to use BGP MPLS/VPLS with mikrotiks. I have two CCR2004-1G-12S+2XS sitting right here and one can be downgraded to v6 and the other can't. I have opened a ticket back in June 15th 2023 reporting this issue with BGP L2VPN VPLS, SUP-119340.
Is it possible to get some priority on this issue and lets get this working again? If you search the forum you can see others reporting the ibgp-rr-client option is missing and its breaking BGP L2VPN. Is BGP L2VPN VPLS going away? If so what's the alternative to this? If it is VXLANs does it also have issues with BGP L2VPN not working with a BGP route reflector?Olga Ļ. [X]13/Sep/23 9:39 AM
Hello!
Sorry for late answer.
The issue is in "To Do list" bug no fixed yet.
Sorry for the inconvenience caused.
Best Regards,
Code: Select all
What it looks like on v7.15.3
[admin@RR] /routing/bgp/advertisements> print
0 peer=RTR1-2 dst=100:1 afi=l2vpn local-pref=100 origin=0 ext-communities=rt:100:1,raw:800a130205dc0000
atomic-aggregate=yes
0 peer=RTR1-1 dst=100:1 afi=l2vpn local-pref=100 origin=0 ext-communities=rt:100:1,raw:800a130205dc0000
atomic-aggregate=yes
PEER should be 172.16.10.3 not the route reflectors IP 172.16.10.1
[admin@RTR1] /interface/vpls> print
Flags: D - DYNAMIC
Columns: NAME, PEER, BGP-VPLS
# NAME PEER BGP-VPLS
0 D vpls1 172.16.10.1 TestVPLS
Router Reflector
Code: Select all
[admin@RR] > export
# 2024-10-14 19:51:13 by RouterOS 7.16.1
# software id =
#
/interface bridge
add name=lobridge
/routing ospf instance
add disabled=no name=ospf-instance-1 redistribute=connected,static router-id=\
172.16.10.1
/routing ospf area
add disabled=no instance=ospf-instance-1 name=ospf-area-1
/ip address
add address=172.16.10.1 interface=lobridge network=172.16.10.1
add address=10.0.0.2/30 interface=ether1 network=10.0.0.0
add address=10.0.0.9/30 interface=ether2 network=10.0.0.8
/routing bgp connection
add address-families=l2vpn as=65530 cluster-id=172.16.0.1 connect=no disabled=\
no input.filter=BGP-ACCEPT-ALL listen=yes local.address=0.0.0.0/0 .role=\
ibgp-rr name=RTR output.filter-chain=BGP-ACCEPT-ALL .as=65530 router-id=172.16.10.1 routing-table=main
/routing filter rule
add chain=BGP-ACCEPT-ALL disabled=no rule="accept;"
/routing ospf interface-template
add area=ospf-area-1 disabled=no interfaces=ether1,ether2 networks=\
10.0.0.0/24,172.16.10.0/24
/system identity
set name=RR
Code: Select all
[admin@RTR1] > export
# 2024-10-14 19:51:49 by RouterOS 7.16.1
# software id =
#
/interface bridge
add name=TestVPLS protocol-mode=none
add name=lobridge
/routing ospf instance
add disabled=no name=ospf-instance-1 redistribute=connected,static router-id=\
172.16.10.2
/routing ospf area
add disabled=no instance=ospf-instance-1 name=ospf-area-1
/interface bridge port
add bridge=TestVPLS interface=ether3
/ip address
add address=172.16.10.2 interface=lobridge network=172.16.10.2
add address=10.0.0.1/30 interface=ether1 network=10.0.0.0
add address=10.0.0.5/30 interface=ether2 network=10.0.0.4
/mpls interface
add disabled=no interface=ether2
/mpls ldp
add disabled=no lsr-id=172.16.10.2 transport-addresses=172.16.10.2
/mpls ldp interface
add disabled=no interface=ether2 transport-addresses=""
/routing bgp connection
add address-families=l2vpn as=65530 disabled=no \
input.filter=BGP-ACCEPT-ALL local.address=172.16.10.2 .role=ibgp name=RR \
output.filter-chain=BGP-ACCEPT-ALL remote.address=172.16.10.1/32 .as=65530 \
router-id=172.16.10.2 routing-table=main
/routing bgp vpls
add bridge=TestVPLS bridge-horizon=1 disabled=no export-route-targets=100:1 \
import-route-targets=100:1 name=TestVPLS rd=100:1 site-id=1
/routing filter rule
add chain=BGP-ACCEPT-ALL disabled=no rule="accept;"
/routing ospf interface-template
add area=ospf-area-1 disabled=no interfaces=ether1,ether2 networks=\
10.0.0.0/24,172.16.10.0/24
/system identity
set name=RTR1
Code: Select all
[admin@RTR2] > export
# 2024-10-14 19:52:10 by RouterOS 7.16.1
# software id =
#
/interface bridge
add name=TestVPLS protocol-mode=none
add name=lobridge
/routing ospf instance
add disabled=no name=ospf-instance-1 redistribute=connected,static router-id=\
172.16.10.3
/routing ospf area
add disabled=no instance=ospf-instance-1 name=ospf-area-1
/interface bridge port
add bridge=TestVPLS interface=ether3
/ip address
add address=172.16.10.3 interface=lobridge network=172.16.10.3
add address=10.0.0.10/30 interface=ether1 network=10.0.0.8
add address=10.0.0.6/30 interface=ether2 network=10.0.0.4
/mpls interface
add disabled=no interface=ether2
/mpls ldp
add disabled=no lsr-id=172.16.10.3 transport-addresses=172.16.10.3
/mpls ldp interface
add disabled=no interface=ether2 transport-addresses=""
/routing bgp connection
add address-families=l2vpn as=65530 disabled=no \
input.filter=BGP-ACCEPT-ALL local.address=172.16.10.3 .role=ibgp name=RR \
output.filter-chain=BGP-ACCEPT-ALL remote.address=172.16.10.1/32 .as=65530 \
router-id=172.16.10.3 routing-table=main
/routing bgp vpls
add bridge=TestVPLS bridge-horizon=1 disabled=no export-route-targets=100:1 \
import-route-targets=100:1 name=TestVPLS rd=100:1 site-id=2
/routing filter rule
add chain=BGP-ACCEPT-ALL disabled=no rule="accept;"
/routing ospf interface-template
add area=ospf-area-1 disabled=no interfaces=ether1,ether2 networks=\
10.0.0.0/24,172.16.10.0/24
/system identity
set name=RTR2