Finally! <3*) ipv6 - added FastTrack support;
What's this about? Could somebody provide some info?*) console - allow to toggle script error logging with "/console settings log-script-errors";
*) console - implement scriptable safe-mode commands and safe-mode handler;
*) console - log errors within scripts to the system log;
*) console - make non-pseudo terminals work with imports;
I cannot wait for free time in the day to play with this! I was hoping to see radsec get fixed but this is a nice, distracting, consolation prize.*) l3hw - added initial HW offloading for VXLAN on compatible switches;
very interesting !!!
Hey, I'm inclined to get happy!*) l2tp - added IPv6 FastPath support;
*) l3hw - added initial HW offloading for VXLAN on compatible switches;
*) l3hw - fixed partial route offloading for 98DX224S, 98DX226S, 98DX3236 switches;
*) qos-hw - fixed global buffer limits for 98CX8410 switch;
*) winbox - added L3HW Advanced and Monitor;
IPv6 getting some love! :D*) ipv6 - added ability to disable dynamic IPv6 LL address generation on non-VPN interfaces;
*) ipv6 - added FastTrack support;
*) ipv6 - added routing FastPath support;
*) ipv6 - added support for neighbor removal and static entries;
MikroTik RouterOS 7.18beta2 (c) 1999-2025 https://www.mikrotik.com/
Press F1 for help
(7 messages not shown)
2025-01-21 16:29:20 system,error,critical router was rebooted without proper shutdown by watchdog timer
2025-01-21 16:31:00 system,clock,critical,info ntp change time Jan/21/2025 16:30:02 => Jan/21/2025 16:31:00
2025-01-21 16:31:02 system,error,critical router was rebooted without proper shutdown by watchdog timer
2025-01-21 16:44:33 system,clock,critical,info ntp change time Jan/21/2025 16:31:38 => Jan/21/2025 16:44:33
2025-01-21 16:44:35 system,error,critical router was rebooted without proper shutdown by watchdog timer
2025-01-21 16:46:23 system,error,critical router was rebooted without proper shutdown by watchdog timer
2025-01-21 16:48:03 system,clock,critical,info ntp change time Jan/21/2025 16:47:00 => Jan/21/2025 16:48:03
2025-01-21 16:48:04 system,error,critical router was rebooted without proper shutdown by watchdog timer
/interface bridge
add frame-types=admit-only-vlan-tagged name=BDI100 protocol-mode=none pvid=99 vlan-filtering=yes
/interface vlan
add interface=BDI100 name=vlan2 vlan-id=2
add interface=ether1 name=vlan30 vlan-id=30
/interface list
add name=WAN
add name=LAN
add name=DMZ
/ip ipsec policy group
add name=group_pelvet
add name=group_core
/ip ipsec profile
set [ find default=yes ] dpd-interval=2m dpd-maximum-failures=5
add dh-group=ecp384 enc-algorithm=aes-128 lifetime=2h name=pf_pha1_pelvet
add dh-group=ecp256 enc-algorithm=aes-128 hash-algorithm=sha384 name=pf_pha1_core prf-algorithm=sha384
/ip ipsec peer
add address=<> exchange-mode=ike2 name="peer=>Radiusa_pelvet" profile=pf_pha1_pelvet
add address=<> exchange-mode=ike2 name="peer=>PBXa_pelvet" profile=pf_pha1_pelvet
add address=<> exchange-mode=ike2 name="peer=>PBXb-Radiusb_pelvet" profile=pf_pha1_pelvet
add address=<> exchange-mode=ike2 name="peer=>core01" port=4501 profile=pf_pha1_core
/ip ipsec proposal
set [ find default=yes ] disabled=yes
add enc-algorithms=aes-128-cbc name=pp_pha2_pelvet pfs-group=ecp384
add enc-algorithms=aes-128-cbc lifetime=4h name=pp_pha2_core pfs-group=ecp384
/ip pool
add name=pool_vlan2 ranges=10.2.2.10-10.2.2.30
/routing ospf instance
add disabled=yes in-filter-chain=ospf100_in name=ospf100 out-filter-chain=ospf100_out redistribute=connected
/routing ospf area
add disabled=yes instance=ospf100 name=area0
/interface bridge port
add bridge=BDI100 interface=ether2 pvid=2
add bridge=BDI100 interface=ether3 pvid=2
add bridge=BDI100 interface=ether4 pvid=2
add bridge=BDI100 interface=ether5 pvid=2
/ip firewall connection tracking
set enabled=yes tcp-established-timeout=2h udp-stream-timeout=2m
/ip neighbor discovery-settings
set discover-interface-list=none protocol=""
/interface bridge vlan
add bridge=BDI100 tagged=all untagged=ether2,ether3,ether4,ether5 vlan-ids=2
/interface list member
add interface=lte1 list=WAN
add interface=vlan30 list=WAN
/interface ovpn-server server
add mac-address=FE:35:CD:54:08:7F name=ovpn-server1
/ip address
add address=100.64.2.1 interface=lo network=100.64.2.1
add address=10.2.2.1/27 interface=vlan2 network=10.2.2.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=5m update-time=no
/ip dhcp-client
add add-default-route=no interface=vlan30 use-peer-dns=no use-peer-ntp=no
/ip dhcp-server
add add-arp=yes address-pool=pool_vlan2 interface=vlan2 lease-time=2h name=dhcp_vlan2
/ip dhcp-server config
set store-leases-disk=never
/ip dhcp-server network
add address=10.2.2.0/27 dns-server=10.2.2.1 gateway=10.2.2.1
/ip dns
set allow-remote-requests=yes servers=195.76.102.1
/ip firewall address-list
add address=10.0.2.0/27 list=ACL150
add address=10.0.3.0/28 list=ACL150
add address=10.0.4.0/27 list=ACL150
add address=10.0.5.0/24 list=ACL150
add address=195.76.102.0/24 list=ACL150
add address=cloud2.mikrotik.com list=ACL180
add address=upgrade.mikrotik.com list=ACL180
add address=cloud.mikrotik.com list=ACL180
add address=pool.ntp.org list=ACL180
add address=3.pool.ntp.org list=ACL180
/ip firewall filter
add action=accept chain=input comment=INPUT src-address-list=ACL150
add action=accept chain=input in-interface-list=WAN packet-size=0-256 protocol=icmp
add action=drop chain=input dst-port=7000,7001,22900 in-interface-list=WAN protocol=tcp src-address-list=ACL180
add action=accept chain=input in-interface-list=WAN src-address-list=ACL180
add action=drop chain=input in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment=MGMT-LTE_modem dst-address=192.168.8.1 out-interface-list=WAN \
src-address=0.0.0.0/0 to-addresses=192.168.8.100
/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set h323 disabled=yes
set sip disabled=yes
set pptp disabled=yes
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip ipsec identity
add generate-policy=port-strict peer="peer=>PBXa_pelvet" policy-template-group=group_pelvet secret=\
<laquesea>
add generate-policy=port-strict peer="peer=>PBXb-Radiusb_pelvet" policy-template-group=group_pelvet secret=\
<laquesea>
add generate-policy=port-strict peer="peer=>Radiusa_pelvet" policy-template-group=group_pelvet secret=\
<laquesea>
add auth-method=digital-signature certificate=IKEv2_MGMT_cl.crt generate-policy=port-strict peer="peer=>core01" \
policy-template-group=group_core
/ip ipsec policy
set 0 disabled=yes
add comment=Policy_pelvet dst-address=10.142.0.7/32 level=unique peer="peer=>PBXa_pelvet" proposal=\
pp_pha2_pelvet src-address=100.64.2.1/32 tunnel=yes
add dst-address=10.128.0.11/32 level=unique peer="peer=>Radiusa_pelvet" proposal=pp_pha2_pelvet src-address=\
100.64.2.1/32 tunnel=yes
add dst-address=10.128.0.15/32 level=unique peer="peer=>PBXb-Radiusb_pelvet" proposal=pp_pha2_pelvet \
src-address=100.64.2.1/32 tunnel=yes
add dst-address=10.142.0.7/32 level=unique peer="peer=>PBXa_pelvet" proposal=pp_pha2_pelvet src-address=\
10.2.2.0/27 tunnel=yes
add dst-address=10.128.0.11/32 level=unique peer="peer=>Radiusa_pelvet" proposal=pp_pha2_pelvet src-address=\
10.2.2.0/27 tunnel=yes
add dst-address=10.128.0.15/32 level=unique peer="peer=>PBXb-Radiusb_pelvet" proposal=pp_pha2_pelvet \
src-address=10.2.2.0/27 tunnel=yes
add comment=Policy_Core01 dst-address=100.64.0.1/32 level=unique peer="peer=>core01" proposal=pp_pha2_core \
src-address=100.64.2.1/32 tunnel=yes
add dst-address=10.0.3.0/28 level=unique peer="peer=>core01" proposal=pp_pha2_core src-address=10.2.2.0/27 \
tunnel=yes
/ip route
add disabled=no distance=5 dst-address=10.0.2.0/27 gateway=195.76.102.1%vlan30 routing-table=main scope=20 \
suppress-hw-offload=no target-scope=10
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh port=22910
set api disabled=yes
set winbox port=8000
set api-ssl disabled=yes
/routing filter rule
add chain=ospf100_out disabled=no rule="if (dst in 0.0.0.0/0 && dst-len>0) {reject}"
add chain=ospf100_in disabled=no rule="if (dst in 10.0.2.0/27) {accept}\
\nif (dst in 10.0.3.0/28) {reject}\
\nif (dst in 10.0.4.0/27) {accept}\
\nif (dst in 10.0.5.0/24) {accept}\
\nif (dst in 10.0.6.0/24) {accept}\
\nif (dst in 100.64.0.2/32) {accept}\
\nif (dst in 192.168.1.0/24) {accept}"
/routing ospf interface-template
add area=area0 disabled=yes interfaces=vlan30 networks=195.76.102.0/24
/system clock
set time-zone-autodetect=no time-zone-name=Europe/Madrid
/system identity
set name=hex01.lb
/system logging
add disabled=yes topics=ipsec,debug,!packet
/system note
set show-at-login=no
/system ntp client
set enabled=yes
/system ntp client servers
add address=pool.ntp.org
add address=3.pool.ntp.org
/system package update
set channel=testing
/system routerboard settings
set auto-upgrade=yes silent-boot=yes
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=none
/tool mac-server ping
set enabled=no
After 10+ years of waiting, we may have hopefully a working modern logging for Mikrotik.*) log - added CEF format support for remote logging:
*) log - added option to select TCP or UDP for remote logging;
Can't believe it's been only 9 years and 8 months since we are waiting for this, seems like yesterday.[...]
*) ipv6 - added FastTrack support;
[...]
/ipv6 settings set allow-fast-path=yes
/ipv6 firewall filter add action=fasttrack-connection chain=forward comment="Enable FastTracked v6 traffic" connection-state=established,related
/ipv6 firewall filter add action=accept chain=forward comment="accept established,related,untracked" connection-state=established,related,untracked
Wow, it was since first v7 release and finally fixed. I'm shocked. But thanks.*) console - fixed issue where ping command displays two lines at the same time;
I have a similar config and see basically the same thing. The counter for fastpath are working, but the actual fast path/ offloading is not working as my CPU is still affected like previous versions. (this is even with the second rule disabled)I would like to understand how to properly activate Fasstrack for IPv6.
The log will show exact line in a script which has failed. Very nice feature, helps a lot while debugging scripts.What's this about? Could somebody provide some info?...
*) console - log errors within scripts to the system log;
...
Have we got a list of which Switches are supported? or is this just the software part been done so far?*) l3hw - added initial HW offloading for VXLAN on compatible switches;
very interesting !!!
Everything will be back to normal after upgrading RB firmware to 7.18beta.Upgraded RB460GX4 from 7.17 basic package and the result is full set of disabled additional packages.
For RB433 only installed packages are still installed after upgrade and no additional list.
EDIT: for RB450Gx4 I see that it's only a list of available packages. Not installed according to "Installed" column.
I made all the settings for IPv6 in the same way as IPv4. I have shown the result above.Maybe analogously to ipv4 fasttrack?
Indeed.NICE WORK.
I'm undecided on what to report the most beautiful, besides the FastTrak, I should copy half the list...
As I had assumed, VXLAN beat MPLS in the race to hardware offload :(*) l3hw - added initial HW offloading for VXLAN on compatible switches;
Oh that is great! Have been asking for that / suggesting it for ages...*) system - added option to list and install available packages (after using "check-for-updates");
Now it did work to create a /ip/cloud/file-share ... but the URL with "routingthecloud.net" does not seem to work in browser (it gets a 404). Is this for BTH use only? i.e. I noticed the /ip/cloud/back-to-home-users seem to have some [unmentioned here] file options. Anyway, I couldn't figure it out.*) cloud - added file-share feature;
While it works! The logging around it could be improved, since there is no log that a redirect happened (other than see another request & previous 301 error logged)*) fetch - added "http-max-redirect-count" parameter, allows to follow redirects;
On this above, what modems/devices support these eSIM commands?*) lte - added initial eSIM management support (CLI only);
FWIW, this allow RouterOS "print" to be output as CSV (or tab-separated) file (or console). Here is an example of esoteric sounding "dsv.remap", which is likely more useful than it sounds:*) console - added dsv.remap to :serialize command to unpack array of maps from print as-value;
*) console - added file-name parameter to :serialize;
*) console - allow tab as dsv delimiter;
# output /ip/firewall/connection using :serialize...
# using tab to console
:put [:serialize to=dsv delimiter="\t" options=dsv.remap [/ip/firewall/connection/print as-value]]
# CSV to file
:serialize to=dsv delimiter="," options=dsv.remap [/ip/firewall/connection/print as-value] file-name=connections.csv
Yes, working good on my CCR1036.Maybe analogously to ipv4 fasttrack?
Most likely some device that still is in development...On this above, what modems/devices support these eSIM commands?
I would like to understand how to properly activate Fasstrack for IPv6.
Code: Select all/ipv6 settings set allow-fast-path=yes
Is that option enough? I'm confused by the identical counter values for both rules.Code: Select all/ipv6 firewall filter add action=fasttrack-connection chain=forward comment="Enable FastTracked v6 traffic" connection-state=established,related /ipv6 firewall filter add action=accept chain=forward comment="accept established,related,untracked" connection-state=established,related,untracked
Screenshot_v6.png
Not possible on CHR.Everything will be back to normal after upgrading RB firmware to 7.18beta.Upgraded RB460GX4 from 7.17 basic package and the result is full set of disabled additional packages.
For RB433 only installed packages are still installed after upgrade and no additional list.
EDIT: for RB450Gx4 I see that it's only a list of available packages. Not installed according to "Installed" column.
Let's try...This has some severe issues with file handling... I have scripts failing that can not remove an existing file.
Still investigating, can not tell exactly what conditions have to be met. 🤨
[eworm@mt] > /file/add name=test
[eworm@mt] > /file/remove test
[eworm@mt] > /file/add name=path/test
[eworm@mt] > /file/remove path/test
no such item
[eworm@mt] > /file/print
# NAME TYPE SIZE LAST-MODIFIED
0 path directory 2025-01-21 22:10:39
1 tmpfs disk 2025-01-21 22:09:37
2 pub directory 2022-03-04 07:46:16
3 skins directory 2022-03-04 07:46:16
4 path/test file 0 2025-01-21 22:10:39
[eworm@mt] > /file/remove path/test
[eworm@mt] >
*) cloud - added file-share feature;
Awesome news. I wonder how the good old RB5009 will improve; it already does gigabit IPv6 without breaking a sweat!Tested with my old RB750Gr3, on speedtest.net with IPv6 server the hEX can now push 919 Mbps
I enabled it, or at least I thought, but doesn't work. It says running, and looked based on BTH's relay service to share files over internet.How this works? Has someone tried already?
Code: Select all*) cloud - added file-share feature;
/ip/cloud/file-share/settings/print
enabled: yes
dns-name: <sn>.routingthecloud.net
status: running
relay-rtts: EUR1 (ip4: 166.163ms, ip6: timeout)
USA1 (ip4: 70.25ms, ip6: timeout)
relay-ipv4-status: connected (region: USA1 ip: <public ipv4> rtt: 70.25ms reachable: directly )
relay-ipv6-status: testing rtt
relay-regions: EUR1
USA1
relay-addressess: <public ipv4>
<public ipv4>.
relay-addressess-ipv6: 2a02::<...>
2602::<...>
certificate: <sn>.routingthecloud.net
/ip/cloud/file-share/print detail
Flags: X - disabled; I - invalid
0 path=/ allow-uploads=yes expires=never key="UaN<keys>hs1"
url="https://9b<sn>.routingthecloud.net/s/UaN<keys>hs1"
direct-url="https://9b<sn>.routingthecloud.net/s/Ua<keys>hs1?dl" downloads=0
2025-01-22 00:32:45 bridge,info "bridge" peer link up
2025-01-22 00:32:45 bridge,info "bridge" peer connected
2025-01-22 00:32:45 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:32:56 bridge,warning "bridge" peer disconnected
2025-01-22 00:32:56 bridge,warning "bridge" peer link down
2025-01-22 00:32:56 bridge,info "bridge" peer link up
2025-01-22 00:32:56 bridge,info "bridge" peer connected
2025-01-22 00:32:56 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:33:06 bridge,warning "bridge" peer disconnected
2025-01-22 00:33:06 bridge,warning "bridge" peer link down
2025-01-22 00:33:06 bridge,info "bridge" peer link up
2025-01-22 00:33:06 bridge,info "bridge" peer connected
2025-01-22 00:33:06 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:33:16 bridge,warning "bridge" peer disconnected
2025-01-22 00:33:16 bridge,warning "bridge" peer link down
2025-01-22 00:33:16 bridge,info "bridge" peer link up
2025-01-22 00:33:16 bridge,info "bridge" peer connected
2025-01-22 00:33:16 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:33:26 bridge,warning "bridge" peer disconnected
2025-01-22 00:33:26 bridge,warning "bridge" peer link down
2025-01-22 00:33:26 bridge,info "bridge" peer link up
2025-01-22 00:33:27 bridge,info "bridge" peer connected
2025-01-22 00:33:27 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:33:37 bridge,warning "bridge" peer disconnected
2025-01-22 00:33:37 bridge,warning "bridge" peer link down
2025-01-22 00:33:37 bridge,info "bridge" peer link up
2025-01-22 00:33:37 bridge,info "bridge" peer connected
2025-01-22 00:33:37 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:33:47 bridge,warning "bridge" peer disconnected
2025-01-22 00:33:47 bridge,warning "bridge" peer link down
2025-01-22 00:33:47 bridge,info "bridge" peer link up
2025-01-22 00:33:47 bridge,info "bridge" peer connected
2025-01-22 00:33:47 bridge,info "bridge" peer becomes primary AA:BB:C0:CA:C0:1A
2025-01-22 00:33:57 bridge,warning "bridge" peer disconnected
2025-01-22 00:33:57 bridge,warning "bridge" peer link down
(add this 10 times)
Confirmed, in v7.18beta2 the IPsec tunnels are established but no "traffic" passes through them and the router restarts by watchdog without creating a supout automatically.Hi,
hex constantly rebooting itself. Only has IPsec tunnel configured for lab.
At least in my case - hAP ac^2. IPv6 traffic is really fasttracked - CPU load went down under load.
After manually adding IPv6 Fasttrack and enabiling IPv6 Fast Path in IPv6 settings, I can confirm that the new IPv6 FastTrack is working corectly:
*) route - added /ip/route/check tool;
By the way, it is worth mentioning that the syntax between routing and routes is still incongruent:
[administrator@fischerdouglas] > /routing/bgp/connection/print where address-families=
ip ipv6 l2vpn l2vpn-cisco vpnv4 vpnv6
[administrator@fischerdouglas] > /routing/route/print where afi=
bad ip4 ip6 l2vpn l2vpn-cisco l2vpn-link link mip4 mip6 vpn4 vpn6
This file share feature is pretty neat. Hopefully it is hardened - from a security perspective - as much as possible. Would not be fun to have a remote code execution just because someone can use a custom crafted POST request or/and special crafted query params.Well yes OF COURSE "file share" function will open up 443 HTTPS from anywhere, it creates a public website with https on your router, which anyone can visit. This function is to create public download links for files, like this: https://hcf087skgys.routingthecloud.net ... 3nJTFhJq3b
You can also enable uploads. Currently it works only for sharing Folders, there is a known bug that single file share does not work.
There is no "issue", it is the new normal. It says it shows the available packages after a "check for updates", and apparently until a reboot.Not possible on CHR.
Everything will be back to normal after upgrading RB firmware to 7.18beta.
Simple reboot does the trick as well (just verified on wAP AC).
I wrote above that the meters are not working correctly. That is why it is not clear through which chain the packets go.
That's a great new feature! I would love to see such functionalities described/announced in detail in the changelog or linked to a dedicated Confluence (help.mikrotik.com/docs) release page. Otherwise, it feels a bit like an Easter egg hunt. Fun, perhaps, but we're not kids anymore. 😊yes, pe1chl is correct.
check for updates command will read the package list from the server. you can install packages directly from the server now. no need to download them and upload them by hand.
the list needs to be refreshed after reboot.
For me this feature is really useful, thank you!Well yes OF COURSE "file share" function will open up 443 HTTPS from anywhere, it creates a public website with https on your router, which anyone can visit.
will it be safe? open port 443 on the router for everyone from where?... will open up 443 HTTPS from anywhere...
/sys log action set [find] disk-file-name="/log"
/ip hotspot profile set [find default=yes] html-directory="/hotspot"
/interface wifi capsman set package-path="/package"
/interface lte settings set firmware-path="/firmware"
/tool sniffer set file-name="/pcap/sniffer.pcap"
/ip proxy set cache-path="/web-proxy"
/ip smb shares set [ find default=yes ] directory="/pub"
yes it is safe, as it only opens up the file share and has a valid HTTPS certificate. Webfig is not opened to the world, when you enable file share. It is a different service.will it be safe? open port 443 on the router for everyone from where?... will open up 443 HTTPS from anywhere...
it should work behind CGNAT. What error did you get when trying to access the URL? Can you switch back to CGNAT and post the URL?I love the new filesharing function, I tried to get it work on my Hap ax lite LTE6 and invested an hour. I could not access it. Then I realized it will never work behind CGNAT, whatever I will try.... Except maybe over BTH VPN. Switching to a connection with no CGNAT and using the shown "File Direct URL" it works like a charm. Now I´d just need some small ARM box with an USB3 or SDCard, sthg like a HEX-S remake or even better a HAPax lite LTE with an SDCard slot or/and USB3.
Very nice release MT, thanks! IPv6 FastTrack and lots of WLAN stability improvements. A home user like me can´t miss much more.
Maybe Ipsec VTI in beta6. ?
Can´t reproduce, sorry! It works now over the LTE & CGNAT. I probably messed up sthg myself.it should work behind CGNAT. What error did you get when trying to access the URL? Can you switch back to CGNAT and post the URL?
NB! there is a known issue with sharing just one file. Share a folder instead.
[admin@roamlte1] /ip/cloud/file-share> export
# 2025-01-22 13:56:28 by RouterOS 7.18beta2
# software id = AAA-BBBB
#
# model = L41G-2axD&FG621-EA
# serial number = CCCCCCCCCC
[admin@roamlte1] /ip/cloud/file-share>
[admin@roamlte1] /ip/cloud/file-share/settings> export
# 2025-01-22 13:59:35 by RouterOS 7.18beta2
# software id = AAA-BBBB
#
# model = L41G-2axD&FG621-EA
# serial number = CCCCCCCCC
[admin@roamlte1] /ip/cloud/file-share/settings>
wow! I'm curious about this feature too. Anyway, thanks to the Mikrotik team that gives me the impression that they listen to their users a little more!> *) net - added initial support for automatic multicast tunneling (AMT) interface;
Is this the solution to route mDNS over WireGuard without using an EOIP tunnel?
If so, is there any usage information?
Thanks
dksoft
> *) net - added initial support for automatic multicast tunneling (AMT) interface;
Is this the solution to route mDNS over WireGuard without using an EOIP tunnel?
That is great, thank you! It would be great if we could select the version to upgrade to, instead of just updating to "latest".yes, pe1chl is correct.
check for updates command will read the package list from the server. you can install packages directly from the server now. no need to download them and upload them by hand.
the list needs to be refreshed after reboot.
/interface bridge
add name=bridge1 vlan-filtering=yes
/interface vxlan
add bridge=bridge1 bridge-pvid=10 local-address=192.168.1.1 name=vxlan-1010 vni=1010
add bridge=bridge1 bridge-pvid=20 local-address=192.168.1.1 name=vxlan-1020 vni=1020
/interface bridge port
add bridge=bridge1 interface=sfp-sfpplus3 pvid=10
add bridge=bridge1 interface=sfp-sfpplus4 pvid=20
/interface vxlan vteps
add interface=vxlan-1010 remote-ip=192.168.1.2
add interface=vxlan-1020 remote-ip=192.168.1.2
/ip address
add address=192.168.1.1 interface=lo network=192.168.1.1
add address=192.168.10.10/24 interface=sfp-sfpplus1 network=192.168.10.0
/ip route
add dst-address=192.168.1.2 gateway=192.168.10.20
/interface ethernet switch
set 0 l3-hw-offloading=yes
But normally the counter values for the two rules in the filter table are identical. That's why there is a dummy rule at the top of the table that shows you the real fasttrack'ed packets/bytes counters.
Feature which will help me considerably are L3HW offloading full vrf support not only the main tableLet us know what features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
Counter values for IPv4
Screenshot_IPv4_counter.png
Counter values for IPv6
Screenshot_IPv6_counter.png
Settings for IPv6
Screenshot_IPv6_settings.png
As you can see from the pictures - the values for IPv4 are different and the values for IPv6 are the same. So my question is - which of the rules in the picture handles IPv6 traffic?
We're looking to implement this in our campus network, which makes use of 802.1x/RADIUS for VLAN assigment.Let us know what features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
# One range, computer does math
/interface/vxlan/template add bridge=bridge interface=uplink vlan-ids=10-19 base-vni=5000 base-group=239.0.1.10 ttl=10
# More explicit, prone to errors
/interface/vxlan/template add bridge=bridge interface=uplink vlan-ids=10-19 vnis=5000-5009 groups=239.0.1.10-239.0.1.19 ttl=10
In this case it looks like your IPv4 firewall has seen a lot of untracked packets (over 6GiB), that traffic is not using fasttrack.
I had HTTPS enabled in /ip/services before the upgrade. It actually replaced an existing LE certificate on the HTTPS service with one generated by file-share with the routingthecloud.net domain. So it's not quite a "different service" if it's messing with /ip/services' HTTPS one... And it seems /ip/cloud/fire-share listens on everything EXCEPT what the standard HTTPS service listens on. I already had an "Allowed IPs" set on HTTPS, with the LAN, so once I removed the LAN subnet... I could see the /ip/cloud/file-share using the URLs.it only opens up the file share and has a valid HTTPS certificate. Webfig is not opened to the world, when you enable file share. It is a different service.
Since I kept getting 404 errors when using file-share URLs, I now get they were going the webfig/rest HTTPS. But it did NOT use the proxy as @normis describes when the HTTPS port conflicts. The <sn>.routingthecloud.net resolves to my WAN IP, and the /ip/cloud/file-share/setting/print shows it having a "direct" connection.To be clear, if you already have yourself opened webfig to the world via https (not recommended though), fileshare will not be able to also run on TCP443, so it will only work through our relay service in this case.
Agree. Or some fine-grain controls on the existing HTTPS one (i.e. allow-webfig=, allow-file-share=, allow-rest=, etc.)It would be nice to have REST API as a separate service too, that you can enable without allowing webfig...
More infoIt's the first public beta, there might be (for sure there are) bugs. Thank for the report, will investigate all the issues described.
For the config examples, all of these are for untagged VLANs, but can tagged VLANs be bridged to vxlans?
A configuration example (using static routing, but could be done through ospf,bgp):
sfp-sfpplus1 - upstream (underlay) interface
sfp-sfpplus3 - bridged port for untagged VLAN 10
sfp-sfpplus4 - bridged port for untagged VLAN 20
vxlan-1010 - overlay port for untagged VLAN 10
vxlan-1020 - overlay port for untagged VLAN 20
&
At this point, some known features are not yet implemented.
Underlay (routing encapsulated VXLAN packets):
1. VTEPs are not supported over ECMP
2. VTEPs are not supported over bond, VLAN interface
3. VTEPs cannot operate within VRFs
4. VTEPs are not supported with IPv6
Overlay (forwarding between Ethernet and VXLAN):
1. VLAN tagging over VXLAN is not supported
2. Routing between different VXLAN VNIs is not supported
3. VTEPs are isolated, and there is no mechanism to control "horizon" between them
These things will be mentioned in our help documentation page shortly.
Yay. Testing it and it works well on two 309's with two RB5009's on either end. I'm able to saturate the link with 9+Gbps.A configuration example (using static routing, but could be done through ospf,bgp):
sfp-sfpplus1 - upstream (underlay) interface
sfp-sfpplus3 - bridged port for untagged VLAN 10
sfp-sfpplus4 - bridged port for untagged VLAN 20
vxlan-1010 - overlay port for untagged VLAN 10
vxlan-1020 - overlay port for untagged VLAN 20
Code: Select all/interface bridge add name=bridge1 vlan-filtering=yes /interface vxlan add bridge=bridge1 bridge-pvid=10 local-address=192.168.1.1 name=vxlan-1010 vni=1010 add bridge=bridge1 bridge-pvid=20 local-address=192.168.1.1 name=vxlan-1020 vni=1020 /interface bridge port add bridge=bridge1 interface=sfp-sfpplus3 pvid=10 add bridge=bridge1 interface=sfp-sfpplus4 pvid=20 /interface vxlan vteps add interface=vxlan-1010 remote-ip=192.168.1.2 add interface=vxlan-1020 remote-ip=192.168.1.2 /ip address add address=192.168.1.1 interface=lo network=192.168.1.1 add address=192.168.10.10/24 interface=sfp-sfpplus1 network=192.168.10.0 /ip route add dst-address=192.168.1.2 gateway=192.168.10.20 /interface ethernet switch set 0 l3-hw-offloading=yes
changes for "wifi" (not "wifi-qcom") should also apply to wifi-qcom-acIs wifi-qcom-ac dead as far as new features and bugfixes are concerned?
not exactly what I was looking for. Can a VXLAN be bridged to sftpplus4.vlan25 for example.>all of these are for untagged VLANs, but can tagged VLANs be bridged to vxlans?
Yes, VLAN can be tagged on the Ethernet side (in the example sfp-sfpplus3 or sfp-sfpplus4). But VXLAN cannot encapsulate VLANs, so it must be configured only for a one untagged VLAN.
Thanks.
>you mentioning these things specifically because they are on the roadmap and just not implemented?
Yes, these things are known limitations of the current implementation. They are on the roadmap, but wanted to understand what use cases are more common.
Do you mean VLAN assignment via RADIUS or Access list?We occasionally notice bugfixes for wifi-qcom-ac in the changelog, which is highly appreciated. However, it would be quite interesting to know if dynamic VLAN assignment is planned for implementation - be it even in the distant future.
I thought this might fix my device not being able to connect to a SSID with FT enabled. Sadly not for me. Oh well!Some nice fixes, I like the look of this one *) wifi - try to authenticate client as non-FT client if it provides incomplete set of FT parameters;
datapath in first place. but yes others as well.Do you mean VLAN assignment via RADIUS or Access list?We occasionally notice bugfixes for wifi-qcom-ac in the changelog, which is highly appreciated. However, it would be quite interesting to know if dynamic VLAN assignment is planned for implementation - be it even in the distant future.
yes, upgrade routerboard firmware too. Regarding the modem: maybe you need to powercycle your chateau to give the modem a cold boot.My Chateau LTE has been having some stability issues and seeing the improvements in this Beta release, i thought I'd upgrade. this went fine, then i noticed there was a modem firmware upgrade available, i did this also. now i cant connect to 3/4G. I noticed just now that my routerboard fw is still at 7.17, with an Upgrade Firmware version of 7.18beta2. should i upgrade this also?
[cesar-ro@RB5009] > /system/resource/print
uptime: 1d1h17m20s
version: 7.18beta2 (testing)
build-time: 2025-01-21 09:27:58
factory-software: 7.0.5
free-memory: 451.9MiB
total-memory: 1024.0MiB
cpu: ARM64
cpu-count: 4
cpu-frequency: 350MHz
cpu-load: 6%
free-hdd-space: 980.7MiB
total-hdd-space: 1024.0MiB
write-sect-since-reboot: 42222
write-sect-total: 11915918
bad-blocks: 0%
architecture-name: arm64
board-name: RB5009UG+S+
platform: MikroTik
i++; on VRF Hardware Offload!Feature which will help me considerably are L3HW offloading full vrf support not only the main tableLet us know what features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
As well as Full MPLS Offloading or multicore processing
I'm using CCR2216 and i'm happy to do any testing thats needed and provide feedback.
Why is your CPU frequency 350Mhz ?Since upgrading to v7.18beta2, I'm seeing write-sect-since-reboot increasing very fast (40k in 24h).
Code: Select all[cesar-ro@RB5009] > /system/resource/print uptime: 1d1h17m20s version: 7.18beta2 (testing) build-time: 2025-01-21 09:27:58 factory-software: 7.0.5 free-memory: 451.9MiB total-memory: 1024.0MiB cpu: ARM64 cpu-count: 4 cpu-frequency: 350MHz cpu-load: 6% free-hdd-space: 980.7MiB total-hdd-space: 1024.0MiB write-sect-since-reboot: 42222 write-sect-total: 11915918 bad-blocks: 0% architecture-name: arm64 board-name: RB5009UG+S+ platform: MikroTik
I'm not sure what is causing this. I can't run /file/print to check further because of the risk of crashing RouterOS due to the container stores I have.
GREAT! - thank you MikroTik team!RouterOS version 7.18beta has been released on the "v7 testing" channel!
*) console - allow to toggle script error logging with "/console settings log-script-errors";
Why is your CPU frequency 350Mhz ?
>all of these are for untagged VLANs, but can tagged VLANs be bridged to vxlans?
Yes, VLAN can be tagged on the Ethernet side (in the example sfp-sfpplus3 or sfp-sfpplus4). But VXLAN cannot encapsulate VLANs, so it must be configured only for a one untagged VLAN.
/interface bridge
add name=bridge vlan-filtering=yes
/interface bridge port
add bridge=bridge frame-types=admit-only-vlan-tagged interface=sfp-sfpplus1-rb5009-3 pvid=100
/interface bridge vlan
add bridge=bridge tagged=sfp-sfpplus1-rb5009-3 untagged=vxlan-10 vlan-ids=10
/interface vxlan
add bridge=bridge bridge-pvid=10 local-address=10.10.10.1 mtu=1600 name=vxlan-10 vni=10
/interface vxlan vteps
add interface=vxlan-10 remote-ip=10.10.10.2
I support this request.Feature which will help me considerably are L3HW offloading full vrf support not only the main tableLet us know what features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
As well as Full MPLS Offloading or multicore processing
About HW VXLAN.
Supported devices are ones that support L3HW offloaded fasttrack/NAT: CRS309-1G-8S+, CRS317-1G-16S+, CRS312-4C+8XG, CRS326-24S+2Q+, CRS326-4C+20G+2Q+, CRS354-48G/P-4S+2Q+, CRS504-4XQ, CRS510-8XS-2XQ, CRS518-16XS-2XQ, CRS520-4XS-16XQ, CCR2116-12G-4S+, CCR2216-1G-12XS-2XQ.
The main goal for v7.18 is to introduce basic VXLAN data-plane support. This allows you to set up static one-to-one mappings between VLANs and VXLANs in vlan-filtering bridge.
A configuration example (using static routing, but could be done through ospf,bgp):
sfp-sfpplus1 - upstream (underlay) interface
sfp-sfpplus3 - bridged port for untagged VLAN 10
sfp-sfpplus4 - bridged port for untagged VLAN 20
vxlan-1010 - overlay port for untagged VLAN 10
vxlan-1020 - overlay port for untagged VLAN 20
Code: Select all/interface bridge add name=bridge1 vlan-filtering=yes /interface vxlan add bridge=bridge1 bridge-pvid=10 local-address=192.168.1.1 name=vxlan-1010 vni=1010 add bridge=bridge1 bridge-pvid=20 local-address=192.168.1.1 name=vxlan-1020 vni=1020 /interface bridge port add bridge=bridge1 interface=sfp-sfpplus3 pvid=10 add bridge=bridge1 interface=sfp-sfpplus4 pvid=20 /interface vxlan vteps add interface=vxlan-1010 remote-ip=192.168.1.2 add interface=vxlan-1020 remote-ip=192.168.1.2 /ip address add address=192.168.1.1 interface=lo network=192.168.1.1 add address=192.168.10.10/24 interface=sfp-sfpplus1 network=192.168.10.0 /ip route add dst-address=192.168.1.2 gateway=192.168.10.20 /interface ethernet switch set 0 l3-hw-offloading=yes
At this point, some known features are not yet implemented.
Underlay (routing encapsulated VXLAN packets):
1. VTEPs are not supported over ECMP
2. VTEPs are not supported over bond, VLAN interface
3. VTEPs cannot operate within VRFs
4. VTEPs are not supported with IPv6
Overlay (forwarding between Ethernet and VXLAN):
1. VLAN tagging over VXLAN is not supported
2. Routing between different VXLAN VNIs is not supported
3. VTEPs are isolated, and there is no mechanism to control "horizon" between them
These things will be mentioned in our help documentation page shortly.
Let us know what VXLAN-related features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
+1 too.i++; on VRF Hardware Offload!
Feature which will help me considerably are L3HW offloading full vrf support not only the main table
As well as Full MPLS Offloading or multicore processing
I'm using CCR2216 and i'm happy to do any testing thats needed and provide feedback.
L3VPN (over MPLS or over EVPN Routes Type 5) also with Hardware Offload+Fastpath+Multicore would be great!
+1I support this request.
Feature which will help me considerably are L3HW offloading full vrf support not only the main table
As well as Full MPLS Offloading or multicore processing
+1 for both !Feature which will help me considerably are L3HW offloading full vrf support not only the main tableLet us know what features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
As well as Full MPLS Offloading or multicore processing
First off. Thank you to the Mikrotik team. This has been a LONG time coming, it is great to have this functionality arrive.At this point, some known features are not yet implemented.
Underlay (routing encapsulated VXLAN packets):
1. VTEPs are not supported over ECMP
2. VTEPs are not supported over bond, VLAN interface
3. VTEPs cannot operate within VRFs
4. VTEPs are not supported with IPv6
Overlay (forwarding between Ethernet and VXLAN):
1. VLAN tagging over VXLAN is not supported
2. Routing between different VXLAN VNIs is not supported
3. VTEPs are isolated, and there is no mechanism to control "horizon" between them
These things will be mentioned in our help documentation page shortly.
Let us know what VXLAN-related features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
Your Router with LVL 4 has only 20 User manager SesionsWhy in my log is THAT:
LAN: radius authentication failed for F4:02:28:75:7A:10: current license allows only 20 active sessions
and:
License maximum active session limit reached.
???
Thank you. I know that. But, device is in basements, works only in special case, and uptime only 15 minutes. First log like this from 10 years. Strange.Your Router with LVL 4 has only 20 User manager SesionsWhy in my log is THAT:
LAN: radius authentication failed for F4:02:28:75:7A:10: current license allows only 20 active sessions
and:
License maximum active session limit reached.
???
https://help.mikrotik.com/docs/spaces/R ... ekeylevels
PS Mega +1 on all work for HW VXLAN.
No more updates for expired instances?*) chr - fixed limited upgrades for expired instances;
Agreed on this, but in-theory if the chipset supports it, the MACSEC will be transparent to the upper layer protocols e.g. IP, VXLAN, MPLS+1 on nz_monkey regarding VXLAN comments and eVPN.
Could I add in( no doubt a new switch chip for future products ), but hardware offloaded MACSEC as part of the underlay.
"And include jumbo frames ( aka 9000 byte + frame)"
My use case is commercial datacenter/carrier providers(via L2) to remote sites, as part of cyber security uplift.
@EdPa:Let us know what VXLAN-related features you need, this could help us prioritize development.
Please stop setting MTU underlay as "just enough"!
Before RouterOS only did send syslog over UDP, you can now select TCP as well.how does that work?
*) log - added option to select TCP or UDP for remote logging;
Like this:how does that work?
*) log - added option to select TCP or UDP for remote logging;
The random link itself is a security measure. Set "expires" and do not put the link anywhere public, then it's just as secure. You can even treat the last part of the URL as a password and give it separately.It would be nice to have the ability to set a password for file sharing.
I guess that L2MTU setting affect number of frame buffers available. E.g.: if switch chip has 1MB of memory, if L2MTU is set to 1516 bytes, then this means space for 691 frames buffered. Setting L2MTU to 2000 bytes reduces number of buffered frames to maximum of 524.
I guess that L2MTU setting affect number of frame buffers available. E.g.: if switch chip has 1MB of memory, if L2MTU is set to 1516 bytes, then this means space for 691 frames buffered. Setting L2MTU to 2000 bytes reduces number of buffered frames to maximum of 524.
Not only that, it will halve the number of buffers to 345, because the increase is in a whole-number-factor of the original buffer size.
What is the format to use for expires?Set "expires"
So with WinBox it is like this Thanks Normis!set 0 expires=2025-01-25
2025-01-23T08:49:43.951+0100 RB951 CEF:0|MikroTik|RB951Ui-2HnD|7.18beta2 (testing)|9|script,debug|Low|msg=debug
2025-01-23T08:48:16.902+0100 RB951 CEF:0|MikroTik|RB951Ui-2HnD|7.18beta2 (testing)|9|script,error|High|msg=error
2025-01-23T08:48:05.161+0100 RB951 CEF:0|MikroTik|RB951Ui-2HnD|7.18beta2 (testing)|9|script,warning|Medium|msg=warning
2025-01-23T08:47:55.690+0100 RB951 CEF:0|MikroTik|RB951Ui-2HnD|7.18beta2 (testing)|9|script,info|Low|msg=info
I can see info as part of an other field, like script,warning, but should be a separated field with correct syslog severity.syslog-severity (alert, auto, critical, debug, emergency, error, info, notice, warning; Default: auto)
Did found that the new CEF log format also support ISO8601 and will give milliseconds. That is fantastic :)That's in old winbox, the new WinBox 4 also uses ISO8601 date format
well..More CEF features are in development for the next betas
Well I tried to beta-test as update to 7.17 was failing and it looks like this change does not help (for in-place update).*) system,arm - automatically increase boot part size on upgrade or netinstall (fixed upgrade failed due to a lack of space on kernel disk/partition);
We are in the middle of a brainSTORM so even the stupidest idea could have positive effect....It does not look even remotely plausible....
on [successful] upgrade or netinstall
Device does not have multiple partitionsif you have multiple partitions, remove them, then reboot twice and update to 7.17. This worked with 2 CCR2004.
Then original question stands - are there any alternatives to netinstall...on [successful] upgrade or netinstall
Simply the "fix" is not installed until is not successfully installed the 7.18beta2.
The fix is for future versions, not to fix current.
Finally!!!*) ipv6 - added FastTrack support;
Works great here with the simple config supplied. Between a CRS518-16XS-2XQ and CRS326-24S+2Q+Let us know what VXLAN-related features you need, this could help us prioritize development.
They should make 7.16.3 (which would be the same size as the kernel that goes with it) with the space fix,Then original question stands - are there any alternatives to netinstall...
Because this time with device-mode s–t no one want lock his devices, so less persons than before do tests...Well, no one reported it for the testing (beta and rc) releases...
Good to know i'm not the only oneBecause this time with device-mode s–t no one want lock his devices, so less persons than before do tests...Well, no one reported it for the testing (beta and rc) releases...
Now if the only added one more drop-down to /ip/dhcp-client to set check-gateway= so you don't need a DHCP script to do it for multiwan... I'd be willing to issue a pardon for 7.17 to Mikrotik.*) dhcpv4-client - allow selecting to which routing tables add default route;
viewtopic.php?p=1121167#p1121155Good to know i'm not the only one
Because this time with device-mode s–t no one want lock his devices, so less persons than before do tests...
(also, 7.17 apparently can brick certain hardware, such as rb450gx4, also reported on 7.18b2 )
all the more reason for moving 7.16.x to "longterm"
Hello,I'm not familiar with that CEF format, but isn't there supposed to be a unique message identifier as well? Or does CEF not specify that?
About the supported devices, besides the ones you cited, are there plans to grant VXLAN HW to CRS3XX that doesn't have fasttrack/NAT offloading?About HW VXLAN.
Supported devices are ones that support L3HW offloaded fasttrack/NAT: CRS309-1G-8S+, CRS317-1G-16S+, CRS312-4C+8XG, CRS326-24S+2Q+, CRS326-4C+20G+2Q+, CRS354-48G/P-4S+2Q+, CRS504-4XQ, CRS510-8XS-2XQ, CRS518-16XS-2XQ, CRS520-4XS-16XQ, CCR2116-12G-4S+, CCR2216-1G-12XS-2XQ.
+1 for both !+1 for both !
Feature which will help me considerably are L3HW offloading full vrf support not only the main table
As well as Full MPLS Offloading AND multicore processing
2025-01-23 20:11:32 system,info,critical Optimal nand stability requires a backup-routerboot upgrade.\r
2025-01-23 20:11:32 system,info,critical Universal package can be found here:\r
2025-01-23 20:11:32 system,info,critical https://help.mikrotik.com/docs/display/ROS/RouterBOARD#RouterBOARD-Settings
installed bb-upgrade-7.6
FAILED to upgrade backup booter: wrong running booter version
and the correct link is this:when trying to enable the feature, do the following:
a) upgrade or downgrade the device specifically to the 7.6 release
b) upgrade your current RouterBOOT version with "/system routerboard upgrade" then reboot the device, so that the RouterBOOT version (current-firmware version when checking "/system routerboard print") is the same as the firmware version ("/system resource print") installed, which should be 7.6.
:local date [/system clock get date];
:local time [/system clock get time];
:local timezone [/system clock get time-zone-name];
:local hostname [/system identity get name];
/system backup save name=email password=xxxxx;
/tool e-mail send to="xxxxxxxx" subject="$date $time $timezone -- $hostname" file=email.backup;
:log info "Backup e-mail sent.";
The thing is, that line 9 is the last line, and it doesn't have 94 columns.2025-01-22 00:00:00 script,error executing script from scheduler (e-mail-backup) failed, please check it manually
2025-01-22 00:00:00 script,error,debug (scheduler:e-mail-backup) syntax error (line 9 column 94)
If run manually command by command through terminal (within curly braces), there are no errors.2025-01-23 01:23:22 script,error executing script e-mail-backup from winbox failed, please check it manually
2025-01-23 01:23:22 script,error,debug syntax error (line 9 column 94)
On v7.17 the same exact script runs without issues.2025-01-23 22:01:03 script,info Backup e-mail sent.
2025-01-23 22:01:03 e-mail,info sent <2025-01-23 22:01:03 xxxxxx - xxxxxx> to: xxxxxxx
/system clock
:local d [get date]
:local t [get time]
:local z [get time-zone-name]
/system identity
:local n [get name]
/system backup
save name=email dont-encrypt=no encryption=aes-sha256 password=pippo
:delay 2s
/tool e-mail send to="xxx@example.com" subject=("$d $t $z -- $n") file="email.backup"
:log info "Backup e-mail sent."
Hummm, Finaly some progress on Hardware Offload.viewtopic.php?t=213301
fixed
filehsaring on network devices?I love the new filesharing function,
router board upgraded, still no LTE connectivity.yes, upgrade routerboard firmware too. Regarding the modem: maybe you need to powercycle your chateau to give the modem a cold boot.My Chateau LTE has been having some stability issues and seeing the improvements in this Beta release, i thought I'd upgrade. this went fine, then i noticed there was a modem firmware upgrade available, i did this also. now i cant connect to 3/4G. I noticed just now that my routerboard fw is still at 7.17, with an Upgrade Firmware version of 7.18beta2. should i upgrade this also?
/interface/lte/monitor lte1 once
the problem started not when i upgraded to the beta version, but just after when i upgraded the modem to 16121.1034.00.01.01.08 and i was wondering if that's the problem.We dont even know what is wrong. Whats the output of
Consider downgrading to ROS 7.17 before doing factory reset. This is BETA.Code: Select all/interface/lte/monitor lte1 once
Only way to know for sure: file support ticket.the problem started not when i upgraded to the beta version, but just after when i upgraded the modem to 16121.1034.00.01.01.08 and i was wondering if that's the problem.We dont even know what is wrong. Whats the output of
Consider downgrading to ROS 7.17 before doing factory reset. This is BETA.Code: Select all/interface/lte/monitor lte1 once
2025-01-24T11:22:27+01:00 MikroTik ether1 detected poe-out status: voltage_on_poe-in
2025-01-24T11:22:28+01:00 MikroTik ether1 detected poe-out status: disabled
2025-01-24T11:28:29+01:00 MikroTik ether2 detected poe-out status: voltage_on_poe-in
2025-01-24T11:28:29+01:00 MikroTik ether2 detected poe-out status: disabled
2025-01-24T11:40:50+01:00 MikroTik ether4 detected poe-out status: voltage_on_poe-in
2025-01-24T11:40:50+01:00 MikroTik ether4 detected poe-out status: wait_for_load
2025-01-24T11:55:39+01:00 MikroTik ether4 detected poe-out status: voltage_on_poe-in
2025-01-24T11:55:39+01:00 MikroTik ether4 detected poe-out status: wait_for_load
Did you tried fetch it over REST API? I moved from SNMP to REST successfully, it is slow and not optimal for this.Retrieving route table via SNMP (snmpnetstat -v2c -c public -Cn -Cr router-IP) no longer returns the complete routing table.
Also, when there are multiple routing tables, it still ends up in a loop (existing problem).
More details on this please - does it affect all devices, or just the newer 802.11ay ones (the older 802.11ad have been quite stable in my experience, still running 6.49.x on them)?*) 60ghz - improved system stability;
Gone for good (in which case the feature should be documented as deprecated), or just removed temporarily due to some issues that are being worked on and then it will be back (and hopefully improved)?*) bridge - removed controller-bridge (CB) and port-extender (PE) support;
memory poe-out, warning ether1 detected poe-out status: voltage_on_poe-in
memory poe-out, warning ether5 detected poe-out status: voltage_on_poe-in
Brilliant support received today from Mikrotik. Problem resolved.the problem started not when i upgraded to the beta version, but just after when i upgraded the modem to 16121.1034.00.01.01.08 and i was wondering if that's the problem.We dont even know what is wrong. Whats the output of
Consider downgrading to ROS 7.17 before doing factory reset. This is BETA.Code: Select all/interface/lte/monitor lte1 once
[GLOVERC7@Boat] > /interface/lte/monitor lte1 once
status: connected
model: FG621-EA
revision: 16121.1034.00.01.01.08
current-operator: EE
current-cellid: 7001604
enb-id: 27350
sector-id: 4
phy-cellid: 274
data-class: LTE
session-uptime: 12m47s
imei: 863359043719802
imsi: 234304307454535
uicc: 8944303633230353117
primary-band: B3@20Mhz earfcn: 1815 phy-cellid: 274
rssi: -77dBm
rsrp: -105dBm
rsrq: -11dB
sinr: 3dB
Useless to post that here when you do not include how it was resolved...Brilliant support received today from Mikrotik. Problem resolved.
hardware offloaded MACSEC at all would be a great leap forward. (if only just to get rid of some catalyst boxes with FRU modules in it which are half a decade old...)+1 on nz_monkey regarding VXLAN comments and eVPN.
Could I add in( no doubt a new switch chip for future products ), but hardware offloaded MACSEC as part of the underlay.
"And include jumbo frames ( aka 9000 byte + frame)"
My use case is commercial datacenter/carrier providers(via L2) to remote sites, as part of cyber security uplift.
would also love to see more information on that. got about 6 setups with 60GHz and 60+5GHz but only two of them in v7 land ... and i am not eager to update to 7.16+ when this means i have to climb a roof or antenna mastMore details on this please - does it affect all devices, or just the newer 802.11ay ones (the older 802.11ad have been quite stable in my experience, still running 6.49.x on them)?*) 60ghz - improved system stability;
Did some testing of "file-share", so have a few more nits ;). This actually might be useful for SMS/text/etc notifications in scripting. So did some quick tests, trying to "share" a CSV of firewall connections...*) cloud - added file-share feature;It's the first public beta, there might be (for sure there are) bugs. Thank for the report, will investigate all the issues described.
It seems that adding the filename and "?dl" at end does actually work to get allow a single file. While the bug I saw was that other files in same path are also exposed if you use a file name but the path= is set to single file in /ip/cloud/file-share.Currently it works only for sharing Folders, there is a known bug that single file share does not work.
:serialize file-name=raid1/connections.csv to=dsv delimiter="," options=dsv.remap [/ip/firewall/connection print detail as-value]
:put "Link to CSV: $[ /ip/cloud/file-share get [/ip/cloud/file-share/add expires=1d path=raid1] url ]/connections.csv?dl"
{
:serialize file-name=raid1/connections.csv to=dsv delimiter="," options=dsv.remap [/ip/firewall/connection print detail as-value]
:local isoexpire [:toarray [:serialize to=json ([:timestamp] + 1d) ] ]
:local fsid [/ip/cloud/file-share/add expires=$isoexpire path=raid1]
:delay 15s
:put "CSV file with connections: $[ /ip/cloud/file-share get $fsid url ]/connections.csv?dl"
}
/ipv6 firewall filter
add action=fasttrack-connection chain=forward connection-state=established,related
add action=accept chain=forward connection-state=established,related,untracked
LibreNMS?No, all our monitoring is done using SNMP.
It logging 4 lines (two login and two logout) per 10 minutes, I think the login timeout is 10mins.I also do not like that each and every poll results in a log line.
2025-01-25 09:20:02 system,info,account user restapi logged in from 192.168.5.113 via rest-api
2025-01-25 09:20:02 system,info,account user restapi logged in via api
2025-01-25 09:30:02 system,info,account user restapi logged out from 192.168.5.113 via rest-api
2025-01-25 09:30:02 system,info,account user restapi logged out via api
2025-01-25 09:31:01 system,info,account user restapi logged in from 192.168.5.113 via rest-api
2025-01-25 09:31:01 system,info,account user restapi logged in via api
2025-01-25 09:41:01 system,info,account user restapi logged out via api
2025-01-25 09:41:01 system,info,account user restapi logged out from 192.168.5.113 via rest-api
2025-01-25 09:41:01 system,info,account user restapi logged in from 192.168.5.113 via rest-api
2025-01-25 09:41:01 system,info,account user restapi logged in via api
2025-01-25 09:51:01 system,info,account user restapi logged out from 192.168.5.113 via rest-api
2025-01-25 09:51:01 system,info,account user restapi logged out via api
Anyone else having this issue?A simple backup to mail script has stopped working on v7.18beta2.
The script is:
When run via scheduler, it fails with:Code: Select all:local date [/system clock get date]; :local time [/system clock get time]; :local timezone [/system clock get time-zone-name]; :local hostname [/system identity get name]; /system backup save name=email password=xxxxx; /tool e-mail send to="xxxxxxxx" subject="$date $time $timezone -- $hostname" file=email.backup; :log info "Backup e-mail sent.";
The thing is, that line 9 is the last line, and it doesn't have 94 columns.2025-01-22 00:00:00 script,error executing script from scheduler (e-mail-backup) failed, please check it manually
2025-01-22 00:00:00 script,error,debug (scheduler:e-mail-backup) syntax error (line 9 column 94)
If run manually via winbox it fails the same.If run manually command by command through terminal (within curly braces), there are no errors.2025-01-23 01:23:22 script,error executing script e-mail-backup from winbox failed, please check it manually
2025-01-23 01:23:22 script,error,debug syntax error (line 9 column 94)
On v7.17 the same exact script runs without issues.2025-01-23 22:01:03 script,info Backup e-mail sent.
2025-01-23 22:01:03 e-mail,info sent <2025-01-23 22:01:03 xxxxxx - xxxxxx> to: xxxxxxx
Yes it works. Instead of re-writing my script for no reason and me trying to find the differences between the two, you could have just pointed to the issue, which is that /tool email file parameter needs the filename in quotes in v7.18. Up until v7.17, this works without quotes.You test this?
viewtopic.php?t=214071#p1121253
IMO, it's a good practice to always put all string values in quotes, especially if there are symbols.Yes it works. Instead of re-writing my script for no reason and me trying to find the differences between the two, you could have just pointed to the issue, which is that /tool email file parameter needs the filename in quotes in v7.18. Up until v7.17, this works without quotes.You test this?
viewtopic.php?t=214071#p1121253
So much for "all changes are included in the changelog"... Thanks MikroTik.
It sounds like you use some configuration which punt traffic to the CPU instead of offloading.Router model: CCR2004-16G-2S+
Winbox v4
I removed v7.18 because it caused lag, Windows not closing, and changes not being saved when the "Save" or "OK" button was clicked. It was a horrible experience.
After factory firmware, many switch features were removed, which is unacceptable. Even though this router has two Marvel switches, you can only perform mirroring, ingress, and egress; the rest of the useful features have vanished. Even these don't work at full speed at 10 Gbps, barely reaching 2 Gbps. Switch rules aren't working, but they work on other routers, for example, the hAP ac2. You've made it like a cheap router with no features for the price. In speed tests, even if the CPU usage is at 30% with an 800 Mbps speed test, this doesn't mean it "can handle a lot," as you mention in videos. Programs and games constantly show internet problems. The CPU runs incredibly hot if I disable CPU flow control; with normal browsing, it already reaches 59 degrees.
You do know that WinBox is still is in beta, only at 4.0beta16... don't you (and by the way this was the first public beta of the 7.18 branch)?Router model: CCR2004-16G-2S+
Winbox v4
I removed v7.18 because it caused lag, Windows not closing, and changes not being saved when the "Save" or "OK" button was clicked. It was a horrible experience.
Which RouterBOARD version you mean as factory firmware? You do know that it is - usually advisable to keep the RouterOS (upgraded at /system/packages/update) and the RouterBoard (upgraded at /system/routerboard) at the same version, don't you? By the way the risk averse practice is (after exporting the configuration withAfter factory firmware, many switch features were removed, which is unacceptable. Even though this router has two Marvel switches, you can only perform mirroring, ingress, and egress; the rest of the useful features have vanished. Even these don't work at full speed at 10 Gbps, barely reaching 2 Gbps. Switch rules aren't working, but they work on other routers, for example, the hAP ac2. You've made it like a cheap router with no features for the price. In speed tests, even if the CPU usage is at 30% with an 800 Mbps speed test, this doesn't mean it "can handle a lot," as you mention in videos. Programs and games constantly show internet problems. The CPU runs incredibly hot if I disable CPU flow control; with normal browsing, it already reaches 59 degrees.
export verbose show-sensitive file=AnyNameYouLike
No reason? I show you how must be coded corectly to avoid use scripting style that casually works...Instead of re-writing my script for no reason
:local date [/system clock get date]; # on this line: useless ; / WARNING: date var have same name as date value
# if are more than one get, go to section /system clock and write only "get x"
:local time [/system clock get time]; # on this line: useless ; / WARNING: time var have same name as time value
:local timezone [/system clock get time-zone-name]; # on this line: useless ;
:local hostname [/system identity get name]; # on this line: useless ;
# NOTICE: for prevent only "some" problems with expected missing parameters, better specify also dont-encrypt and encryption
/system backup save name=email password=xxxxx; # on this line: useless ;
# WARNING: missing a delay, sometime is not possible read instantly the file...
/tool e-mail send to="xxxxxxxx" subject="$date $time $timezone -- $hostname" file=email.backup; # on this line: useless ;
# ERROR: missing "" on email.backup AND WARNING: when used $xxx inside a string is better use ( ).
# Sometime not using ( ) cause some unexpected behavior. This is a mistake I often make too.
:log info "Backup e-mail sent."; # on this line: useless ;
Exactly...IMO, it's a good practice to always put all string values in quotes, especially if there are symbols.
Thank you moving this forward!About HW VXLAN.
[...]
Actually I think putting a ; at the end of each line is not "useless" but is a style that prevents problems in the future.No reason? I show you how must be coded corectly to avoid use scripting style that casually works...
The missing "" are not only the problem, expect broken it again on future versions....
I'm also interested in the vlan assignment via datapath (qcom-ac driver).datapath in first place. but yes others as well.
Do you mean VLAN assignment via RADIUS or Access list?
They are already in the RFCs ( https://www.ietf.org/ ) - just implement it properly as other network vendor.About HW VXLAN.
Supported devices are ones that support L3HW offloaded fasttrack/NAT: CRS309-1G-8S+, CRS317-1G-16S+, CRS312-4C+8XG, CRS326-24S+2Q+, CRS326-4C+20G+2Q+, CRS354-48G/P-4S+2Q+, CRS504-4XQ, CRS510-8XS-2XQ, CRS518-16XS-2XQ, CRS520-4XS-16XQ, CCR2116-12G-4S+, CCR2216-1G-12XS-2XQ.
The main goal for v7.18 is to introduce basic VXLAN data-plane support. This allows you to set up static one-to-one mappings between VLANs and VXLANs in vlan-filtering bridge.
A configuration example (using static routing, but could be done through ospf,bgp):
sfp-sfpplus1 - upstream (underlay) interface
sfp-sfpplus3 - bridged port for untagged VLAN 10
sfp-sfpplus4 - bridged port for untagged VLAN 20
vxlan-1010 - overlay port for untagged VLAN 10
vxlan-1020 - overlay port for untagged VLAN 20
Code: Select all/interface bridge add name=bridge1 vlan-filtering=yes /interface vxlan add bridge=bridge1 bridge-pvid=10 local-address=192.168.1.1 name=vxlan-1010 vni=1010 add bridge=bridge1 bridge-pvid=20 local-address=192.168.1.1 name=vxlan-1020 vni=1020 /interface bridge port add bridge=bridge1 interface=sfp-sfpplus3 pvid=10 add bridge=bridge1 interface=sfp-sfpplus4 pvid=20 /interface vxlan vteps add interface=vxlan-1010 remote-ip=192.168.1.2 add interface=vxlan-1020 remote-ip=192.168.1.2 /ip address add address=192.168.1.1 interface=lo network=192.168.1.1 add address=192.168.10.10/24 interface=sfp-sfpplus1 network=192.168.10.0 /ip route add dst-address=192.168.1.2 gateway=192.168.10.20 /interface ethernet switch set 0 l3-hw-offloading=yes
At this point, some known features are not yet implemented.
Underlay (routing encapsulated VXLAN packets):
1. VTEPs are not supported over ECMP
2. VTEPs are not supported over bond, VLAN interface
3. VTEPs cannot operate within VRFs
4. VTEPs are not supported with IPv6
Overlay (forwarding between Ethernet and VXLAN):
1. VLAN tagging over VXLAN is not supported
2. Routing between different VXLAN VNIs is not supported
3. VTEPs are isolated, and there is no mechanism to control "horizon" between them
These things will be mentioned in our help documentation page shortly.
Let us know what VXLAN-related features you need, this could help us prioritize development. Also, work on EVPN has started, but would like to hear from you about the most important capabilities and how you imagined they would look like in RouterOS.
[bajodel@ros7-lab] /routing/bgp> export verbose
/routing bgp template
set default as=65530 name=default
[bajodel@ros7-lab] /routing/bgp/template/set default address-families=ip as=65000 multihop=yes name=toRRs router-id=10.8.0.10
[bajodel@ros7-lab] /routing/bgp> export
/routing bgp template
set toRRs address-families=ip as=65000 multihop=yes name=toRRs router-id=10.8.0.10
The whole concept of templates is riddled with bugs. Another one is that winbox will not keep inheritance of parameters from templates, it will just copy them (e.g. into the connection).
Jan/27/2025 12:00:49 dhcp,debug processing client:005056bf3ea9 iapd:0x2, no existing binding found, won't create
Jan/27/2025 12:00:49 dhcp,debug,packet send <pppoe-user3> -> fe80::10e6:78c6:0:2%23
Jan/27/2025 12:00:49 dhcp,debug,packet type: reply
Jan/27/2025 12:00:49 dhcp,debug,packet transaction-id: 0effc1
Jan/27/2025 12:00:49 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Jan/27/2025 12:00:49 dhcp,debug,packet -> serverid: 00030001 005056bf 358d
Jan/27/2025 12:00:49 dhcp,debug,packet -> rapid_commit: [empty]
Jan/27/2025 12:00:49 dhcp,debug,packet -> dns_servers:
Jan/27/2025 12:00:49 dhcp,debug,packet XXXX:XXXX:0:10::10
Jan/27/2025 12:00:49 dhcp,debug,packet XXXX:XXXX:0:10::11
Jan/27/2025 12:00:49 dhcp,debug,packet -> ia_pd:
Jan/27/2025 12:00:49 dhcp,debug,packet t1: 43200
Jan/27/2025 12:00:49 dhcp,debug,packet t2: 69120
Jan/27/2025 12:00:49 dhcp,debug,packet id: 0x2
Jan/27/2025 12:00:49 dhcp,debug,packet -> status: 6 - no prefix
Jan/27/2025 12:01:30 dhcp,debug,packet recv server: <pppoe-user3> fe80::10e6:78c6:0:2 -> ff02::1:2
Jan/27/2025 12:01:30 dhcp,debug,packet type: solicit
Jan/27/2025 12:01:30 dhcp,debug,packet transaction-id: a639a7
Jan/27/2025 12:01:30 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Jan/27/2025 12:01:30 dhcp,debug,packet -> oro: 23
Jan/27/2025 12:01:30 dhcp,debug,packet -> elapsed_time: 0
Jan/27/2025 12:01:30 dhcp,debug,packet -> rapid_commit: [empty]
Jan/27/2025 12:01:30 dhcp,debug,packet -> ia_pd:
Jan/27/2025 12:01:30 dhcp,debug,packet t1: 0
Jan/27/2025 12:01:30 dhcp,debug,packet t2: 0
Jan/27/2025 12:01:30 dhcp,debug,packet id: 0x2
Jan/27/2025 12:01:30 dhcp,debug processing client:005056bf3ea9 iapd:0x2, no existing binding found, won't create
Jan/27/2025 11:57:01 dhcp,debug resending..
Jan/27/2025 11:57:01 dhcp,debug,packet send pppoe-out1 -> ff02::1:2%6
Jan/27/2025 11:57:01 dhcp,debug,packet type: solicit
Jan/27/2025 11:57:01 dhcp,debug,packet transaction-id: 0effc1
Jan/27/2025 11:57:01 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Jan/27/2025 11:57:01 dhcp,debug,packet -> oro: 23
Jan/27/2025 11:57:01 dhcp,debug,packet -> elapsed_time: 224
Jan/27/2025 11:57:01 dhcp,debug,packet -> rapid_commit: [empty]
Jan/27/2025 11:57:01 dhcp,debug,packet -> ia_pd:
Jan/27/2025 11:57:01 dhcp,debug,packet t1: 0
Jan/27/2025 11:57:01 dhcp,debug,packet t2: 0
Jan/27/2025 11:57:01 dhcp,debug,packet id: 0x2
Jan/27/2025 11:57:01 dhcp,debug,packet recv client: pppoe-out1 fe80::f4f7:8778:f0:4 -> fe80::10e6:78c6:0:2
Jan/27/2025 11:57:01 dhcp,debug,packet type: reply
Jan/27/2025 11:57:01 dhcp,debug,packet transaction-id: 0effc1
Jan/27/2025 11:57:01 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Jan/27/2025 11:57:01 dhcp,debug,packet -> serverid: 00030001 005056bf 358d
Jan/27/2025 11:57:01 dhcp,debug,packet -> rapid_commit: [empty]
Jan/27/2025 11:57:01 dhcp,debug,packet -> dns_servers:
Jan/27/2025 11:57:01 dhcp,debug,packet XXXX:XXXX:0:10::10
Jan/27/2025 11:57:01 dhcp,debug,packet XXXX:XXXX:0:10::11
Jan/27/2025 11:57:01 dhcp,debug,packet -> ia_pd:
Jan/27/2025 11:57:01 dhcp,debug,packet t1: 43200
Jan/27/2025 11:57:01 dhcp,debug,packet t2: 69120
Jan/27/2025 11:57:01 dhcp,debug,packet id: 0x2
Jan/27/2025 11:57:01 dhcp,debug,packet -> status: 6 - no prefix
Jan/27/2025 11:57:01 dhcp,debug ia_pd: bad status in advertise: no prefix (6)
Jan/27/2025 12:00:48 dhcp,debug resending..
If you have not already, please write to support@mikrotik.com and attach a supout.PPSK authentication has issues.
Note: There is a very high chance that this post will be deleted.They are already in the RFCs ( https://www.ietf.org/ ) - just implement it properly as other network vendor.About HW VXLAN.
The "Half-baked" solution breaks interoperability in multi-vendor environment.
If you have not already, please write to support@mikrotik.com and attach a supout.PPSK authentication has issues.
While not a solution to your problem, I have applied as workaround a daily reset around midnight on 1 cap AC experiencing exactly the same behavior since 7.16.1 (it used to take between 2 or 3 days before it ran out of memory, I should try with latest 7.18 beta release to see what it does now...).I have tried switch off fast handovers - leaked, normal handover - leaked, completely different SSID - leaked. Leakage is not big (and it takes time to investigate it), but memory steadily going down to kernel panic after couple of days. It seems there is dependency on amount of traffic or amount of connected devices (mostly Apple).
While not a solution to your problem, I have applied as workaround a daily reset around midnight on 1 cap AC experiencing exactly the same behavior since 7.16.1 (it used to take between 2 or 3 days before it ran out of memory, I should try with latest 7.18 beta release to see what it does now...).I have tried switch off fast handovers - leaked, normal handover - leaked, completely different SSID - leaked. Leakage is not big (and it takes time to investigate it), but memory steadily going down to kernel panic after couple of days. It seems there is dependency on amount of traffic or amount of connected devices (mostly Apple).
I don't care counters are reset as long as users are able to work when needed.
OTOH a hAP AC2 with the same SW version (and same platform), doesn't exhibit this problem.
Minimal config, AP only and everything bridged.
2025-01-27_15-18-55.jpg
/interface bridge add name=bridge1
/ipv6 address add address=::1 from-pool=LAN6 interface=bridge1
/ipv6 dhcp-client add add-default-route=yes interface=ether3 pool-name=LAN6 rapid-commit=no request=prefix
/ipv6 address add address=2a07:9280::2 advertise=no interface=ether2
/ipv6 dhcp-relay add dhcp-server=2a07:9280::1 interface=ether3 name=relay1
/ipv6 nd set [ find default=yes ] managed-address-configuration=yes other-configuration=yes
/ipv6 dhcp-server add address-pool=pool1 interface=ether2 lease-time=10s name=server1 prefix-pool=pool1
/ipv6 pool add name=pool1 prefix=2a06:9280::/56 prefix-length=60
/ipv6 address add address=2a07:9280::1 advertise=no interface=ether2
/ipv6 nd set [ find default=yes ] managed-address-configuration=yes other-configuration=yes
With major releases come major changes.RouterOS does not use NFTables yet, and they are probably stuck with IPTables because there must be a lot of framework bypasses in that scope.
Hmm although off topic and at risk of being deleted (which is fair)With major releases come major changes.RouterOS does not use NFTables yet, and they are probably stuck with IPTables because there must be a lot of framework bypasses in that scope.
I fully expect that Mikrotik will change to bpfilter rather than NFTables, but I wouldn't expect to see it until RouterOS v8 alpha/beta cycle.
Semi-off-topic...Hmm although off topic and at risk of being deleted (which is fair)
The release dates of major RouterOS versions as per Wikipedia are as per below
Version 7: December 2021
Version 6: November 2012
Version 5: March 2010
Version 4: October 2009
Version 3: January 2008
Apart from 6 -> 7 there was 1 to 2 year between major versions and between 6 -> 7 was around 9 years. So far its been around 2 years from ROS 7 but based on current development its unlikely to see ROS 8 in at least 2-3 years
Where do you have that info from? Has there been some announcement that I missed?Mikrotik have a significantly larger team of developers working on RouterOS core functionality now than they did in the RouterOS v6 to v7 transition phase
Unfortunately yes and yes :(E.g. the bugs introduced in BGP in 7.16 were completely neglected in 7.17, and in 7.18 there were some fixes but still problems that were not there in 7.15.
But we do get all kinds of changes for home usage and a method to protect routers installed incorrectly.
No announcement, but look at the sheer size of recent changelogs and the breadth of features that are being worked on, it seems clear that more developers must be working on RouterOS.Where do you have that info from? Has there been some announcement that I missed?
I still get the perception that the number of developers limits the number of projects they can run concurrently, and the attention often shifts to projects that probably make more money in the short term...
E.g. the bugs introduced in BGP in 7.16 were completely neglected in 7.17, and in 7.18 there were some fixes but still problems that were not there in 7.15.
But we do get all kinds of changes for home usage and a method to protect routers installed incorrectly.
Thats true though but unfortunately some important features seems to be fading into the background like BGP related things. I opened tickets about L3VPN and one of them is hanging unanswered since october.No announcement, but look at the sheer size of recent changelogs and the breadth of features that are being worked on, it seems clear that more developers must be working on RouterOS.
I can't speak for RoS 5 and before.Apart from 6 -> 7 there was 1 to 2 year between major versions and between 6 -> 7 was around 9 years. So far its been around 2 years from ROS 7 but based on current development its unlikely to see ROS 8 in at least 2-3 years
@Glavni_5GHz association rejected, FTE indicated that STA uses RSNXE, but RSNXE was not included.
*) wifi - try to authenticate client as non-FT client if it provides incomplete set of FT parameters;Just got Samsung s25 ultra and it doesnt want to roam(Older s23 roamed just fine), i get this in log.
Is this related to 7.18 or something else i never saw such message?Code: Select all@Glavni_5GHz association rejected, FTE indicated that STA uses RSNXE, but RSNXE was not included.
I don't know about the BGP itself (although I got the impression that both v6 and v7 used proprietary code for this) , but the system routing was the other way around, wasn't it? RoS 6 used something made by Mikrotik, and RoS is using the default one?That may be true, but before they used a standard BGP implementation and Linux routing, and in v7 it was replaced by in-house written code and frankly for me it has only caused trouble.
So that I don't end up being the annoying person who only talks about bad things, a compliment for a change...*) cloud - added file-share feature;
I agree, lots of use cases. Like SMS/"Telegram"/etc notifications too. Or, stuff like being able to "share" a peer's WG keys using file-shares's "expires-after".I may be expecting too much, but to me it seems quite reasonable to put one thing together and imagine that they are creating an infrastructure for "desired state automation".*) cloud - added file-share feature;
Yes, that is correct. Ever since v4, RouterOS uses their own proprietary BGP implementation.I don't know about the BGP itself (although I got the impression that both v6 and v7 used proprietary code for this)That may be true, but before they used a standard BGP implementation and Linux routing, and in v7 it was replaced by in-house written code and frankly for me it has only caused trouble.
I'm still pissed I lost the "dynamic-in" rules – still no equivalent in V7...with the awesome UI and filtering of v6 [...] and especially filters with a UI and not by manually writing every filter.
/routing filter
add chain=dynamic-in distance=1 set-check-gateway=ping set-distance=1
v7 does not have equivalent to dynamic-in and connected-in chains.
Somewhat OT: I’m not trying to diminish the problems you’re dealing with (and I really hope MT puts some effort into fixing it), but BGP was basically designed for routing between autonomous systems (i.e, external routing). For non-ISP networking, I personally prefer OSPF in most cases because of its simplicity and fast convergence.I agree, but I also want to stress that loading 4 full tables on an internet border gateway is not the only use-case for BGP.
Absolutely. Similar to what you described, we are using BGP inside our network to manage routing btw. different sites and locations.I agree, but I also want to stress that loading 4 full tables on an internet border gateway is not the only use-case for BGP.
I almost don't want to report this... But noticed "cloud" or "file-share" are not selectable in device-mode. If the whole of idea was minimizing the attack surface, we're already off to some inconsistency ;).Because this time with device-mode s–t no one want lock his devices, so less persons than before do tests...
/system/device-mode/print
mode: advanced
allowed-versions: 7.13+,6.49.8+
flagged: no
flagging-enabled: yes
scheduler: yes
socks: yes
fetch: yes
pptp: yes
l2tp: yes
bandwidth-test: yes
traffic-gen: no
sniffer: yes
ipsec: yes
romon: yes
proxy: yes
hotspot: yes
smb: yes
email: yes
zerotier: yes
container: yes
install-any-version: no
partitions: no
routerboard: no
attempt-count: 0
Maybe (or not) it's related to the issue I reported on the 7.16 release thread.I am just reporting that route table retrieval via SNMP is broken, not looking for alternative solutions.
It happened again on v7.18b1.I too have issues after 7.16 with BGP/routing.
Not the ones you describe, but since v7.16 there were multiple instances on multiple routers that the routing process would take up 100% CPU (single core) and the logs would get repeated errors about SNMP timeouts. Only reboot would resolve that.
> /log/print where message ~ "SNMP"
2025-01-28 23:26:08 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-28 23:41:08 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-28 23:56:08 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-29 00:11:09 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-29 00:26:09 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-29 00:38:53 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-29 00:51:07 snmp,warning SNMP did not get OID data within expected time, ignoring OID
2025-01-29 01:06:07 snmp,warning SNMP did not get OID data within expected time, ignoring OID
> /system/resource/cpu/print
Columns: CPU, LOAD, IRQ, DISK
# CPU LOAD IRQ DISK
0 cpu0 3% 1% 0%
1 cpu1 0% 0% 0%
2 cpu2 1% 0% 0%
3 cpu3 100% 0% 0%
> /tool/profile cpu=3 duration=10
Columns: NAME, CPU, USAGE
NAME CPU USAGE
networking 3 0%
management 3 0%
ethernet 3 0%
routing 3 95.5%
firewall 3 0.5%
chacha_neon 3 0%
poly1305_neon 3 0%
udp_tunnel 3 0%
cpu3 96%
> /ip route/print
action timed out - try again, if error continues contact MikroTik support and send a supout file (13)
Error: OID not increasing: iso.3.6.1.2.1.9999.1.1.6.4.1.4.10.26.37.2
>= iso.3.6.1.2.1.9999.1.1.6.4.1.4.10.26.35.3
I know XORP passed through those several choices.Yes, that is correct. Ever since v4, RouterOS uses their own proprietary BGP implementation.
I don't know about the BGP itself (although I got the impression that both v6 and v7 used proprietary code for this)
During the v2 era they used Quagga. If I recall correctly, their own implementation (routing-test package at the time) appeared in the last versions of 2.9.x. and lasted as a test package until the end of v3.
(Don't quote me on the versions above - it's been 15-20 years so my memory may be a little fuzzy on the numbers).
During v2-v3 there was a community way ("MikroLinux") to install quagga, bypassing the then buggy version of quagga used.
We were also able to install OLSR, BIND, PHP, Perl, and other custom packages.
Then on v3.23 (if I recall correctly) they changed the packages format to signed ones, ending this custom packages era.
Then I think on v5.26 there was another hack that added apt to x86 installations allowing to install almost any package you wanted. I used this mainly to run HAproxy. Pretty useful!
I wish they still used Quagga (or FRR nowadays) with the awesome UI and filtering of v6. We would have way more features, more stability and a great way to manage BGP and especially filters with a UI and not by manually writing every filter.
Indeed, router must be properly build and maintain a valid BGP table from them in every single AFI/SAFI, and moving selected routes to the proper RIB/FIB. Unless this, CCR2x16 is only a shiny expensive home gateway, or I don't know what market did they targeted with that. Maybe it hasn't been decided yet?I agree, but I also want to stress that loading 4 full tables on an internet border gateway is not the only use-case for BGP.
+1Just wanted to pop in here and say a big thank you to the MikroTik team implementing Fast Track for IPv6
I agree with complaint about "cloud" not being selectable in device mode ... and it should be disabled by default just like many other (more usable) options ;-)I almost don't want to report this... But noticed "cloud" or "file-share" are not selectable in device-mode.Because this time with device-mode s–t no one want lock his devices, so less persons than before do tests...
Just checked at work with other wifi vendor and phone roams fine, so its again problem mikrotik side it seams..*) wifi - try to authenticate client as non-FT client if it provides incomplete set of FT parameters;Just got Samsung s25 ultra and it doesnt want to roam(Older s23 roamed just fine), i get this in log.
Is this related to 7.18 or something else i never saw such message?Code: Select all@Glavni_5GHz association rejected, FTE indicated that STA uses RSNXE, but RSNXE was not included.
…a valid BGP table from them in every single AFI/SAFI…
This message already existed before. Even before the wifi driver update so many people have trouble with (7.15+).Just got Samsung s25 ultra and it doesnt want to roam(Older s23 roamed just fine), i get this in log.
Is this related to 7.18 or something else i never saw such message?Code: Select all@Glavni_5GHz association rejected, FTE indicated that STA uses RSNXE, but RSNXE was not included.
Well if I configured them :)…a valid BGP table from them in every single AFI/SAFI…
All SAFIs? Well, then you’re in for a long wait! 😉
Not saying it's not already ... but defconf is only applied when device is reset to factory defaults (where "factory" part is a bit misleading because it's not config applied in factory when manufacturing device, it's config set as default in any particular ROS version).Please add fasttrack ipv6 in defconf
Where do you hurry? A fresh feature is not mature enough to be enabled by default.Please add fasttrack ipv6 in defconf
Not All AFI/SAFI, just the basic that is expected in a ISP/Telco environment recognizing that Underlay and Overlay exists and needs to be on different scopes.…a valid BGP table from them in every single AFI/SAFI…
All SAFIs? Well, then you’re in for a long wait! 😉
I think your 100% CPU problem can well be caused by that. In my network it is reproducible that an SNMP walk of the route table results in an endless loop, when you use standard tools like "snmpnetstat -v2c -c public -Cn -Cr x.x.x.x" they will just keep spitting out the same route entry forever, probably tying up the process.I believe the snmp error about OID not increasing was occurring a few releases back when snmp routes support was first introduced.
Rerunning snmpwalk got stuck and eventually timed out, and rerunning it again it returned the same error.
This router and others that have had this behavior are being monitored by LibreNMS via SNMP so I guess there's something in the SNMP/routing that causes this issue.
Other routers that are not being monitored via SNMP haven't exhibited this bug.
I am still hoping for a solution where defconf for the firewall can be applied to an existing router... some command that removes the firewall config and reloads it from defconf, if only as a commandline script.Not saying it's not already ... but defconf is only applied when device is reset to factory defaults (where "factory" part is a bit misleading because it's not config applied in factory when manufacturing device, it's config set as default in any particular ROS version).Please add fasttrack ipv6 in defconf
...a valid BGP table from them in every single AFI/SAFI...
Seizing the AFI/SAFI theme, I remembered the lack of support due to BGP Flow Spec in RouterOS, I decided to bring back to the table the suggestion of hook-events.All SAFIs?
If RouterOS would exposed a bit more what happens in the backyard trought Hooks for almos any event, user could solve their own problems with scripting without depending so much of development of MikroTik.BGP Flowspec
An example of how an advanced hook action to a Script would be useful is to allow users to implement their own BGP Flowspec rules themselves.
As far as I can imagine, if today there were a { [actions] } in /routing/filter/rule that allowed a call to a script where the debug.fwp-ptr attribute was passed as one of the call arguments of the script, it would be possible to create a set of scripts in which you could create dynamic entries in /ip/firewall/filter/ and /ip/firewall/raw/ to then have very similar results to the BGP Flow Spec protocol.
IMO volume sales are with users needing easy to manage reliable network performance value.... As I see there are two type of MTik users. Ones likes playing with new features and the others would likes to serve customers with existing features in a stable environment. Not so easy to make happy both types of users.
I think device-mode was a knee-jerk reaction to some bad publicity about MikroTik routers being compromised and then used to generate insane amounts of traffic.But noticed "cloud" or "file-share" are not selectable in device-mode. If the whole of idea was minimizing the attack surface, we're already off to some inconsistency ;).
It's actually a downprovementI think the whole device-mode thing is more theater than actual improvement
So far none of changes in firewall defconf was ever applied when upgrading ROS. So I don't see this one coming either. Messing with FW rules has huge potential to screw things up behind user's back. E.g. if somebody has some mangle rules ... which would fail completely after some ROS upgrade would enable fasttrack. And, mind you, most users (even many of members of this forum) don't read list of changes, let alone some discussions or articles on the web.I am still hoping for a solution where defconf for the firewall can be applied to an existing router... some command that removes the firewall config and reloads it from defconf, if only as a commandline script.
Not saying it's not already ... but defconf is only applied when device is reset to factory defaults (where "factory" part is a bit misleading because it's not config applied in factory when manufacturing device, it's config set as default in any particular ROS version).