QuickSet works fine in latest versions. But since some routers come with older versions, some older versions on some devices did have bugs. Specifically one where if you changed the IP address and DHCP range, it only pick up the IP address, and set the /ip/dhcp-server/network to be 0.0.0.0/0. You could work around this by just setting the DHCP range again after doing an Apply on the IP address before hitting OK - as once it knows the IP address, it will set DHCP right.
So I'd recommend connecting to router...
- do an upgrade to latest version (see docs)
- enabling auto-update in /system/routerboard to upgrade the "BIOS" to match RouterOS version(see docs)
- reboot to install any RouterOS software upgrade
- reboot a 2nd time install any RouterOS fireware
- then...do a /system/reset-configuration keep-users=yes
- finally... QuickSet should work
But that is a lot. The last reset-configuration is because the default configuration can change between releases. And QuickSet internally make some assumption about the configuration loaded — so a newer version's QuickSet, may not work with an older version's default configuration. So if you just upgraded, without reset-configuration... you may end up with some oddities in how QuickSet works because of the version mismatch.
If ANY of this does not align, then you're open to bugs in what should be the simple setup process....
Now eventually the new factory unit (and ones on dealer/distrubutors shelves...) will come with version without the QuickSet 0.0.0.0 bug.
Seriously, I don't know what the admin-mac is or what it is used for.
I read some of the threads, faithfully staying in my 20-40% comprehension level, and I see that it is, by default, set to the same mac-address as the lowest numbered eth port, and that there might be a problem is/when restoring from an rsc. That's the extent of my understanding.
If auto-mac is enabled, it's lowest MAC address NOT lowest port number. So with auto-mac things like VETH/etc might become the MAC address used by bridge with auto-mac=yes.
Since it's better if the bridge's MAC is stable... The default configuration (as applied by /system/reset-configuration or on any factory device) will actually search for lowest ethernet in bridge, but then set that as that "static" MAC of bridge & disable the "lowest MAC" auto-mac=no. So that logic is not automatic.
But if you start messing with bridge ports, you can accidentally have a wrong admin-mac, i.e. if you remove something like ether2 from /bridge/port as that normally be the first ethernet port in bridge at defaults, but the act of remove it would not change /interface/bridge's admin-mac automatically - that the "lowest ethernet port" rule is applied when the defaults are applied so only once.
For reference, docs on bridge (
https://help.mikrotik.com/docs/spaces/R ... +Switching) say:
By default, bridge MAC address will be chosen automatically, depending on the bridge port configuration. To avoid unwanted MAC address changes, it is recommended to disable "auto-mac" and manually specifying the MAC address by using "admin-mac".
But the default configs,, generally, does something like this:
/interface bridge
add name=bridge disabled=no auto-mac=yes protocol-mode=rstp comment=defconf;
:local bMACIsSet 0;
:foreach k in=[/interface find where !(slave=yes || name="ether1" || passthrough=yes || name="ether1" || name~"bridge")] do={
:local tmpPortName [/interface get $k name];
:if ($bMACIsSet = 0) do={
:if ([/interface get $k type] = "ether") do={
/interface bridge set "bridge" auto-mac=no admin-mac=[/interface get $tmpPortName mac-address];
:set bMACIsSet 1;
}
}
:if (([/interface get $k type] != "ppp-out") && ([/interface get $k type] != "lte")) do={
/interface bridge port
add bridge=bridge interface=$tmpPortName comment=defconf;
}
}
(from:
https://help.mikrotik.com/docs/spaces/R ... s-APRouter )
And while that logic is same for likely a decade. There are other subtle changes to the default configuration over the various version – why re-apply the latest one from latest stable version at install time is BETTER than doing anything with the factory installed one. Since you'd be missing out on an improvements (or bug fixes) in these defaults.