{ /ipv6 fire filter remove [find where comment="defconf: fasttrack6"] add chain=forward action=fasttrack-connection connection-state=established,related comment="defconf: fasttrack6" :local idone [find where comment="defconf: fasttrack6"] :local idtwo [find where comment="defconf: accept established,related,untracked" and chain=forward] :put $idone :put $idtwo move $idone destination=$idtwo }For full default firewall rules:
ip-service - show all TCP/UDP connections on the system;
ip-service - show all TCP/UDP ports on system, including ports in containers;
route - added options to set dynamic-in and connected-in chains in /routing/settings;
[rchan@Home] > /routing/settings/set dynamic-in-chain="dynamic-in"
[rchan@Home] > /routing filter rule
add chain=dynamic-in disabled=no rule="set comment \"test\"; accept;"
You are not supposed to save your backup in flash memory! That normally is useless anyway.will measures be taken to increase free space on 16mb devices? hardly enough space to save a backup!
Is this related to spikes in CPU due to "mvpp2" and "management" processes in any way? Or is it something else unrelated?*) bridge - improved stability in case of configuration error (introduced in v7.15);
> /system/resource/cpu/print
Columns: CPU, LOAD, IRQ, DISK
# CPU LOAD IRQ DISK
0 cpu0 71% 1% 0%
1 cpu1 76% 0% 0%
2 cpu2 76% 1% 0%
3 cpu3 85% 1% 0%
> /tool/profile duration=10 cpu=total
Columns: NAME, USAGE
NAME USAGE
networking 3.6%
management 4.2%
winbox 0%
ethernet 0.3%
logging 0%
console 0.6%
crypto 0%
routing 69.6%
queuing 0.2%
firewall 0.1%
profiling 0%
kernel 0.8%
chacha_neon 0%
poly1305_arm 0%
libchacha20poly1305 0%
8021q 0%
total 79.4%
Can we also get ability to specify address-list to which IP address will be added once client is bound? It would greatly simplify NAT rules with dual-WAN setups when hairpin mangling is required.*) dhcpv4/v6-client - added check-gateway parameter;
*) arp - added warning, when "Published" ARP entry used on an interface with "reply-only" ARP mode enabled;
*) bonding - added setting for LACP active/passive modes;
*) bridge - added new STP monitoring fields for bridge and ports (Tx/Rx BPDU, Tx/Rx TC, forward/discard transitions, last topology change, message-age, max-age, remaining-hops, bridge-id);
*) bridge - fixed bridge port hang when using invalid port IDs;
*) bridge - fixed dhcp-snooping in QinQ setups;
*) bridge - fixed minor memory leak on link down;
*) bridge - fixed multicast packet flow on hardware offloaded bridge which acts as "multicast-router";
*) bridge - improved default bridge and port layout on console and GUI;
*) bridge - improved stability in case of configuration error (introduced in v7.15);
*) bridge - moved "TCHANGE" logs from bridge,stp to bridge,stp,debug;
*) bridge - rename "ports" to "interface" under MDB table for configuration consistency with other menus;
*) bridge - renamed STP monitor fields (port-number to port-id, designated-port-number to designated-port-id, designated-bridge to designated-bridge-id);
*) bridge - show designated-* monitor field for all port roles;
*) bridge - show warning instead of causing error when using multicast MAC as admin-mac (introduced in v7.17);
*) dot1x - fixed dynamic switch ACL rules on boards with a lot of ports (e.g. CRS520);
*) l3hw - remove VLAN tag before VXLAN encapsulation (fixes pvid behavior for bridged VXLAN);
*) switch - do not count rx-too-long multiple times on 100Gbps QSFP28;
*) switch - fixed egress mirroring for packets coming from external CPU port (e.g. CRS520, CCR2216, CCR2116);
*) switch - flush CPU port FDB entries on switch disable;
*) switch - improve rate limit accuracy for MT7531, MT7621, EN7562CT;
*) switch - improved boot stability on devices with Alpine CPU and switch chip;
*) switch - improved stability when enabling IGMP snooping with VXLAN (introduced in v7.18);
The naming of things and how bridges in RouterOS are implemented aligns with how the Linux kernel bridge implementation does things.Compared to other vendors and even to the standards, the bridge implementations, the nomenclature, and etc, were so weird!
*) route - make AFI naming consistent;
[admin@test] > /routing/bgp/connection/print where afi=
ip ipv6 l2vpn l2vpn-cisco vpnv4 vpnv6
[admin@test] > /routing/route/find where afi=
bad ip ipv6 l2vpn l2vpn-cisco l2vpn-link link mip4 mip6 vpnv4 vpnv6
Please correct hlen to 0 for htype 8 (and other networks without MAC). It should solve the problem SUP-115093 (closed without solution).*) dhcpv4-server - accept packets with htype 6;
Did a netinstall on a brand new RB5009, manually reconfigured everything the same as the RB4011 (did not restore a backup) and after putting it to work, same behavior. 70% CPU usage over all 4 cores, eaten by "routing" process.Routing is getting from bad to worse with each version.
70% total CPU usage (across 4 CPU cores) by "routing" process, right after upgrading to 7.19b2.
Router (RB4011) has 8 BGP peers, and ~3000 routes and practically zero traffic (1-2mbps).
Code: Select all> /system/resource/cpu/print Columns: CPU, LOAD, IRQ, DISK # CPU LOAD IRQ DISK 0 cpu0 71% 1% 0% 1 cpu1 76% 0% 0% 2 cpu2 76% 1% 0% 3 cpu3 85% 1% 0%
Code: Select all> /tool/profile duration=10 cpu=total Columns: NAME, USAGE NAME USAGE networking 3.6% management 4.2% winbox 0% ethernet 0.3% logging 0% console 0.6% crypto 0% routing 69.6% queuing 0.2% firewall 0.1% profiling 0% kernel 0.8% chacha_neon 0% poly1305_arm 0% libchacha20poly1305 0% 8021q 0% total 79.4%
This is great! It's the small things like this that do help. Really like it includes containers too.*) ip-service - show all TCP/UDP connections on the system;
*) ip-service - show all TCP/UDP ports on system, including ports in containers;
*) ip-service - show error message when service enable fails;
Y'all should probably include the CA's used by common DoH DNS providers... Or maybe they are not used by DoH yet, because I tried to enable "Verify SSL Certificate", but that didn't work with Cloudflare, Google, nor Quad9. But assuming it work for DoH, users can avoid the search for right Cloudflare/etc certs while still enabling SSL checks.*) certificate - added built-in root certificate authorities store;
I have a tool that diff the "command schema" between version... so you see the starting point for Wi-Fi Easy Connect (had to lookup "dpp", https://www.wi-fi.org/discover-wi-fi/wi-fi-easy-connect) FWIW:Wow, awesome what you can read between the lines.
wifi: {
add: {
security.authentication-types: {
- desc: "wpa-psk|wpa2-psk|wpa-eap|wpa2-eap|wpa3-psk|owe|wpa3-eap|wpa3-eap-192[,SecurityAuthenticationTypes*]"
+ desc: "wpa-psk|wpa2-psk|wpa-eap|wpa2-eap|wpa3-psk|owe|wpa3-eap|wpa3-eap-192|dpp[,SecurityAuthenticationTypes*]"
}
}
Yes! I agree! This is great!This is great! It's the small things like this that do help. Really like it includes containers too.*) ip-service - show all TCP/UDP connections on the system;
*) ip-service - show all TCP/UDP ports on system, including ports in containers;
*) ip-service - show error message when service enable fails;
Only tiny grip be the "protocol" column should be after the port in the default column
This ideia of adding default CAs could be just a "smart button" that triggers some internal script that downloads and installs the actual sets of CA certificate.Y'all should probably include the CA's used by common DoH DNS providers... Or maybe they are not used by DoH yet, because I tried to enable "Verify SSL Certificate", but that didn't work with Cloudflare, Google, nor Quad9. But assuming it work for DoH, users can avoid the search for right Cloudflare/etc certs while still enabling SSL checks.*) certificate - added built-in root certificate authorities store;
IMO having default certs seems like a good idea. And I'm sure some will disagree, and be suggesting !) for this one... since it does change the decade+ long scheme that user always add their root certs.
Also, the root certificate list should be in winbox. I found them via CLI which show them at "/certificate/builtin/print". Over time, I'd imagine the check-certificate=yes in various places could default =yes.
[rchan@Home] > /routing/settings/set dynamic-in-chain="dynamic-in"
[rchan@Home] > /routing filter rule
add chain=dynamic-in disabled=no rule="set comment \"test\"; accept;"
If the idea of reviewing the consistency of OSPF terminology follows the same logic as what happened with the Bridge part(triggered by a new protocol that interacts with it, EVPN in Bridge case).While you are focusing on fixing inconsistency’s you should change the OSPF “LSA” tab to “LSDB” or “Database” since that’s what it is. A link state database.
I know it’s been named like that for awhile but I believe changing it for accuracy is better than leaving it for historical reasons.
classic. My experience with "/undo" basically.didnt help
I can confirm it doesn't work and the scope of the issue can simply be narrowed to ECMP with L4 or L3-Inner isn't working with fasttracking enabled. In my tests, it doesn't matter if you use routing marks via mangle or routing rules.ECMP with L4 multipath hashing AND PCC routing marks are currently incompatible with FASTTRACKing...? hope it can be fixed soon...!
We either set hashing to l3 , OR disable fasttrack... Could it be inspected please? I created "bug" ticket on support portal...
I'm giving it a try by only setting reselect-time, will keep you (and others) posted.channel.reselect-time=01:00 can be used in conjunction with reselect-interval=7d to scan channels at 1am every 7days?
Nice, no more workarounds with script!*) dhcpv4/v6-client - added check-gateway parameter;
Was working before?I can confirm it doesn't work and the scope of the issue can simply be narrowed to ECMP with L4 or L3-Inner isn't working with fasttracking enabled. In my tests, it doesn't matter if you use routing marks via mangle or routing rules.
There was no zerotier present on that wAP to begin with, so why should it be there ?0x17e0d0 manual upgrade request failed, no file (zerotier-7.19beta2-arm.npk)
So many moves on Bridging, Switching, ARP, and other very fundamental layers.
I think(I hope) this can be happening for a good reason!
Compared to other vendors and even to the standards, the bridge implementations, the nomenclature, and etc, were so weird!
"Ask and it will be given to you" :) /Matthew 7:7/*) route - make AFI naming consistent;Viva! Hurrah!Code: Select all[admin@test] > /routing/bgp/connection/print where afi= ip ipv6 l2vpn l2vpn-cisco vpnv4 vpnv6 [admin@test] > /routing/route/find where afi= bad ip ipv6 l2vpn l2vpn-cisco l2vpn-link link mip4 mip6 vpnv4 vpnv6
They listened...
Thank you!
There is no information in the logs. It is unclear whether there is an attempt to select another channel or not.wifi - add channel.reselect-time parameter which allows to perform channel re-sellection at given time of day (CLI only);
sorry for late replyhow to undo this?
i was playing around , and i want to bring it to how it was, without /routing filter rule
/routing/settings/set dynamic-in-chain=""
Problem is still there. New one "no existing binding found, won't create" come up as well.*) dhcpv6-server - fix when expired static binding is declined with false "binding belogs to another server" reason;
Mar/01/2025 23:40:16 dhcp,debug,packet recv server: <pppoe-user1> fe80::2 -> ff02::1:2
Mar/01/2025 23:40:16 dhcp,debug,packet type: renew
Mar/01/2025 23:40:16 dhcp,debug,packet transaction-id: a1d20b
Mar/01/2025 23:40:16 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Mar/01/2025 23:40:16 dhcp,debug,packet -> serverid: 00030001 005056bf 358d
Mar/01/2025 23:40:16 dhcp,debug,packet -> oro: 23
Mar/01/2025 23:40:16 dhcp,debug,packet -> elapsed_time: 314
Mar/01/2025 23:40:16 dhcp,debug,packet -> ia_pd:
Mar/01/2025 23:40:16 dhcp,debug,packet t1: 1800
Mar/01/2025 23:40:16 dhcp,debug,packet t2: 2880
Mar/01/2025 23:40:16 dhcp,debug,packet id: 0x2
Mar/01/2025 23:40:16 dhcp,debug,packet -> ia_prefix:
Mar/01/2025 23:40:16 dhcp,debug,packet prefix: XXXX:XXXX:3:3001::/64
Mar/01/2025 23:40:16 dhcp,debug,packet valid time: 3600
Mar/01/2025 23:40:16 dhcp,debug,packet pref. time: 2880
Mar/01/2025 23:40:16 dhcp,debug processing client:005056bf3ea9 iapd:0x2, binding exists, binding belongs to another server
Mar/01/2025 23:40:16 dhcp,debug,packet send <pppoe-user1> -> fe80::2%35
Mar/01/2025 23:40:16 dhcp,debug,packet type: reply
Mar/01/2025 23:40:16 dhcp,debug,packet transaction-id: a1d20b
Mar/01/2025 23:40:16 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Mar/01/2025 23:40:16 dhcp,debug,packet -> serverid: 00030001 005056bf 358d
Mar/01/2025 23:40:16 dhcp,debug,packet -> dns_servers:
Mar/01/2025 23:40:16 dhcp,debug,packet XXXX:XXXX:0:10::10
Mar/01/2025 23:40:16 dhcp,debug,packet XXXX:XXXX:0:10::11
Mar/01/2025 23:40:16 dhcp,debug,packet -> ia_pd:
Mar/01/2025 23:40:16 dhcp,debug,packet t1: 43200
Mar/01/2025 23:40:16 dhcp,debug,packet t2: 69120
Mar/01/2025 23:40:16 dhcp,debug,packet id: 0x2
Mar/01/2025 23:40:16 dhcp,debug,packet -> ia_prefix:
Mar/01/2025 23:40:16 dhcp,debug,packet prefix: XXXX:XXXX:3:3001::/64
Mar/01/2025 23:40:16 dhcp,debug,packet valid time: 0
Mar/01/2025 23:40:16 dhcp,debug,packet pref. time: 0
====================================================================================================================
Mar/02/2025 09:41:50 dhcp,debug processing client:005056bf3ea9 iapd:0x2, no existing binding found, won't create
Mar/02/2025 09:41:50 dhcp,debug,packet send <pppoe-user3> -> fe80::10e6:78c6:0:2%22
Mar/02/2025 09:41:50 dhcp,debug,packet type: reply
Mar/02/2025 09:41:50 dhcp,debug,packet transaction-id: 61a941
Mar/02/2025 09:41:50 dhcp,debug,packet -> clientid: 00030001 005056bf 3ea9
Mar/02/2025 09:41:50 dhcp,debug,packet -> serverid: 00030001 005056bf 358d
Mar/02/2025 09:41:50 dhcp,debug,packet -> rapid_commit: [empty]
Mar/02/2025 09:41:50 dhcp,debug,packet -> dns_servers:
Mar/02/2025 09:41:50 dhcp,debug,packet XXXX:XXXX:0:10::10
Mar/02/2025 09:41:50 dhcp,debug,packet XXXX:XXXX:0:10::11
Mar/02/2025 09:41:50 dhcp,debug,packet -> ia_pd:
Mar/02/2025 09:41:50 dhcp,debug,packet t1: 43200
Mar/02/2025 09:41:50 dhcp,debug,packet t2: 69120
Mar/02/2025 09:41:50 dhcp,debug,packet id: 0x2
Mar/02/2025 09:41:50 dhcp,debug,packet -> status: 6 - no prefix
/routing/settings/set dynamic-in-chain=""
I'm glad you asked. I missed that one in my first reading. That's another great one for me, so thank Mikrotik. I've complained intermittently about since 7.0beta about this one. Late is better than never.Similarly two questions
What do the following mean.
*) route - added options to set dynamic-in and connected-in chains in /routing/settings;
/routing filter rule add chain=setcheckgw disabled=no rule="if ( afi ipv4 ) { set gw-check icmp; accept }"
/routing settings set dynamic-in-chain=setcheckgw
That's much too low for adlist. Try something like this:I would once again like to point out DNS Adlist weird behaviour, as I am considering it being a bug.
After the router reboot, I can find the following log entries:
- [adlist] adlist read: max cache size reached
- cache full, not storing [ignoring repeated messages]
I have my cache size set to 4096 and even with an under 500 entries, it is almost full. The thing is, that I have an entry in the Adlist section, but - it is greayed out / disabled. My suspicion is, that ROS still might update the list in the background? What is the Pause button for?
Disabled, means disabled imo. It should definitely be removed from the memory, but it does not seems so. Only once I delete the Adlist URL entry, it gets removed. In my book, this is clearly a bug - if I disable the feature, it should not occupy the memory anymore. At least not after the reboot / DNS cache flush?
His point was to demonstrate that disabled Adlist entry still seem to consume cache, when it should not.That's much too low for adlist. Try something like this
Yep, channel changed over night. So reselect-time has an implicit reselect-interval of 24h.I'm giving it a try by only setting reselect-time, will keep you (and others) posted.channel.reselect-time=01:00 can be used in conjunction with reselect-interval=7d to scan channels at 1am every 7days?
*) wifi - add channel.reselect-time parameter which allows to perform channel re-sellection at given time of day (CLI only);
Configuring these parameters via the command line allows you to do even that:As "reselect-interval=2h" while having "reselect-time=01:00" would be complete nonsense.
reselect-interval=8h..12h reselect-time=08:00:00..09:00:00
When updating from an older version of RouterOS, built-in root certificates are not trusted and cannot be used for certificate verification.This is great! It's the small things like this that do help. Really like it includes containers too.*) ip-service - show all TCP/UDP connections on the system;
*) ip-service - show all TCP/UDP ports on system, including ports in containers;
*) ip-service - show error message when service enable fails;
Only tiny gripe be the "protocol" column should be after the port in the default column layout.
Y'all should probably include the CA's used by common DoH DNS providers... Or maybe they are not used by DoH yet, because I tried to enable "Verify SSL Certificate", but that didn't work with Cloudflare, Google, nor Quad9. But assuming it work for DoH, users can avoid the search for right Cloudflare/etc certs while still enabling SSL checks.*) certificate - added built-in root certificate authorities store;
IMO having default certs seems like a good idea. And I'm sure some will disagree, and be suggesting !) for this one... since it does change the decade+ long scheme that user always add their root certs.
Also, the root certificate list should be in winbox. I found them via CLI which show them at "/certificate/builtin/print". Over time, I'd imagine the check-certificate=yes in various places could default =yes.
/certificate/settings/set builtin-trust-anchors=trusted
ovpn_mgmt: terminating... - TLS error: ssl: no trusted CA certificate found (6)
FWIW, Mikrotik added docs to help on this one: https://help.mikrotik.com/docs/spaces/R ... uthoritiesY'all should probably include the CA's used by common DoH DNS providers... Or maybe they are not used by DoH yet, because I tried to enable "Verify SSL Certificate", but that didn't work with Cloudflare, Google, nor Quad9. [...]*) certificate - added built-in root certificate authorities store;
/certificate/settings/set builtin-trust-anchors=trusted
The issue may be due to DHCP snooping as described by @TrevinLC1997 and @lurker888.Upgrading to this version completely breaks routing on my RB5009 from my LAN's side. Every packet towards the router seems to get dropped, thus I can't access the config with winbox anymore. [...] the device still connects to the internet, and replies to ping from WAN. [...] I can also access the config from the external device. [...] this problem is somehow bridge related? [...]
I isolated the issue to BFD. When enabled it causes high CPU usage.Did a netinstall on a brand new RB5009, manually reconfigured everything the same as the RB4011 (did not restore a backup) and after putting it to work, same behavior. 70% CPU usage over all 4 cores, eaten by "routing" process.Routing is getting from bad to worse with each version.
70% total CPU usage (across 4 CPU cores) by "routing" process, right after upgrading to 7.19b2.
Router (RB4011) has 8 BGP peers, and ~3000 routes and practically zero traffic (1-2mbps).
Code: Select all> /system/resource/cpu/print Columns: CPU, LOAD, IRQ, DISK # CPU LOAD IRQ DISK 0 cpu0 71% 1% 0% 1 cpu1 76% 0% 0% 2 cpu2 76% 1% 0% 3 cpu3 85% 1% 0%
Code: Select all> /tool/profile duration=10 cpu=total Columns: NAME, USAGE NAME USAGE networking 3.6% management 4.2% winbox 0% ethernet 0.3% logging 0% console 0.6% crypto 0% routing 69.6% queuing 0.2% firewall 0.1% profiling 0% kernel 0.8% chacha_neon 0% poly1305_arm 0% libchacha20poly1305 0% 8021q 0% total 79.4%
The setup is 8 BGP peers with BFD enabled, over 8 Wireguard tunnels.
What parameters do you use for BFD?I isolated the issue to BFD. When enabled it causes high CPU usage.
I experience the issue on multiple routers and I set up a new router with empty configuration with just BGP + BFD and the issue still occurs.
I reported the bug on ticket #SUP-181114
What are you looking for?When I see new feature about EAP identity in registration table... how hard will be for devs to add channel utilization stats? I would like to see it in CAPsMAN, it will be very usefull.
Hey! I have to thank the MikroTik team for "isis" vs IS-IS" too!"Ask and it will be given to you" :) /Matthew 7:7/
Viva! Hurrah!Code: Select all[admin@test] > /routing/bgp/connection/print where afi= ip ipv6 l2vpn l2vpn-cisco vpnv4 vpnv6 [admin@test] > /routing/route/find where afi= bad ip ipv6 l2vpn l2vpn-cisco l2vpn-link link mip4 mip6 vpnv4 vpnv6
They listened...
Thank you!
*) route - make AFI naming consistent;
[admin@test] > /routing/isis/instance/print
Flags: X - disabled, I - inactive
[admin@test] > /routing/route/print where isis
That a router adjusts its time after reboot when it gets the correct time trough a NTP server is from me an informational message.2025-03-05T11:31:21.363+0000 RB2011-test CEF:0|MikroTik|RB2011iLS|7.19beta2 (testing)|10|system,critical,info|Very-High|dvchost=RB2011-test msg=serial\=xxxx MikroTik: cloud change time Mar/05/2025 11:30:58 \=> Mar/05/2025 11:31:21
Well, actually a change of time-of-day is a very critical event, but one could argue that in a device without built-in clock it could be labeled a little less severe when the time adjustment is forward, and less than 5 minutes.Critically of this action seems for me to be way to high. Exactly Very High :)
Well, actually a change of time-of-day is a very critical event, but one could argue that in a device without built-in clock it could be labeled a little less severe when the time adjustment is forward, and less than 5 minutes.
/queue type
add kind=cake name=queue1
/queue simple
add name=queue1 target="" total-queue=queue1
/queue tree
add name=queue1 parent=global queue=queue1
/queue type
remove [find where default=no]
Well, in your case it would have been valuable when you were warned because what happened is likely not what you intended!When upgrading my fleet from 7.17.2 to 7.18.1 ... I saw time jump of a few hours after reboot due to upgrade on one of devices. So the "after boot" time jump can be rather large. However I'd say that severity of first time jump (if caused by NTP client) after reboot can be down-tuned to informational ... regardless the size of time jump.
fs over remote protocol like sshfs and similar.Regarding file - improved responsiveness on slow filesystems;
Which filesystems exactly are considered as slow?
Well, in your case it would have been valuable when you were warned because what happened is likely not what you intended!
E.g. a device was powercycled without clean shutdown ...
That's no longer true. With recent versions you can not go before release build date.... netinstalled device will jump from 1.1.1970...
That's no longer true. With recent versions you can not go before release build date.... netinstalled device will jump from 1.1.1970...
What parameters do you use for BFD?I isolated the issue to BFD. When enabled it causes high CPU usage.
I experience the issue on multiple routers and I set up a new router with empty configuration with just BGP + BFD and the issue still occurs.
I reported the bug on ticket #SUP-181114
I have several routers using BFD, e.g. a CCR2004 with 14 peers 8 of them using BFD and at the moment 3 RB5009 with 5 peers of which 4 use BFD, and I do not experience that issue on 7.18.1 (I think you already had it in 7.18)
But I use a 1-second BFD interval, maybe you have 1 millisecond?
/routing bfd configuration
add disabled=no interfaces=all min-rx=200ms min-tx=200ms multiplier=5
You still have the same BGP problems on 7.19b2? Do you have a forum post listing them all? I also have BGP with stuck routes on 7.16.1 that drive me crazy.Ok I seemed to remember that you posted it has been a problem for a while...
But indeed there are several BGP problems and the silence from MikroTik is deafening...
However, on my routers (with 7.18 and 7.18.1) there is no CPU usage problem, only the issues I mentioned before.
The CPU issue is on v7.19beta2.Ok I seemed to remember that you posted it has been a problem for a while...
But indeed there are several BGP problems and the silence from MikroTik is deafening...
However, on my routers (with 7.18 and 7.18.1) there is no CPU usage problem, only the issues I mentioned before.
I have not installed 7.19b2 yet. It does not list a fix for any of my problems in the changes list.You still have the same BGP problems on 7.19b2? Do you have a forum post listing them all? I also have BGP with stuck routes on 7.16.1 that drive me crazy.
It means that something was seriously wrong. In a normal upgrade procedure, the new packages are installed and the device is cleanly rebooted. That includes closing the configuration database and setting its time to the current time.Well, in your case it would have been valuable when you were warned because what happened is likely not what you intended!
E.g. a device was powercycled without clean shutdown ...
Nope, device was cleanly rebooted due to ROS upgrade. I can't explain the few hours jump myself, usually it is, as everybody says, a few minutes.
pppoe-client and l2tp-client please. It's very helpful when a router have multiple ppp.*) dhcpv6-client - allow selecting to which routing tables add default route;
Great, step 2 after this new feature was already changed in 7.18(beta, rc) for the dhcp-v4-client !!
The last step will be to implement this in the PPPoE-Client as well :-)
Maybe in a 7.19beta3?? :-D
Certainly something to carefully look at and consider a netinstall!
Happened to me too, rolling back to 7.18.1I just tested 7.18.1 against 7.19beta2 and on the beta roaming is completely broken for me.
It didnt work A SINGLE time without disconnecting my client (aka my phone).
I opened a ticket for this SUP-180964
I upgraded from 7.18beta2 to 7.19beta: ... ROAMING is not working again!
/interface wifi channel add band=5ghz-ac disabled=no name=Home-5GHz-auto reselect-interval=1h..2h skip-dfs-channels=10min-cac width=20/40/80mhz
/interface wifi channel add band=2ghz-n disabled=no name=Home-2.4GHz-auto reselect-interval=1h..1h30m width=20/40mhz
/interface wifi channel add band=2ghz-ax disabled=no name=Home-2.4GHz-auto-AX reselect-interval=1h..1h30m width=20/40mhz
/interface wifi channel add band=5ghz-ax disabled=no name=Home-5GHz-auto-AX reselect-interval=1h..2h skip-dfs-channels=10min-cac width=20/40/80mhz
/interface wifi security add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=yes disabled=no encryption=ccmp ft=yes ft-over-ds=yes group-key-update=1h management-protection=allowed name=secur-Home passphrase=wifi_password wps=disable
/interface wifi steering add disabled=no name=steering-Home neighbor-group=NG-Home rrm=yes wnm=yes
/interface wifi configuration add chains=0,1 channel=Home-5GHz-auto country=Panama disabled=no dtim-period=3 mode=ap multicast-enhance=enabled name=Home-5ghz qos-classifier=priority security=secur-Home ssid=MikroAP steering=steering-Home tx-chains=0,1 tx-power=20
/interface wifi configuration add chains=0,1 channel=Home-2.4GHz-auto country=Panama disabled=no mode=ap multicast-enhance=enabled name=Home-2ghz qos-classifier=priority security=secur-Home ssid=MikroAP steering=steering-Home tx-chains=0,1 tx-power=10
/interface wifi configuration add chains=0,1 channel=Home-2.4GHz-auto-AX country=Panama disabled=no mode=ap multicast-enhance=enabled name=Home-2ghz-AX qos-classifier=dscp-high-3-bits security=secur-Home ssid=MikroAP steering=steering-Home tx-chains=0,1 tx-power=10
/interface wifi configuration add chains=0,1 channel=Home-5GHz-auto-AX country=Panama disabled=no dtim-period=3 mode=ap multicast-enhance=enabled name=Home-5ghz-AX qos-classifier=dscp-high-3-bits security=secur-Home ssid=MikroAP steering=steering-Home tx-chains=0,1 tx-power=20
-10dBm? Did you put your phone inside the AP or what? :D-10dB
For me this is working without problems:How to “correctly” use the “2g-probe-delay=yes” parameter is unclear. If I just add this parameter to the CAPsMAN settings I described above - everything breaks down. And roaming disappears.
/interface wifi steering
add 2g-probe-delay=yes disabled=no name=[My name redacted] neighbor-group=[My group redacted] rrm=yes wnm=yes
-10dBm? Did you put your phone inside the AP or what? :D
On version 7.19?
For me this is working without problems:
Code: Select all/interface wifi steering add 2g-probe-delay=yes disabled=no name=[My name redacted] neighbor-group=[My group redacted] rrm=yes wnm=yes
connect-priority=0/1 ft=yes ft-over-ds=yes
# 2025-03-06 17:34:36 by RouterOS 7.19beta2
# software id = ZQCL-RJAH
/interface wifi steering
add 2g-probe-delay=yes disabled=no name=steering_home neighbor-group=dynamic-rbhn-5cba8134 rrm=yes wnm=yes
add 2g-probe-delay=yes disabled=no name=steering_guests neighbor-group=dynamic-rbhn-guests-5cba8134 rrm=yes wnm=yes
add 2g-probe-delay=yes disabled=no name=steering_iot neighbor-group=dynamic-rbhn-iot-f1990f75 rrm=yes wnm=yes
/interface wifi datapath
add bridge=bridgeSwitch client-isolation=yes disabled=no name=datapath_guests vlan-id=111
add bridge=bridgeSwitch client-isolation=yes disabled=no name=datapath_iot vlan-id=112
add bridge=bridgeSwitch client-isolation=no disabled=no name=datapath_home vlan-id=110
/interface wifi security
add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=no disabled=no ft=yes ft-over-ds=yes management-protection=required name=security_home wps=disable
add authentication-types=wpa2-psk connect-priority=0/1 disable-pmkid=no disabled=no ft=yes ft-over-ds=yes management-protection=allowed name=security_guests wps=disable
add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=no disabled=no ft=yes ft-over-ds=yes management-protection=allowed name=security_iot wps=disable
/interface wifi configuration
add channel="channel_2G_40Ce_ch1(-1<>6)_f2412(2402-2442)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_2G_home_ch(-1<>6)" security=security_home ssid=rbhn
add channel="channel_2G_40eC_ch13(8<>14)_f2472(2442-2482)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_2G_home_ch(7<>14)" security=security_home ssid=rbhn
add channel="channel_5G_80_ch106(100<>112)_f5500(5490-5570)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_5G_home_ch(100<>112)" security=security_home ssid=rbhn
add channel="channel_5G_80_ch122(116<>128)_f5580(5570-5650)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_5G_home_ch(116<>128)" security=security_home ssid=rbhn
add channel="channel_5G_80_ch138(132<>144)_f5660(5650-5730)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_5G_home_ch(132<>144)" security=security_home ssid=rbhn
add datapath=datapath_guests disabled=no name="configWifi_2G_guests_ch(any)" security=security_guests ssid=rbhn-guests
add datapath=datapath_iot disabled=no name="configWifi_2G_iot_ch(any)" security=security_iot ssid=rbhn-iot
add datapath=datapath_guests disabled=no name="configWifi_5G_guests_ch(any)" security=security_guests ssid=rbhn-guests
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no identity-regexp=chr master-configuration="configWifi_2G_home_ch(-1<>6)" name-format=%I_wifi-2G slave-configurations="configWifi_2G_guests_ch(any),configWifi_2G_iot_ch(any)" supported-bands=2ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=lvr|bdr master-configuration="configWifi_2G_home_ch(7<>14)" name-format=%I_wifi-2G slave-configurations="configWifi_2G_guests_ch(any),configWifi_2G_iot_ch(any)" supported-bands=2ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=lvr master-configuration="configWifi_5G_home_ch(100<>112)" name-format=%I_wifi-5G slave-configurations="configWifi_5G_guests_ch(any)" supported-bands=5ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=chr master-configuration="configWifi_5G_home_ch(116<>128)" name-format=%I_wifi-5G slave-configurations="configWifi_5G_guests_ch(any)" supported-bands=5ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=bdr master-configuration="configWifi_5G_home_ch(132<>144)" name-format=%I_wifi-5G slave-configurations="configWifi_5G_guests_ch(any)" supported-bands=5ghz-ax
/interface wifi channel
add band=2ghz-ax disabled=no frequency=2412 name="channel_2G_40Ce_ch1(-1<>6)_f2412(2402-2442)" skip-dfs-channels=disabled width=20/40mhz-Ce
add band=2ghz-ax disabled=no frequency=2472 name="channel_2G_40eC_ch13(8<>14)_f2472(2442-2482)" skip-dfs-channels=disabled width=20/40mhz-eC
add band=5ghz-ax disabled=no frequency=5500 name="channel_5G_80_ch106(100<>112)_f5500(5490-5570)" skip-dfs-channels=disabled width=20/40/80mhz
add band=5ghz-ax disabled=no frequency=5580 name="channel_5G_80_ch122(116<>128)_f5580(5570-5650)" skip-dfs-channels=disabled width=20/40/80mhz
add band=5ghz-ax disabled=no frequency=5660 name="channel_5G_80_ch138(132<>144)_f5660(5650-5730)" skip-dfs-channels=disabled width=20/40/80mhz
interface/wifi/steering/neighbor-group> print
0 name="dynamic-rbhn-5cba8134" bssids=...,...,...
1 name="dynamic-rbhn-guests-5cba8134" bssids=...,...,...
2 name="dynamic-rbhn-iot-f1990f75" bssids=...,...,...
Sorry, typo, should be -20 ... maybe -22 to be precise ... fixed in my post above.-10dBm? Did you put your phone inside the AP or what? :D-10dB
Are you sure that you receive any packet/frame after step 1 on client devices from new AP?1. The client roams successfully
2. Then the MT disconnects my client.
3. After a few seconds the client reconnects to the AP it roamed to and everything works.
# 2025-03-06 17:34:36 by RouterOS 7.19beta2
# software id = ZQCL-RJAH
/interface wifi steering
add 2g-probe-delay=yes disabled=no name=steering_home neighbor-group=dynamic-rbhn-5cba8134 rrm=yes wnm=yes
add 2g-probe-delay=yes disabled=no name=steering_guests neighbor-group=dynamic-rbhn-guests-5cba8134 rrm=yes wnm=yes
add 2g-probe-delay=yes disabled=no name=steering_iot neighbor-group=dynamic-rbhn-iot-f1990f75 rrm=yes wnm=yes
/interface wifi datapath
add bridge=bridgeSwitch client-isolation=yes disabled=no name=datapath_guests vlan-id=111
add bridge=bridgeSwitch client-isolation=yes disabled=no name=datapath_iot vlan-id=112
add bridge=bridgeSwitch client-isolation=no disabled=no name=datapath_home vlan-id=110
/interface wifi security
add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=no disabled=no ft=yes ft-over-ds=yes management-protection=required name=security_home wps=disable
add authentication-types=wpa2-psk connect-priority=0/1 disable-pmkid=no disabled=no ft=yes ft-over-ds=yes management-protection=allowed name=security_guests wps=disable
add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=no disabled=no ft=yes ft-over-ds=yes management-protection=allowed name=security_iot wps=disable
/interface wifi configuration
add channel="channel_2G_40Ce_ch1(-1<>6)_f2412(2402-2442)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_2G_home_ch(-1<>6)" security=security_home ssid=rbhn
add channel="channel_2G_40eC_ch13(8<>14)_f2472(2442-2482)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_2G_home_ch(7<>14)" security=security_home ssid=rbhn
add channel="channel_5G_80_ch106(100<>112)_f5500(5490-5570)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_5G_home_ch(100<>112)" security=security_home ssid=rbhn
add channel="channel_5G_80_ch122(116<>128)_f5580(5570-5650)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_5G_home_ch(116<>128)" security=security_home ssid=rbhn
add channel="channel_5G_80_ch138(132<>144)_f5660(5650-5730)" country=Czech datapath=datapath_home disabled=no mode=ap name="configWifi_5G_home_ch(132<>144)" security=security_home ssid=rbhn
add datapath=datapath_guests disabled=no name="configWifi_2G_guests_ch(any)" security=security_guests ssid=rbhn-guests
add datapath=datapath_iot disabled=no name="configWifi_2G_iot_ch(any)" security=security_iot ssid=rbhn-iot
add datapath=datapath_guests disabled=no name="configWifi_5G_guests_ch(any)" security=security_guests ssid=rbhn-guests
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no identity-regexp=chr master-configuration="configWifi_2G_home_ch(-1<>6)" name-format=%I_wifi-2G slave-configurations="configWifi_2G_guests_ch(any),configWifi_2G_iot_ch(any)" supported-bands=2ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=lvr|bdr master-configuration="configWifi_2G_home_ch(7<>14)" name-format=%I_wifi-2G slave-configurations="configWifi_2G_guests_ch(any),configWifi_2G_iot_ch(any)" supported-bands=2ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=lvr master-configuration="configWifi_5G_home_ch(100<>112)" name-format=%I_wifi-5G slave-configurations="configWifi_5G_guests_ch(any)" supported-bands=5ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=chr master-configuration="configWifi_5G_home_ch(116<>128)" name-format=%I_wifi-5G slave-configurations="configWifi_5G_guests_ch(any)" supported-bands=5ghz-ax
add action=create-dynamic-enabled disabled=no identity-regexp=bdr master-configuration="configWifi_5G_home_ch(132<>144)" name-format=%I_wifi-5G slave-configurations="configWifi_5G_guests_ch(any)" supported-bands=5ghz-ax
/interface wifi channel
add band=2ghz-ax disabled=no frequency=2412 name="channel_2G_40Ce_ch1(-1<>6)_f2412(2402-2442)" skip-dfs-channels=disabled width=20/40mhz-Ce
add band=2ghz-ax disabled=no frequency=2472 name="channel_2G_40eC_ch13(8<>14)_f2472(2442-2482)" skip-dfs-channels=disabled width=20/40mhz-eC
add band=5ghz-ax disabled=no frequency=5500 name="channel_5G_80_ch106(100<>112)_f5500(5490-5570)" skip-dfs-channels=disabled width=20/40/80mhz
add band=5ghz-ax disabled=no frequency=5580 name="channel_5G_80_ch122(116<>128)_f5580(5570-5650)" skip-dfs-channels=disabled width=20/40/80mhz
add band=5ghz-ax disabled=no frequency=5660 name="channel_5G_80_ch138(132<>144)_f5660(5650-5730)" skip-dfs-channels=disabled width=20/40/80mhz
interface/wifi/steering/neighbor-group> print
0 name="dynamic-rbhn-5cba8134" bssids=...,...,...
1 name="dynamic-rbhn-guests-5cba8134" bssids=...,...,...
2 name="dynamic-rbhn-iot-f1990f75" bssids=...,...,...
disconnected, not responding, signal strength -57
disconnected, connection lost, signal strength -69
/interface wifi channel add disabled=no frequency=2412,2437,2462 name=CHAN-2G reselect-interval=4h..6h width=20mhz
/interface wifi channel add disabled=no frequency=5500,5260,5660 name=CHAN-5G-Beneden reselect-time=03:00:00 width=20/40/80mhz
/interface wifi channel add disabled=no frequency=5660,5260,5500 name=CHAN-5G-Boven reselect-time=03:15:00 width=20/40/80mhz
/interface wifi channel add disabled=no frequency=5580 name=CHAN-5G-Buiten reselect-time=03:30:00 width=20/40mhz
/interface wifi security add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=yes disabled=no ft=yes ft
-over-ds=yes group-encryption=ccmp group-key-update=1h management-protection=allowed name=MYSSID-PSK passphrase=REDACTED
/interface wifi steering add 2g-probe-delay=yes disabled=no name=MYSSID-steering neighbor-group=MYSSID rrm=yes wnm=yes
/interface wifi configuration add channel=CHAN-2G country=Netherlands disabled=no mode=ap name=
MYSSID-CONF-2G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering tx-power=9
/interface wifi configuration add channel=CHAN-5G-Boven country=Netherlands disabled=no mode=ap name=MYSSID-CONF-Boven-5G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering
/interface wifi configuration add channel=CHAN-5G-Beneden country=Netherlands disabled=no mode=ap name=MYSSID-CONF-Beneden-5G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering
/interface wifi configuration add channel=CHAN-5G-Buiten country=Netherlands disabled=no mode=ap name=MYSSID-CONF-Buiten-5G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering tx-power=17
/interface wifi access-list add action=accept comment="REDACTED" disabled=no mac-address= REDACTED vlan-id=50
/interface wifi access-list add action=accept comment="REDACTED" disabled=no mac-address= REDACTED vlan-id=51
/interface wifi access-list add action=accept comment="Default to VLAN ID 53" disabled=no vlan-id=53
/interface wifi capsman set ca-certificate=auto enabled=yes interfaces=VLAN99 package-path=/packages require-peer-certificate=no
upgrade-policy=none
/interface wifi provisioning add action=create-dynamic-enabled comment=AP-Beneden-5G disabled=no master-configuration=MYSSID-CONF-Beneden-5G name-format="%I - 5G" radio-mac= REDACTED
/interface wifi provisioning add action=create-dynamic-enabled comment=AP-Boven-5G disabled=no master-configuration=MYSSID-CONF-Boven-5G name-format="%I - 5G" radio-mac= REDACTED
/interface wifi provisioning add action=create-dynamic-enabled comment=AP-Buiten-5G disabled=no master-configuration=MYSSID-CONF-Buiten-5G name-format="%I - 5G" radio-mac= REDACTED
/interface wifi provisioning add action=create-dynamic-enabled disabled=no master-configuration=MYSSID-CONF-2G name-format="%I - 2G" supported-bands=2ghz-ax
Well, in the 7.18 topic we discussed a little about whether they would use the "btrfs balance" or the "block-level mdraid" function for the RAID setups, and now we know: it is "balance".*) rose-storage - show btrfs balance and scrub errors if any;
Without testing: shouldn't this be "wifi-qcom-ac"?*) wifi-qcom - fix OWE authentication for 802.11ac interfaces in station mode;
I can confirm. We have 2x hAP ax2 connected in a repeater mode. Disconnects happen only with my daughters iPhone 14, on 5GHz radio. It flaps so fast, that I can barely make a screenshot of which device is constantly reconnecting. I am not sure it is even reflected in a log.Wifi is in total mess on 7.19 beta2 and devices loose connection.
My log is full of this when i roam around.
@Dnevna_5GHz reauthenticating
@Dnevna_5GHz associated, but was associated already
@Dnevna_5GHz reconnecting, signal strength -55
@Dnevna_5GHz disassociated, key handshake timeout, signal strength -55
And bunch of disconnects while using devices with this in log.
disconnected, not responding, signal strength -56
Wifi degraded for me as well, lots of:
disconnected, not responding, signal strength -57
disconnected, connection lost, signal strength -69Code: Select all/interface wifi channel add disabled=no frequency=2412,2437,2462 name=CHAN-2G reselect-interval=4h..6h width=20mhz /interface wifi channel add disabled=no frequency=5500,5260,5660 name=CHAN-5G-Beneden reselect-time=03:00:00 width=20/40/80mhz /interface wifi channel add disabled=no frequency=5660,5260,5500 name=CHAN-5G-Boven reselect-time=03:15:00 width=20/40/80mhz /interface wifi channel add disabled=no frequency=5580 name=CHAN-5G-Buiten reselect-time=03:30:00 width=20/40mhz /interface wifi security add authentication-types=wpa2-psk,wpa3-psk connect-priority=0/1 disable-pmkid=yes disabled=no ft=yes ft -over-ds=yes group-encryption=ccmp group-key-update=1h management-protection=allowed name=MYSSID-PSK passphrase=REDACTED /interface wifi steering add 2g-probe-delay=yes disabled=no name=MYSSID-steering neighbor-group=MYSSID rrm=yes wnm=yes /interface wifi configuration add channel=CHAN-2G country=Netherlands disabled=no mode=ap name= MYSSID-CONF-2G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering tx-power=9 /interface wifi configuration add channel=CHAN-5G-Boven country=Netherlands disabled=no mode=ap name=MYSSID-CONF-Boven-5G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering /interface wifi configuration add channel=CHAN-5G-Beneden country=Netherlands disabled=no mode=ap name=MYSSID-CONF-Beneden-5G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering /interface wifi configuration add channel=CHAN-5G-Buiten country=Netherlands disabled=no mode=ap name=MYSSID-CONF-Buiten-5G security=MYSSID-PSK ssid=MYSSID steering=MYSSID-steering tx-power=17 /interface wifi access-list add action=accept comment="REDACTED" disabled=no mac-address= REDACTED vlan-id=50 /interface wifi access-list add action=accept comment="REDACTED" disabled=no mac-address= REDACTED vlan-id=51 /interface wifi access-list add action=accept comment="Default to VLAN ID 53" disabled=no vlan-id=53 /interface wifi capsman set ca-certificate=auto enabled=yes interfaces=VLAN99 package-path=/packages require-peer-certificate=no upgrade-policy=none /interface wifi provisioning add action=create-dynamic-enabled comment=AP-Beneden-5G disabled=no master-configuration=MYSSID-CONF-Beneden-5G name-format="%I - 5G" radio-mac= REDACTED /interface wifi provisioning add action=create-dynamic-enabled comment=AP-Boven-5G disabled=no master-configuration=MYSSID-CONF-Boven-5G name-format="%I - 5G" radio-mac= REDACTED /interface wifi provisioning add action=create-dynamic-enabled comment=AP-Buiten-5G disabled=no master-configuration=MYSSID-CONF-Buiten-5G name-format="%I - 5G" radio-mac= REDACTED /interface wifi provisioning add action=create-dynamic-enabled disabled=no master-configuration=MYSSID-CONF-2G name-format="%I - 2G" supported-bands=2ghz-ax
i've just rolled back this morning due to devices dropping switching more than needed etc...Wifi is in total mess on 7.19 beta2 and devices loose connection.
My log is full of this when i roam around.
@Dnevna_5GHz reauthenticating
@Dnevna_5GHz associated, but was associated already
@Dnevna_5GHz reconnecting, signal strength -55
@Dnevna_5GHz disassociated, key handshake timeout, signal strength -55
And bunch of disconnects while using devices with this in log.
disconnected, not responding, signal strength -56
*) console - added on-error to "for" and "foreach" loops;
*) console - do not treat return values as errors in scripts run from scheduler;
7.19beta4 fixes this. Sadly there is still no fix for the scheduling issues with the CPU on pppoe connections, I have to keep my RB5009 locked on 1400 MHz, instead of 'auto', because it will otherwise drop packets and not reach its full speed when sending at 1 gbit :(Upgrading to this version completely breaks routing on my RB5009 from my LAN's side. Every packet towards the router seems to get dropped, thus I can't access the config with winbox anymore. Interestingly enough the device still connects to the internet, and replies to ping from WAN. Also using wireguard from an external network allows me to connect to the device and route traffic through it. I can also access the config from the external device. the wg0 interface isn't part of the bridge. So I am assuming this problem is somehow bridge related? But honestly, I don't know where to start debugging this.
Which ROS version did you upgrade from?Thank You MikroTik team form new experience with RouterOS with 7.19beta4 version! :)
I have bricked (ROS 7.19beta4 bricked) my home RB493G RouterBoard!!!
I had to netinstall and back to stable ROS 7.17.2, because RB was booting.....booting.....booting... loop...
I was ipgrading from ROS 7.17.2.Which ROS version did you upgrade from?
@BartoszP: I run beta version on my main home router religiously. I do this by choice, well aware of the risks. I know that if it fails, I can just netinstall. But if it causes my device to brick, should I rather not report it here? Is that what you are suggesting?@fragtion:
Please try yo understand: beta testing is beta testing.
Do it on a spare device/test lab etc or agree problems with your main device or Internet connection.
what sounds like "what happend to my beloved and main router ...."I have bricked (ROS 7.19beta4 bricked) my home RB493G RouterBoard!!!
it's released to public, so someone's gotta test it and report when things don't go as planned
MikroTik support confirmed this as a bug and that it will be fixed in the next beta release.I isolated the issue to BFD. When enabled it causes high CPU usage.
Did a netinstall on a brand new RB5009, manually reconfigured everything the same as the RB4011 (did not restore a backup) and after putting it to work, same behavior. 70% CPU usage over all 4 cores, eaten by "routing" process.
The setup is 8 BGP peers with BFD enabled, over 8 Wireguard tunnels.
I experience the issue on multiple routers and I set up a new router with empty configuration with just BGP + BFD and the issue still occurs.
I reported the bug on ticket #SUP-181114
I tried a second time and the same thing happened. I am upgrading from ROS 7.17.2 to 7.19beta4. After that RB493 does not load ROS.Thank You MikroTik team form new experience with RouterOS with 7.19beta4 version! :)
I have bricked (ROS 7.19beta4 bricked) my home RB493G RouterBoard!!!
I had to netinstall and back to stable ROS 7.17.2, because RB was booting.....booting.....booting... loop...
.This exist on 7.18.1 so, probably, also exist on 7.19beta
BUG:
Removing not default queue type used on queue simple or queue tree before removing/changing the existant queue cause permalock.
How to replicate:Code: Select all/queue type add kind=cake name=queue1 /queue simple add name=queue1 target="" total-queue=queue1 /queue tree add name=queue1 parent=global queue=queue1 /queue type remove [find where default=no]
You can do either one. mdraid is also available, and is the way I tested things for the first year or so of ROSE being a thing.Well, in the 7.18 topic we discussed a little about whether they would use the "btrfs balance" or the "block-level mdraid" function for the RAID setups, and now we know: it is "balance".*) rose-storage - show btrfs balance and scrub errors if any;
Will "break" functionality ever be added for loops? (Don't tell me about workarounds)What's new in 7.19beta4 (2025-Mar-06 14:10):
*) console - added on-error to "for" and "foreach" loops;
Or a way to exit from a script midway? ("exit" command with ok/error parameter)Will "break" functionality ever be added for loops? (Don't tell me about workarounds)What's new in 7.19beta4 (2025-Mar-06 14:10):
*) console - added on-error to "for" and "foreach" loops;
That would only work for mistakes that make the router unreachable (like deleting the bridge that you use to connect to the router), but not for RouterOS errors that make the router crash and bootloop (like deleting a queue type that is in use), right?For such purposes, you should use "Safe Mode". Very much suggested, especially for new users.
https://help.mikrotik.com/docs/spaces/R ... t-SafeMode
When working on CAKE, please also add a way to show the status of the queue, the output of "tc -s qdisc show dev xxxx".We have discovered that CAKE type queue can crash router in v7.18 and v7.19 – we are working on a fix for that. However, it is not as simple as - add queue and router crashes. Seems that a set of events or precise timing is required for the problem to appear. And yes - when your router fits the "match" then this happens right away. For others - CAKE queues works just fine. We will fix this ASAP and release new versions.
The actual problem isn't about the backup but what we are going to do with 16mb devices in the future. Is is the end for these devices? Is mikrotik going to find a way to update without problems in the future? Should we replace all these devices with more space?You are not supposed to save your backup in flash memory! That normally is useless anyway.will measures be taken to increase free space on 16mb devices? hardly enough space to save a backup!
Make your backup in the RAMdisk (i.e. in the root directory on those 16MB devices), and then download it to your computer.
It's not related to loops and there is an :error command already for that.Or a way to exit from a script midway? ("exit" command with ok/error parameter)
Will "break" functionality ever be added for loops? (Don't tell me about workarounds)
:error can only exit with error. what would be useful is an exit that exits without error.It's not related to loops and there is an :error command already for that.
I tried a third time... First i upgraded ROS to 7.18.1 - this bricked RB493G too! I had to use Netinstall and revert to 7.17.2I tried a second time and the same thing happened. I am upgrading from ROS 7.17.2 to 7.19beta4. After that RB493 does not load ROS.Thank You MikroTik team form new experience with RouterOS with 7.19beta4 version! :)
I have bricked (ROS 7.19beta4 bricked) my home RB493G RouterBoard!!!
I had to netinstall and back to stable ROS 7.17.2, because RB was booting.....booting.....booting... loop...
The problem is that working on new features and fixing bugs in existing features inevitably leads to code expansion and people complaining that their device got inoperative as a result of an update... and that all takes time to handle.Everything here requires either time or money, not just keeping the flash size small. Please take a look at the changelog and see where the effort goes in recent versions.
That one I'm already doing. Anything less than 64MB is a no sale for me.And now that we know that, new devices with 16MB should simply not be released, or at least they should be boycotted.
Maybe this is their plan, which is what they made the packaging system list whats available, once thats mainstream they can break up alot of code into smaller packages and easier for people to find compared to previous methodI would not expect fixing bugs in an existing feature to result in a massive code expansion. If that is the case, I would submit the code for a review.
I agree with the statement regarding features. However, why do certain features have to be packed into the base package instead of an extra package? There are already several very small extra packages, despite the frequent emphasis on package overhead.
It's about structure of DHCP server's response packet ... some DHCP clients are sensitive regarding order in which different DHCP options are included in the packet (in theory order should not matter).Can someone explain what does this mean?
*) dhcpv4-server - "Relay-Agent-Information" (82) option moved at the end of option list in response packets;
If you upgraded to 7.19beta from 7.17.x or older, then you may have to properly set-up device mode prior to downgrading https://help.mikrotik.com/docs/spaces/R ... evice-modeWorse, I cannot downgrade.
I had no idea I'd have to do this (and don't know how, though I could probably figure it out from reading the MTK help pages). For what it's worth, I have a dozen routeros .npk packages on my laptop, going back to the 6.x series, and the file size of the latest beta is no larger than any of the previous ones. Also, I have been happily upgrading in place for years without any issues at all until this issue cropped up.Also, when you are so lucky to have a device like the RB951G-2HnD (low-end router from the good old days when you still got 128MB flash) you should have partitioned it before installing a beta!
Thanks for the pointer. I read the manual section on device mode and have now tried advanced, home, and even basic—no luck with any of them, and 7.19beta4 stubbornly remains installed.If you upgraded to 7.19beta from 7.17.x or older, then you may have to properly set-up device mode prior to downgrading https://help.mikrotik.com/docs/spaces/R ... evice-modeWorse, I cannot downgrade.
But after uploading the older routeros .npk into Files and running /system/packages/downgrade, and rebooting, the version does not change.
Success! ... mostly. I managed to downgrade to 7.14.3(stable) by putting the exactly corresponding RouterOS and Wireless packages, and nothing else, in Files, then setting device-mode to advanced, and finally doing system/package/downgrade and rebooting. The router now grabs a WAN-side address from the cable modem via DHCP, as before, so I have wireless connectivity again.But after uploading the older routeros .npk into Files and running /system/packages/downgrade, and rebooting, the version does not change.
Does anything with regard to this appear in /log ? One thing to worry: if you're downgrading, you have to upload .npk files for all packages installed ... for RB951 I'd expect routeros and wireless packages to be installed.
Does connect-to=<l2tp-server>@vrf do what you want for L2TP?pppoe-client and l2tp-client please. It's very helpful when a router have multiple ppp.*) dhcpv6-client - allow selecting to which routing tables add default route;
Great, step 2 after this new feature was already changed in 7.18(beta, rc) for the dhcp-v4-client !!
The last step will be to implement this in the PPPoE-Client as well :-)
Maybe in a 7.19beta3?? :-D
I thought I'd tried exactly this before, with no success... but it worked perfectly this time. Thanks!system/routerboard/upgrade
system/reboot
No, it's not the same like pushing a route in multiple table.Does connect-to=<l2tp-server>@vrf do what you want for L2TP?
pppoe-client and l2tp-client please. It's very helpful when a router have multiple ppp.
Confirm.Problem with IPsec IKEv2 with multi identities (Remote ID type address and match by remote id) is still broken.
Was the instability of CAKE that you previously mentioned really limited to having an interface with a CAKE queue and then deleting the queue type?*) queue - fixed system failure when CAKE kind queue was configured but queue type definition does not exist anymore (introduced in v7.18);
I upgraded to it on 3 devices (2 mipsbe, 1 arm) and everything looks good until nowWhat's new in 7.19beta5 (2025-Mar-12 12:42):
I tested in one of those devices, apparently it did not happened.*) queue - fixed system failure when CAKE kind queue was configured but queue type definition does not exist anymore (introduced in v7.18);
P.s.: 7.19beta5 fixes this issue.Well well well it seems that now even i do have wifi issues :D
This didn't happen before 7.19beta2 and i think i will switch to my other partition (7.18beta2) later to check:
Screenshot 2025-03-03 135122.png
Anyone with similar issues on 7.19beta2?
EDIT: I just update the other partition to 7.18.1 and copied the config will check now.
EDIT: EDIT: I just noticed that the echo dot i have here now doesnt disconnect every 30 seconds.
I thought that had been an issue the whole time. I guess not :/
EDIT:EDIT:EDIT:
I just tested 7.18.1 against 7.19beta2 and on the beta roaming is completely broken for me.
It didnt work A SINGLE time without disconnecting my client (aka my phone).
I opened a ticket for this SUP-180964
Roaming WORKS fine in 7.19beta5 , thanks.What's new in 7.19beta5 (2025-Mar-12 12:42):
...
*) wifi - fixed sending of reassociation response frames (introduced in v7.19beta2);
...
Roaming WORKS fine in 7.19beta5 , thanks.What's new in 7.19beta5 (2025-Mar-12 12:42):
...
*) wifi - fixed sending of reassociation response frames (introduced in v7.19beta2);
...
What's new in 7.19beta5 (2025-Mar-12 12:42):
*) wifi - fixed sending of reassociation response frames (introduced in v7.19beta2);
Roaming WORKS fine in 7.19beta5 , thanks.
Sorry for the silly question... I hardly use Wi-Fi on Mikrotik.I can confirm it too. It is MUCH, MUCH BETTER now. The repeating reconnection is gone.
And those helped too:
steering.2g-probe-delay=yes
.connect-priority=0/1
Dont know what the 2012 standard covers but otherwise yes.What's new in 7.19beta5 (2025-Mar-12 12:42):
*) wifi - fixed sending of reassociation response frames (introduced in v7.19beta2);Roaming WORKS fine in 7.19beta5 , thanks.Sorry for the silly question... I hardly use Wi-Fi on Mikrotik.I can confirm it too. It is MUCH, MUCH BETTER now. The repeating reconnection is gone.
And those helped too:
steering.2g-probe-delay=yes
.connect-priority=0/1
When you're talking about "reassociation", "Roaming", and "reconnection"...
Are you talking about:?
- 802.11r-2008
- 802.11k-2008
- 802.11v-2011
- 802.11-2012
Woooow!Dont know what the 2012 standard covers but otherwise yes.
Yes, when you have a hAP ac2 it is better to do a netinstall and also to give up on wifi-qcom-ac.
That simply will not last. Go back to "wireless" and when you want new drivers buy a hAP ax2 or ax3.
fischerdouglas, I am sure you've seen this little detail:Woooow!Dont know what the 2012 standard covers but otherwise yes.
Seeking for compliance with standards that are almost 15 years old?
That's a little scary, but also a little exciting.
(introduced in v7.19beta2);
see viewtopic.php?t=202423&start=600#p1054046This is Mikrotik fault, and they know it. They can easily split wifi-qcom-ac package for IPQ4019 only, but they are not willing to do. It's in vain, it's in vain, it's in vain.
fischerdouglas, I am sure you've seen this little detail:
Woooow!
Seeking for compliance with standards that are almost 15 years old?
That's a little scary, but also a little exciting.
So no, not covering 2012 standard from scratch. Just fixing a bug introduced in this exact beta version.Code: Select all(introduced in v7.19beta2);
see viewtopic.php?t=202423&start=600#p1054046This is Mikrotik fault, and they know it. They can easily split wifi-qcom-ac package for IPQ4019 only, but they are not willing to do. It's in vain, it's in vain, it's in vain.
*) dhcpv6-client - allow selecting to which routing tables add default route;
The situation with GTS is a little involved. The short answer: The certs issued by GTS *are* trusted under the current collection of Mikrotik trust anchors. (I have verified this with google's DoH servers, where the signature traces to GTS Root R1)I'm curious as to why GTS (Google Trust Services) root CAs are missing in built-in root certificate authorities.
The situation with GTS is a little involved. The short answer: The certs issued by GTS *are* trusted under the current collection of Mikrotik trust anchors. (I have verified this with google's DoH servers, where the signature traces to GTS Root R1)
The long answer: GTS is something of a semi-root certificate, in the sense that it is included by default on many systems (such as Chrome) and on Android, many of google's domains are actually *pinned* to them (so no amount of https mitm trickery done by next generation firewalls works on them). Also they have a *really* long lifetime, until 2035 if I recall correctly. So if you inspect the certs on such a system, you will see the certs resolved to GTS roots. In a lot of senses they behave like roots, but ultimately they have some sort of unusual agreement where they got other roots to sign their roots. (This is actually how new roots are introduced in a PKI scheme. Also when rotating roots, one of the previous roots signs the new one...)
Exactly correct, and thanks for looking up the appropriate references.Oh, I see. Some GTS root certificates are cross-signed with other roots "to ensure optimal support across a wide range of devices", as per their FAQ.
In any case, I think GTS is a CA big enough to be considered. It has its own ACME implementation that is used in-house (by Firebase services, for example) and by big third parties (like Cloudflare).
Google themselves recommend having all of their root certificates imported by applications connecting to Google services.
Ok but why do you use such a tiny amount of storage for the cache?I have once again log full or red "cache full, not storing" DNS Adlist related messages. My cache size is raised to 8192 KiB and Adlist size was something over the 2000 KiB. I definitely removed the functionality from the router.
AC2 only has 128Mb RAM ??Ok but why do you use such a tiny amount of storage for the cache?I have once again log full or red "cache full, not storing" DNS Adlist related messages. My cache size is raised to 8192 KiB and Adlist size was something over the 2000 KiB. I definitely removed the functionality from the router.
Reading above you have hAP ac2, that has 1GB of RAM or 1000000KiB, you can easily reserve 20480 or even 50000 KiB of that for cache.
(I usually just type an extra zero after the default 2048 for larger installations)
I have to agree @Sit75.This is Mikrotik fault, and they know it. They can easily split wifi-qcom-ac package for IPQ4019 only, but they are not willing to do. It's in vain, it's in vain, it's in vain.
Correct, I edited it. I meant ax2.AC2 only has 128Mb RAM ??
It's AX2 we're talking about.
The problems with splitting the software in many small packages are:The wAP and cAP lines suffer from the same problem of having little permanent storage space, and they don't have a USB port. Why does the main RouterOS package need to load all the USB device drivers on these devices? Wouldn't it be possible to reduce the size of routeros.npk by about 2MiB if there were a separate package for these drivers?
I agree with your points. I would just point out that an ac2 I netinstalled with 7.18 stable had 300k free. The current 7.19beta5 added roughly 100k to the base package. (Though Mikrotik does tend to do some disk space optimization between betas and the stable release, so maybe it will disappear.) The QCA984 firmware is 530k compressed. I believe only the Audiences have it, which have 128MB of storage. BTW the wireless (legacy) package is 1970kB, the qcom-ac is 2744kB, so just removing this firmware would roughly bring the new driver in line with the old one, and almost triple the available space after install. At 300k free, experience has shown that users run into trouble, with ~800k things seem to run smoothly, so I think sooner or later the qcom-ac driver will have to be split.The problems with splitting the software in many small packages are:
1. some packages may be or get dependent on others, and the architecture has no provision for "pulling in packages".
e.g. in v6 there were separate packages for "security" (encryption), "ppp", "dhcp", "ipv6" etc, and at some point there were several functions that did not only require the obvious package (like "ppp") but also only worked when "dhcp" or "security" was also loaded.
this became confusing, both for the users and likely also for the developers.
2. there is a nonzero overhead for just having a package. say it is 16kB, just a guess. when you split something like an 8kB USB driver into a package that then becomes 24kB, you will end up using more memory than before in devices that do require that function (e.g. the hAP ac2, known for its space shortage, DOES have USB)
3. due to the way that a compressing filesystem works, the compression factor becomes less when you put less data in it.
that is because compression works by replacing repeatedly ocurring sequences of data with a shorter "pointer" sequence.
when there is less data in a package, there will be fewer repeats, and thus less compression.
so a device driver that is part of the base package will take up less space within that, than it would within its own individual package.
Sola dosis facit venenum by ParacelsoThe problems with splitting the software in many small packages are:The wAP and cAP lines suffer from the same problem of having little permanent storage space, and they don't have a USB port. Why does the main RouterOS package need to load all the USB device drivers on these devices? Wouldn't it be possible to reduce the size of routeros.npk by about 2MiB if there were a separate package for these drivers?
1. some packages may be or get dependent on others, and the architecture has no provision for "pulling in packages".
e.g. in v6 there were separate packages for "security" (encryption), "ppp", "dhcp", "ipv6" etc, and at some point there were several functions that did not only require the obvious package (like "ppp") but also only worked when "dhcp" or "security" was also loaded.
this became confusing, both for the users and likely also for the developers.
2. there is a nonzero overhead for just having a package. say it is 16kB, just a guess. when you split something like an 8kB USB driver into a package that then becomes 24kB, you will end up using more memory than before in devices that do require that function (e.g. the hAP ac2, known for its space shortage, DOES have USB)
3. due to the way that a compressing filesystem works, the compression factor becomes less when you put less data in it.
that is because compression works by replacing repeatedly ocurring sequences of data with a shorter "pointer" sequence.
when there is less data in a package, there will be fewer repeats, and thus less compression.
so a device driver that is part of the base package will take up less space within that, than it would within its own individual package.
i updated the script to save to RAM. however, space decreased to 0kb since then. can't update the script, can't save any settings, can't even reboot the router! it is basically read-only now.You are not supposed to save your backup in flash memory! That normally is useless anyway.will measures be taken to increase free space on 16mb devices? hardly enough space to save a backup!
Make your backup in the RAMdisk (i.e. in the root directory on those 16MB devices), and then download it to your computer.
I agree. I really wish they would think more about this possibility. That's why I admire Mikrotik, they try to do their best to give their equipment a longer lifespan. Packet separation like in v6 was very good, in my opinion. In my networks, I don't use ipv6, bgp, etc., so I would remove the packet to free up a little more space.Yes, I think that "applications" should all be split off in separate packages. Because there are no inter-dependency issues and often not everyone wants them. And they are now easy to install. That would include such things as:
- CAPsMAN
- Hotspot
- Web Proxy
- SMB server / Media server
- Bandwidth test / server / Speed Test
- Traffic Generator
- "advanced servers" (TFTP, SNMP, Socks)
The WiFi/Wireless split in 7.13 made things worse for those that did not install the new drivers, because the new driver configuration and CAPsMAN is always installed even when you don't have the new driver. Fortunately there is still some space in that case because the old wireless is much smaller, bit still.
A similar problem exists when adding L2TP client interfaces in a VRF - the /32 route is created without the @vrf part and so is invalid. Good luck with getting it fixed - I reported it in 7.12 (SUP-134802) and it's not been resolved yet.*) dhcpv6-client - allow selecting to which routing tables add default route;
This seems to be broken if the selected routing table was created by VRF:
- Create VRF "test" and add interface ether1.
- Add a DHCPv6 client to ether1, enable "Add Default Route" and set Routing Table to "test".
A default route with gateway fe80::201:23ff:fe45:6789%ether1 gets created, but it's invalid und unreachable. That's because it's resolved in the wrong table (main).
The correct syntax is fe80::201:23ff:fe45:6789%ether1@test (confirmed by creating the route manually).
Same issue with the DHCPv4 client by the way.
BFD active on any bgp session(s) ?the new bgp implementation in 7.19beta (all betas) seems not working fine on x86 platform, it is overloading the cores with very high routing usage.
we experience high (70-90%) on a lot of cores, with normal irq usage where have high cpu.
regards
no bfd in my configBFD active on any bgp session(s) ?the new bgp implementation in 7.19beta (all betas) seems not working fine on x86 platform, it is overloading the cores with very high routing usage.
we experience high (70-90%) on a lot of cores, with normal irq usage where have high cpu.
regards
that might be the problem.
yes we tried a reboot, then the same behavior, and then downgrade.ok then there might be something "new" or maybe it is related to a deeper level problem like offloading of the NIC(s) not working correctly at this point.
were you able to reboot the x86 router ? (i know - quite hard when BGP is involved, 'cause it might impact a whole other aspects when a BGP router in a setup goes down - even for planned reboot)
thanks - so i, at least until beta/rc phases are over, will stay away from it (;yes we tried a reboot, then the same behavior, and then downgrade.ok then there might be something "new" or maybe it is related to a deeper level problem like offloading of the NIC(s) not working correctly at this point.
were you able to reboot the x86 router ? (i know - quite hard when BGP is involved, 'cause it might impact a whole other aspects when a BGP router in a setup goes down - even for planned reboot)
oh, i just saw this happens on CHR toothe new bgp implementation in 7.19beta (all betas) seems not working fine on x86 platform, it is overloading the cores with very high routing usage.
we experience high (70-90%) on a lot of cores, with normal irq usage where have high cpu.
regards
I have (seemingly) the same issue and I've reported it in ticket #SUP-181114.the new bgp implementation in 7.19beta (all betas) seems not working fine on x86 platform, it is overloading the cores with very high routing usage.
we experience high (70-90%) on a lot of cores, with normal irq usage where have high cpu.
regards
A similar problem exists when adding L2TP client interfaces in a VRF - the /32 route is created without the @vrf part and so is invalid. Good luck with getting it fixed - I reported it in 7.12 (SUP-134802) and it's not been resolved yet.
This seems to be broken if the selected routing table was created by VRF:
- Create VRF "test" and add interface ether1.
- Add a DHCPv6 client to ether1, enable "Add Default Route" and set Routing Table to "test".
A default route with gateway fe80::201fe45:6789%ether1 gets created, but it's invalid und unreachable. That's because it's resolved in the wrong table (main).
The correct syntax is fe80::201fe45:6789%ether1@test (confirmed by creating the route manually).
Same issue with the DHCPv4 client by the way.
They’re cooking*) wifi - fixed incorrect attribution of 802.11be capability to 802.11ax APs in output of scan command (introduced in v7.19beta2);
Could you please clarify in more details?What's new in 7.19beta6 (2025-Mar-19 09:56):
*) file - fixed missing files from The Dude (introduced in v7.18);
Whatever the issue may be, it's not resolved in beta6. I just tried it and the CPU usage is stuck at 70%, all from the "routing" process.None of the reported BGP problems are BFD-related or specific to v7.19beta.
One is caused by BGP connection flap with configured input filters other is related to large address lists to be loaded by routing protocols.
Thanks problem will be fixed in the next beta.
Māris B.
I'm fairly confused here if this is not ready why it was available in both CLI and Winbox normally if MT is cooking something it was always available in CLI first until it was ready for prime time, now they are gonna removed it because it doesn't work or no available docs atm or both? as always very inconsistent*) net - remove support for automatic multicast tunneling (AMT) interface (introduced in v7.18);
RB1100AHx2 (year 2011 model) is discontinued, unsupported, have powerpc CPU and have 128.0 MiB disk and is born for RotuerOS v5.11.Hi:
7.19beta6 is too big for the RB1100AHx2, by a few bytes: ERROR: not enough disk space, 20.7MiB is required and only 20.7 MiB is free.
The router was never re-partitioned, i.e. has a single "part0" with 64 MiB size. There are no files or directories under /files. -- azg
Official reply, please:Are there partitions used on this router? Two partitions would split the disk.
They are supported five years AFTER discontinued. This is the official Mikrotik policy. The RB1100AH2 may very well have been launched at 2011, but was still being sold at a much more recent date. So, doesn't matter when something was launched, only when it was discontinued.Official reply, please:
Are discontinued PPC products from year 2011 still fully supported?
Thanks.
Checking Archive.org:They are supported five years AFTER discontinued. This is the official Mikrotik policy. The RB1100AH2 may very well have been launched at 2011, but was still being sold at a much more recent date. So, doesn't matter when something was launched, only when it was discontinued.Official reply, please:
Are discontinued PPC products from year 2011 still fully supported?
Thanks.
I also have one of those, serial starting with "3411", factory routerboot=2.38There is a 512Mbit Flash chip from ST on the upper side of the 1100AH board, and RouterBOOT says its 64MB. I went as far back as ROS 6.20 with RouterBOOT 3.18 -- always shows 64MB. Looks like some models shipped with 64MB. No worries - it served long. Greetings - azg
As written above, it could be fixed by MikroTik.There is a 512Mbit Flash chip from ST on the upper side of the 1100AH board, and RouterBOOT says its 64MB. I went as far back as ROS 6.20 with RouterBOOT 3.18 -- always shows 64MB. Looks like some models shipped with 64MB. No worries - it served long. Greetings - azg
hiWhat's new in 7.19beta5 (2025-Mar-12 12:42):
*) dhcpv4-client/server - added support for DHCPv4 reconfigure messages;
Reconfiguration must be allowed on client side too.hiWhat's new in 7.19beta5 (2025-Mar-12 12:42):
*) dhcpv4-client/server - added support for DHCPv4 reconfigure messages;
how to use this?
i created static lease, enable 'use reconfigure' in dhcp server, and after click send reconfigure in lease.
shows error "send reconfigure error - no reconfigure parameters for this binding"
I've been checking on the windows 11 client and it doesn't seem to support this option.Reconfiguration must be allowed on client side too.
hi
how to use this?
i created static lease, enable 'use reconfigure' in dhcp server, and after click send reconfigure in lease.
shows error "send reconfigure error - no reconfigure parameters for this binding"
After it is allowed, renew/release DHCP client.
Now you will be able to perform configure.
I'm not sure if this will work, but you could try to declare a switch rule with the action "Redirect to CPU" for the RADIUS Server (I guess port 1812).I try to use dot1X on a CRS328-24P with external RADIUS server. Switch bridging its all ports and reaching RADIUS sever over a bond interface. However dot1X doesn't work if HW offload enabled, RADIUS server replies doesn't reaching the switch CPU. If I disable HW offload under /interface/bridge/port dot1X getting works but switch can forwards only ~500Mbps in this mode. I de-configured bond and using simple interface as a workaround to use HW forwarding.
This is known?
Why would you want to send the message when the client does not support it????I've been checking on the windows 11 client and it doesn't seem to support this option.
is there any information on how to reconfigure my devices to support this option?
or is there a possible workaround, such as sending a message even if the client does not support the option?
There were awful FT issues which got fixed in beta5.My wireless came really bonkers with the latest betas :-( Having 2x AX2, connected as a repeater (station bridge). I can see some "disconnected, reason code 3, signal -69" messages in there, cca 10 times a day. Found some related threads, but no conclusion. Sent supout.rif few days back.
I am now back at the stable 7.18.2, can see code 3 and code 8 once, so the outage is not so frequent. The repeater bridge station radio is at the -64 to -71 signal, tx power 18. Maybe the connection is too weak?
Has anyone seen difference in client connections between the 7.18 stable and 7.19 betas? Were there any changes in regards to roaming, etc.?
I don't really understand the meaning of this feature if it is not supported by 99%+ of dhcp clients.Why would you want to send the message when the client does not support it????I've been checking on the windows 11 client and it doesn't seem to support this option.
is there any information on how to reconfigure my devices to support this option?
or is there a possible workaround, such as sending a message even if the client does not support the option?
Of course nothing will happen in that case!
[oreggin@rtr1.CPE] > /mpls/ldp/remote-mapping/print where dst-address~"b00b"
Flags: I - INACTIVE; D - DYNAMIC
Columns: VRF, DST-ADDRESS, NEXTHOP, LABEL, PEER
# VRF DST-ADDRESS NEXTHOP LABEL PEER
0 ID main b00b::10:0:10:11 17 10.0.10.1:0
2 ID main b00b::10:0:10:1 impl-null 10.0.10.1:0
3 ID main b00b::10:0:10:12 18 10.0.10.1:0
4 ID main b00b::10:0:10:13 19 10.0.10.1:0
12 main b00b::10:0:10:1 fe80::20c:42ff:fe53:1491%ether2 impl-null
13 main b00b::10:0:10:12 fe80::20c:42ff:fe53:1491%ether2 18
14 main b00b::10:0:10:13 fe80::20c:42ff:fe53:1491%ether2 19
:local 6PEs {"b00b::10:0:10:1";"b00b::10:0:10:12";"b00b::10:0:10:13"}
foreach 6PE in=$6PEs do={
:local StatusDynamic [ /mpls/ldp/remote-mapping/get [ find dst-address="$6PE" dynamic ] value-name=inactive ]
:if ( $StatusDynamic = true ) do={
:local LabelDynamic [ /mpls/ldp/remote-mapping/get [ find dst-address="$6PE" dynamic ] value-name=label ]
:local GW [ /routing/route/get [ find dst-address="$6PE/128" active ] value-name=gateway ]
:local LabelStatic
:onerror e { set $LabelStatic [ /mpls/ldp/remote-mapping/get [ find dst-address="$6PE" !dynamic ] value-name=label ] }
:if ( $LabelStatic != "no such item" ) do={
:local StatusStatic
:onerror e { set $StatusStatic [ /mpls/ldp/remote-mapping/get [ find dst-address="$6PE" !dynamic ] value-name=inactive ] }
if ( $StatusStatic = true or $LabelStatic != $LabelDynamic ) do={
/mpls/ldp/remote-mapping/remove [ find dst-address="$6PE" !dynamic ]
/mpls/ldp/remote-mapping/add dst-address="$6PE" nexthop=$GW label=$LabelDynamic vrf=main
}
} else={
/mpls/ldp/remote-mapping/add dst-address="$6PE" nexthop=$GW label=$LabelDynamic vrf=main
}
}
}
Thanks for answer, I tried switch rule but my colleagues cross-configured, so I build a lab for this and test further.I'm not sure if this will work, but you could try to declare a switch rule with the action "Redirect to CPU" for the RADIUS Server (I guess port 1812).I try to use dot1X on a CRS328-24P with external RADIUS server. Switch bridging its all ports and reaching RADIUS sever over a bond interface. However dot1X doesn't work if HW offload enabled, RADIUS server replies doesn't reaching the switch CPU. If I disable HW offload under /interface/bridge/port dot1X getting works but switch can forwards only ~500Mbps in this mode. I de-configured bond and using simple interface as a workaround to use HW forwarding.
This is known?
Might be worth filing a support request anyway.
There were awful FT issues which got fixed in beta5.My wireless came really bonkers with the latest betas :-( Having 2x AX2, connected as a repeater (station bridge). I can see some "disconnected, reason code 3, signal -69" messages in there, cca 10 times a day. Found some related threads, but no conclusion. Sent supout.rif few days back.
I am now back at the stable 7.18.2, can see code 3 and code 8 once, so the outage is not so frequent. The repeater bridge station radio is at the -64 to -71 signal, tx power 18. Maybe the connection is too weak?
Has anyone seen difference in client connections between the 7.18 stable and 7.19 betas? Were there any changes in regards to roaming, etc.?
Other than that, everything seems fine to me.
Can you elaborate quickly what youre talking about?It seems much better in my case (hAP ac2) after Beta5 fixes too. Number of sudden disconnections decreased quite significantly. I have the mostly Apple devices with wpa3 and FT. What is still visible is the memory leak related to each disconnection. There is very strong correlation between number of disconnections and free RAM memory. Reported in SUP-175544.
There were awful FT issues which got fixed in beta5.
Other than that, everything seems fine to me.
It would be a dream! I would like MT to evaluate thisAre there any plans to split RouterOS 7 into smaller packages (like RouterOS 6 was split) to prevent 16 MB devices from running out of disk space?
As the size of RouterOS grows there are more and more complains in the stable release threads from users who soft-bricked their 16MB devices with updates...
Why do you think, this solve every problem about 16MB flash size?It would be a dream! I would like MT to evaluate thisAre there any plans to split RouterOS 7 into smaller packages (like RouterOS 6 was split) to prevent 16 MB devices from running out of disk space?
As the size of RouterOS grows there are more and more complains in the stable release threads from users who soft-bricked their 16MB devices with updates...
This can't succeed since wifi-qcom-ac package is always larger than wireless package.Regarding the package file size on 16MB devices. Is there a current 'best practice' for this?
I havn't actually had a significant problem until now but I could not load wifiwave2 drivers on any 16MB devices with latest firmware. Would start by uninstalling Wireless, but there's just not enough space to install wave2 drivers
Hopefully this means lack of DHCPAUTH. RFC3203 resp. the newer RFC6704 mandates DHCPAUTH for FORCERENEW messages for a good reason.how to use this?
i created static lease, enable 'use reconfigure' in dhcp server, and after click send reconfigure in lease.
shows error "send reconfigure error - no reconfigure parameters for this binding"
I would love to see a preference in winbox to enable safe mode by default. It's a hard habit to learn.I don't want to bother you in this thread,
but wouldn't it be better to find the safe-mode active by default (maybe it can be disabled with an option when launching winbox)
and ask for confirmation of the changes when exiting winbox?
but wouldn't it be better to find the safe-mode active by default
Safe mode by default sounds like a truly awful idea
Safe-mode active by default on a per-group basis behavior! Or, per-user?I would love to see a preference in winbox to enable safe mode by default. It's a hard habit to learn.
There was a discussion about the different ways config and safe mode could work recently on the forum.I don't particularly like safe-mode, at the very least I would want Winbox/Terminal to blatantly indicate that it is active, across ALL connected sessions regardless of where it was turned on
Even better I would prefer if MikroTik implemented a variant that took a backup of the current state, constantly flashed some sort of notification with a countdown timer of X minutes:seconds, and you had to manually cancel it. If you don't then it would restore the previous state (and not just rollback on connection loss, so you could still perform connection breaking changes that might result in a brief outage)
I do this with a custom script that takes a backup and schedules it to restore, but its not an integrated 1-click feature
+1@MT any chance on fixing BGP sessions refresh on winbox3 just like how ros v6 behave?
Can you elaborate quickly what youre talking about?It seems much better in my case (hAP ac2) after Beta5 fixes too. Number of sudden disconnections decreased quite significantly. I have the mostly Apple devices with wpa3 and FT. What is still visible is the memory leak related to each disconnection. There is very strong correlation between number of disconnections and free RAM memory. Reported in SUP-175544.
I got an ac2 that im not monitoring that runs as a full on Wi-Fi router and yes after 30 days and many, many wifi disconnects the ram is only 16 MB free but thats still alright id say.
It runs 7.18rc2 though, but from what I understand that one has the same issue?
i had some disconections on a hap ax2, then i jumped from 7.18.2 to 7.19 beta6 a day ago and has behaved well so farHas anyone seen difference in client connections between the 7.18 stable and 7.19 betas? Were there any changes in regards to roaming, etc.?
40 mins ago it crashed with OOMIt looks like completely different in my case. Memory steadily leaking. I have investigate the problem and really found out the leak is related (proportional - strong correlation) to number of WiFi connection/disconnection and maybe WiFi roaming too. I have hundreds of connection/disconnection a day. It is sometimes possible, if a device is close to the edge of WiFi coverage. You can not avoid it (it is a radio interface, where level of signal fluctuate), but WiFi router should be capable to cope with this situation without memory leak.
Can you elaborate quickly what youre talking about?
I got an ac2 that im not monitoring that runs as a full on Wi-Fi router and yes after 30 days and many, many wifi disconnects the ram is only 16 MB free but thats still alright id say.
It runs 7.18rc2 though, but from what I understand that one has the same issue?
40 mins ago it crashed with OOMIt looks like completely different in my case. Memory steadily leaking. I have investigate the problem and really found out the leak is related (proportional - strong correlation) to number of WiFi connection/disconnection and maybe WiFi roaming too. I have hundreds of connection/disconnection a day. It is sometimes possible, if a device is close to the edge of WiFi coverage. You can not avoid it (it is a radio interface, where level of signal fluctuate), but WiFi router should be capable to cope with this situation without memory leak.
done that. less than 200kb free. still critically low.Time to netinstall that device
I'm not sure what the difference might be. I reported an issue with iOS devices in particular struggling with the beta, and beta6 improved the situation immensely--to the point that they no longer seem spurious. IOW, my hAP ax2 has been handling the situation better since upgrading to beta6.i had some disconections on a hap ax2, then i jumped from 7.18.2 to 7.19 beta6 a day ago and has behaved well so farHas anyone seen difference in client connections between the 7.18 stable and 7.19 betas? Were there any changes in regards to roaming, etc.?
UPDATE
disconection still occur on 7.19 beta6
We are still waiting for VPNv6 support over IPv4 infrastructure.Did anyone configure VPNv6 successfully to work?
I also perceive somewhat of improvement, but wifi "stalls" still happen a few times per day, especially when there is more traffic, for example when i push some heavy transfer from one laptop to another across wifi there is more chances of happeningI'm not sure what the difference might be. I reported an issue with iOS devices in particular struggling with the beta, and beta6 improved the situation immensely--to the point that they no longer seem spurious. IOW, my hAP ax2 has been handling the situation better since upgrading to beta6.
i had some disconections on a hap ax2, then i jumped from 7.18.2 to 7.19 beta6 a day ago and has behaved well so far
UPDATE
disconection still occur on 7.19 beta6