The "packages" in RouterOS are said to be separate filesystems that are loop-mounted into the root filesystem at boot.What type of package manager introduces such a significant storage overhead? OpenWRT has been using "opkg" for years without issues. However, OpenWRT also provides board-specific builds - perhaps this is the key to addressing flash storage limitations on 16MB devices.
Assuming this is still about the "possible SYN flooding on tcp port 53": YES. When having hundreds of clients on the local network, there can be enormous bursts of DNS requests. The CCR2004 should be able to handle that. I have configured 10000 concurrent requests and 1000 TCP connections and I do not appreciate that the service would then be temporarily cut off due to "SYN flooding"...either way, I'd like to be able to tune this checks. Since they are in place, why not using them directly and tune them for our needs.
just done, nothing happen.Avoid this command in this version, your device will crashed and put the device on boot loop.
/queue/type/remove [find default =no]
Can confirm, couple weeks ago my RB4001 crashed with /queue/type/remove [find], I had to reset it due to a boot loop.Avoid this command in this version, your device will crashed and put the device on boot loop.
/queue/type/remove [find default =no]
I don't mind that it logs a bogus message, but I worry that when it detects the condition (also later during operation, without logging the warning again) it will temporarily disallow new connections on that port.We have seen this behavior as well with winbox, but port 8291 was only exposed to management vlan and I'm the only one accessing the device during that time so this SYN flooding warning is just a fluke at least for me
/queue type
add kind=cake name=queue1
/queue simple
add name=queue1 target="" total-queue=queue1
/queue tree
add name=queue1 parent=global queue=queue1
/queue type
add kind=cake name=queue1
/queue simple
add name=queue1 target="" total-queue=queue1
/queue tree
add name=queue1 parent=global queue=queue1
/queue type
remove [find where default=no]
This is just an example how it can be done right way. I have seen enough headaches with Fortinet just as with Mikrotik, but this is beside the point. The point is lacking this kind of basic sanity checks on configuration changes. Even if some bug will cause this and there's no sanity check stopping it from happening and you are up to netinstall.Oh, okay - if even Fortinet gets it right, that certainly says something. 😊
It is not as bad as you suggest. Yes, sometimes you can remove an object and leave something else dangling, but usually you will just get an "unknown" or some HEX number at the place where it was referred, and nothing bad happens.The point is lacking this kind of basic sanity checks on configuration changes. Even if some bug will cause this and there's no sanity check stopping it from happening and you are up to netinstall.
I believe that a (better) system should require a "commit" action to save changes. When making many configuration changes - such as adjusting firewall rules extensively - it is the final result that matters, not the many steps taken to get there. If the end result is just three changes to existing rules, the system should not save every intermediate step automatically.There is always something to be said about the configuration mechanism.
Some people prefer a system where all config is only done in RAM and a "save" is required to commit it to nonvolatile memory.
Some systems have a "transaction" mechanism where you can change different parameters and "commit" the whole transaction in a single config change. Sometimes useful when you want to change things and the intermediate situation is not working or conflicting.
I was about to say that but it has a limit of 100 commands.
I have to say: similar also happened approx. 1 or 2 years back while I was in safe mode. I enabled safe mode, did at max. 10 changes or like. Then I left safe mode. It did undo most - but not all changes I have made while I was in safe mode. I guess it is because safe-mode utilizes the undo/history system to accomplish the task. This is why I do not use safe-mode. I was so baffled by this experience that I tried to find a "step by step" to reproduce this bug and report to Mikrotik support - but I was not able to find a simple command sequence to trigger the bug.
No way to compare commit, commit trial, commit dry-run, commit full, rollback... With that thing called "safe-mode".
I was already giving the same advice a few years ago, it's how I work...[..] I make a full binary backup and then assign a restore via the scheduler with enough time in advance.[...]
0) If it's a bug like the one reported above(¹), you're fu–ed anyway... 1) Make a binary backup 2) Make one export 3) Schedule the reload on A) REBOOT and on B) after xx minutes (It depends on how long you think it will take to make the changes, usually 10 minutes is enough) NOTE: This do not do reboot-loop for reload the backup, since on binary backup reloaded is not present the scheduled reload at reboot. 4) Do the work 5) Make again one export 6) Compare prev/next export for review the differencies 7) If all is OK remove scheduled reload on point 3)(¹) viewtopic.php?p=1131405#p1131111
I have added a Linux VM with BIND9 as a resolver and offer it as a second DNS resolver to DHCP clients.Assuming this is still about the "possible SYN flooding on tcp port 53": YES. When having hundreds of clients on the local network, there can be enormous bursts of DNS requests. The CCR2004 should be able to handle that. I have configured 10000 concurrent requests and 1000 TCP connections and I do not appreciate that the service would then be temporarily cut off due to "SYN flooding"...
This sounds as horrible as the old technique of operating old Cisco IOS without Commit, where you would schedule a reboot and if by the time of the reboot you didn't cancel that reboot or if you didn't do a "copy running-config startup-config" you might be saved by the scheduled reboot.I was already giving the same advice a few years ago, it's how I work...[..] I make a full binary backup and then assign a restore via the scheduler with enough time in advance.[...]
example code
0) If it's a bug like the one reported above(¹), you're fu–ed anyway... 1) Make a binary backup 2) Make one export 3) Schedule the reload on A) REBOOT and on B) after xx minutes (It depends on how long you think it will take to make the changes, usually 10 minutes is enough) 4) Do the work 5) Make again one export 6) Compare prev/next export for review the differencies 7) If all is OK remove scheduled reload on point 3)(¹) viewtopic.php?p=1131405#p1131111
Your D53G-5HacD2HnD logs look a lot like the kind of mess I was seeing in my logs on the RB2011. Note that the RB2011 was not directly to blame. By upgrading it to v7.16.2 or higher, it became intolerant of the problem that was actually in another box. Look at the hardware connected to ether2 on your D53G-5HacD2HnD.Could this be related? viewtopic.php?p=1131360#p1131360
I only experienced it in 7.18.1 using RB5009UG+S+IN, CCR2004-1G-12S+2XS and CCR2216-1G-12XS-2XQ.Is this only on 7.18.1?
/interface ovpn-server server add mac-address=[...] name=ovpn-server1
While it's disabled by default, I would prefer default config and especially updates not to create bogus interfaces.
Mikrotik has gotten back to me. It appears that if you rig the QCA8337 or the Atheros 8327 for hardware bridging with VLANs, you need to enable independent-learning for VLAN 1 (my default/untagged VLAN) for the hardware RSTP functions to work correctly.FYI for those using RSTP. There appears to be a bug in the Switch code for the QCA8337 switch used in the RB750Gr2. Since at least as early as v7.16.2 it has a habit of passing received BPDU packets through the switch to other connected devices. For v7.17 a work around is to disable hardware switching and use the software bridge and Fast Forwarding instead. This fix appears to break in v7.18.1 along with other related quirks.
I'm discussing this at length with MikroTik support in SUP-179002, but thought the community should know.
It all depends on the architecture and processor.What will happen with 16MB devices? It's very hard to install updates. This means is the end of these devices?
I have hap ac2 devices, how do you upgrade them to 32 MB ? I would like to keep upgrading them without the fear to brick them.It all depends on the architecture and processor.What will happen with 16MB devices? It's very hard to install updates. This means is the end of these devices?
The size of the general package, in which a lot of usually unnecessary things are now packed, is different.
On HAP AC2 (arm) I change the flash memory to 32 MB.
Now, on 7.18.1 it used 16.6 out of 32 mb.
For the Hex S, such a trick did not work - it does not support more than 16 mb, but it has an SD Card
But now 17% (13.1 out of 16 Mb) is free on one of these devices (mmips)
On Cap Ac (ARM) access points, 6% of the space is free (only for the shared package and Wireless).
viewtopic.php?p=1124163#p1124163I have hap ac2 devices, how do you upgrade them to 32 MB ? I would like to keep upgrading them without the fear to brick them.
It all depends on the architecture and processor.
The size of the general package, in which a lot of usually unnecessary things are now packed, is different.
On HAP AC2 (arm) I change the flash memory to 32 MB.
Now, on 7.18.1 it used 16.6 out of 32 mb.
For the Hex S, such a trick did not work - it does not support more than 16 mb, but it has an SD Card
But now 17% (13.1 out of 16 Mb) is free on one of these devices (mmips)
On Cap Ac (ARM) access points, 6% of the space is free (only for the shared package and Wireless).
Back in RouterOS 6.x all_packages-xxx-6.x.x.zip used to actually contain all packages, both extra and the ones contained in the bundle, so you could choose to install from it only what is needed for your particular use case and not to install ppp, hotspot, mpls, ipv6 for example and save roughly 1MB which is pretty significant on a 16MB devices and avoids any lack of storage space issues... and upgrades wold only upgrade what is already installed.What will happen with 16MB devices? It's very hard to install updates. This means is the end of these devices?
No as they released new devices with 16MB :DWhat will happen with 16MB devices? It's very hard to install updates. This means is the end of these devices?
Which would mean they will have to do something about current bloating of ROS base package.No as they released new devices with 16MBWhat will happen with 16MB devices? It's very hard to install updates. This means is the end of these devices?
And the 5 year claim still applies, no?
Well yeah definitely. You can't release a product that breaks on every 2nd updateWhich would mean they will have to do something about current bloating of ROS base package.
No as they released new devices with 16MB :D
And the 5 year claim still applies, no?
Well, let me tell you why no one's answering.I guess nobody's replied because this is a terrible, terrible idea. Nobody wants Wireguard plus some proprietary Russian "improvements" on top running anywhere near their networks. Shipping this would be the end of Mikrotik.and of course amnezia wireguard in an options package.
An what potential benefits would it bring? If you think your Wireguard traffic is at risk of DPI monitoring or attacks, run a box on your local network to run Amnezia - at least in that example you can get rooted by the FSB and the rest of us will stay safe.
If you need support you can go to Telegram! I'm going to be chuckling about that one for some time!
usb1 is the device while usb1-part1 is just a partition on the device.Hello everyone,
I'm using the stable version 7.18.1 on my hAP ac², where I started using a USB flash drive to save files to avoid taking up space in the RB's internal memory, which is only 16 MB.
This led to the following issue: the flash drive I initially used was a SanDisk 3.2Gen1 128GB, which became defective. I had to replace it with the same model but with a smaller capacity, a SanDisk 3.2Gen1 32GB.
I discovered a possible bug: when I insert the new 32GB flash drive, the RB still recognizes the previous 128GB flash drive, even though it is not mounted or inserted in the RB. It detects it as usb1, and the inserted 32GB flash drive as usb1-part1.
If I try to eject and remove usb1, it also removes usb1-part1, and vice versa. It seems like the system is recognizing both drives as one.
I have already tried a factory reset, reboot, and downgrade, but the issue persists.
For reference, I'm using the FAT32 file system.
Just netinstalled this device. 7.18.1 is now running, but flash-space is tight.Today was the day I thought, 7.18.1, now I can upgrade. But it did not upgrade:
Well yeah, before upgrade I checked system resources:Code: Select all2025-03-03 11:22:21 system,error upgrade failed, free 13 kB of disk space 2025-03-03 11:22:21 system,error GENERAL: upgrade failed, free 13 kB of disk space
Yeah, 168kib is not much. But again: yet another major release consuming more space. 7.14 was a disaster (space wise). 7.15 regained quite a lot of space. Since 7.16 decreasing space again. Now 7.18.1 - and my device can't upgrade. Leaves me puzzled.Code: Select allversion: 7.17.2 (stable) free-hdd-space: 168.0KiB total-hdd-space: 16.0MiB architecture-name: arm board-name: D53G-5HacD2HnD platform: MikroTik
And after a reboot I now see:Code: Select allversion: 7.18.1 (stable) free-hdd-space: 44.0KiB total-hdd-space: 16.0MiB board-name: D53G-5HacD2HnD platform: MikroTik
No space is left.Code: Select all2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:40:41 system,error,critical could not save configuration changes, not enough storage space available.
Now, not even /system/reboot is possible. It times out.Code: Select allversion: 7.18.1 (stable) free-hdd-space: 0 total-hdd-space: 16.0MiB architecture-name: arm board-name: D53G-5HacD2HnD platform: MikroTik
Code: Select all/system/reboot Reboot, yes? [y/N]: y system will reboot shortly action timed out - try again, if error continues contact MikroTik support and send a supout file (13)
cant upgrade .. have u found a solution without netinstall the device ?
usb1 is the device while usb1-part1 is just a partition on the device.Hello everyone,
I'm using the stable version 7.18.1 on my hAP ac², where I started using a USB flash drive to save files to avoid taking up space in the RB's internal memory, which is only 16 MB.
This led to the following issue: the flash drive I initially used was a SanDisk 3.2Gen1 128GB, which became defective. I had to replace it with the same model but with a smaller capacity, a SanDisk 3.2Gen1 32GB.
I discovered a possible bug: when I insert the new 32GB flash drive, the RB still recognizes the previous 128GB flash drive, even though it is not mounted or inserted in the RB. It detects it as usb1, and the inserted 32GB flash drive as usb1-part1.
If I try to eject and remove usb1, it also removes usb1-part1, and vice versa. It seems like the system is recognizing both drives as one.
I have already tried a factory reset, reboot, and downgrade, but the issue persists.
For reference, I'm using the FAT32 file system.
Reformat usb1 if you just want a device with a file system instead of a partition.
Solution: netinstall 7.17.2. This 7.18.1 was a running zombie. While up and running, I was unable to reboot by /system/reboot. It was not possible to downgrade. Uninstall extra packages as well not possible. Not even deleting all installed certificates did regain a single byte. Nothing. All these actions seem to have one common requirement: save configuration. If this fails, you're out of luck.
Just netinstalled this device. 7.18.1 is now running, but flash-space is tight.
And after a reboot I now see:Code: Select allversion: 7.18.1 (stable) free-hdd-space: 44.0KiB total-hdd-space: 16.0MiB board-name: D53G-5HacD2HnD platform: MikroTik
No space is left.Code: Select all2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:39:54 system,error,critical could not save configuration changes, not enough storage space available. 2025-03-04 00:40:41 system,error,critical could not save configuration changes, not enough storage space available.
Now, not even /system/reboot is possible. It times out.Code: Select allversion: 7.18.1 (stable) free-hdd-space: 0 total-hdd-space: 16.0MiB architecture-name: arm board-name: D53G-5HacD2HnD platform: MikroTik
Code: Select all/system/reboot Reboot, yes? [y/N]: y system will reboot shortly action timed out - try again, if error continues contact MikroTik support and send a supout file (13)
hi i have the same problem
could not save configuration changes, not enough storage space available.
cant upgrade .. have u found a solution without netinstall the device ?
br
mark
Same problem at CCR1072 and v7.18.1I can see a massive increase in latency spikes and loss after upgrading to v7.18 on multiple CCR2004-1G-12S+2XS
![]()
Intel AX210 has some quite limited frequency range on 5ghz.Hi,
I have "funny Problem" with cAPGi-5HaxD2HaxD and the 7.18.1 and the latest 7.17.2 Version, Only the 7.18 Version works flawlessly:
Some Android devices (mainly with Mediatek AC or AX Chipset, but also some Linux machines with Intel 210 AX Wifi Nics) have tthe Problem that they
don't see the SSID of the 5 GHz Band, when 7.18.1 or 7.17.2 Version.
After rescanning several time, sometimes they are able to "see" it but still unable to connect, because they say in the logs the SSID disappears.....
ONLY the 7.18 Work fine regarding this issue - don't know why.
First I thoght it is a simpley "country setting" issu, but no, it has nothing to do with dhe channel or country selection, even I I use only the Channel 36-42 the issue is absolutely the same .
I am a bit disappointed that the issure re-occured with the last Update 7.18.1 though.....
The Other Problem which exists with ALL Versions so far, my Linux machine with Intel 210AX does only connect on 5 GHz in 300N Mode, not AC and not AX.... but Just for the record, I didn't examine that problem too deep yet...
Cheers
4920441
/console/clear-history
/console/clear-history
This warrants its own ticket to support and/or its own thread. There's too much to unpack here to address it in the 7.18.1 release thread.If someone could hear us out... We are in deep trouble with Mikrotik. We bought 12 CCR2216's to replace our aging 1072 fleet (we are a mid sized FTTH/Wireless ISP).
@elcano89 you surely bought the 12 CCR2216 units directly from an official MikroTik distributor. Since you have already created a MikroTik support ticket, I would recommend contacting your distributor as well, explaining the issue and providing your SUP number. A distributor might have a better chance of being heard by MikroTik than just being one of many support requests.If someone could hear us out... We are in deep trouble with Mikrotik. We bought 12 CCR2216's to replace our aging 1072 fleet (we are a mid sized FTTH/Wireless ISP).
[admin@xxx-AP3] > /ip cloud/print
ddns-enabled: yes
ddns-update-interval: none
update-time: yes
public-address: 212.xx.xx.xx
dns-name: he80xxxxx.sn.mynetname.net
status: updated
warning: Router is behind a NAT. Remote connection might not work.
I have the same issue. (WAPAC) Deleting files does not free any disk space, console cleared, and cant reboot the device remotely. I find it truly shocking you cant reboot a device if there is no free disk available? I think there is an internal OS Partition which has filled up, and there is no way to clear out the usage such as temp files.Solution: netinstall 7.17.2. This 7.18.1 was a running zombie. While up and running, I was unable to reboot by /system/reboot. It was not possible to downgrade. Uninstall extra packages as well not possible. Not even deleting all installed certificates did regain a single byte. Nothing. All these actions seem to have one common requirement: save configuration. If this fails, you're out of luck.
hi i have the same problem
could not save configuration changes, not enough storage space available.
cant upgrade .. have u found a solution without netinstall the device ?
br
mark
uptime: 6d19h56m24s
version: 7.18.1 (stable)
build-time: 2025-02-28 11:31:28
factory-software: 6.44.6
free-memory: 31.7MiB
total-memory: 128.0MiB
cpu: ARM
cpu-count: 4
cpu-frequency: 672MHz
cpu-load: 1%
free-hdd-space: 0
total-hdd-space: 16.0MiB
write-sect-since-reboot: 29625
write-sect-total: 388563
architecture-name: arm
board-name: wAP ac
I had a similar problem.I have the same issue. (WAPAC) Deleting files does not free any disk space, console cleared, and cant reboot the device remotely. I find it truly shocking you cant reboot a device if there is no free disk available? I think there is an internal OS Partition which has filled up, and there is no way to clear out the usage such as temp files.
Solution: netinstall 7.17.2. This 7.18.1 was a running zombie. While up and running, I was unable to reboot by /system/reboot. It was not possible to downgrade. Uninstall extra packages as well not possible. Not even deleting all installed certificates did regain a single byte. Nothing. All these actions seem to have one common requirement: save configuration. If this fails, you're out of luck.Code: Select alluptime: 6d19h56m24s version: 7.18.1 (stable) build-time: 2025-02-28 11:31:28 factory-software: 6.44.6 free-memory: 31.7MiB total-memory: 128.0MiB cpu: ARM cpu-count: 4 cpu-frequency: 672MHz cpu-load: 1% free-hdd-space: 0 total-hdd-space: 16.0MiB write-sect-since-reboot: 29625 write-sect-total: 388563 architecture-name: arm board-name: wAP ac
Thanks for the advice, It seems based on this that it is recommended to netinstall when moving from v6 to v7.I had a similar problem.
I have the same issue. (WAPAC) Deleting files does not free any disk space, console cleared, and cant reboot the device remotely. I find it truly shocking you cant reboot a device if there is no free disk available? I think there is an internal OS Partition which has filled up, and there is no way to clear out the usage such as temp files.Code: Select alluptime: 6d19h56m24s version: 7.18.1 (stable) build-time: 2025-02-28 11:31:28 factory-software: 6.44.6 free-memory: 31.7MiB total-memory: 128.0MiB cpu: ARM cpu-count: 4 cpu-frequency: 672MHz cpu-load: 1% free-hdd-space: 0 total-hdd-space: 16.0MiB write-sect-since-reboot: 29625 write-sect-total: 388563 architecture-name: arm board-name: wAP ac
This is a consequence of the RoOs successive upgrade.
At some point, RoOS does not partition the disk correctly when upgrading from version 6 to version 7.
Mikrotik mentioned this in one of the descriptions for the 7th line.
The only option for you is to export the configuration to the console, copy and save it as a script.
Next, NetInstall 7.18.1 and loading the configuration through the console or script.
Yes, that certainly is the case. Netinstall and import an export made just before (not a restore of a backup).Thanks for the advice, It seems based on this that it would be recommended to netinstall when moving from v6 to v7.
The ticket system allows submitting feature requests ;)This sounds as horrible as the old technique of operating old Cisco IOS without Commit, where you would schedule a reboot and if by the time of the reboot you didn't cancel that reboot or if you didn't do a "copy running-config startup-config" you might be saved by the scheduled reboot.
I was already giving the same advice a few years ago, it's how I work...
example code
0) If it's a bug like the one reported above(¹), you're fu–ed anyway... 1) Make a binary backup 2) Make one export 3) Schedule the reload on A) REBOOT and on B) after xx minutes (It depends on how long you think it will take to make the changes, usually 10 minutes is enough) 4) Do the work 5) Make again one export 6) Compare prev/next export for review the differencies 7) If all is OK remove scheduled reload on point 3)(¹) viewtopic.php?p=1131405#p1131111
I also used scripts in TCL for situations where I needed to change interface IPs and would lose access during the commands... A huge GAMBIARRA.
I think it's worth considering the possibility of having 2 options...Just to give you an example, Arista's EOS gives you 2 options!
- The first being "safe-mode" centric, as most current MikroTik users are used to.
- The second being "commit/rollback" centric, as most users of more robust equipment are used to.
Why can't MikroTik consider a way to deliver both possibilities and leave it up to the operator?
- configure terminal, where the commands take effect immediately after being applied.
- configure session, where the commands only take effect at the time of commit.
I'm seeing similar problems with several different CRS devices using S+RJ10 SFP+ modules.I have a problem with SFP PON module on Heh S
After updating to 7.18.1, a problem appeared.
After a hot reboot, the link on the SFP port is not raised.
If the provider reboot the module remotely, everything is ok.
If I warm reboot the Hex S - the link on the SFP port does not rise.
sfp-type: SFP/SFP+/SFP28/SFP56
sfp-connector-type: RJ45
sfp-link-length-copper-active-om4: 1m
sfp-vendor-name: MikroTik
sfp-vendor-part-number: S+RJ10
sfp-vendor-revision: 2.16
My ISP advised me to set the speed on the port manually.
I'm seeing similar problems with several different CRS devices using S+RJ10 SFP+ modules.
When running 7.18 and 7.18.1 , the links using S+RJ10 very often never complete autonegotation and the links never come up. Other links using DA cables or other SFP+ modules work fine.
Sometimes, bouncing the port down and up will establish the links.
The links always come up with RouterOS 7.17.2 and lower.
SFP info:
From 7.18 change log:The links always come up with RouterOS 7.17.2 and lower.
S+RJ10 are only supposed to run with auto-negotiation on.My ISP advised me to set the speed on the port manually.
I'm seeing similar problems with several different CRS devices using S+RJ10 SFP+ modules.
When running 7.18 and 7.18.1 , the links using S+RJ10 very often never complete autonegotation and the links never come up. Other links using DA cables or other SFP+ modules work fine.
Sometimes, bouncing the port down and up will establish the links.
The links always come up with RouterOS 7.17.2 and lower.
SFP info:
Also I want to try to enable the "Ignore Rx Lose" option. But remotely I don't want to play this game :)
Was the instability of CAKE that you previously mentioned really limited to having an interface with a CAKE queue and then deleting the queue type?*) queue - fixed system failure when CAKE kind queue was configured but queue type definition does not exist anymore (introduced in v7.18);
DoH server connection error: SSL: ssl: no trusted CA certificate found (6)
DoH server connection error: SSL: ssl: no trusted CA certificate found (6) [ignoring repeated messages]
DoH server connection error: SSL: ssl: no trusted CA certificate found (6)
DoH server connection error: SSL: ssl: no trusted CA certificate found (6) [ignoring repeated messages]
Can you share your config? Just to be sure...Im not using DoH in DNS settings (Use DoH is empty) and never used it, anybody knows whats this about?
/ip dns export
Can you share your config? Just to be sure...Im not using DoH in DNS settings (Use DoH is empty) and never used it, anybody knows whats this about?
Code: Select all/ip dns export
ip dns
set cache-max-ttl=5d cache-size=5000KiB doh-max-concurrent-queries=5000 max-concurrent-queries=5000 max-concurrent-tcp-sessions=50 servers=192.168.2.2 verify-doh-cert=yes
Hi,@matiss sent supoutCode: Select allip dns set cache-max-ttl=5d cache-size=5000KiB doh-max-concurrent-queries=5000 max-concurrent-queries=5000 max-concurrent-tcp-sessions=50 servers=192.168.2.2 verify-doh-cert=yes
verify-doh-cert=yes
I already did that, i enabled it and entered random letter "a" and then set verify-doh=no then disabled it and looks good.Hi,
@matiss sent supoutCode: Select allip dns set cache-max-ttl=5d cache-size=5000KiB doh-max-concurrent-queries=5000 max-concurrent-queries=5000 max-concurrent-tcp-sessions=50 servers=192.168.2.2 verify-doh-cert=yes
If you don't use DoH why do you have it enabled? I understand that it will be a bug, because it won't let you configure it if you don't set use-doh to yes.
Code: Select allc
Regards,
Well my pingtest is only in local net but i don't see any issues here.The folks reporting increased latency and packet loss with 7.18 have really dampened my enthusiasm to upgrade. Anyone gotten to the bottom of that yet?
We reviewed the received supout.rif file.@matiss sent supoutCode: Select allip dns set cache-max-ttl=5d cache-size=5000KiB doh-max-concurrent-queries=5000 max-concurrent-queries=5000 max-concurrent-tcp-sessions=50 servers=192.168.2.2 verify-doh-cert=yes
🔴️ 2025-03-06 14:48:04 lte;error lte1 mbim: >>> E #46 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:04 lte;error lte1 mbim: >>> E #47 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:04 lte;error lte1 mbim: >>> E #48 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:04 lte;error lte1 mbim: >>> E #49 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:05 lte;error lte1 mbim: >>> E #50 - ms uicc: 2, error: MS_SELECT_FAILED
🔴️ 2025-03-06 14:48:27 lte;error lte1 mbim: >>> E #51 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:27 lte;error lte1 mbim: >>> E #52 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:27 lte;error lte1 mbim: >>> E #53 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:27 lte;error lte1 mbim: >>> E #54 - ms uicc: 3, error: MS_INVALID_LOGICAL_CHANNEL
🔴️ 2025-03-06 14:48:28 lte;error lte1 mbim: >>> E #55 - ms uicc: 2, error: MS_SELECT_FAILED
Should be fine IMO. the difference is nowhere near that much. even 500k would surprise meWith 1472 KiB free space can I upgrade from 7.16.2 without problems?
Manually setting the speed on the SFP PON helped me.My ISP advised me to set the speed on the port manually.
I'm seeing similar problems with several different CRS devices using S+RJ10 SFP+ modules.
When running 7.18 and 7.18.1 , the links using S+RJ10 very often never complete autonegotation and the links never come up. Other links using DA cables or other SFP+ modules work fine.
Sometimes, bouncing the port down and up will establish the links.
The links always come up with RouterOS 7.17.2 and lower.
SFP info:
Also I want to try to enable the "Ignore Rx Lose" option. But remotely I don't want to play this game :)
By now i downgraded to 7.17.2 and packet loss gone, latency returned to stable and normal.The folks reporting increased latency and packet loss with 7.18 have really dampened my enthusiasm to upgrade. Anyone gotten to the bottom of that yet?
The problem appears when traffic through CCR1072 is more than 2-3 Gbps duplex at 7.18.1.Well my pingtest is only in local net but i don't see any issues here.The folks reporting increased latency and packet loss with 7.18 have really dampened my enthusiasm to upgrade. Anyone gotten to the bottom of that yet?
The other ones aren't updated yet.
As an AX3 user I have my fingers crossed!*) wifi - improved stability for wifi interfaces;
Same problem with 7.18.2.I'm seeing similar problems with several different CRS devices using S+RJ10 SFP+ modules.
When running 7.18 and 7.18.1 , the links using S+RJ10 very often never complete autonegotation and the links never come up. Other links using DA cables or other SFP+ modules work fine.
Why not? I can confirm its http (not https). There are no sensitive data in those data.Is the upgrade packages are really downloaded via http? Why? And took very long time to download 7.18.2 few minutes ago.
If https is used, then client can verify authenticity of server it's talking to.Why not?Is the upgrade packages are really downloaded via http? Why?
1. I can recreate this by disabling BTH and re-enabling it.. same issueI've upgraded, and notice that my ipv4 NAT is masq to the same IP regardless of my srcnat rules.
The BTH dynamic NAT seems to be marked as "unknown" interface and it eating all of the masq?
I'm going to create a backup/regular wireguard user with full access.. disable the BTH and re-enable it.. see if the issue is fixed without me losing access via my primary BTH.
Regarding the small diskspace on devices with 16 MB flash, I really hope that MikroTik will split the routeros package in several smaller packages for RouterOS 7.x like it is done for RouterOS 6.x.
Likely this would be the right thing to do, especially after reassuring the users that 16 MB flash won't have issues with updates (e.g. in this thread back from RouterOS 6 era when the 16 MB flash devices were introduced).
If MTik have apply a diet on routeros and makes separate builds for some kind of usage types (wireless, other) then that would not resolve this issue just win some time. These 16M flash devices mainly wireless stuffs, maybe skipping unrelated functions from this kind of build win some space and time. It is uncomfortable only for endusers, yet...Here’s the legend: at a computer trade show in 1981, Bill Gates supposedly uttered this statement, in defense of the just-introduced IBM PC’s 640KB usable RAM limit: “640K ought to be enough for anybody.”
Which SFP modules are having issues?Many issues with the SFP in hexS, constant down/up.
It had to be downgraded after 10 minutes.
Digitally signed by MT provides the same protection as having https on the connection, but additionally it protects agains other methods of getting bad packages.If https is used, then client can verify authenticity of server it's talking to.
Why not?
Yes, npk files do have some verification built in (I believe that packages are digitally signed by MT so it's not trivial to alter the contents). But two layers of security are better than one. And we definitely don't want to install some hacked versions of ROS, do we?
[cont] failed to extract layer
was unable to import, container ......
You have the only ax3 made in Latvia then. ;-)I am not seeing much difference but then again I am lucky enough not to have those problems with disconnects like some others do.holvoe, can you comment on the wifi changes, good bad ugly??
For example:Which SFP modules are having issues?Many issues with the SFP in hexS, constant down/up.
It had to be downgraded after 10 minutes.
there is no real safety issue or problem downloading routeros packages via HTTP instead HTTPS...If https is used, then client can verify authenticity of server it's talking to.
Why not?
Yes, npk files do have some verification built in (I believe that packages are digitally signed by MT so it's not trivial to alter the contents). But two layers of security are better than one. And we definitely don't want to install some hacked versions of ROS, do we?
A milion times (literally).ever upgraded a linux server?
Not on my servers, I always edit sources.list and change http to https.nearly every package is also downloaded via HTTP (e.g. in "apt upgrade"...)
Thats why i use EL-Based :)(e.g. in "apt upgrade"...)
Just upload npk files and downgrade.HOW I DOWNGRADE TO 7.18.1?
I just update and i got tons of drops on network.
I use VLAN tagged network for split regular network from audio low latency network.
7.18.1 was just fine.
I get this when just 1 PC boots up, did you find a reason for it ?Yes I think that could be part of the reason, but what I observe is that on our main office network where there is lots of equipment running 24h/day I see this message immediately after the reboot (and I considered the same thing as you), however on other locations I see the message when the people come in during the morning. E.g. this was logged after a scheduled reboot last night at 01:01 to update to 7.18.1:I think the reason this has a high probability of appearing at reboot is because while the router is being rebooted, clients in the network are still firing DNS queries at it ...
2025-03-04T01:01:17+01:00 MikroTik HeadOffice possible SYN flooding on tcp port 53
2025-03-04T06:06:52+01:00 MikroTik Branch3 possible SYN flooding on tcp port 53
2025-03-04T08:24:20+01:00 MikroTik Branch4 possible SYN flooding on tcp port 53
2025-03-04T08:52:10+01:00 MikroTik Branch2 possible SYN flooding on tcp port 53
Yes! Maybe I don't want to share info with my ISP or anyone else about what I downloaded...Anyone can make a certificate these days.
It's all become so trivial...
The purpose of https is to encrypt the connection between two points, not to certify what passes through it...
However, yes, .npk files have 32 bit of signature at the end (and also .dpk, and also .fwf) so they can't be tampered with.
For now I fixed it by having a dedicated Linux VM serve as the DNS resolver for the network.I get this when just 1 PC boots up, did you find a reason for it ?2025-03-04T01:01:17+01:00 MikroTik HeadOffice possible SYN flooding on tcp port 53
2025-03-04T06:06:52+01:00 MikroTik Branch3 possible SYN flooding on tcp port 53
2025-03-04T08:24:20+01:00 MikroTik Branch4 possible SYN flooding on tcp port 53
2025-03-04T08:52:10+01:00 MikroTik Branch2 possible SYN flooding on tcp port 53
My thoughts were some kind of game lobby or game server search tool spamming the local DNS
edited: Nevermind. Likely not related.Same problem at CCR1072 and v7.18.1I can see a massive increase in latency spikes and loss after upgrading to v7.18 on multiple CCR2004-1G-12S+2XS
![]()
![]()
For what it matters, the passwords I'm using there is very strong and come with a very special characters, so maybe the upgrade didn't appreciate some of those special characters ...
In any system that involves things like scripting languages, web interfaces, etc I at least avoid these characters all the time:
@ % " $ & # + < > (space)
That never hurts even when it is not really necessary.
Thanks for the heads-up on passwords containing very special characters.after upgrading three Audience Mesh (RBD25G-5HPacQD2HPnD) from 7.16 to 7.18.2, I am no longer able to login, neither using the web interface nor WinBox.
:
For what it matters, the passwords I'm using there is very strong and come with a very special characters, so maybe the upgrade didn't appreciate some of those special characters ...
Guys do you have a comprehensive list about it?And I'd say that all multi-byte characters (UTF-8 or any other multi-byte encoding) are problematic as well.In any system that involves things like scripting languages, web interfaces, etc I at least avoid these characters all the time:
@ % " $ & # + < > (space)
That never hurts even when it is not really necessary.
Guys do you have a comprehensive list about it?
And I'd say that all multi-byte characters (UTF-8 or any other multi-byte encoding) are problematic as well.
I don't see too many reports regarding instability of recent ROS/routerboard versions on RB4011 ... so your observations might be related to your particular configuration (either configuration is marginalky wrong or it triggers some obscure bug). In which case you'll have to make some effort to identify (as precisrly as possible) the condition triggering the problem ... and communicate it directly to Support. Without doing it the problem might bever be corrected.QQ: is it safe to upgrade routerboard firmware to v7.18.2 in RB4011? In the past I've had stability issues and I've found that "firmware" 7.7 to be behaving okay.
There isn't a dedicated changelog for routerboard firmware. Occasionally there are changes, mentioned in ROS changelog. But that doesn't mean there aren't other changes in firmware which aren't important (to MT at least) to be mentioned. OTOH I remember that changes in firmware were not frequent already in times when routerboard firmware version was unrelated to ROS version ... and I'd expect that routerboard firmware for mature devices (such as RB4011) doesn't change very often (apart from version number).QQ2: Is there any changelog to routerboard firmware?
QQ: is it safe to upgrade routerboard firmware to v7.18.2 in RB4011? In the past I've had stability issues and I've found that "firmware" 7.7 to be behaving okay.
QQ2: Is there any changelog to routerboard firmware?
What's new in 7.18 (2025-Feb-24 10:47):
*) device-mode - do not allow changing CPU frequency if "routerboard" is not allowed by device mode (introduced in v7.17);
*) routerboot - disable packet switching during etherboot for hEX refresh ("/system routerboard upgrade" required);
*) routerboot - improved stability for IPQ8072 ("/system routerboard upgrade" required);
What's new in 7.17.2 (2025-Feb-06 11:10):
*) device-mode - do not allow changing CPU frequency if "routerboard" is not allowed by device mode (introduced in v7.17);
What's new in 7.17 (2025-Jan-16 10:19):
!) device-mode - after upgrade, mode "enterprise" is renamed to "advanced" and traffic-gen, partition (command "repartition"), routerboard and install-any-version features will be disabled;
*) device-mode - added routerboard, install-any-version and partitions features;
*) ethernet - improved linking after reboot for hAP ax lite devices ("/system routerboard upgrade" required);
*) routerboot - fixed boot MAC for devices with Alpine CPU ("/system routerboard upgrade" required);
*) routerboot - fixed boot MAC for MIPSBE CRS3xx and CRS5xx switches ("/system routerboard upgrade" required);
*) routerboot - improved stability for IPQ8072 and IPQ6010 when flash-boot is used ("/system routerboard upgrade" required);
*) sfp - improved initialization for certain SFP modules on CRS309 and CRS317 devices ("/system routerboard upgrade" required);
What's new in 7.16.2 (2024-Nov-26 14:09):
*) ethernet - improved linking after reboot for hAP ax lite devices ("/system routerboard upgrade" required);
*) routerboot - improved stability for IPQ8072 and IPQ6010 when flash-boot is used ("/system routerboard upgrade" required);
What's new in 7.16.1 (2024-Oct-10 17:03):
*) sfp - improved initialization for certain SFP modules on CRS309 and CRS317 devices ("/system routerboard upgrade" required);
What's new in 7.16 (2024-Sep-20 16:00):
*) routerboard - improved Etherboot stability for CRS320-8P-8B-4S+ device ("/system routerboard upgrade" required);
*) routerboard - improved Etherboot stability for IPQ-40xx devices ("/system routerboard upgrade" required);
*) routerboot - improved boot process ("/system routerboard upgrade" required);
*) system - set flash-boot mode as "boot-device" after system reset initiated by reset button ("/system routerboard upgrade" required);
What's new in 7.15.3 (2024-Jul-24 13:36):
*) routerboard - improved Etherboot stability for CRS320-8P-8B-4S+ device ("/system routerboard upgrade" required);
What's new in 7.14 (2024-Feb-29 09:10):
*) routerboard - added "reset-button" support for RBwAPR-2nD device;
What's new in 7.13.2 (2024-Jan-12 11:51):
*) routerboard - added "reset-button" support for RBwAPR-2nD device;
What's new in 7.12 (2023-Nov-09 09:45):
*) routerboard - added "reset-button" support for RB800, RB1100 and RB1100AHx2 devices;
*) routerboard - fixed "reset-button" support for wAP ac and wAP R ac devices;
What's new in 7.11 (2023-Aug-15 09:33):
*) routerboard - fixed "gpio-function" setting on RBM33G ("/system routerboard upgrade" required);
*) routerboard - improved RouterBOOT stability for Alpine CPUs ("/system routerboard upgrade" required);
*) routerboard - removed unnecessary serial port for netPower16P and hAP ax lite devices ("/system routerboard upgrade" required);
*) routerboot - increased etherboot bootp timeout to 40s on MIPSBE and MMIPS devices ("/system routerboard upgrade" required);
What's new in 7.10 (2023-Jun-15 08:17):
*) routerboard - fixed memory test on CCR2116-12G-4S+ ("/system routerboard upgrade" required);
*) routerboard - improved RouterBOOT stability for Alpine CPUs ("/system routerboard upgrade" required);
*) routerboot - increased "preboot-etherboot" maximum value to 30 seconds ("/system routerboard upgrade" required);
What's new in 7.9.2 (2023-May-30 16:49):
*) routerboard - improved RouterBOOT stability for Alpine CPUs ("/system routerboard upgrade" required);
What's new in 7.9 (2023-May-02 08:35):
*) routerboot - added "preboot-etherboot" and "preboot-etherboot-server" settings ("/system routerboard upgrade" required) (CLI only);
What's new in 7.8 (2023-Feb-24 11:03):
*) lte - LtAP improved modem detection in lower mini-PCie slot ("/system routerboard upgrade" required);
*) routerboot - fixed format storage for RBM33G device ("/system routerboard upgrade" required);
*) routerboot - fixed protected routerboot for RBM33G device ("/system routerboard upgrade" required);
QQ: is it safe to upgrade routerboard firmware to v7.18.2 in RB4011?
As explained in my post, I logged into the devices to update them with the very same credentials that don't work now after the update. Nothing else has changed, no IP address or whatever. In my case, the passwords were stored in Firefox, but to be entirely sure I also tried the ones I had stored in my keepass file, all to no avail. Tried via web and WinBox and SSH (haven't set up public key authentication, unfortunately ...), nothing worked. I'll try to reproduce the problem with another device still on 7.16 and the same password and see what happens ...Thanks for the heads-up on passwords containing very special characters.after upgrading three Audience Mesh (RBD25G-5HPacQD2HPnD) from 7.16 to 7.18.2, I am no longer able to login, neither using the web interface nor WinBox.
:
For what it matters, the passwords I'm using there is very strong and come with a very special characters, so maybe the upgrade didn't appreciate some of those special characters ...
Are you sure you are trying to login from an authorized IP address via authorized network?
If you have the password in a pw manager did you try to copy & paste the the password?
Did you try WinBox MAC also?
Do you have the opportunity to login via SSH key-authentication?
Or MikroTik mobile app?
Just few more ideas:As explained in my post, I logged into the devices to update them with the very same credentials that don't work now after the update. Nothing else has changed, no IP address or whatever. In my case, the passwords were stored in Firefox, but to be entirely sure I also tried the ones I had stored in my keepass file, all to no avail. Tried via web and WinBox and SSH (haven't set up public key authentication, unfortunately ...), nothing worked. I'll try to reproduce the problem with another device still on 7.16 and the same password and see what happens ...
Update your winbox?
As explained in my post, I logged into the devices to update them with the very same credentials that don't work now after the update. Nothing else has changed, no IP address or whatever. In my case, the passwords were stored in Firefox, but to be entirely sure I also tried the ones I had stored in my keepass file, all to no avail. Tried via web and WinBox and SSH (haven't set up public key authentication, unfortunately ...), nothing worked. I'll try to reproduce the problem with another device still on 7.16 and the same password and see what happens ...
Same here... I am not at home and I can't connect to my router to try to fix it.Looks like Mikrotik doesn't test their releases on 16MB devices at all. My hAP AC2 has 0MB free after update to ROS 7.18 and now Ican't even reboot it... Forced will go to do netinstall...
16 MB devices should not be used as routers any more.
Well, for 33% of price increase one gets 300% faster device (when comparing RBD52G and RB750Gr3) ... OK, with half of RAM, but mine is one of the early ones with 256MB RAM. And better internal interconnect topology.hAP ac2 without wireless or wifi-qcom-ac is not a reasonably expected use of that device.
Normally you would buy a hEX for that use-case.
Also noticed this. Lo (Loopback) interface is also not exported.After updating from 7.16.1 to 7.18.1 /export show-sensitive terse started showing new bogus interface
/interface ovpn-server server add mac-address=[...] name=ovpn-server1
While it's disabled by default, I would prefer default config and especially updates not to create bogus interfaces.
> /system/resource/print
uptime: 5d21h43m20s
version: 7.18.2 (stable)
build-time: 2025-03-11 11:59:04
factory-software: 6.42.1
free-memory: 22.9MiB
total-memory: 64.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 650MHz
cpu-load: 3%
free-hdd-space: 3316.0KiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 699
write-sect-total: 78019
architecture-name: mipsbe
board-name: LtAP mini
platform: MikroTik
> /system/package/print
Flags: X - DISABLED; A - AVAILABLE
Columns: NAME, VERSION, BUILD-TIME, SIZE
# NAME VERSION BUILD-TIME SIZE
0 wireless 7.18.2 2025-03-11 11:59:04 1468.1KiB
1 routeros 7.18.2 2025-03-11 11:59:04 10.5MiB
Yes and things don't seem to improve in the new versions...Space issue primarily concerns ARM platform.
Testing all the settings, it doesn't seem to be AES-256-CTR, but using it together with Auth: sha256
-----> OK
add enc-algorithms=aes-256-ctr lifetime=1h name=pp_pha2_RemoteOffices pfs-group=ecp521
-----> NOK
add enc-algorithms=aes-256-ctr lifetime=1h auth-algorithms=sha256 name=pp_pha2_RemoteOffices pfs-group=ecp521
Failed with: auth-algorithms=sha256
Look on page 1 of this topic!I have upgraded a PPC 1100AHx2 router to 7.18.2 from 7.13 and the login page is messed up. Any ideas?
Interesting.Space issue primarily concerns ARM platform.
> /system/resource/print
uptime: 1h29m37s
version: 7.18.2 (stable)
build-time: 2025-03-11 11:59:04
factory-software: 6.45.9
free-memory: 31.5MiB
total-memory: 128.0MiB
cpu: ARM
cpu-count: 4
cpu-frequency: 896MHz
cpu-load: 1%
free-hdd-space: 148.0KiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 830
write-sect-total: 11616
architecture-name: arm
board-name: wAP R ac
platform: MikroTik
Are you referring to the posts about variables being removed from branding? This router has never had any branding applied AFAIK. It has been running regular Mikrotik firmware updated at various times from some version of 5 when it was installed brand new from the box.Look on page 1 of this topic!I have upgraded a PPC 1100AHx2 router to 7.18.2 from 7.13 and the login page is messed up. Any ideas?
+10000Sorry Mikrotik but I think you are seriously underestimating the problems of 16MB flash devices. This weekend happened to me with my beloved AC2. I purchased this device in 2021 when there was still ROS v6, when v7 arrived at something like 7.5 I simply upgraded without any particular problems. With 7.13 (or 7.12? I don't remember) the Wifi-Wireless packets were split and I still thank you for making the AC2 series with a serious wifi but I encountered memory problems and decided to proceed with Netinstall. Since then I have never had any particular problems with memory considering that it is a home router with default configuration, Capsman, 2-3 custom rules in the firewall and several Wireguard and SSTP VPNs that it manages very well. Once I got to 7.17.2 I waited for 7.18.2 to be released and when I rebooted I found myself with a working router but again with 0 Kb free and without any possibility of doing anything, even a simple reboot was impossible. I accidentally discovered on this forum the command "/console/clear-history" (but why is it not reported in any official document? a list of useful commands for ROS maintenance would not be bad) that initially gave me about 50 Kb but once I rebooted I found myself again with 0 Kb free and no way to free up memory. I had to waste a lot of time to make a backup and proceed with netinstall. It would be much appreciated if Mikortik once and for all explained whether once netinstall has been executed the user can simply restore the backup file without the risk of restoring any residues or it is advisable (which is what I did) to use the .RSC file which however does not import certificates for example. However, netinstall was useful and I find myself with the same configurations with 250-350 Kb free with the router operating, without any configuration I had 380 Kb free. However, I find it a bit negative that by moving from a stable to a stable (7.17. 2 > 7.18. 2) I found myself in these conditions that I could accept with alpha-beta versions but not on stable versions. I believe that we need to find a quick solution for these 16MB flash devices (you have to accept the fact that it was in 2021 and still today a serious mistake of underestimation to introduce such small devices to the market) as reading on the forum it is a growing problem. Either a way is found to reduce the size of ROS, as many propose by dividing the packages or perhaps a way to ensure that netinstall is not necessary to free up space, in the end it is not clear what happens in the flash for which the space is reduced to such an extent that it can no longer be freed up unless formatted. Personally I have understood two things: I will avoid any future purchase of Mikrotik devices that do not have at least 128 MB of flash (I will never understand, in 2013 the entire 951 home series had 128 MB of RAM, what logic in reducing it 10 years later?!) and go very easy with future ROS updates at least on 16 MB devices, but I wonder if before the release of a stable version they really do some tests or not... Oh little tip: the new features related to USB disks are very nice but please put those "Disk" settings in order because it's total chaos like this!
ip addr show enp5s0
3: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 6c:24:08:0d:7f:16 brd ff:ff:ff:ff:ff:ff
altname enx6c24080d7f16
inet 192.168.88.2/32 scope global noprefixroute enp5s0
valid_lft forever preferred_lft forever
inet6 fe80::d8c5:3d72:c264:879/64 scope link noprefixroute
valid_lft forever preferred_lft forever
sudo ./netinstall-cli -v -i enp5s0 routeros-7.18.2-arm.npk
Version: 7.18.2(2025-03-11 13:07:03)
Waiting for Link-UP on enp5s0
Using client IP 192.168.88.3
Could not match client IP 192.168.88.3 to interface enp5s0
sudo ./netinstall-cli -v -a 192.168.88.2 routeros-7.18.2-arm.npk
Version: 7.18.2(2025-03-11 13:07:03)
Using interface enp5s0
Using interface enp5s0
Waiting for Link-UP on enp5s0
Server IP and client IP cannot be the same
Did you even read the manual of netinstall-cli? It doesn't seem like you did.And two way with netinstall :Code: Select allsudo ./netinstall-cli -v -i enp5s0 routeros-7.18.2-arm.npk Version: 7.18.2(2025-03-11 13:07:03) Waiting for Link-UP on enp5s0 Using client IP 192.168.88.3 Could not match client IP 192.168.88.3 to interface enp5s0
Code: Select allsudo ./netinstall-cli -v -a 192.168.88.2 routeros-7.18.2-arm.npk Version: 7.18.2(2025-03-11 13:07:03) Using interface enp5s0 Using interface enp5s0 Waiting for Link-UP on enp5s0 Server IP and client IP cannot be the same
Both way do not work....
/netinstall-cli
Version: 7.18.2(2025-03-11 13:07:03)
No packages supplied
./netinstall-cli [-r] [-e] [-b] [-o] [-k <keyfile>] [-s <userscript>] {-i <interface> | -a <client-ip>} [PACKAGE]+
-r apply default configuration
-e apply empty configuration
-r and -e are mutually exclusive
by default existing configuration will be kept
-b remove branding
-o install devices only once
-v verbose mode
Are you sure?1. I am not using a /32 subnet, but a /24
inet 192.168.88.2/32
Then the docs page seems to be wrong.netinstall HAS a -v flag on linux
I see no use in disabling NetworkManager for netinstalling?I am sure I used a /24. It is weird, I had to disable NetworkManager service and perform many tests to be able to netinstall. I was not easy at all :(
net.ifnames=0
Thanks ! Good to know !Thanks to namespaces the netinstall can be made bullet-proof on Linux. I use this scripts as a wrapper: https://aur.archlinux.org/cgit/aur.git/ ... netinstall
Wait, that's not standard? I've ever only used the package from AUR, not the manual thing from Mikrotik download ¯\_(ツ)_/¯.Thanks to namespaces the netinstall can be made bullet-proof on Linux. I use this scripts as a wrapper: https://aur.archlinux.org/cgit/aur.git/ ... netinstall
previously i had hap ac2 without any problem (wifi-qcom-ac package) some days ago i have access to a hap ax2, i migrated keeping the same config (only bridge)Intel AX210 has some quite limited frequency range on 5ghz.Hi,
I have "funny Problem" with cAPGi-5HaxD2HaxD and the 7.18.1 and the latest 7.17.2 Version, Only the 7.18 Version works flawlessly:
Some Android devices (mainly with Mediatek AC or AX Chipset, but also some Linux machines with Intel 210 AX Wifi Nics) have tthe Problem that they
don't see the SSID of the 5 GHz Band, when 7.18.1 or 7.17.2 Version.
After rescanning several time, sometimes they are able to "see" it but still unable to connect, because they say in the logs the SSID disappears.....
ONLY the 7.18 Work fine regarding this issue - don't know why.
First I thoght it is a simpley "country setting" issu, but no, it has nothing to do with dhe channel or country selection, even I I use only the Channel 36-42 the issue is absolutely the same .
I am a bit disappointed that the issure re-occured with the last Update 7.18.1 though.....
The Other Problem which exists with ALL Versions so far, my Linux machine with Intel 210AX does only connect on 5 GHz in 300N Mode, not AC and not AX.... but Just for the record, I didn't examine that problem too deep yet...
Cheers
4920441
Got my own experience with that and BE200.
Try changing it to something like 5500mhz.
Up to channel 128 works fine tho
Connecting an old 2008 Mac Pro with 15.3.2 installed to an AX3 SMB Server i get the following resultsCan a few people test built-in SMB performance? On two of my devices, SMB to macOS is really bad (11-20MB/s), but on 7.16.2 and 7.17.2 it's fine (200-900MB/s).
So it works as expected and is maxing out your 1Gbps link as the CrystalDiskMark is represented in MB/s vs Mbps which is a good thing
From where?7.18ab244pppoe
ask mikrotikFrom where?7.18ab244pppoe
I was 100% sure that it was the mac cpu being the limiting factor ( i mean its almost 20 years old) BUT:So it works as expected and is maxing out your 1Gbps link as the CrystalDiskMark is represented in MB/s vs Mbps which is a good thing
... and it's a black magic (pun intended) as to why it only works at half speed when SMB client is MAC device. Personally I wouldn't consider 50MB/s (give or take) "a struggle" ... but there might be other problems (as hinted but not elaborated by @itimo01) when using a MAC.
Hello,previously i had hap ac2 without any problem (wifi-qcom-ac package) some days ago i have access to a hap ax2, i migrated keeping the same config (only bridge)
Intel AX210 has some quite limited frequency range on 5ghz.
Got my own experience with that and BE200.
Try changing it to something like 5500mhz.
Up to channel 128 works fine tho
i only have 2 devices connected to 5ghz radio, both with windows 10, one with intel ac9260 wNIC the other with intel ax210 wNIC
since i have hap ax2 ax210 client have frequent disconnects, the 9260ac client also losses packets at the same time but just dont disconnect
i put a MK audience to make a wireless capture at problem moment and looks like hap ax2 radio just go to take a nap for some seconds, no beacons no nothing when the problem arises, capture shows clients retrying but without ap response
somebody with similar problem?
i started with 7.16.2 which hap ac2 had and worked flawlessly hap ax2 have the problem with 7.16.2, upgraded the hap ax2 to 7.18.2 but the problem stays
Problems is recurrent, happens at least 3 times per day
/system/resource/print
uptime: 1w6d9h3m49s
version: 7.18.2 (stable)
build-time: 2025-03-11 11:59:04
factory-software: 7.5
free-memory: 636.7MiB
total-memory: 1024.0MiB
cpu: ARM64
cpu-count: 4
cpu-frequency: 864MHz
cpu-load: 3%
free-hdd-space: 87.7MiB
total-hdd-space: 128.0MiB
write-sect-since-reboot: 331737
write-sect-total: 7227970
bad-blocks: 0%
architecture-name: arm64
board-name: hAP ax^2
platform: MikroTik
system/package/print
Columns: NAME, VERSION, BUILD-TIME, SIZE
# NAME VERSION BUILD-TIME SIZE
0 user-manager 7.18.2 2025-03-11 11:59:04 332.1KiB
1 wifi-qcom 7.18.2 2025-03-11 11:59:04 10.2MiB
2 rose-storage 7.18.2 2025-03-11 11:59:04 3136.1KiB
3 routeros 7.18.2 2025-03-11 11:59:04 12.3MiB
4 zerotier 7.18.2 2025-03-11 11:59:04 836.1KiB
5 container 7.18.2 2025-03-11 11:59:04 100.1KiB
/interface/wifi/ex
# 2025-03-28 20:06:50 by RouterOS 7.18.2
# model = C52iG-5HaxD2HaxD
/interface wifi security
add authentication-types=wpa2-psk disabled=no group-encryption=ccmp group-key-update=20m name=sec1 wps=\
disable
/interface wifi
set [ find default-name=wifi1 ] channel.frequency=5500 .secondary-frequency=disabled .skip-dfs-channels=\
disabled configuration.country=Greece .manager=local .mode=ap .ssid=FFast datapath.bridge=bridge1 \
.client-isolation=no disabled=no security.authentication-types=wpa2-psk,wpa3-psk .ft=yes .ft-over-ds=\
yes
# no connection to CAPsMAN, managed locally
set [ find default-name=wifi2 ] configuration=cfg1 configuration.manager=capsman-or-local .mode=ap
/interface wifi cap
set caps-man-addresses=127.0.0.1 certificate=request discovery-interfaces=bridge1
/interface wifi capsman
set ca-certificate=auto enabled=yes package-path="" require-peer-certificate=no upgrade-policy=none
/interface wifi configuration
add channel.width=20mhz country=Greece datapath=datapath1 disabled=yes mode=ap name=cfg1 security=sec1 \
security.ft=yes .ft-over-ds=yes ssid=Capsman
/interface wifi datapath
add bridge=bridge1 client-isolation=no disabled=no name=datapath1
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no master-configuration=cfg1
interface/wifi/registration-table/pr
Flags: A - AUTHORIZED
Columns: INTERFACE, SSID, MAC-ADDRESS, UPTIME, LAST-ACTIVITY, SIGNAL, AUTH-TYPE, BAND
# INTERFACE SSID MAC-ADDRESS UPTIME LAST-ACTIVITY SIGNAL AUTH-TYPE BAND
0 A wifi1 FFast 12:2D:49:xx:xx:xx 8h12m6s 54s10ms -55 wpa3-psk 5ghz-ac
1 A wifi1 FFast F6:7E:F3:xx:xx:xx 5h36m43s 9s -71 wpa3-psk 5ghz-ac
2 A wifi1 FFast AA:8F:89:xx:xx:xx 4h1m36s 0ms -61 wpa3-psk 5ghz-ac
3 A wifi1 FFast D0:9C:7A:xx:xx:xx 2h15m19s 3s -81 wpa3-psk 5ghz-ac
4 A wifi1 FFast 9C:30:5B:xx:xx:xx 29m31s 0ms -61 ft-wpa3-psk 5ghz-ac
5 A wifi1 FFast 14:5F:94:xx:xx:xx 29m19s 3s -60 wpa2-psk 5ghz-ac
set [ find default-name=wifi2 ] configuration=cfg1 configuration.manager=capsman-or-local .mode=ap
/interface wifi cap
set caps-man-addresses=127.0.0.1 certificate=request discovery-interfaces=bridge1
Yea, ive ran into this...but only if you're using the exact same IP pool (10.1.1.100 - 10.1.1.199). When I notice that, ill just add another IP (10.1.1.99 - 10.1.1.199) and it will create it just fine.When doing a demo for my co-workers today, I noticed that you can use the "DHCP setup" wizard only once.
It creates the same name for the IP pool every time, so the second time you use it, it errors out with "pool already exists".
(I tried using it to create a new DHCP instance for a new VLAN that I had just created)
It would be better to include the interface name in the pool name, also for self-documenting the setup.
You're comparing different devices which use different drivers.I did the same tests on a hAPac2 with the same version 7.18.2 and when adding the virtual interface it does NOT add it as a port to the bridge automatically.
I appreciate your thought and contribution. Tried this, if I interpret correctlybtw this config is wrong:
If you want to use the local interfaces in capsman you set them to "local" and switch to the radio tab and hit "provision".Code: Select allset [ find default-name=wifi2 ] configuration=cfg1 configuration.manager=capsman-or-local .mode=ap /interface wifi cap set caps-man-addresses=127.0.0.1 certificate=request discovery-interfaces=bridge1
I'm using capsman (with local interfaces) + NO ft-over-ds and never had any issues.
There was the thought going around on some topics if this might only happen on "non-capsman" devices. Not sure if someone ever tried this.
So if you want to try you can provision your radio with capsman ig.
/interface wifi
set [ find default-name=wifi2 ] configuration.mode=ap
/interface wifi datapath
add bridge=bridge1 client-isolation=no disabled=no name=datapath1
/interface wifi security
add authentication-types=wpa2-psk,wpa3-psk disabled=no group-encryption=ccmp group-key-update=20m name=sec1 wps=disable
/interface wifi configuration
add channel.frequency=5500 country=Greece datapath=datapath1 disabled=no mode=ap name=cfg1 security=sec1 security.ft=yes ssid=FFast
/interface wifi cap
set caps-man-addresses=127.0.0.1 certificate=request discovery-interfaces=bridge1
/interface wifi capsman
set ca-certificate=auto enabled=yes package-path="" require-peer-certificate=no upgrade-policy=none
/interface wifi provisioning
add action=create-dynamic-enabled disabled=no master-configuration=cfg1
2025-03-31 12:12:58 wireless,info 9C:30:5B:xx:xx:xx@wifi1 disconnected, connection lost, signal strength -60
2025-03-31 12:13:09 wireless,info 9C:30:5B:xx:xx:xx@wifi1 connected, signal strength -71
/routing table
add disabled=no fib name=test
add disabled=no fib name=test
Thanks for the heads up!I just realized I forgot to give a heads-up in this thread too, like I did in "v7.18rc [testing]":
Heads-up - breaking changes for management and monitoring:
*) console - put !empty sentence when API query returns nothing;
Same applies to other objects as well - partitions can have same name as well to create more confusion. Partitions can be renamed from command line though...I noticed that it is possible to add multiple routing tables with the same name:This is accepted without error message and then there are two tables with name test, and it is unclear which one is used.Code: Select all/routing table add disabled=no fib name=test add disabled=no fib name=test
SUP-184107 created.
definitely. ive upgraded a CCR 1072 vrrp-stack to 7.18.2, afterwards the vrrp instances have been disabled with weird errors. due to no time for debugging, after downgrade to 7.16.2 everything was fine.Is VRRP having any issues with this release. That’s the only thing stopping me from moving up my main core network.
Read something about connection syncing
Well, at least partitions also have a number that is visible to the user.Same applies to other objects as well - partitions can have same name as well to create more confusion. Partitions can be renamed from command line though...
If this were be the config related, then it should be mentioned the difference of configuration with pre 7.17 firmware.I have multiple VRRP (legacy IP and v6) running on CCR2216 with ROS 7.18.2 without issues. Maybe config related?
I think that is just a non-updated state. If you change the interface's name, it disappears.The only drawback the 7.18.2 router shows 'Connection tracking innactive' for VRRP instance, but the connection tracking is working.
Actually in most places it just works fine. You get the "already have such item" error and the add is refused.Be it routing table names or partition names - all points towards the need of better configuration integrity checks. We might not be able to get full reference level checks but object name level checks should be one of most basic things there is...
My experience is that ping watchdog reboots device real fast ... when pings start to fail. Beware that it'll trip also when "reference" device becomes unavailable for some reason. The question remains whether pings will fail when cAPs become "non-operational" though.I'm curious if I enable ping watchdog, if that reboots the cAPs faster.
I've got another cAP that went into a non-operational state but it recovered by itself in about 30 minutes. On the CRS switch I see the ethernet port alocated for the cAP flapping continuously until the device recovered.My experience is that ping watchdog reboots device real fast ... when pings start to fail. Beware that it'll trip also when "reference" device becomes unavailable for some reason. The question remains whether pings will fail when cAPs become "non-operational" though.I'm curious if I enable ping watchdog, if that reboots the cAPs faster.
/ip/route/add dst-address=192.168.100.0/24 gateway=vrf-A@vrf-A
Have you changed the bridge priority? I would set 0 for the root bridge and F000 for the AP.My devices never rebooted or kernel paniced. A sole RSTP/bridge issue. I always resolved it by toggling ethernet interface to get port to forward again. Now my devices run 7.15.3 and the issue never appeared again. One could think it is something from 7.18 causing it........