I think the VLAN is working nicely regardless of the frame=type setting for ether 7. But, when I change ether7 from frame=type=admit-all to frame-type=admit-only-vlan-tagged I lose the ability to connect to the CRS via ROMON from the 5009.
CRS326 config:
# 2025-04-10 11:20:26 by RouterOS 7.18.2
# software id = 4RSG-G05N
#
# model = CRS326-24G-2S+
# serial number = HGC09QKCXFY
/interface bridge
add admin-mac=D4:01:C3:83:B5:2F auto-mac=no comment=defconf frame-types=\
admit-only-vlan-tagged name=bridge vlan-filtering=yes
/interface vlan
add comment=vlan32 interface=bridge name=vlan32 vlan-id=32
/interface list
add name=LAN
add name=TRUSTED
/ip pool
add comment=OffiBridge name=OffBridge ranges=192.168.55.100-192.168.55.200
/ip smb users
set [ find default=yes ] disabled=yes
/port
set 0 name=serial0
/interface bridge port
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged \
interface=ether1
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=ether11
add bridge=bridge comment=defconf interface=ether12
add bridge=bridge comment=defconf interface=ether13
add bridge=bridge comment=defconf interface=ether14
add bridge=bridge comment=defconf interface=ether15
add bridge=bridge comment=defconf interface=ether16
add bridge=bridge comment=defconf interface=ether17
add bridge=bridge comment=defconf interface=ether18
add bridge=bridge comment=defconf interface=ether19
add bridge=bridge comment=defconf interface=ether20
add bridge=bridge comment=defconf interface=ether21
add bridge=bridge comment=defconf interface=ether22
add bridge=bridge comment=defconf interface=ether23
add bridge=bridge comment=defconf interface=sfp-sfpplus1
add bridge=bridge comment=defconf interface=sfp-sfpplus2
/ip firewall connection tracking
set udp-timeout=10s
/ip neighbor discovery-settings
set discover-interface-list=all
/ipv6 settings
set disable-ipv6=yes
/interface bridge vlan
add bridge=bridge tagged=bridge,ether1,sfp-sfpplus1 vlan-ids=32
/interface list member
add interface=bridge list=LAN
add interface=vlan32 list=TRUSTED
add interface=bridge list=TRUSTED
/interface ovpn-server server
add mac-address=FE:31:7F:F7:44:46 name=ovpn-server1
/ip address
add address=192.168.2.7/24 comment=defconf interface=bridge network=\
192.168.2.0
add address=10.21.32.2/24 interface=vlan32 network=10.21.32.0
add address=192.168.55.1 comment=OffBridge interface=ether24 network=\
192.168.55.1
/ip dhcp-server
add address-pool=OffBridge comment=OffBridge interface=ether24 name=Offbridge
/ip dns
set servers=1.1.1.1,10.21.32.1
/ip hotspot profile
set [ find default=yes ] html-directory=hotspot
/ip ipsec profile
set [ find default=yes ] dpd-interval=2m dpd-maximum-failures=5
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=10.21.32.1 routing-table=main \
suppress-hw-offload=no
/ip smb shares
set [ find default=yes ] directory=/flash/pub
/system clock
set time-zone-name=America/New_York
/system identity
set name=CRS326
/system note
set show-at-login=no
/system routerboard settings
set enter-setup-on=delete-key
/tool romon
set enabled=yes
/tool sniffer
set filter-interface=vlan32 filter-ip-protocol=icmp
# 2025-04-10 11:20:57 by RouterOS 7.18.2
# software id = 7RPI-TTI6
#
# model = RB5009UG+S+
# serial number = HJ30
/interface bridge
add admin-mac=F4:1E:57:C3:6E:8A auto-mac=no comment=defconf frame-types=\
admit-only-vlan-tagged name=bridge port-cost-mode=short vlan-filtering=\
yes
/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether2 ] comment=\
"Server1 -- Blue Iris vlan62 access port"
set [ find default-name=ether3 ] comment=\
"Server2 -- Proxmox/HA vlan62 access port"
set [ find default-name=ether4 ] comment=\
"hAPax3-downstairs trunk vlans 2, 12, 32, 42"
set [ find default-name=ether5 ] comment=\
"hAPax3-upstairs trunk vlans 2, 12, 32, 42"
set [ find default-name=ether6 ] comment="Joseph PC access port vlan32"
set [ find default-name=ether7 ] comment="MGMT access port vlan32"
set [ find default-name=ether8 ] comment=OffBridge
set [ find default-name=sfp-sfpplus1 ] comment=CSS326
/interface wireguard
add comment=Wireguard disabled=yes listen-port=53212 mtu=1420 name=wireguard1
/interface vlan
add comment="TV VLAN42" interface=bridge name=vlan-TV vlan-id=42
add comment="Guest WiFi VLAN2" interface=bridge name=vlan-guest vlan-id=2
add comment="IoT VLAN12" interface=bridge name=vlan-iot vlan-id=12
add comment="Management VLAN32" interface=bridge name=vlan-mgmt vlan-id=32
add comment="MOCA VLAN52" interface=bridge name=vlan-moca vlan-id=52
add interface=bridge name=vlan-printers vlan-id=82
add comment="Servers VLAN62" interface=bridge name=vlan-server vlan-id=62
add comment="VONAGE VLAN72" interface=bridge name=vlan-vonage vlan-id=72
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
add name=TRUSTED
add name=Iot-Cameras
/ip pool
add comment=offbridge-dhcp-server name=offbridge-dhcp-server ranges=\
192.168.55.2-192.168.55.200
add name=guest-pool ranges=10.21.2.100-10.21.2.252
add name=iot-pool ranges=10.21.12.100-10.21.12.252
add name=cameras-pool ranges=10.21.22.100-10.21.22.252
add name=mgmt-pool ranges=10.21.32.100-10.21.32.252
add name=TV-pool ranges=10.21.42.100-10.21.42.252
add name=MOCA-pool ranges=10.21.52.100-10.21.52.252
add name=servers-pool ranges=10.21.62.100-10.21.62.252
add name=vonage-pool ranges=10.21.72.100-10.21.72.252
/ip dhcp-server
add address-pool=guest-pool interface=vlan-guest name=dhcp-guest
add address-pool=iot-pool interface=vlan-iot name=dhcp-iot
add address-pool=mgmt-pool interface=vlan-mgmt name=dhcp-mgmt
add address-pool=offbridge-dhcp-server comment=offbridge-dhcp-server \
interface=ether8 name=offbridge-dhcp-server
add address-pool=MOCA-pool interface=vlan-moca name=dhcp-moca
add address-pool=servers-pool interface=vlan-server name=dhcp-servers
add address-pool=TV-pool interface=vlan-TV name=dhcp-TV
add address-pool=vonage-pool interface=vlan-vonage name=dhcp-vonage
/disk settings
set auto-media-interface=bridge auto-media-sharing=yes auto-smb-sharing=yes
/interface bridge port
add bridge=bridge comment="hAPax3-upstairs trunk vlan1" interface=ether5
add bridge=bridge comment="JRS PC; assign vlan32; access port" frame-types=\
admit-only-untagged-and-priority-tagged interface=ether6 pvid=32
add bridge=bridge comment=\
"MGMT; assign vlan32; access port -- temp trunk for CRS" interface=ether7
add bridge=bridge comment="CSS326; trunk vlan1" frame-types=\
admit-only-vlan-tagged interface=sfp-sfpplus1
add bridge=bridge comment=\
"Server1 -- Blue Iris; assign vlan62 tag; access port" frame-types=\
admit-only-untagged-and-priority-tagged interface=ether2 \
internal-path-cost=10 path-cost=10 pvid=62
add bridge=bridge comment=\
"Server2 -- Proxmox/HA; assign vlan62 tag; access port" frame-types=\
admit-only-untagged-and-priority-tagged interface=ether3 \
internal-path-cost=10 path-cost=10 pvid=62
add bridge=bridge comment="hAPax3-downstairs; trunk vlan1" frame-types=\
admit-only-vlan-tagged interface=ether4 internal-path-cost=10 path-cost=\
10
/ip neighbor discovery-settings
set discover-interface-list=TRUSTED
/ipv6 settings
set disable-ipv6=yes
/interface bridge vlan
add bridge=bridge comment=\
"ports bridge,4,5,sfp to carry vlan2 tagged frames out of 5009" tagged=\
bridge,ether4,ether5,sfp-sfpplus1 vlan-ids=2
add bridge=bridge comment=\
"port bridge,4,5,sfp to carry vlan12 tagged frames out of 5009" tagged=\
bridge,ether4,ether5,sfp-sfpplus1 vlan-ids=12
add bridge=bridge comment="ports bridge,4,5,sfp to carry vlan32 out of 5009 AN\
D assign vlan32 to frames arriving on ports 6,7 -- temp moved 7 to tagged \
from untagged" tagged=bridge,sfp-sfpplus1,ether4,ether5,ether7 untagged=\
ether6 vlan-ids=32
add bridge=bridge comment=\
"ports bridge,4,5,sfp to carry vlan42 frames out of 5009" tagged=\
bridge,ether4,ether5,sfp-sfpplus1 vlan-ids=42
add bridge=bridge comment="ports bridge,sfp to carry vlan52 out of 5009" \
tagged=bridge,sfp-sfpplus1 vlan-ids=52
add bridge=bridge comment="ports bridge,sfp to carry vlan62 frames out of 5009\
\_AND assign vlan62 to frames arriving ports 2,3" tagged=\
bridge,sfp-sfpplus1 untagged=ether2,ether3 vlan-ids=62
add bridge=bridge comment=\
"ports bridge,sfp to carry vlan72 frames out of 5009" tagged=\
bridge,sfp-sfpplus1 vlan-ids=72
add bridge=bridge comment=\
"ports bridge,sfp to carry vlan 82 frames out of 5009" tagged=\
bridge,sfp-sfpplus1 vlan-ids=82
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=wireguard1 list=TRUSTED
add interface=ether8 list=TRUSTED
add interface=wireguard1 list=LAN
add comment="LAN OffBridge" interface=ether5 list=LAN
add comment="TRUSTED OffBridge" interface=ether5 list=TRUSTED
add comment="LAN VLAN2" interface=vlan-guest list=LAN
add comment="LAN VLAN22" interface=*D list=LAN
add comment="LAN VLAN12" interface=vlan-iot list=LAN
add comment="LAN VLAN32" interface=vlan-mgmt list=LAN
add comment="TRUSTED VLAN32" interface=vlan-mgmt list=TRUSTED
add interface=vlan-iot list=Iot-Cameras
add interface=*D list=Iot-Cameras
add comment="TEMP " interface=ether1 list=TRUSTED
add comment="LAN VLAN62" interface=vlan-server list=LAN
add comment="LAN VLAN52" interface=vlan-moca list=LAN
add comment="LAN VLAN42" interface=vlan-TV list=LAN
add interface=ether7 list=TRUSTED
/interface ovpn-server server
add mac-address=FE:4D:49:0E:82:FA name=ovpn-server1
/ip address
add address=192.168.55.1/24 interface=ether8 network=192.168.55.0
add address=10.10.100.212/24 interface=wireguard1 network=10.10.100.0
add address=10.21.2.1/24 interface=vlan-guest network=10.21.2.0
add address=10.21.12.1/24 interface=vlan-iot network=10.21.12.0
add address=10.21.32.1/24 interface=vlan-mgmt network=10.21.32.0
add address=10.21.42.1/24 interface=vlan-TV network=10.21.42.0
add address=10.21.52.1/24 interface=vlan-moca network=10.21.52.0
add address=10.21.62.1/24 interface=vlan-server network=10.21.62.0
add address=10.21.72.1/24 interface=vlan-vonage network=10.21.72.0
/ip cloud
set ddns-enabled=yes ddns-update-interval=1d
/ip dhcp-client
add comment=defconf interface=ether1
/ip dhcp-server
add address-pool=cameras-pool interface=*D name=dhcp-cameras
/ip dhcp-server alert
add alert-timeout=1d disabled=no interface=bridge
/ip dhcp-server network
add address=10.21.2.0/24 dns-server=10.21.2.1 gateway=10.21.2.1
add address=10.21.12.0/24 dns-server=10.21.12.1 gateway=10.21.12.1
add address=10.21.22.0/24 dns-server=10.21.22.1 gateway=10.21.22.1
add address=10.21.32.0/24 dns-server=1.1.1.1 gateway=10.21.32.1
add address=10.21.42.0/24 dns-server=10.21.42.1 gateway=10.21.42.1
add address=10.21.52.0/24 dns-server=10.21.52.1 gateway=10.21.52.1
add address=10.21.62.0/24 dns-server=10.21.62.1 gateway=10.21.62.1
add address=10.21.72.0/24 dns-server=10.21.72.1 gateway=10.21.72.1
add address=192.168.55.0/24 dns-server=1.1.1.1 gateway=192.168.55.1 netmask=\
24
/ip dns
set allow-remote-requests=yes cache-size=10000KiB servers=1.1.1.1,9.9.9.9
/ip dns static
add address=10.21.32.1 name=212-rb5009-new.212.internal type=A
add address=10.21.32.1 name=RB5009-new.212.internal ttl=9w6d10h40m type=A
add address=10.21.32.1 name=212.10.10.100.212.internal ttl=9w6d10h40m type=A
add address=10.21.32.22 name=JRS-PC.212.internal type=A
add address=192.168.2.2 comment=212router.internal name=212router.internal \
type=A
add address=10.21.32.2 comment=212router.internal name=212router.internal \
type=A
add address=10.10.100.80 comment=729router.internal name=729router.internal \
type=A
/ip firewall address-list
add address=XXXXX.dyndns.org list=dynamic-WANIP
add address=192.168.0.103 comment="Home Assistant" list=\
ALLOWED-REMOTE-SERVERS
add address=192.168.55.0/24 list=admin
add address=10.0.0.0/8 list=admin
add address=192.168.2.168 comment="Blue Iris 2" list=ALLOWED-REMOTE-SERVERS
add address=192.168.0.101 comment="Blue Iris" list=ALLOWED-REMOTE-SERVERS
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment=\
"defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=accept chain=input comment="Allow INPUT users to services" \
dst-port=53 in-interface-list=LAN log-prefix=users-to-services protocol=\
udp
add action=accept chain=input comment="Allow INPUT users to services" \
dst-port=53 in-interface-list=LAN protocol=tcp
add action=accept chain=input comment="Allow INPUT from TRUSTED" \
in-interface-list=TRUSTED
add action=accept chain=input comment="Allow INPUT WG Handshake" dst-port=\
51880 log-prefix=Allow-WG-Handshake protocol=udp
add action=accept chain=input comment="NTP to Devices" in-interface=vlan-mgmt \
protocol=udp src-port=123
add action=drop chain=input comment="Drop all INPUT" log-prefix=DROP-ALL
add action=fasttrack-connection chain=forward comment=\
"defconf: fasttrack established related" connection-state=\
established,related hw-offload=yes
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=accept chain=forward comment="Allow FORWARD LAN to WAN" \
in-interface-list=LAN log-prefix=Allow-LAN-WAN out-interface-list=WAN
add action=accept chain=forward comment="Allow FORWARD TRUSTED" \
in-interface-list=TRUSTED log-prefix=Allow-TRUSTED out-interface-list=LAN
add action=accept chain=forward comment=\
"Allow FORWARD Admin & remote wg admin to wireguard" in-interface-list=\
TRUSTED out-interface=wireguard1 src-address-list=admin
add action=accept chain=forward comment=\
"Allow FORWARD IOT-CAMERAS iface to ALLOWED-REMOTE-SERVER" \
dst-address-list=ALLOWED-REMOTE-SERVERS in-interface-list=Iot-Cameras \
out-interface=wireguard1
add action=accept chain=forward comment="Allow WG relay" in-interface=\
wireguard1 out-interface=wireguard1
add action=drop chain=forward comment="Drop all FORWARD" log-prefix=DROP-ALL
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
add action=masquerade chain=srcnat out-interface=wireguard1
/ip route
add comment=355 disabled=no distance=1 dst-address=192.168.0.0/24 gateway=\
wireguard1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add comment=255 disabled=no distance=1 dst-address=192.168.1.0/24 gateway=\
wireguard1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add comment=355-Cameras disabled=no distance=1 dst-address=192.168.5.0/24 \
gateway=wireguard1 pref-src="" routing-table=main scope=30 \
suppress-hw-offload=no target-scope=10
add comment=629 disabled=no distance=1 dst-address=192.168.20.0/24 gateway=\
wireguard1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add comment=76 disabled=no distance=1 dst-address=192.168.30.0/24 gateway=\
wireguard1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add comment=371 disabled=no distance=1 dst-address=192.168.40.0/24 gateway=\
wireguard1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add comment=125 disabled=no distance=1 dst-address=192.168.70.0/24 gateway=\
wireguard1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no \
target-scope=10
add disabled=no distance=1 dst-address=192.168.4.0/24 gateway=10.10.100.80 \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
add disabled=no distance=1 dst-address=10.0.0.0/8 gateway=wireguard1 \
routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/system clock
set time-zone-name=America/New_York
/system identity
set name=212-RB5009-New
/system note
set show-at-login=no
/system ntp client
set enabled=yes
/system ntp client servers
add address=216.239.35.4
add address=104.16.132.229
/system script
add dont-require-permissions=yes name=export-download owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="\
\n\
\n/system\
\n:local cdate [clock get date] \
\n:local yyyy [:pick \$cdate 0 4]\
\n:local MM [:pick \$cdate 5 7]\
\n:local dd [:pick \$cdate 8 10]\
\n:local identitydate \"\$[identity get name]_\$yyyy-\$MM-\$dd\"\
\n/export show-sensitive file=\"\$identitydate\"\
\n\
\n/tool fetch upload=yes mode=ftp ascii=no src-path=\"/\$[\$identitydate].\
rsc\" dst-path=\"/mikrotik-backups/\$[\$identitydate].rsc\" address=192.16\
8.2.22 port=21 user=mikrotik password=XXXXX\
\n\
\n/file remove \"\$[\$identitydate].rsc\"\
\n\
\n:log info (\"Uploaded rsc backup to 192.168.2.22 as \".\$identitydate)"
add dont-require-permissions=yes name=Netwatch owner=admin policy=\
ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="#\
###################################\
\n# Netwatch script\
\n#\
\n# Used as both up and down script\
\n# Created Jotne 2021 v1.5\
\n#\
\n####################################\
\n:local Host \$host\
\n/tool netwatch\
\n:local Status [get [find where host=\"\$Host\"] status]\
\n:local Comment [get [find where host=\"\$Host\"] comment]\
\n:local Interval [get [find where host=\"\$Host\"] interval]\
\n:local Since [get [find where host=\"\$Host\"] since]\
\n:log info \"script=netwatch watch_host=\$Host comment=\\\"\$Comment\\\" \
status=\$Status interval=\$Interval since=\\\"\$Since\\\"\"\
\n\
\n:local thisBox [/system identity get name];\
\n\
\n:tool e-mail send to=jXXXXX@domain.com subject=\"\$thisBox \$Status\
\_to \$Host\" body=( [ :system clock get date ] . \" \" . [ :system clock \
get time ] . \"\$thisBox \$Status to \$Host\" )\
\n"
/tool e-mail
set from=jXXXXX@domain.com port=587 server=smtp.gmail.com tls=starttls \
user=jXXXXX@domain.com
/tool mac-server
set allowed-interface-list=none
/tool mac-server mac-winbox
set allowed-interface-list=TRUSTED
/tool netwatch
add comment=Netwatch-8.8.4.4 disabled=no down-script=Netwatch host=8.8.4.4 \
http-codes="" interval=5m name=Netwatch-8.8.4.4 test-script="" type=\
simple up-script=Netwatch
add disabled=no down-script=Netwatch host=192.168.0.11 http-codes="" \
interval=1m name=Netwatch-192.168.0.11 test-script="" type=simple \
up-script=Netwatch
/tool romon
set enabled=yes