From reading many prior threads, using the CRS as a switch-only results in much better performance.
I am having a hard time identifying exactly what form of config changes the use from switch to router.
In this context, I have seen references to a determining factor being whether the CRS has an IP address assigned to it's bridge.
I have also seen reference to the determingin factor being whether the bridge is included as a tagged port in "/interface bridge vlans" as being a determining factor.
Both of these make sense because the bridge (in my basic understanding, thanks to many educators here) is what involves the CPU, and the involvement of the CPU is (I think) the distinguishing aspect of using the device as a router.
I am particularly interested in how a CRS passing VLAN-tagged frames (and having access and trunk ports) would be configured as a switch-only.
I am totally unclear about the correct "/ip route" entries because my guess is that ip routing is a CPU (and therefore routing) function.
(Note: Please try, if possible, to keep the explanations simple.)
Perhaps something like this (this is just a partial config to learn about this particular concept of switch vs. router config on the CRS line):
/interface bridge
add admin-mac=D4:01:C3:83:B5:2F auto-mac=no comment=defconf name=bridge vlan-filtering=yes
/interface vlan
add comment=vlan32 interface=bridge name=vlan32 vlan-id=32
/ip pool
add comment=OffiBridge name=OffBridge ranges=192.168.55.100-192.168.55.200
/ip dhcp-server
add address-pool=OffBridge comment=OffBridge interface=ether24 name=Offbridge
/interface bridge port
add bridge=bridge comment=defconf frame-types=admit-only-vlan-tagged \
interface=ether1
add bridge=bridge comment="vlan32 access" frame-types=\
admit-only-untagged-and-priority-tagged interface=ether2 pvid=32
add bridge=bridge comment=Trunk frame-types=admit-only-vlan-tagged interface=\
ether3
add bridge=bridge comment=defconf interface=ether4 comments="vlan2 access" frame-types=\
admit-only-untagged-and-priority-tagged pvid=2
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=ether6
add bridge=bridge comment=defconf interface=ether7
add bridge=bridge comment=defconf interface=ether8
add bridge=bridge comment=defconf interface=ether9
add bridge=bridge comment=defconf interface=ether10
add bridge=bridge comment=defconf interface=ether11
add bridge=bridge comment=defconf interface=ether12
add bridge=bridge comment=defconf interface=ether13
add bridge=bridge comment=defconf interface=ether14
add bridge=bridge comment=defconf interface=ether15
add bridge=bridge comment=defconf interface=ether16
add bridge=bridge comment=defconf interface=ether17
add bridge=bridge comment=defconf interface=ether18
add bridge=bridge comment=defconf interface=ether19
add bridge=bridge comment=defconf interface=ether20
add bridge=bridge comment=defconf interface=ether21
add bridge=bridge comment=defconf interface=ether22
add bridge=bridge comment=defconf interface=ether23
add bridge=bridge comment=defconf interface=sfp-sfpplus1
add bridge=bridge comment=defconf interface=sfp-sfpplus2
/interface bridge vlan
add bridge=bridge tagged=bridge,ether1,sfp-sfpplus1 untagged=ether2 vlan-ids=\
32
/ip address
add address=10.21.32.2/24 interface=vlan32 network=10.21.32.0
add address=192.168.55.1 comment=OffBridge interface=ether24 network=\
192.168.55.1
/ip dns
set servers=1.1.1.1,10.21.32.1
/ip route
add disabled=no dst-address=0.0.0.0/0 gateway=10.21.32.1 routing-table=main \
suppress-hw-offload=no
/system ntp client
set enabled=yes
/system ntp client servers
add address=216.239.35.4
add address=104.16.132.229
/tool romon
set enabled=yes
/tool sniffer
set filter-ip-address=10.0.0.0/8