/ip firewall layer7-protocol
add comment="snmp-set request filter by shados" name="snmp-set" regexp="^\\x30.\\x02\\x01\\.\\x04.+\\xA3.*"
/ip firewall filter add chain=forward in-interface=PUBLIC protocol=udp dst-port=161 action=drop
/ip firewall filter add chain=input in-interface=PUBLIC protocol=udp dst-port=161 action=drop
This is really the kicker, huh?Don't worry. This exploit is not malicious or harmful, just proof of concept code. This is feauture, not a bug in the clear way=)
This is true, but adds a lot of overhead that is not really needed. L7 firewall is a heavy hitter in terms of CPU on a busy router. It's use must be carefully monitored. Depending on the network design, my earlier post is sufficient for most applications.BTW you can specify hardguessing snmp community and filter requests with L7 filter:Code: Select all/ip firewall layer7-protocol add comment="snmp-set request filter by shados" name="snmp-set" regexp="^\\x30.\\x02\\x01\\.\\x04.+\\xA3.*"
Care to share? Post a link.I have recorded demonstration screencast of routeros 3.13 on rb333 vulnerability.
Don't worry. This exploit is not malicious or harmful, just proof of concept code. This is feauture, not a bug in the clear way=)
BTW you can specify hardguessing snmp community and filter requests with L7 filter:I have recorded demonstration screencast of routeros 3.13 on rb333 vulnerability.Code: Select all/ip firewall layer7-protocol add comment="snmp-set request filter by shados" name="snmp-set" regexp="^\\x30.\\x02\\x01\\.\\x04.+\\xA3.*"
I'm not satisfied that that filter will stop variations of this exploit. Everyone has the source code for it, so they could alter it in any way that is effective.
Butch's idea to stop snmp as it comes in to your network will reduce 99% of the risk.
rapidshare is best than disfunctional tiktube =)rapidshare sucks : )
PS - What we still don't know is if anything else is writable. Changing system identity isn't a big deal but it sure is if you could use this to do anything else.
tiktube won't be able to host such large screencasts anyway. the video size (dimensions) is limited. maybe we will make screencast size support in new tiktuberapidshare is best than disfunctional tiktube =)rapidshare sucks : )
PS - What we still don't know is if anything else is writable. Changing system identity isn't a big deal but it sure is if you could use this to do anything else.
I'll try to find somthing more than "/system identity". Just wait a while.
It is great idea! I will wait for that. I have a lot of training videos for RouterOS, which I would like to share.maybe we will make screencast size support in new tiktube
snmpset -c public -v 1 10.0.0.35 SNMPv2-MIB::sysName.0 s kaka
OK, because we both know that you are right. And code was created only to draw attention to the "problem" =) Thanks for support.how will we know if that 800x600px video is not actually an uncompressed MPEG2, but some small sized screencast?
about the "bug". the only bug here is that snmp-write is enabled by default, and is not documented. you don't need this fancy program, just this command would suffice:
so SNMP-write IS SUPPORTED, but not yet added to manual (as you know, v3 manual is not ready)Code: Select allsnmpset -c public -v 1 10.0.0.35 SNMPv2-MIB::sysName.0 s kaka
to clarify again - there is no exploit or vulnerability. you can simply change the identity with a valid SNMP-write command. plus see my other postI hope it's indeed a dud and would welcome others to do further testing or documenting. If it's real, I'd be really upset that mikrotik isn't prepared for something 99% similar to the stupid bug in february.
Normis,so SNMP-write IS SUPPORTED, but not yet added to manual (as you know, v3 manual is not ready)
to clarify again - there is no exploit or vulnerability. you can simply change the identity with a valid SNMP-write command. plus see my other postI hope it's indeed a dud and would welcome others to do further testing or documenting. If it's real, I'd be really upset that mikrotik isn't prepared for something 99% similar to the stupid bug in february.
Also all interfaces should be disabled by default in "ip->neighbors" or to be active only for local networks, not for routed.already done, next version has snmp-write configuration, lack of which WAS the bug!
an exploit is something that was not intended by the makers of the software, and can be used to do bad things to your device.
by your definition, winbox and telnet are also exploits, because by default they are open, and there is a known default password.
How do you able to crash the router, which version of the RouterOS and on which hardware ?Did you know that there it is possible to crash(and auto-reboot...) a mikrotik router via bwtest(if it has auth disabled) using nmap on port 2000? If auth is enable, you may fill the log file with fake messages
Yes thats true, but administrator must be informed (with a message box at first login) thatdid you know that default installation of routerOS is considered to be unsafe, because there is no password, many processes are listening on every interface etc. thats why you have to configure your router and set up firewall, acl, disable everything you do not need, want to be exposed.
All the vulnerabilities that I have wrote before, are active in any version for any hardware, I think that it is iperf's bug not mikrotik's. You will find all the vulnerabilities listed and descripted soon in another site. For the moment I am too busy.How do you able to crash the router, which version of the RouterOS and on which hardware ?Did you know that there it is possible to crash(and auto-reboot...) a mikrotik router via bwtest(if it has auth disabled) using nmap on port 2000? If auth is enable, you may fill the log file with fake messages
How do you able to crash the router, which version of the RouterOS and on which hardware ?Did you know that there it is possible to crash(and auto-reboot...) a mikrotik router via bwtest(if it has auth disabled) using nmap on port 2000? If auth is enable, you may fill the log file with fake messages
Which version of nmap do you use? Which version of routeros do you use? router architecture (ppc, mipsel, mipsbe, x86)?Run
nmap -sV -p 2000 Mikrotik_ROUTER_IP
and wait about 1min..