Community discussions

MikroTik App
 
sophal
newbie
Topic Author
Posts: 34
Joined: Thu Aug 07, 2008 6:09 am
Location: Cambodia

iBGP and eBGP

Fri Jan 23, 2009 6:08 am

Dear all,

I have plan iBGP and eBGP.
Please help correct my code and see my network diagram below:

Configurations

R2

/ip address
add address=10.150.1.5/24 disabled=no interface=lan
add address=203.33.189.1/24 disabled=no interface=lan
add address=203.223.36.174/30 disabled=no interface=wan

/routing bgp instance
set default as=38579 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=yes redistribute-ospf=no redistribute-other-bgp=yes redistribute-rip=no redistribute-static=yes router-id=203.223.36.174

/routing bgp peer
add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=default multihop=yes name=peer1 nexthop-choice=default out-filter="" remote-address=203.223.36.173 remote-as=17726 route-reflect=no tcp-md5-key="" ttl=255 update-source= "(unknown)"

add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance= default multihop=no name=peer2 nexthop-choice=force-self out-filter="" remote-address=10.150.1.4 remote-as=38579 route-reflect=yes tcp-md5-key="" ttl=255 update-source="(unknown)"

add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance= default multihop=no name=peer3 nexthop-choice=force-self out-filter="" remote-address=10.150.1.6 remote-as=38579 route-reflect=yes tcp-md5-key="" ttl=255 update-source="(unknown)"


/routing bgp network
add disabled=no network=203.33.189.0/24 synchronize=yes
add disabled=no network=10.150.1.0/24 synchronize=yes

/ip route
add bgp-prepend=10 comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=203.223.36.173 routing-mark=as-17726-out scope=30 target-scope=10
add bgp-as-path=1 bgp-local-pref=150 comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=203.223.36.173 routing-mark=as-17726-in scope=30 target-scope=10

/ip firewall mangle
add action=passthrough chain=prerouting comment="" disabled=no in-interface=lan src-address=203.33.189.0/24


R2

/ip address
add address=10.150.1.4/24 disabled=no interface=lan
add address=203.33.189.2/24 disabled=no interface=lan
add address=203.113.185.242/30 disabled=no interface=wan

/routing bgp instance
set default as=38579 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=yes redistribute-ospf=no redistribute-other-bgp=yes redistribute-rip=no redistribute-static=yes router-id=203.113.185.242

/routing bgp peer
add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=default multihop=yes name=peer1 nexthop-choice=default out-filter="" remote-address= 203.113.185.241 remote-as=7552 route-reflect=no tcp-md5-key="" ttl=255 update-source= "(unknown)"

add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance= default multihop=no name=peer2 nexthop-choice=force-self out-filter="" remote-address=10.150.1.5 remote-as=38579 route-reflect=yes tcp-md5-key="" ttl=255 update-source="(unknown)"

add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance= default multihop=no name=peer3 nexthop-choice=force-self out-filter="" remote-address=10.150.1.6 remote-as=38579 route-reflect=yes tcp-md5-key="" ttl=255 update-source="(unknown)"

/routing bgp network
add disabled=no network=203.33.189.0/24 synchronize=yes
add disabled=no network=10.150.1.0/24 synchronize=yes

/ip route
add bgp-prepend=10 comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 203.113.185.241 routing-mark=as-17726-out scope=30 target-scope=10

add bgp-as-path=1 bgp-local-pref=150 comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 203.113.185.241 routing-mark=as-17726-in scope=30 target-scope=10

/ip firewall mangle
add action=passthrough chain=prerouting comment="" disabled=no in-interface=lan src-address=203.33.189.0/24

R3

/ip address
add address=203.33.189.3/24 disabled=no interface=wan
add address=10.150.1.6/24 disabled=no interface=wan
add address=10.10.10.1/24 disabled=no interface=lan

/routing bgp instance
set default as=38579 client-to-client-reflection=yes comment="" disabled=no ignore-as-path-len=no name=default out-filter="" redistribute-connected=yes redistribute-ospf=no redistribute-other-bgp=yes redistribute-rip=no redistribute-static=yes router-id=10.150.1.6

/routing bgp peer
add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=bgp1 multihop=no name=peer1 nexthop-choice=force-self out-filter="" remote-address=10.150.1.5 remote-as=38579 route-reflect=yes tcp-md5-key="" ttl=255 update-source="(unknown)"

add address-families=ip comment="" default-originate=never disabled=no hold-time=3m in-filter="" instance=bgp1 multihop=no name=peer1 nexthop-choice=force-self out-filter="" remote-address=10.150.1.4 remote-as=38579 route-reflect=yes tcp-md5-key="" ttl=255 update-source="(unknown)"

/routing bgp network
add disabled=no network=203.33.189.0/24 synchronize=yes
add disabled=no network=10.150.1.0/24 synchronize=yes

/ip route
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 203.33.189.1 routing-mark=R1 scope=30 target-scope=10
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway= 203.33.189.2 routing-mark=R2 scope=30 target-scope=10

I hope normis help me
You do not have the required permissions to view the files attached to this post.
Last edited by sophal on Fri Jan 30, 2009 8:40 am, edited 1 time in total.
 
changeip
Forum Guru
Forum Guru
Posts: 3833
Joined: Fri May 28, 2004 5:22 pm

Re: iBGP and eBGP

Fri Jan 23, 2009 6:23 am

whats not working ?
 
mknnoc
Trainer
Trainer
Posts: 229
Joined: Thu Feb 28, 2008 6:40 am
Location: cambodia

Re: iBGP and eBGP

Fri Jan 23, 2009 6:33 am

what is your bandwidth for both transits?
 
sophal
newbie
Topic Author
Posts: 34
Joined: Thu Aug 07, 2008 6:09 am
Location: Cambodia

Re: iBGP and eBGP

Fri Jan 23, 2009 7:05 am

whats not working ?

thanks.

The problem

My ip:203.33.189.0/24 can through the both ISP-A and ISP-B but couldn't get back from ISP-A and ISP-B. I'm not sure my code correct or not. Please correct my code.
possible load balancing is not working?

what is your bandwidth for both transits?

ISP-A=10Mbps
ISP-B=25Mbps