First you need local access to fix this. You cannot do this with only remote access.
Actually you can do it remotely. I've done many that way.
In case anybody needs to do this, these are the steps I used.
Step by step to downgrade rb133c/rb112 to 2.9.51
The only problem that I've seen with the downgrade is the wireless settings are defaulted. ie, disabled and all settings lost.
And on some downgrades the dhcp server on ether1 would lose the gateway and dns entries. About 10 of 40 had this happen...weird.
I've done about 40 this way. Only one failed and it was using antenna b. I don't know why it was hooked up that way
but it was. Document your settings!!!!
This is for basic routed connection. Wlan to tower, Ether1 to customer. Nat'd.
Security settings are maintained during downgrade but wireless setting to use it must be re-entered.
Wireless settings go to default and disables the wireless card, so if you don't re-enable it and
enter some settings via script you'll be doing a truck roll.
1-login to device to be downgraded with winbox
2-copy os 2.9.51 to file
3-record ssid, authentication, band and antenna of wireless -or minimum requirements to connect on your system
and enter that info in the script part A
4-copy and paste part A in terminal
5-close winbox and wait 3 minutes
6-login with winbox
7-check dhcp servers gateway and dns settings if using dhcp. They tend to dissappear.
8-rename wireless name in wireless settings if you do that. ie, customer name
9-copy and paste part B. system reboots
10-login with winbox and check everything. Remove all files and backup.
11-Move on to the next device to be downgraded.
### Copy RouterOs 2.9.51 to the RB133C
### Don't panic during the downgrade. It takes 60 seconds before the connection drops
### and another 120 seconds before it reconnects. Total of 3 minutes after applying part A.
### You may lose your dhcp servers gateway and dns settings after the downgrade. Some do, some don't.
### You will have to rename your wireless name after the downgrade.
#### Part A ####
### --- Working wireless settings---###
### Copy and paste the settings for the AP you're working with.
### /interface wireless set wlan1 band=2.4ghz-b ssid="RWGALVA-SW"
### insert the ssid between the " and \ like this -- ssid=\"ssid goes here\""
### Put your wirless settings in the script
### Check to see if wireless is using antenna B antenna-mode=ant-b
#### Copy and paste the following ####
# Removing the auto-upgrade config. Don't need that anymore. My upgrade script was named "upgrade".
# and my schedule for the upgrade was named "sched_upgrade". If you didn't have anything like that, remove this.
/system upgrade upgrade-package-source remove [find]
/system script remove upgrade
/system scheduler remove sched_upgrade
# Disable supout file creation It causes the units to hang at times and I don't like it.
/system watchdog
set auto-send-supout=no automatic-supout=no no-ping-delay=5m watch-address=none watchdog-timer=no
# Making the new backup Always a good idea. Name it what you want.
/system backup save name=os_downgrade
# Making the script to re-enable the wireless This will reconfigure the wireless. I put 60 second
# delay to make sure system was up and running.
/system script
add name=reload source=\
":delay 60\r\
\n/interface wireless set wlan1 disabled=no band=2.4ghz-b ssid=\"Your_SSID\""
# Scheduling the script. Scheduled to run at startup
/system scheduler
add disabled=no interval=0s name=reload on-event=reload start-time=startup
# Downgrading the O/S. Scary part, but it works if you entered the correct wireless settings, so relax.
# You did enter the correct settings, didn't you!!!
/system package downgrade
y
#### Part B ####
### Log back in and clean up
## check this ##
## / ip dhcp-server network export
## should look like this
## add address=192.168.10.0/24 gateway=192.168.10.1 dns-server=205.171.3.65
## -- Watch the ether ip address -- could be 192.168.0.1
#### Copy and paste the following
# Removing the downgrade scripts
/system script remove reload
/system scheduler remove reload
# Getting rid of unused packages. Edit as necessary
/system package
uninstall hotspot
uninstall ppp
uninstall routing
uninstall rstp-bridge-test
uninstall webproxy-test
uninstall wireless-crd
uninstall wireless-legacy
# Rebooting the system
/system reboot
y