you could use mangle to mark incoming packets with a mark and add a route saying where to send packets marked with such mark
consider the following image:
Drawing2.gif
on the left RB you should:
-mark all packets coming from IN1 interface with mark X
-add a route that forwards packets marked with mark X to the right RB
-add a route that forwards packets marked with mark Y to the computer on the left (packets from internet)
on the right RB you should:
-mark all packets coming from IN2 interface with mark Y
-add a route that forwards packets marked with mark Y to the left RB
-add a route that forwards packets marked with mark X to the internet (packets from left comp destined to internet)
I hope you get the point.
marking packets can be done using mangle, something like this (im not sure if the syntax is 100% correct):
on the left RB:
/ip firewall mangle add chain=prerouting action=mark-routing in-interface=<IN1> new-routing-mark=X
/ip route add routing-mark=X gateway=<RIGHT-RB-IP>
/ip route add routing-mark=Y gateway=<LEFT-COMP-IP>
(<IN1> - the actual name of the IN1 interface on the left RB, <RIGHT-RB-IP> - ip address of the right RouterBoard, <LEFT-COMP-IP> - ip address of the left computer)
on the right RB:
/ip firewall mangle add chain=prerouting action=mark-routing in-interface=<IN2> new-routing-mark=Y
/ip route add routing-mark=Y gateway=<LEFT-RB-IP>
/ip route add routing-mark=X gateway=<INTERNET-GATEWAY-IP>
(<IN2> - the actual name of the IN2 interface on the right RB, <LEFT-RB-IP> - ip address of the left RouterBoard, <INTERNET-GATEWAY-IP> - ip address of the right RB's default gateway for the internet access)
You do not have the required permissions to view the files attached to this post.