I'm having quite a bit of fun following various guides and watching nothing happen.
My setup is most likely similar to hundreds of others.
Two locations. One router at each location. Each router does NAT so the internal network is represented by one public IP.
I am attempting to connect the two routers via PPTP by following http://www.mikrotik.com/testdocs/ros/3. ... ontent.php. I've also looked at and tried http://wiki.mikrotik.com/wiki/PPTPServer, but the wiki one didn't mention the client setup (which I assumed would be the same client methods as in the testdocs). Neither method helped packets travel from one internal network to the other. I think I'm missing something basic, but have no idea what it is.
Here is what I think would really help beginners like me get up on their feet: An example configuration script starting with no configuration on the router up to the point of a running pptp server. Then another configuration script starting with no config and ending with a working pptp client.
Both configurations would need to have:
-ether1 as the INTERNET port with a 'public' ip. (for testing it would be ok if both 'public' IPs were on the same subnet)
-ether2 as the LAN port with a private IP. (each router with a diff subnet)
-NAT for all users on the LAN side
This script needs to include any firewall filters, default routes..etc that are needed for a basic pptp tunnel.
Everything so that someone could take two routers, put one config on each one, hook them together via the INTERNET ports (if the internet IPs are on the same subnet), and be able to ping all interfaces on both routers when connected to the LAN side of either router.
I think this would help every newbie that comes along, as we could then take the example configuration, look at it, and see where we made mistakes.
I know it's a lot to ask, but this is a beginner forum, no?
Here's the start of a simple setup
Code: Select all
/interface set ether1 name=ether1-gateway
/interface set ether2 name=ether2-local-master
/ip address add address=192.168.0.5/24 interface=ether1-gateway comment="Public IP"
/ip address add address=10.0.1.0/24 interface=ether2-local-master comment="Lan IP"