Eth1 - static IP from ISP.
Eth2 - dhcp server to LAN
Eth2 connected to switch.
Config:
/ip add add address=xxx.yyy.zzz.aaa/xx interface ether1
/ip add add address=192.168.1.1/24 int ether2
/ip pool add name=dhcp_pool1 ranges=192.168.1.2-192.168.1.254
/ip dhcp-server add add-arp=yes address-pool=dhcp_pool1 disabled=no interface=ether2
/ip dhcp-server network add address=192.168.1.0/24 comment="" gateway=192.168.1.1
/ip dns set primary-dns=DNS_IP_1 secondary-dns=DNS_IP_2
/ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=ether1
Basic configuration done