I hava an RB450G.
Unfortunately I did not manage to make it work. I'll tel you a few things about what I want to do and about the ISP that will be used, so you'll make an idea.
Requirements: NAT for 2 PCs, each one getting IPs via DHCP, each PC in each own separate private network, so that they'll be completely isolated.
ISP: My ISP uses an authentication software developed by them inhouse. Some people that have seen the linux script that they offer for linux users say that they programmed it very silly.
The program can be tricked, many have done it on budget routers like Dlink DI-524.
The program connects to a DHCP server and receives IP,Subnet Mask, Gateway, DNS addresses.
In order to trick it I have to use 10.x.x.x local addresses instead of 192.x.x.x
Another aspect is that the ISP sends packets with TTL=1 so that entry level routers without TTL incrementing will not work.
Now let me tell you what I did:
1)I've set the WAN, LAN interfaces and TTL incrementing via terminal
/ ip address add address=85. ... ... ... /27 network=85. ... ... ... broadcast=85. ... ... ... interface=ether1
/ip route add gateway=85. ... ... ...
/ ip address add address=10.25.44.1 /29 network=10.25.44.0 broadcast=10.25.44.7 interface=ether2
/ ip address add address=10.25.45.1/30 network=10.25.45.0 broadcast=10.25.45.3 interface=ether3
/ip firewall mangle add action=change-ttl chain=prerouting new-ttl=set:64
2)I've set the DHCP server , the DNS server and NAT exacly as shown in this tutorial, for the first LAN(ether2), and then everything again, for the second LAN(ether3).
http://wiki.mikrotik.com/wiki/Internet_Sharing
The problem is that the ISP's application doesn't connect, it says "comunication error with the server"
Ping from WAN(ether1) to the gateway 85. ... works.
But ping from WAN(ether1) to LAN(ether2, ether3) timeouts.
ARP ping from WAN(ether1) to LAN(ether2, ether3) works but with around 25% packet loss.
What am I doing wrong?