/interface 6to4
add comment="HE IPv6" disabled=no local-address=84.42.xxx.xxx mtu=1280 name=sit1 remote-address=216.66.84.46
/ipv6 address
add address=2001:470:1xxx:xxxx::2/64 advertise=yes comment="6to4 tunnel endpoint" disabled=no eui-64=no interface=sit1
add address=2001:470:1xxx:xxxx:20c:42ff:fe3d:2bf8/64 advertise=yes comment="" disabled=no eui-64=yes interface=br0
/ipv6 nd
add advertise-dns=no advertise-mac-address=yes disabled=no hop-limit=unspecified interface=all managed-address-configuration=yes mtu=unspecified other-configuration=no ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m reachable-time=2m retransmit-interval=5s
/ipv6 nd prefix default set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:xxxx:xxxx::1 scope=30 target-scope=10
Both. Don't you know bugs are undocumented features? =)So I have torn out eth1 from the bridge and disabled br0. Now it looks like Router Advertisement is being sent approx. every 250s. Now, it works. But I need eth1, eth2 and ath0 bridged.
UPDATE: I get it back to the previous state and now no more advertisement. Is this bug or a feature?
0 ID prefix=2001:470:1f15:692::/64 interface=br0 on-link=yes autonomous=yes valid-lifetime=4w2d preferred-lifetime=1w
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=01:00:00:00:01:00
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: adding prefix=2001:470:1f15:692::/64
Apr 25 21:33:42 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Apr 25 21:48:28 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
+1I have got RB433AH and the behavior is same as in case of RB450G. So this seems to be a general problem of all RBs.
The must be a bug in the RADVD daemon, because it claims that RA packet has been sent but no packet appears in Wireshark.
Devs, please provide some fix. RA is key feature of IPv6. I can't use IPv6 without RA.
/system scheduler
add comment="" disabled=no interval=1h name=schedule1 on-event=\
"/ipv6 address print\r\
\n/ipv6 address disable 1\r\
\n/ipv6 address enable 1\r\
\n" start-date=jan/01/1970 start-time=21:15:00
{
:local ipv6addresses [/ipv6 address find global disabled=no advertise=yes]
/ipv6 address set $ipv6addresses disabled=yes
/ipv6 address set $ipv6addresses disabled=no
}
Jun 1 08:22:06 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0 <<< Here OK, RA captured by Wireshark
Jun 1 08:26:44 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jun 1 08:30:00 r4bu110 system,info: device changed by admin <<< Here scheduler enables ath0
Jun 1 08:30:02 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jun 1 08:30:02 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jun 1 08:30:02 r4bu110 radvd,debug: radvd: adding prefix=2001:470:1f0b:127d::/64
Jun 1 08:30:02 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument <<< After this no more RA
Jun 1 08:33:45 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0 <<< No packets captured by Wireshark
Jun 1 08:37:51 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jun 1 20:54:45 r4bu110 radvd,debug: radvd: received Router Solicitation on interface=br0 <<< request for RA sent by Nokia E52
Jun 1 20:54:45 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0 <<< but no packet captured by Wireshark in (no response from ROS)
Jun 1 20:54:45 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jun 1 20:54:45 r4bu110 radvd,debug: radvd: adding prefix=2001:470:1f0b:127d::/64
Jun 1 20:54:45 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
interface bridge disable br0
interface wireless disable ath0
interface bridge enable br0
19:39:23 radvd,debug sending Router Advertisement on bridge01_NSSR-LAN
19:39:23 radvd,debug adding link-layer address option, mac-address=00:0C:42:3E:92:11
19:39:23 radvd,debug adding prefix=2a01:138:9003:18::/64
19:39:23 radvd,debug sendmsg failed on bridge01_NSSR-LAN (fe80::20c:42ff:fe3e:9211): Invalid argument
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes comment="" disabled=no forward-delay=15s l2mtu=1524 max-message-age=20s mtu=1500 name=bridge01_NSSR-LAN priority=0x8000 \
protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=bridge01_NSSR-LAN comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=eth04 path-cost=10 point-to-point=auto priority=0x80
add bridge=bridge01_NSSR-LAN comment="" disabled=no edge=auto external-fdb=auto horizon=none interface=eth02 path-cost=10 point-to-point=auto priority=0x80
/interface bridge settings
set use-ip-firewall=no use-ip-firewall-for-pppoe=no use-ip-firewall-for-vlan=no
hi all,Some first results will be available in 5.0beta3 when it is released, cannot say about 4.x version.
what other choice do I have? RADVD is not working!DHCPv6 ?? You will install a DHCPv6 on each client machine ?
Exactly. The radvd / Router Advertisement Daemon advertises the router address [other routes, rdnss], the prefixesIMHO, DHCPv6 can't provide router address to the clients. Router must advertise itself.
Jul 19 16:06:02 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:06:02 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:06:02 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:10:42 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:14:31 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:16:20 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:19:38 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Jul 19 16:24:26 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: sending Router Advertisement on br0
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: adding DNS server option, address=2001:470:20::2
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: adding prefix=2002:542a:c86e:2::/64
Jul 19 16:26:38 r4bu110 radvd,debug: radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
Hello,
please wait till 4.12 release there this problem should be resolved.
Regards,
/system logging add action=memory topics=radvd
/ipv6 firewall filter add action=log chain=output protocol=icmpv6
/interface bridge add name=bridge1
/ipv6 nd add interface=bridge1 ra-interval=10s-15s
/ipv6 address add address=2001:db8::1/64 advertise=yes interface=bridge1
skip Router Advertisement sending on bridge1: no link local address
/interface bridge set 0 auto-mac=no admin-mac=fe:00:00:00:00:01
/interface eoip add mac-address=02:D4:2D:05:59:B5 name=eoip-tunnel1 remote-address=192.168.44.44
/interface bridge port add bridge=bridge1 interface=eoip-tunnel1
sendmsg failed on bridge1 (fe80::d4:2dff:fe05:59b5): Invalid argument
wireless,info 00:1B:77:B8:2E:EA@ath0: connected
radvd: received Router Solicitation on interface=br0
radvd: sending Router Advertisement on br0
radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
radvd: adding DNS server option, address=2001:470:20::2
radvd: adding prefix=2001:470:1f0b:127d::/64
radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
radvd: received Router Solicitation on interface=br0
radvd: sending Router Advertisement on br0
radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
radvd: adding DNS server option, address=2001:470:20::2
radvd: adding prefix=2001:470:1f0b:127d::/64
radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
dhcp,info dhcp1 assigned 10.0.10.7 to 00:1B:77:B8:2E:EA
radvd: received Router Solicitation on interface=br0
radvd: sending Router Advertisement on br0
radvd: adding link-layer address option, mac-address=10:10:10:3D:2B:F9
radvd: adding DNS server option, address=2001:470:20::2
radvd: adding prefix=2001:470:1f0b:127d::/64
radvd: sendmsg failed on br0 (fe80::20b:6bff:fedd:3463): Invalid argument
fe80::20b:6bff:fedd:3463
/ipv6 address
add address=2001:470:1f10:9c1::2/64 advertise=yes comment="" disabled=no eui-64=no interface=sit1
add address=2001:470:1f11:9c1::200/64 advertise=yes comment="" disabled=no eui-64=no interface="Workstations VLAN200"
add address=2001:470:1f11:9c1::100/64 advertise=yes comment="" disabled=no eui-64=no interface="DMZ VLAN100"
add address=2001:470:1f11:9c1::500/64 advertise=yes comment="" disabled=no eui-64=no interface="Anonymous VLAN500"
/ipv6 nd
add advertise-dns=no advertise-mac-address=yes disabled=no hop-limit=64 interface=all managed-address-configuration=no mtu=unspecified other-configuration=\
no ra-delay=3s ra-interval=3m20s-10m ra-lifetime=1h reachable-time=1h retransmit-interval=unspecified
/ipv6 nd prefix default
set autoconfig=yes on-link=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add comment="" disabled=no distance=1 dst-address=2000::/3 gateway=2001:470:1f10:9c1::1 scope=30 target-scope=10
Unfortunatelly, the problem still exists in 4.16 Hmm... perhaps I've to go back to 4.13?We had a RB750G running 4.10 doing the invalid argument thing with ether2-5 were slaved. 4.13 fixed it right up for us
MT have indicated fix will be in RC8 ... http://forum.mikrotik.com/viewtopic.php?f=1&t=47846BTW: 5.0rc7 has the RA problem as well.
I installed ROS v5rc8 at my RB450G and RB433AH and RAs works for me now. So it is fixed - finally. I will open a bottle.*) radv - fixed problem when wrong link local address was used to send advertisements on bridge interface;