Just mark your connections using PCC and then put a routing mark on them.
Then add default backup routes for all the different routing marks with a higher distance over the other DSL lines.
If there are troubles with your DSL just disable your PPPOE client (or interface) and PCC will work over the other lines.
So how do you decide your ADSL connection has problems ? You want to ping something or ... ?This don't work, becaume my adsl routers will be connected with my routeros and this conection will work, but not my pppoe in router.
Void,So how do you decide your ADSL connection has problems ? You want to ping something or ... ?This don't work, becaume my adsl routers will be connected with my routeros and this conection will work, but not my pppoe in router.
/system script
add name=TESTADSLSCRIPT policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="#SCRIPT MI\
RAR ESTADO ADSLs#\r\
\n\r\
\n#set variables\r\
\n:local pingcount 3\r\
\n:local ipA 192.168.7.2\r\
\n#ADSL1\r\
\n:local GatewayA 192.168.7.1\r\
\n:local ipB 192.168.8.2\r\
\n#ADSL2\r\
\n:local GatewayB 192.168.8.1\r\
\n:local website www.google.com\r\
\n\r\
\n\r\
\n#ping gateways with src\r\
\n:local pingresultA [/ping \$website src-address=\$ipA count=\$pingcount]\
\r\
\n:local pingresultB [/ping \$website src-address=\$ipB count=\$pingcount]\
\r\
\n\r\
\n\r\
\n:if ((\$pingresultA=0) && (\$pingresultB>0)) do={ /system script run ADS\
L1FALLA; :log warning \" Falla ADSL1\" }\r\
\n\r\
\n:if ((\$pingresultA>0) && (\$pingresultB=0)) do={ /system script run ADS\
L2FALLA; :log warning \" Falla ADSL2\" }\r\
\n\r\
\n:if ((\$pingresultA=0) && (\$pingresultB=0)) do={ /system script run FAL\
LANTODASADSL; :log warning \" Fallan todas las ADSL\" }\r\
\n\r\
\n:if ((\$pingresultA>0) && (\$pingresultB>0)) do={ /system script run FUN\
CIONANTODASADSL; :log info \" Funcionan todas las ADSL\" }\r\
\n"
add name=FUNCIONANTODASADSL policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="#SCRIPT SI\
LAS DOS FUNCIONAN BIEN#\r\
\n:local GatewayA 192.168.7.1\r\
\n:local GatewayB 192.168.8.1\r\
\n/ip firewall mangle set [find comment=\"ADSL1 CONN\"] disabled=no;\r\
\n/ip firewall mangle set [find comment=\"ADSL2 CONN\"] disabled=no;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL1GW\"] di\
sabled=no;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL2GW\"] di\
sabled=no;\r\
\n/ip firewall mangle set [find comment=\"Conexiones del router de la red1\
\"] disabled=no;\r\
\n/ip firewall mangle set [find comment=\"Paquetes del router de la red1\"\
] disabled=no;\r\
\n/ip firewall mangle set [find comment=\"Conexiones del router de la red2\
\"] disabled=no;\r\
\n/ip firewall mangle set [find comment=\"Paquetes del router de la red2\"\
] disabled=no;\r\
\n/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR1\"\
] gateway=\$GatewayB;\r\
\n/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR2\"\
] gateway=\$GatewayA;\r\
\n:log info \"Se ha ejecutado el script de 2 ADSL ok\";\r\
\n"
add name=FALLANTODASADSL policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="#SCRIPT SI\
LAS DOS ADSL FALLAN#\r\
\n:local GatewayA 192.168.7.1\r\
\n:local GatewayB 192.168.8.1\r\
\n/ip firewall mangle set [find comment=\"ADSL1 CONN\"] disabled=yes;\r\
\n/ip firewall mangle set [find comment=\"ADSL2 CONN\"] disabled=yes;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL1GW\"] di\
sabled=yes;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL2GW\"] di\
sabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Conexiones del router de la red\
1\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Paquetes del router de la red1\
\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Conexiones del router de la red\
2\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Paquetes del router de la red2\
\"] disabled=yes;\r\
\n#/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR1\
\"] gateway=\$GatewayB;\r\
\n#/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR2\
\"] gateway=\$GatewayB;\r\
\n:log info \"Se ha ejecutado el script de ADSLs FALLAN\";\r\
\n/system script run ERROR;"
add name=ADSL1FALLA policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="#SCRIPT SI\
ADSL1 FALLA#\r\
\n:local GatewayA 192.168.7.1\r\
\n:local GatewayB 192.168.8.1\r\
\n/ip firewall mangle set [find comment=\"ADSL1 CONN\"] disabled=yes;\r\
\n/ip firewall mangle set [find comment=\"ADSL2 CONN\"] disabled=yes;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL1GW\"] di\
sabled=yes;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL2GW\"] di\
sabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Conexiones del router de la red\
1\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Paquetes del router de la red1\
\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Conexiones del router de la red\
2\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Paquetes del router de la red2\
\"] disabled=yes;\r\
\n/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR1\"\
] gateway=\$GatewayB;\r\
\n/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR2\"\
] gateway=\$GatewayA;\r\
\n:log info \"Se ha ejecutado el script de ADSL1 FALLA\";\r\
\n/system script run ERROR;"
add name=ADSL2FALLA policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff source="#SCRIPT SI\
ADSL2 FALLA#\r\
\n:local GatewayA 192.168.7.1\r\
\n:local GatewayB 192.168.8.1\r\
\n/ip firewall mangle set [find comment=\"ADSL1 CONN\"] disabled=yes;\r\
\n/ip firewall mangle set [find comment=\"ADSL2 CONN\"] disabled=yes;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL1GW\"] di\
sabled=yes;\r\
\n/ip firewall mangle set [find comment=\"Marca la ruta como ADSL2GW\"] di\
sabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Conexiones del router de la red\
1\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Paquetes del router de la red1\
\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Conexiones del router de la red\
2\"] disabled=yes;\r\
\n#/ip firewall mangle set [find comment=\"Paquetes del router de la red2\
\"] disabled=yes;\r\
\n/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR1\"\
] gateway=\$GatewayA;\r\
\n/ip route set [find comment=\"TRAFICO DEL ROUTER Y TRAFICO SIN MARCAR2\"\
] gateway=\$GatewayB;\r\
\n:log info \"Se ha ejecutado el script de ADSL2 FALLA\";\r\
\n/system script run ERROR;"
/ip route
add dst-address=213.180.204.3/32 gateway=192.168.1.1 scope=10 target-scope=10
add dst-address=93.158.134.3/32 gateway=192.168.2.1 scope=10 target-scope=10
add dst-address=1.1.1.1/32 gateway=213.180.204.3 scope=30 target-scope=10 check-gateway=ping
add dst-address=2.2.2.2/32 gateway=93.158.134.3 scope=30 target-scope=10 check-gateway=ping
add gateway=1.1.1.1 routing-mark=ISP1 scope=30 target-scope=30
add gateway=2.2.2.2 routing-mark=ISP2 scope=30 target-scope=30
add distance=10 gateway=2.2.2.2 routing-mark=ISP1 scope=30 target-scope=30
add distance=10 gateway=1.1.1.1 routing-mark=ISP2 scope=30 target-scope=30
/ip route
add dst-address=213.180.204.3/32 gateway=192.168.1.1 scope=10 target-scope=10
add dst-address=93.158.134.3/32 gateway=192.168.2.1 scope=10 target-scope=10
add gateway=213.180.204.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping
add gateway=93.158.134.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping
add distance=10 gateway=93.158.134.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping
add distance=10 gateway=213.180.204.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping
This don't work, becaume my adsl routers will be connected with my routeros and this conection will work, but not my pppoe in router.
add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.101.1 scope=30 target-scope=10
Code: Select all/ip route add dst-address=213.180.204.3/32 gateway=192.168.1.1 scope=10 target-scope=10 add dst-address=93.158.134.3/32 gateway=192.168.2.1 scope=10 target-scope=10 add gateway=213.180.204.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping add gateway=93.158.134.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping add distance=10 gateway=93.158.134.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping add distance=10 gateway=213.180.204.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping
hmmm... but again, what if the modem is up, but no connection to the internet? =) distance=2 won't help =)I activated the 2, with diferent distance, 1 and 2 ; D!
more than 8, I think ))) but... what's problem? =)Next week i have to make the same for 3 adsl.. I think i'll have 8 rules ; (
I activated the 2 routers but with diferent distance. Now if one fails, router will work with the other, and I can enter always with my prefered line.hmmm... but again, what if the modem is up, but no connection to the internet? =) distance=2 won't help =)
I have problem with this.oops, I don't exactly remember where I have got this fake addresses in my investigations, but actually they are not needed - it's maybe just more beautiful (and easy-to-change) to use them ))) below is 'lite' version
Code: Select all/ip route add dst-address=213.180.204.3/32 gateway=192.168.1.1 scope=10 target-scope=10 add dst-address=93.158.134.3/32 gateway=192.168.2.1 scope=10 target-scope=10 add gateway=213.180.204.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping add gateway=93.158.134.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping add distance=10 gateway=93.158.134.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping add distance=10 gateway=213.180.204.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping
Hello,treborr, please make supout.rif at that moment and send it to support@mikrotik.com together with "/ip rou pr det" output...
One question:
did you copy paste any part of these rules via terminal or console?
If yes, try to copy paste the export file without the "/32" in the dst addresses/gateways.
I have this problem and reported to Maris via support, but he says that rules are Active..
You can see the rules active but as you say, the rules don't work correct. True?! Is something like this?
I have the same problem if I disable the isp1 ethernet (example), and enable it. The routes shown aren't the same than after reboot.
In winbox it is without /32. /32 is only in terminal "/ip route print detail" and than in copy paste.Work diferent with the /32 or without in the copy paste?
yes?
and after that i have to build a route rule using the connection marks: ISP2_conn /ISP1fu**, you are so fast.. xD
point 4, for wxample like this:
/ip firewall mangle
add action=mark-connection chain=input comment="IN router1" disabled=no in-interface=ether2-ISP1 new-connection-mark=ISP1_conn passthrough=no
add action=mark-connection chain=input comment="IN router2" disabled=no in-interface=ether3-ISP2 new-connection-mark=ISP2_conn passthrough=no
Yes i always wait cca 1 minute. Yes the 192.168.10.1 is static address.disconnected?.. "gw-check-ok" is always "yes"... have you waited a minute?..
is 192.168.10.1 static address?..
/ip route
add dst-address=213.180.204.3 type=blackhole distance=20 scope=30 target-scope=10
add dst-address=93.158.134.3 type=blackhole distance=20 scope=30 target-scope=10
sorry?..the Kargen off Highlander
/ip route
add dst-address=213.180.204.3/32 gateway=192.168.1.1 scope=10 target-scope=10
add dst-address=93.158.134.3/32 gateway=192.168.2.1 scope=10 target-scope=10
add gateway=213.180.204.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping
add gateway=93.158.134.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping
add distance=10 gateway=93.158.134.3 routing-mark=ISP1 scope=30 target-scope=30 check-gateway=ping
add distance=10 gateway=213.180.204.3 routing-mark=ISP2 scope=30 target-scope=30 check-gateway=ping
I was hoping to use it on my core router. It is set up as a pppoe server for my network with queues, lots of mangle rules, etc. I want the 2nd connection to function only as a backup, no need for load sharing etc.what's your setup? do you need mangling at all?
[admin@750G] /ip route> print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 A S 0.0.0.0/0 74.125.19.148 1
1 S 0.0.0.0/0 74.125.19.147 2
2 A S 0.0.0.0/0 74.125.19.147 1
3 S 0.0.0.0/0 74.125.19.148 2
4 ADC 70.XXX.2.0/24 70.XXX.2.210 ether1PUBLIC 0
5 A S 74.125.19.147/32 70.XXX.2.2 1
6 A S 74.125.19.148/32 70.XXX.2.1 1
7 ADC 192.168.9.0/24 192.168.9.1 ether5JETCORP 0
8 ADC 192.168.88.0/24 192.168.88.1 JetWire_Bridge 0
[admin@750G] /ip route>
/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
74.125.19.148 scope=30 target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=12.0.0.1 scope=30 \
target-scope=10
add disabled=no distance=1 dst-address=12.0.0.1/32 gateway=70.XXX.2.2 scope=\
10 target-scope=10
add disabled=no distance=1 dst-address=74.125.19.148/32 gateway=70.XXX.2.1 \
scope=10 target-scope=10
Only a true bloodthirsty (but polite) 1000 year old warrior would ask that question !do you need mangling at all?
sure, in case of backup link you don't need to check it - you need checking only in case of load-balance, when both links are simultaneously primary and backup for each otherI am hoping the 2nd conenction won't need to be pinged, cause if its down it doses not matter
what are your gateways? 192.168.1.1 and 1.2? or 10.111.0.1 and 10.112.0.1?..why not work???
/ip route
add dst-address=98.137.149.56/32 gateway=192.168.1.1 scope=10 target-scope=10 comment="yahoo" disabled=no
add dst-address=66.249.92.104/32 gateway=192.168.2.1 scope=10 target-scope=10 comment="google" disabled=no
add gateway=98.137.149.56 routing-mark=route-to-isp1 scope=30 target-scope=30 check-gateway=ping disabled=no
add gateway=66.249.92.104 routing-mark=route-to-isp2 scope=30 target-scope=30 check-gateway=ping disabled=no
add distance=10 gateway=66.249.92.104 routing-mark=route-to-isp1 scope=30 target-scope=30 check-gateway=ping disabled=no
add distance=10 gateway=98.137.149.56 routing-markroute-to-isp2 scope=30 target-scope=30 check-gateway=ping disabled=no
/ip route print detail
/ ip route
add dst-address=0.0.0.0/0 gateway=10.111.0.1 routing-mark=to_wlan1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=10.112.0.1 routing-mark=to_wlan2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=10.111.0.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=10.112.0.1 distance=2 check-gateway=ping
/ip route
add dst-address=Host1 gateway=GW1 scope=10
add dst-address=Host2 gateway=GW2 scope=10
/ip route
add distance=1 gateway=Host1 routing-mark=ISP1 check-gateway=ping
add distance=2 gateway=Host2 routing-mark=ISP1 check-gateway=ping
/ip route
add distance=1 gateway=Host2 routing-mark=ISP2 check-gateway=ping
add distance=2 gateway=Host1 routing-mark=ISP2 check-gateway=ping
I did, but doesn't work. As I said, router seems to work, but not workstations.if you want tow line to work together you should use Load-balance try pcc
/ip pool
add name=dhcp_pool1 ranges=192.168.5.30-192.168.5.49
/ip dhcp-server
add address-pool=dhcp_pool1 authoritative=after-2sec-delay bootp-support=\
static disabled=no interface=iLAN lease-time=3d name=dhcp1
/port
/interface pppoe-client
add ac-name="" add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=\
"" dial-on-demand=no disabled=no interface=iARNET max-mru=1480 max-mtu=\
1480 mrru=disabled name=pppoe-ARNET password=9999999 profile=default \
service-name="" use-peer-dns=no user=\
user@isp
# Router IP.
/ip address
add address=192.168.5.2/24 broadcast=192.168.5.255 comment="" disabled=no \
interface=iLAN network=192.168.5.0
# ISP FIBER. Here, use-peer-DNS is set to "no" because it changes /ip dns config.
#I want in that config DNSs from both ISPs. I also did it en PPPoE interaface config.
/ip dhcp-client
add add-default-route=yes comment="" default-route-distance=0 disabled=no \
interface=iFIBER use-peer-ntp=yes
/ip dhcp-server config
set store-leases-disk=5m
# DHCP SVR local network with 5 dns servers. 1º and 3º belongs to ISP FIBER.
# 2º and 4º to ISP ARNET.
/ip dhcp-server network
add address=192.168.5.0/24 comment="" dns-server=\
200.49.130.31,200.45.191.35,200.49.130.30,200.45.48.233,192.168.5.2 \
gateway=192.168.5.2 netmask=24
# One DNS for ISP FIBER and the another for ISP ARNET.
/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=4096KiB \
max-udp-packet-size=512 primary-dns=200.49.130.31 secondary-dns=\
200.45.48.233
# Here starts the config of PCC article. I guess there's nothing important.
/ip firewall address-list
add address=192.168.0.0/16 comment="" disabled=no list=illegal-addr
add address=10.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=172.16.0.0/12 comment="" disabled=no list=illegal-addr
add address=169.254.0.0/16 comment="" disabled=no list=illegal-addr
add address=127.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=224.0.0.0/3 comment=multicast disabled=no list=illegal-addr
add address=223.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=198.18.0.0/15 comment="" disabled=no list=illegal-addr
add address=192.0.2.0/24 comment="" disabled=no list=illegal-addr
add address=185.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=180.0.0.0/6 comment="" disabled=no list=illegal-addr
add address=179.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=176.0.0.0/7 comment="" disabled=no list=illegal-addr
add address=175.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=104.0.0.0/6 comment="" disabled=no list=illegal-addr
add address=100.0.0.0/6 comment="" disabled=no list=illegal-addr
add address=49.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=46.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=42.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=39.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=36.0.0.0/7 comment="" disabled=no list=illegal-addr
add address=31.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=27.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=23.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=14.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=5.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=2.0.0.0/8 comment="" disabled=no list=illegal-addr
add address=0.0.0.0/7 comment="" disabled=no list=illegal-addr
add address=128.0.0.0/16 comment="" disabled=no list=illegal-addr
add address=192.168.5.0/24 comment="my local network, all NATed" disabled=no \
list=local-addr
# Here I have some disabled. Another rules (specially with action "jump") are Invalid I don't know why.
# Nevertheless, if I disable all, it is still not working.
/ip firewall filter
add action=accept chain=forward comment="Allow traffic between clients" \
disabled=no in-interface=iLAN out-interface=iLAN
add action=jump chain=forward comment="Sanity Check Forward" disabled=no \
jump-target=sanity-check
add action=jump chain=sanity-check comment="Deny illegal NAT traversal" \
disabled=no jump-target=drop packet-mark=NAT-T
add action=accept chain=input comment=\
"Allow The Router to be visible via Neighbor Discovery to WinBox" \
disabled=no dst-address=255.255.255.255 dst-port=5678 in-interface=iLAN \
protocol=udp
add action=add-src-to-address-list address-list=blocked-addr \
address-list-timeout=3d chain=sanity-check comment="Block port scans" \
disabled=yes protocol=tcp psd=20,3s,3,1
add action=add-src-to-address-list address-list=blocked-addr \
address-list-timeout=1d chain=sanity-check comment=\
"*** Block TCP Null scan" disabled=no protocol=tcp tcp-flags=\
fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list=blocked-addr \
address-list-timeout=1d chain=sanity-check comment=\
"*** Block TCP Xmas scan" disabled=no protocol=tcp tcp-flags=\
!fin,!syn,!rst,!psh,!ack,!urg
add action=jump chain=sanity-check comment="" disabled=no jump-target=drop \
protocol=tcp src-address-list=blocked-addr
add action=jump chain=sanity-check comment="*** Drop TCP RST" disabled=no \
jump-target=drop protocol=tcp tcp-flags=rst
add action=jump chain=sanity-check comment="*** Drop TCP SYN+FIN" disabled=no \
jump-target=drop protocol=tcp tcp-flags=fin,syn
add action=jump chain=sanity-check comment=\
"Dropping invalid connections at once" connection-state=invalid disabled=\
no jump-target=drop
add action=accept chain=sanity-check comment=\
"Accepting already established connections" connection-state=established \
disabled=no
add action=accept chain=sanity-check comment=\
"Also accepting related connections" connection-state=related disabled=no
add action=jump chain=sanity-check comment=\
"*** Drop all traffic that goes to multicast or broadcast addresses" \
disabled=no dst-address-type=broadcast,multicast jump-target=drop
add action=jump chain=sanity-check comment=\
"Drop illegal destination addresses" disabled=no dst-address-list=\
illegal-addr dst-address-type=!local in-interface=iLAN jump-target=drop
add action=jump chain=sanity-check comment="Drop everything that goes from loc\
al interface but not from local address" disabled=no in-interface=iLAN \
jump-target=drop src-address-list=!local-addr
add action=jump chain=sanity-check comment="Drop illegal source addresses" \
disabled=no in-interface=iFIBER jump-target=drop src-address-list=\
illegal-addr
add action=jump chain=sanity-check comment="Drop illegal source addresses" \
disabled=no in-interface=iARNET jump-target=drop src-address-list=\
illegal-addr
add action=jump chain=sanity-check comment=\
"*** Drop all traffic that comes from multicast or broadcast addresses" \
disabled=no jump-target=drop src-address-type=broadcast,multicast
add action=accept chain=input comment=\
"Allow local traffic (between router applications)" disabled=no \
dst-address-type=local src-address-type=local
add action=jump chain=input comment="DHCP protocol would not pass sanity check\
ing, so enabling it explicitly before other checks" disabled=no dst-port=\
67 in-interface=iLAN jump-target=dhcp protocol=udp src-port=68
add action=jump chain=input comment="Sanity Check" disabled=no jump-target=\
sanity-check
add action=jump chain=input comment="*** Dropping packets not destined to the \
router itself, including all broadcast traffic" disabled=no \
dst-address-type=!local jump-target=drop
add action=accept chain=input comment=\
"Allow pings, but at a very limited rate (5 packets per sec)" disabled=\
yes icmp-options=8:0-255 limit=5,5 protocol=icmp
add action=jump chain=input comment=\
"Allowing some services to be accessible from the local network" \
disabled=no in-interface=iLAN jump-target=local-services
add action=jump chain=input comment=\
"Allowing some services to be accessible from the Internet" disabled=no \
in-interface=iFIBER jump-target=public-services
add action=jump chain=input comment=\
"Allowing some services to be accessible from the Internet" disabled=no \
in-interface=iARNET jump-target=public-services
add action=jump chain=input comment="" disabled=no jump-target=drop
add action=accept chain=dhcp comment="" disabled=no dst-address=\
255.255.255.255 src-address=0.0.0.0
add action=accept chain=dhcp comment="" disabled=no dst-address-type=local \
src-address=0.0.0.0
add action=accept chain=dhcp comment="" disabled=no dst-address-type=local \
src-address-list=local-addr
add action=drop chain=local-services comment="SSH (22/TCP)" disabled=no \
dst-port=22 protocol=tcp
add action=accept chain=local-services comment=DNS disabled=no dst-port=53 \
protocol=udp
add action=accept chain=local-services comment=DNS disabled=no dst-port=53 \
protocol=tcp
add action=accept chain=local-services comment="HTTP Proxy (3128/TCP)" \
disabled=no dst-port=3128 protocol=tcp
add action=accept chain=local-services comment="Winbox (8291/TCP)" disabled=\
no dst-port=8291 protocol=tcp
add action=accept chain=local-services comment=SNMP disabled=no dst-port=161 \
protocol=udp
add action=accept chain=local-services comment=NTP disabled=no dst-port=123 \
protocol=udp
add action=accept chain=local-services comment="Neighbor discovery" disabled=\
no dst-port=5678 protocol=udp
add action=log chain=local-services comment=\
"Temporary Logging to check for things we should not drop" disabled=no \
log-prefix=""
add action=drop chain=local-services comment="" disabled=yes
add action=accept chain=public-services comment="SSH (22/TCP)" disabled=no \
dst-port=22 protocol=tcp
add action=accept chain=public-services comment="PPTP (1723/TCP)" disabled=\
yes dst-port=1723 protocol=tcp
add action=accept chain=public-services comment="Winbox (8291/TCP)" disabled=\
no dst-port=8291 protocol=tcp
add action=accept chain=public-services comment="GRE for PPTP" disabled=yes \
protocol=gre
add action=drop chain=forward comment=Skype disabled=no layer7-protocol=Skype
add action=log chain=public-services comment=\
"Temporary Logging to check for things we should not drop" disabled=yes \
log-prefix=""
add action=drop chain=public-services comment="" disabled=yes
/ip firewall mangle
add action=mark-packet chain=prerouting comment="Detect NAT Traversal" \
disabled=no dst-address-list=local-addr in-interface=iFIBER \
new-packet-mark=nat-traversal passthrough=no
add action=mark-packet chain=prerouting comment="" disabled=no \
dst-address-list=local-addr in-interface=iARNET new-packet-mark=\
nat-traversal passthrough=yes
add action=mark-connection chain=input comment="Config b\E1sica" disabled=no \
in-interface=iFIBER new-connection-mark=conn_FIBER passthrough=yes
add action=mark-connection chain=input comment="" disabled=no in-interface=\
iARNET new-connection-mark=conn_ARNET passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=conn_FIBER \
disabled=no new-routing-mark=rt_FIBER passthrough=yes
add action=mark-routing chain=output comment="" connection-mark=conn_ARNET \
disabled=no new-routing-mark=rt_ARNET passthrough=yes
add action=accept chain=prerouting comment="" disabled=no dst-address=\
!192.168.5.0/24 in-interface=iLAN
add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=iLAN new-connection-mark=conn_FIBER \
passthrough=yes per-connection-classifier=both-addresses:2/0
add action=mark-connection chain=prerouting comment="" disabled=no \
dst-address-type=!local in-interface=iLAN new-connection-mark=conn_ARNET \
passthrough=yes per-connection-classifier=both-addresses:2/1
add action=mark-routing chain=prerouting comment="" connection-mark=\
conn_FIBER disabled=no in-interface=iLAN new-routing-mark=rt_FIBER \
passthrough=yes
add action=mark-routing chain=prerouting comment="" connection-mark=\
conn_ARNET disabled=no in-interface=iLAN new-routing-mark=rt_ARNET \
passthrough=yes
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
iFIBER
add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
iARNET
add action=dst-nat chain=dstnat comment=RDP disabled=no dst-port=3389 \
in-interface=!iLAN protocol=tcp src-address-list="" to-addresses=\
192.168.5.9 to-ports=3389
add action=src-nat chain=srcnat comment=RDP disabled=no out-interface=!iLAN \
protocol=tcp src-address=192.168.5.9 src-port=3389 to-ports=1024-65535
# I disabled this. I don't understand what is doing.
add action=redirect chain=dstnat comment="Transparent DNS Cache" \
connection-mark=dns disabled=yes in-interface=iLAN
add action=redirect chain=dstnat comment="Transparent Web Cache" disabled=no \
dst-port=80 protocol=tcp to-ports=3128
# I disabled this. I don't understand what is doing.
add action=redirect chain=dstnat comment="Transparent proxy for NTP requests" \
connection-mark=ntp disabled=yes in-interface=iLAN
# All transparent proxy stuff. It's running, but doesn't cache anything. Again, I don't unterstand why.
/ip proxy
set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
cache-on-disk=yes enabled=yes max-cache-size=none max-client-connections=\
1000 max-fresh-time=3d max-server-connections=1000 parent-proxy=0.0.0.0 \
parent-proxy-port=0 port=3128 serialize-connections=no src-address=\
0.0.0.0
/ip proxy access
add action=deny comment="" disabled=no dst-host=:facebook
/ip proxy cache
/store
add comment="" disabled=no disk=primary-master name=user-manager1 type=\
user-manager
add comment="" disabled=no disk=primary-master name=web-proxy1 type=web-proxy
# Here is the main problem I guess.
# I replaced PCC code for Advanced Balancing..... code.
# gateway 201.231.156.1 for ISP FIBER.
# gateway 200.3.60.15 for ISP ARNET.
# Main routes for both ISPs are not here. They are created dynamically when I plug the modems.
# What the distance for those dynamic routes should be?
/ip route
add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=137.254.16.57 routing-mark=rt_ARNET scope=30 \
target-scope=10
add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
0.0.0.0/0 gateway=69.147.112.160 routing-mark=rt_FIBER scope=30 \
target-scope=10
add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
0.0.0.0/0 gateway=137.254.16.57 routing-mark=rt_FIBER scope=30 \
target-scope=10
add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
0.0.0.0/0 gateway=69.147.112.160 routing-mark=rt_ARNET scope=30 \
target-scope=10
add comment="ping Yahoo Mail - host1" disabled=no distance=1 dst-address=\
69.147.112.160/32 gateway=201.231.156.1 scope=10 target-scope=10
add disabled=no distance=20 dst-address=69.147.112.160/32 type=blackhole
add comment="ping Sun - host2" disabled=no distance=1 dst-address=\
137.254.16.57/32 gateway=200.3.60.15 scope=10 target-scope=10
add comment="" disabled=no distance=20 dst-address=137.254.16.57/32 type=\
blackhole
Hi Jamie. I'm sorry I don't have an answer for your question. I just want to ask you how do you configure network settings in your workstations in order to work.Hi all,
I have been trying to get this working for about a week now! Basically my setup is very similar to what you have all achieved, except I want my default route to have more than one gateway in. When the route has one gateway in its fine and the next hop correctly detects if the link is down. If I then add a second gateway the default route it no longer detects if the gateways are, see below;
add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
1.1.1.1/32 gateway=81.187.244.77,81.187.164.216 scope=30 target-scope=10
4 address=81.187.164.216 gw-state=recursive forwarding-nexthop=81.187.84.221
scope=10 check-gateway=none
5 address=81.187.244.77 gw-state=recursive forwarding-nexthop=81.187.84.222
scope=10 check-gateway=none
So even though I am doing a gateway check on the two gateways the actual nexthop seems to be disregrding it! Do you think this is a bug because I know you can use multiple gateways in other scenarios!
Thanks
Jamie
http://www.fusionmanageit.co.uk
that so nice for you because sure it helpfully to accept as talk to you but i think some people will forget to give karma've added my skype id to my signature for faster conversation..
I just copied all my settings above. Do you see something wrong?rgodoy have you setup NAT correctly in the first place?
maybe, provide some links?..Multiple host checking setup
/ip route print
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0> S 0.0.0.0/0 10.1.1.1 1
1> S 0.0.0.0/0 10.2.2.2 1
2> S 0.0.0.0/0 10.2.2.2 2
3> S 0.0.0.0/0 10.1.1.1 2
4>A S 8.8.4.4/32 10.18.33.1 1
5> SB 8.8.4.4/32 20
6>A S 8.8.8.8/32 192.168.222.1 1
7> SB 8.8.8.8/32 20
8>A S 10.1.1.1/32 208.67.222.222 1
9> S 10.1.1.1/32 8.8.8.8 1
10>A S 10.2.2.2/32 208.67.220.220 1
11> S 10.2.2.2/32 8.8.4.4 1
12>ADC 10.18.33.0/24 10.18.33.85 SkyNET 0
13>ADC 10.18.85.0/24 10.18.85.1 LAN 0
14>ADC 192.168.222.0/24 192.168.222.194 CDMA 0
15>A S 208.67.220.220/32 10.18.33.1 1
16> SB 208.67.220.220/32 20
17>A S 208.67.222.222/32 192.168.222.1 1
18> SB 208.67.222.222/32 20
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0> S dst-address=0.0.0.0/0 gateway=10.1.1.1
gateway-status=10.1.1.1 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=1 scope=30 target-scope=10
1> S dst-address=0.0.0.0/0 gateway=10.2.2.2
gateway-status=10.2.2.2 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=1 scope=30 target-scope=10
2> S dst-address=0.0.0.0/0 gateway=10.2.2.2
gateway-status=10.2.2.2 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=2 scope=30 target-scope=10
3> S dst-address=0.0.0.0/0 gateway=10.1.1.1
gateway-status=10.1.1.1 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=2 scope=30 target-scope=10
4>A S dst-address=8.8.4.4/32 gateway=10.18.33.1
gateway-status=10.18.33.1 reachable SkyNET distance=1 scope=10
target-scope=10
5> SB dst-address=8.8.4.4/32 type=blackhole distance=20
6>A S dst-address=8.8.8.8/32 gateway=192.168.222.1
gateway-status=192.168.222.1 reachable CDMA distance=1 scope=10
target-scope=10
7> SB dst-address=8.8.8.8/32 type=blackhole distance=20
8>A S dst-address=10.1.1.1/32 gateway=208.67.222.222
gateway-status=208.67.222.222 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=1 scope=10 target-scope=10
9> S dst-address=10.1.1.1/32 gateway=8.8.8.8
gateway-status=8.8.8.8 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=1 scope=10 target-scope=10
10>A S dst-address=10.2.2.2/32 gateway=208.67.220.220
gateway-status=208.67.220.220 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=1 scope=10 target-scope=10
11> S dst-address=10.2.2.2/32 gateway=8.8.4.4
gateway-status=8.8.4.4 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=1 scope=10 target-scope=10
12>ADC dst-address=10.18.33.0/24 pref-src=10.18.33.85 gateway=SkyNET
gateway-status=SkyNET reachable distance=0 scope=10
13>ADC dst-address=10.18.85.0/24 pref-src=10.18.85.1 gateway=LAN
gateway-status=LAN reachable distance=0 scope=10
14>ADC dst-address=192.168.222.0/24 pref-src=192.168.222.194 gateway=CDMA
gateway-status=CDMA reachable distance=0 scope=10
15>A S dst-address=208.67.220.220/32 gateway=10.18.33.1
gateway-status=10.18.33.1 reachable SkyNET distance=1 scope=10
target-scope=10
16> SB dst-address=208.67.220.220/32 type=blackhole distance=20
17>A S dst-address=208.67.222.222/32 gateway=192.168.222.1
gateway-status=192.168.222.1 reachable CDMA distance=1 scope=10
target-scope=10
18> SB dst-address=208.67.222.222/32 type=blackhole distance=20
Flags: X - disabled, A - active, D - dynamic,
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme,
B - blackhole, U - unreachable, P - prohibit
0 S dst-address=0.0.0.0/0 gateway=10.1.1.1
gateway-status=10.1.1.1 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=1 scope=30 target-scope=10
routing-mark=ISP1
1 S dst-address=0.0.0.0/0 gateway=10.2.2.2
gateway-status=10.2.2.2 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=2 scope=30 target-scope=10
routing-mark=ISP1
2 S dst-address=0.0.0.0/0 gateway=10.2.2.2
gateway-status=10.2.2.2 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=1 scope=30 target-scope=10
routing-mark=ISP2
3 S dst-address=0.0.0.0/0 gateway=10.1.1.1
gateway-status=10.1.1.1 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=2 scope=30 target-scope=10
routing-mark=ISP2
4 A S dst-address=8.8.4.4/32 gateway=10.18.33.1
gateway-status=10.18.33.1 reachable SkyNET distance=1 scope=10
target-scope=10
5 SB dst-address=8.8.4.4/32 type=blackhole distance=20
6 A S dst-address=8.8.8.8/32 gateway=192.168.222.1
gateway-status=192.168.222.1 reachable CDMA distance=1 scope=10
target-scope=10
7 SB dst-address=8.8.8.8/32 type=blackhole distance=20
8 A S dst-address=10.1.1.1/32 gateway=208.67.222.222
gateway-status=208.67.222.222 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=1 scope=10 target-scope=10
9 S dst-address=10.1.1.1/32 gateway=8.8.8.8
gateway-status=8.8.8.8 recursive via 192.168.222.1 CDMA
check-gateway=ping distance=1 scope=10 target-scope=10
10 A S dst-address=10.2.2.2/32 gateway=208.67.220.220
gateway-status=208.67.220.220 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=1 scope=10 target-scope=10
11 S dst-address=10.2.2.2/32 gateway=8.8.4.4
gateway-status=8.8.4.4 recursive via 10.18.33.1 SkyNET
check-gateway=ping distance=1 scope=10 target-scope=10
12 ADC dst-address=10.18.33.0/24 pref-src=10.18.33.85 gateway=SkyNET
gateway-status=SkyNET reachable distance=0 scope=10
13 ADC dst-address=10.18.85.0/24 pref-src=10.18.85.1 gateway=LAN
gateway-status=LAN reachable distance=0 scope=10
14 ADC dst-address=192.168.222.0/24 pref-src=192.168.222.194 gateway=CDMA
gateway-status=CDMA reachable distance=0 scope=10
15 A S dst-address=208.67.220.220/32 gateway=10.18.33.1
gateway-status=10.18.33.1 reachable SkyNET distance=1 scope=10
target-scope=10
16 SB dst-address=208.67.220.220/32 type=blackhole distance=20
17 A S dst-address=208.67.222.222/32 gateway=192.168.222.1
gateway-status=192.168.222.1 reachable CDMA distance=1 scope=10
target-scope=10
18 SB dst-address=208.67.222.222/32 type=blackhole distance=20
0 address=8.8.4.4 gw-state=recursive forwarding-nexthop=10.18.33.1 scope=10 check-gateway=icmp gw-check-ok=yes
1 address=8.8.8.8 gw-state=recursive forwarding-nexthop=192.168.222.1 scope=10 check-gateway=icmp gw-check-ok=yes
2 address=10.1.1.1 gw-state=recursive forwarding-nexthop=192.168.222.1 scope=10 check-gateway=icmp gw-check-ok=no
3 address=10.2.2.2 gw-state=recursive forwarding-nexthop=10.18.33.1 scope=10 check-gateway=icmp gw-check-ok=no
4 address=10.18.33.1 gw-state=reachable scope=10 check-gateway=none
5 address=192.168.222.1 gw-state=reachable scope=10 check-gateway=none
6 address=208.67.220.220 gw-state=recursive forwarding-nexthop=10.18.33.1 scope=10 check-gateway=icmp gw-check-ok=yes
7 address=208.67.222.222 gw-state=recursive forwarding-nexthop=192.168.222.1 scope=10 check-gateway=icmp gw-check-ok=yes
/ip firewall mangle
add action=mark-routing chain=prerouting src-address=192.168.33.0/24 new-routing-mark=ISP1
thank you for the testing =)Well, thanks very much for the corrections, it works now.
the article is about failover, not balancing or something, soPerhaps you should add (just for some routing beginners like me) that you need to add something like this to have it work (with the Routing marks):
Code: Select all/ip firewall mangle add action=mark-routing chain=prerouting src-address=192.168.33.0/24 new-routing-mark=ISP1
Let's suppose <...> we have some policy routing rules, so all outgoing traffic is marked with ISP1 (which goes to GW1) and ISP2 (which goes to GW2) marks
I don't know how mark ALL OUTGOING traffic. As I wrote above, I use some default routes without marks to have internet connection.so all outgoing traffic is marked with ISP1 (which goes to GW1) and ISP2 (which goes to GW2) marks
0 A S dst-address=0.0.0.0/0 gateway=94.87.83.254
gateway-status=94.87.83.254 reachable via WAN1
distance=1 scope=30 target-scope=10 routing-mark=to_WAN1
3 S dst-address=0.0.0.0/0 gateway=192.168.0.0
gateway-status=192.168.0.0 unreachable distance=2
target-scope=10 routing-mark=to_WAN2
6 A S dst-address=0.0.0.0/0 gateway=94.87.83.254
gateway-status=94.87.83.254 reachable scope=30 target-scope=10
7 S dst-address=0.0.0.0/0 gateway=192.168.0.0
gateway-status=192.168.0.0 unreachable distance=2 target-scope=10
16 ADC dst-address=192.168.0.0/24 pref-src=192.168.0.59 gateway=WAN2
gateway-status=WAN2 reachable distance=0 scope=10
17 ADC dst-address=192.168.33.0/24 pref-src=192.168.33.1 gateway=LAN2
gateway-status=LAN2 reachable distance=0 scope=10
18 ADC dst-address=192.168.168.0/24 pref-src=192.168.168.1 gateway=LAN1
gateway-status=LAN1 reachable distance=0 scope=10
19 ADC dst-address=94.87.83.224/27 pref-src=94.87.83.242 gateway=WAN1
gateway-status=WAN1 reachable distance=0 scope=10
ip address print detail
0 address=192.168.168.1/24 network=192.168.168.0 interface=LAN1 actual-interface=LAN1
1 address=192.168.0.59/24 network=192.168.0.0 interface=WAN2 actual-interface=WAN2
2 address=192.168.33.1/24 network=192.168.33.0 interface=LAN2 actual-interface=LAN2
3 D address=94.87.83.242/27 network=94.87.83.224 interface=WAN1 actual-interface=WAN1
/ip firewall mangle print detail
0 ;;; DEFAULT ROUTING table for traffic from LAN to connected (WAN) networks
chain=prerouting action=accept dst-address=94.87.83.0/24
in-interface=LAN1
1 chain=prerouting action=accept dst-address=192.168.0.0/24
in-interface=LAN1
2 ;;; INPUT in WAN1, out WAN1
chain=input action=mark-connection new-connection-mark=WAN1_conn
passthrough=yes in-interface=WAN1
3 chain=output action=mark-routing new-routing-mark=to_WAN1
passthrough=no connection-mark=WAN1_conn
4 ;;; INPUT in WAN2, out WAN2
chain=input action=mark-connection new-connection-mark=WAN2_conn
passthrough=yes in-interface=WAN2
5 chain=output action=mark-routing new-routing-mark=to_WAN2
passthrough=no connection-mark=wan2_conn
6 ;;; Forward in WAN1, out WAN1
chain=forward action=mark-connection new-connection-mark=WAN1_forward
passthrough=yes connection-state=new in-interface=WAN1
7 chain=prerouting action=mark-routing new-routing-mark=to_WAN1
passthrough=no in-interface=LAN1 connection-mark=WAN1_forward
8 ;;; Forward in WAN2, out WAN2
chain=forward action=mark-connection new-connection-mark=WAN2_forward
passthrough=yes connection-state=new in-interface=WAN2
9 chain=prerouting action=mark-routing new-routing-mark=to_WAN2
passthrough=no in-interface=LAN1 connection-mark=WAN2_forward
/ip route print detail
0 A S dst-address=0.0.0.0/0 gateway=172.16.1.1
gateway-status=172.16.1.1 recursive via 94.87.83.254 WAN1
distance=1 scope=30 target-scope=10 routing-mark=to_WAN1
1 S dst-address=0.0.0.0/0 gateway=172.16.2.2
gateway-status=172.16.2.2 recursive via 192.168.0.1 WAN2
distance=2 scope=30 target-scope=10 routing-mark=to_WAN1
2 A S dst-address=0.0.0.0/0 gateway=172.16.2.2
gateway-status=172.16.2.2 recursive via 192.168.0.1 WAN2
distance=1 scope=30 target-scope=10 routing-mark=to_WAN2
3 S dst-address=0.0.0.0/0 gateway=172.16.1.1
gateway-status=172.16.1.1 recursive via 94.87.83.254 WAN1
distance=2 scope=30 target-scope=10 routing-mark=to_WAN2
4 A S dst-address=8.8.4.4/32 gateway=192.168.0.1
gateway-status=192.168.0.1 reachable via WAN2 distance=1
scope=10 target-scope=10
5 SB dst-address=8.8.4.4/32 type=blackhole distance=20
6 A S dst-address=8.8.8.8/32 gateway=94.87.83.254
gateway-status=94.87.83.254 reachable via WAN1
distance=1 scope=10 target-scope=10
7 SB dst-address=8.8.8.8/32 type=blackhole distance=20
8 A S dst-address=172.16.1.1/32 gateway=208.67.222.222
gateway-status=208.67.222.222 recursive via 94.87.83.254 WAN1
check-gateway=ping distance=1 scope=10 target-scope=10
9 S dst-address=172.16.1.1/32 gateway=8.8.8.8
gateway-status=8.8.8.8 recursive via 94.87.83.254 WAN1
check-gateway=ping distance=1 scope=10 target-scope=10
10 A S dst-address=172.16.2.2/32 gateway=208.67.220.220
gateway-status=208.67.220.220 recursive via 192.168.0.1 WAN2
check-gateway=ping distance=1 scope=10 target-scope=10
11 S dst-address=172.16.2.2/32 gateway=8.8.4.4
gateway-status=8.8.4.4 recursive via 192.168.0.1 WAN2
check-gateway=ping distance=1 scope=10 target-scope=10
12 ADC dst-address=192.168.0.0/24 pref-src=192.168.0.59
gateway=WAN2 gateway-status=WAN2 reachable distance=0 scope=10
13 ADC dst-address=192.168.33.0/24 pref-src=192.168.33.1
gateway=LAN2 gateway-status=LAN2 reachable distance=0 scope=10
14 ADC dst-address=192.168.168.0/24 pref-src=192.168.168.1
gateway=LAN1 gateway-status=LAN1 reachable distance=0 scope=10
15 ADC dst-address=94.87.83.224/27 pref-src=94.87.83.242
gateway=WAN1 gateway-status=WAN1 reachable distance=0 scope=10
16 A S dst-address=208.67.220.220/32 gateway=192.168.0.1
gateway-status=192.168.0.1 reachable via WAN2
distance=1 scope=10 target-scope=10
17 SB dst-address=208.67.220.220/32 type=blackhole distance=20
18 A S dst-address=208.67.222.222/32 gateway=94.87.83.254
gateway-status=94.87.83.254 reachable via WAN1
distance=1 scope=10 target-scope=10
19 SB dst-address=208.67.222.222/32 type=blackhole distance=20