Can you post more info about your setup, particularly IP addresses in use?
Here's a sample config. You'll have to modify it to work in your network.
MikroTik 1
/ip address
add interface=ether1 address=10.1.1.1/24 comment"LAN subnet"
add interface=ether2 address=192.168.1.2/30 comment="Point-to-point router connection"
/ip route add gateway=192.168.1.1 comment="Default route to MikroTik 2"
MikroTik 2
/ip address
add interface=ether1 address=192.0.2.2/24 comment="WAN to ISP"
add interface=ether2 address=192.168.1.1/30 comment="Point-to-point router connection"
/ip route dst-address=10.1.1.0/24 gateway=192.168.1.1 comment="Route to reach LAN subnet"
/ip route gateway=192.0.2.1 comment="ISP gateway"
/ip firewall nat
add chain=srcnat action=masquerade out-interface=ether1 comment="NAT all traffic to Internet"