That's all messed up.
Read
http://wiki.mikrotik.com/wiki/Manual:Packet_Flow - it shows the packet flow through the facilities.
'input' - traffic directly TO the router (destination IP address is on the router itself)
'output' - traffic sourced originated FROM the router
'forward' - traffic THROUGH the router
dst-nat happens in prerouting, which is before any of them. It changes the destination IP address to an IP address behind the router, so all your firewall filter rules for the forwarded traffic don't apply because you're in the wrong chain (the packet will be in 'forward', not 'input'). Also, setting an empty routing-mark is pointless. If you're trying to protect the router from being accessed from the Internet (which is a good idea) and also want only traffic originated from behind the router to flow through it with the exception of traffic forwarded to 192.168.88.50 with a destination port of 55554 on TCP and UDP the firewall filters, NAT and mangle would look something like this:
/ip firewall filter
# delete all existing rules
remove [find]
# allow all packets that belong to connections that have already been OK'd by the packets establishing them not having been dropped
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
# unconditionally allow ICMP
add action=accept chain=input protocol=icmp
# allow connections to be established from every interface but the WAN
add action=accept chain=input in-interface=!ether1-gateway
# drop everything else
add action=drop chain=input
# allow all packets that belong to connections that have already been OK'd by the packets establishing them not having been dropped
# allow all interfaces other than the WAN to establish new connections
add action=accept chain=forward connection-state=established
add action=accept chain=forward connection-state=related
add action=accept chain=forward in-interface=!ether1-gateway
# permit traffic from the WAN forwarded to 192.168.88.250 destined to tcp/55554 and udp/55554
add action=accept in-interface=ether1-gateway dst-address=192.168.88.250 protocol=tcp dst-port=55554
add action=accept in-interface=ether1-gateway dst-address=192.168.88.250 protocol=udp dst-port=55554
# drop everything else
add action=drop chain=forward
/ip firewall mangle
# delete all mangle rules, what is shown makes no sense
delete [find]
/ip firewall nat
# delete all existing rules
remove [find]
# port forward udp/55554 and tcp/55554 to 192.168.88.250
add action=dst-nat chain=dstnat dst-port=55554 protocol=tcp to-addresses=192.168.88.250 to-ports=55554
add action=dst-nat chain=dstnat dst-port=55554 protocol=udp to-addresses=192.168.88.250 to-ports=55554
# source NAT everything going out to the WAN
add action=masquerade chain=srcnat out-interface=ether1-gateway
That should be fine to paste in via a network connection, if you want to make sure, use the console or safe mode:
http://wiki.mikrotik.com/wiki/Manual:Console#Safe_Mode - generally a good idea when you're editing critical portions of the configuration.